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About This Guide
This guide describes the Dell™ Active System Manager product, which provides an integrated set of tools 
and services to automate environment infrastructure and streamline the new equipment verification and 
qualification process. 

This guide provides information needed to maintain and support the hardware and software environment 
of the Active System Manager product, and describes the architecture and operations of the Active System 
Manager product. Specifically, it also describes the following information:

• Overview of the Active System Manager client software, including concepts and features specific to 
using the software.

• Instructions for installing the Active System Manager client software.

• User guidance on the features and functionality of the following aspects of the software:

— Active System Manager server accounts.

— Active System Manager client user interface, including managing template files and reserving 
sessions

— Authoring and modifying templates

— Connecting local and remote users to running sessions and allowing users to monitor and manage 
these sessions

• Guidance for system administrators to manage Active System Manager inventory management; for 
example, integrating new resource types into the software, adding managed and control resources and 
links to the environment, and viewing, modifying, and deleting existing entries. 

• System administration for maintaining the Active System Manager software and hardware 
environment. 

This preface contains the following topics:

• Intended Audience

• Organization

• Conventions

• Documentation Lineup
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Intended Audience
Intended Audience

This guide is intended for system and network administrators who are responsible for managing an 
environment with the Active System Manager software, and should be familiar with the following 
concepts:

• Basic principles and use of the Active System Manager product

• Inventory and change management

• UNIX operating system and common UNIX commands

• Physical environment (layout, connectivity, inventory)

• Oracle database administration

• Licensing concepts

• Web applications and XML language

In addition to these concepts, Dell also recommends reading the Active System Manager Web Interface 
User Guide in conjunction with this guide. 

Organization

This guide is organized as follows:

• Chapter 1, “Active System Manager Overview”

Describes the overall Dell Automation Suite, including the key benefits, all high-level functions, 
concepts, and features.

• Chapter 2, “Getting Started”

Provides the basic information you need to install, configure, launch, and uninstall the Active System 
Manager client software. It also describes how to connect to the Active System Manager server and 
verify the connection status.

• Chapter 3, “Account Management”

Defines how to set up one or more server Active System Manager server accounts and to switch 
between a number of Active System Manager servers. It also describes how to edit and delete 
previously created server accounts.

• Chapter 4, “User Profile Management”

Describes the security features available in the Active System Manager software, including how to 
manage users (or administrators), groups, and permissions for users, administrators, and groups.

• Chapter 5, “Inventory Management”

Describes the Inventory perspective and associated tools that you use to catalog and define the 
equipment in your network environment. 
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Organization
• Chapter 6, “Using Inventory”

Describes the Active System Manager Inventory perspective and all of the functions available for using 
your inventory. 

• Chapter 7, “Repository Management”

Describes the Active System Manager Inventory perspective and all of the functions available for you 
to manage repositories and Resource Adapters.

• Chapter 8, “Template Management”

Describes the Templates perspective and all of the functions available for you to create, open, update, 
save, and close templates. It also describes how to import and export templates directly from the Active 
System Manager Topology view into the Templates perspective. Lastly, it describes how to work with 
configuration files to use in a template for equipment provisioning.

• Chapter 9, “Session Management”

Describes the Active System Manager Sessions perspective and all of the functions available for you to 
view, modify, and save the template of an running session, and remotely run test cases associated with 
it. You can also start and stop resource console sessions, execute remote commands, or power on and 
power off managed resources. 

• Chapter 10, “Orchestration Management”

Describes how to work with Orchestrations in the Active System Manager and helps you learn how to 
create, update, and delete orchestrations. The advanced feature allows you to view the graphical view 
of orchestration while execution, error handling in orchestration, and linking orchestrations with a 
selected template.

• Chapter 11, “Working with Test and Script Execution”

Describes how to work with test cases and resource script execution and Active System Manager views.

• Chapter 12, “Reports”

Describes the Active System Manager report generation feature and all of the functions available for 
you to create and print user reports for your inventory.

• Chapter 13, “Settings”

Describes the Active System Manager Settings feature and all of the functions available for you to 
manage your inventory settings.

• Chapter 14, “Dashboard”

Describes the Active System Manager Dashboard feature and all of the functions available.
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Conventions

This guide uses special conventions for the following elements:

• Notes

• Syntax Conventions

• Administrator Role Icon

Notes 
Notes and caution statements provide special information. Their appearance and usage is as follows:

Note Indicates information that emphasizes or supplements the main text. A note supplies information 
that may apply only in special cases; for example, memory limitations or equipment configurations.

Syntax Conventions
Table 1 describes the text format and character conventions used in this guide.

Table 1 Syntax Conventions 

Text Format Convention Example

Bold Indicates toolbar buttons, menu selections, field 
names, or items that you click, press, or type. 

Click Add or select the SaveAs option.

Courier Indicates console output, path names, source 
code, and filenames.

C:\dell\activesystemmanager

Italic Indicates path names for which you must supply 
a value.
Indicates a referenced name, especially in 
glossary, where See references occur.
Indicates external documentation references.

Drag the interfaces into the WP group, or select Bind > WP 
name, or right-click the interface, and select Bind > WP 
name.
This feature is called property-based scheduling.
For more information, see the Active System Manager 
Release Notes.

Right angle bracket > Indicates a procedural series of submenus that 
open from a primary menu.

Click File > New > Worksheet.

Separator characters 
(@, _)

Separates a subscriber name or administrator 
name and a domain name or domain alias, or 
console output that requires text to include a 
space.

support@dell.com
The format for any image file is:
/osimage/username_that_imported_the_image/
imagename
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Administrator Role Icon
For administrator only tasks, the administrator icon is used to identify that sole role. For non-administrator 
tasks, no icon is used. 

The Active System Manager administrator can perform the following functions (not available for standard 
users):

• Manage resource types and instances, including resource pools

• Define user groups and permissions 

• Define and manage software repositories

• Access and manage all templates

• Configure system-wide session notifications and reminders

• Access and manage all sessions

• Start and stop ASAP Rescheduling along with other associated properties

• Manage Archive Bins and rules for both templates and sessions 

Documentation Lineup

The current lineup of the Active System Manager product guide documentation for this release includes the 
following:

• Active System Manager User Guide—Describes the installation, operation, and usage of the Active 
System Manager Control Center client software. This guide provides information for end users and 
system administrator roles. 

• Active System Manager Online Help—Provides quick online access to the GUI Help and reference 
material, including the Active System Manager User Guide.

• Active System Manager Solution Guide for AS800—Describes the Active System Manager installation 
and deployment in the context of managing a Dell AS800 converged infrastructure solution.

• Active System Manager Release Notes—Provides a summary of the latest Active System Manager 
features, software changes, and system requirements, as well as the customer-facing known issues and 
resolved issues unique to each particular release.
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Active System Manager Overview
C h a p t e r  1
Active System Manager Overview
The Active System Manager solution sits at the center of the Active System, and simplifies infrastructure 
configuration, collapses management tools, and drives automation and consistency. Through capabilities 
such as template-based provisioning, automated configuration and infrastructure life cycle management, 
the Active System Manager product enables IT to respond rapidly to business needs, maximize data center 
efficiency and strengthen quality of IT service delivery. 

Rapidly Respond to Business Needs 

Active System Manager streamlines the complex and tedious task of infrastructure configuration. It enables 
IT to quickly on-board new infrastructure or rapidly reconfigure existing infrastructure. This significantly 
speeds time to production for new workloads or scaling of resources for existing workloads. 

This dramatic simplification in infrastructure configuration is achieved through automated discovery and 
inventory of bladed infrastructure, and centralization of infrastructure requirements in the form of 
templates. Once defined, templates within Active System Manager can be repeatedly and consistently 
utilized to streamline workload deployment. 

Maximize Data Center Efficiency 

Active System Manager empowers IT to achieve higher efficiencies through automation. By reducing, and 
in most cases eliminating manual steps, IT organizations can free up time to focus on initiatives that make 
a deeper impact on their organization and the business. 

While automation is a cornerstone of efficiency, many IT organizations today are also encumbered with 
multiple management consoles. Active System Manager offers an intuitive, single point of control for key 
infrastructure configuration and management functions, enabling IT to minimize the number of consoles 
that are needed on a regular basis.

Strengthen Quality of IT Service Delivery 

Assuring service levels is always tricky; there are just too many variables that can impact service delivery. 
Active System Manager addresses key factors that impact service levels, namely infrastructure 
configuration errors, incorrect problem troubleshooting and slow recovery from failures. 

Active System Manager dramatically improves accuracy of infrastructure configuration by reducing 
manual touch points. If an unexpected error (such as a hardware fault) occurs or if business needs change, 
Active System Manager enables rapid and smooth workload migration, thereby improving recovery time. 

Active System Manager also enables better infrastructure management decisions through user workloads 
and multi-level graphical views of infrastructure templates. These capabilities enable an IT administrator 
to make better decisions up front and troubleshoot problems more effectively if they do occur, thereby 
minimizing unexpected downtime and improving recovery time.
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The Active System Manager, enhances the functionality of Active System Manager by providing a more 
complete, end-to-end automation solution for both physical and virtual resources. The software enables a 
cloud like environment, and support pre-built provisioning templates and custom orchestrated workflows 
for a wide range of physical or virtual environments.

It offers the ability to: 

• Enhance the discovery and inventory of all components across multiple Active Systems.

• Create and manage the capacity of resources and resource pools spanning multiple systems.

• Simplify adding new or existing infrastructure resources to the resource pools, with an extensive 
plug-and-play capability.

• Automate template-based provisioning and de-provisioning of multi-VM workloads (along with the 
required virtual networking and storage capabilities).

• Create and publish infrastructure templates.

• Associate multiple custom and flexible orchestrations for end-to-end life cycle management of 
workloads.

• Schedule, allocate, and ensure the capacity for complex workloads at current or future times.

• Provide an Infrastructure as a Service (IaaS) portal for the IT administrator.

Table 1-1 Features and Benefits

Features Function Benefit

Inventory • Discovery and management of 
resources.

• Accelerates the manual and often 
laborious process of discovering and 
providing an inventory of new 
infrastructure.

Automation • Fully automated provisioning of 
end-to-end physical and virtual 
infrastructure, using a visual 
drag-and-drop authoring interface.

• Ensures a solid, high quality foundation 
for new workloads.

• Speeds up the deployment of new 
infrastructure.

Orchestration • Pre-built and custom-orchestrated 
provisioning workflows for fine-grained 
control of provisioning methods and 
policies, for setup, run-time, and 
tear-down.

• Pre-built workflows offer straight 
forward guidance based on best 
practices.

• Customization offers flexibility required 
for unique enterprise needs.

Scheduling and 
Allocation

• Advanced scheduling and reservation 
system for highly efficient allocation of 
resources and guaranteed resource 
commitments.

• Ensure business, and in turn their 
applications, get prioritized access to 
the resources they demand, and pay 
for.

• Drive efficiency in the datacenter by 
minimizing oversubscription of costly 
resources.

Enterprise Integration • LDAP/AD capabilities and role-based 
access control for enterprise 
management.

• Simple and efficient integration with 
enterprise resources.

Capacity Optimization • Unified management of both physical 
and virtual resources, along with 
capacity-based scheduling capabilities.

• Provides optimized resource allocation 
and ensures high asset utilization.
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Active System Manager supports two different roles: users and administrators. Roles are associated to a 
user profile; for more information, see Chapter 4, “User Profile Management.” Each role comes with a 
specific set of built-in permissions. Those permissions are not configurable contrary to those that you can 
set in the user profile. 

The administrator has more access to a larger set of functionality within the Active System Manager 
system. The role of the Active System Manager administrator includes all of the capabilities of the Active 
System Manager user, because the administrator may also be a user, and can also extend them by including 
additional responsibilities for inventory management, Template management and sessions, and report 
management.

For example, the Active System Manager administrator can perform the following functions (not available 
for standard users):

• Manage resource types and instances, including resource pools

• Define user groups and permissions 

• Define and manage software repositories

• Access and manage all templates

• Configure system-wide session notifications and reminders

• Access and manage all sessions

• Start and stop ASAP Rescheduling along with other associated properties

• Manage Archive Bins and rules for both templates and sessions 

Table 1-2 lists and describes the Active System Manager administrator tasks.

Table 1-2 Active System Manager Administrator Tasks 

Task Description

Installing, upgrading, 
and uninstalling the 
Active System Manager 
software

Typically, the Active System Manager administrator is responsible for installing, upgrading, and uninstalling 
the Active System Manager client and server software. The administrator owns the <Active System 
Manager _home> directory, where the Active System Manager server software is installed. The Active 
System Manager administrator makes the Active System Manager server available to all users. The Active 
System Manager client software is designed to be installed by all Active System Manager users on their 
client hardware platforms. 
For information on how to install and configure the Active System Manager server software, see the Active 
System Manager Server Installation Guide.
For information about installing the Active System Manager client software, see Chapter 2, “Getting Started.”

Consulting the Active 
System Manager user 
community

Configuring the Active System Manager software can be a complex and time-consuming task, depending on 
the level of customization required in your organization. Further, because the Active System Manager 
software addresses the needs of many different types of users—from individual environment users to 
department managers—there can be several different interpretations of how best to configure the 
environment, depending on the tasks the user needs to perform and the user’s role in the organization. 

Consulting the Active 
System Manager user 
community

Before modifying the Active System Manager environment, the Active System Manager administrator should 
consult with environment planners, environment developers, QA managers, and other key members of the 
testing team, to determine what site-specific changes and customizations are needed. In general, it is best to 
install the product, then implement, and test system-wide changes before deploying the product for general 
use.

Integrating the Active 
System Manager 
software with other 
products

The Active System Manager administrator is responsible for installing integrations with third-party products. 
The Active System Manager software integrates with configuration management tools (ClearCase and 
Concurrent Versions Systems [CVS]).
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Managing inventory The Active System Manager administrator is responsible for building and managing the environment’s 
resource inventory, which includes the various general resource types within your environment, as well as 
specific instances that require a particular configuration for a particular piece of network equipment. 
The administrator uses the Active System Manager application to define and catalog the specific types of 
equipment interfaces, and each general type of network hardware in the environment. 
For more information about how to manage the inventory, see Chapter 5, “Inventory Management.”

Managing Active System 
Manager templates and 
sessions

The administrator can use the Active System Manager application and all of the functions to create, update, 
save, validate, schedule, and delete templates. In addition, the administrator can cancel or edit present or 
future sessions of other users, or delete past sessions. 
The administrator can set up system-wide Archive Bin rules. 
For more information about Archive Bin rules or how to manage templates and sessions, see Chapter 9, 
“Session Management.”

Creating administrator or 
custom reports

The Active System Manager software includes a set of pre-defined, web-based support that has the ability to 
create administrator-specific reports, and provides the ability for administrators to create and generate 
custom, BIRT-based reports. 
For more information, see Chapter 11, “Working with Test and Script Execution.” 

Managing security 
privileges

The Active System Manager administrator has many built-in permissions, separate from the user role. 
For more information about the built-in permissions, see Table 4-1 on page 4-19. 

Table 1-2 Active System Manager Administrator Tasks (continued)

Task Description
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Active System Manager User Interface Elements

The Active System Manager user interface elements contains the following:

• Active System Manager Software Menu Options

• Perspectives

• Views

• Editors

• Preferences

• Icons

Active System Manager Software Menu Options
Table 1-3 lists and describes the available Active System Manager software menu options.

Table 1-3 Active System Manager Menu Options 

Menu Description

File Allows you to perform the following functions:
• Create new resources, templates, instances, inventory 

import plug-ins, sessions, and types.
• Close and save elements related to your network.
• Revert, move, rename, refresh, and print elements within 

your network.

• Connect to an Active System Manager server.
• Import a CSV and export the resources, templates, 

Resource Adapters, user repositories, provisioning 
repository elements, etc. in your network.

• View the properties for a given element.
• Exit the Active System Manager software.

Edit Allows you to perform undo, redo, cut, copy, paste, delete, select all, and find/replace functions.

View Note: The View menu is only available on the Session and 
Template perspectives when a Template or session editor is 
open.
Allows you to perform the following functions:
• Enlarge the focus of your view workspace by zooming in, 

or by clicking the Zoom icon.
• Decrease the focus of your view workspace by zooming 

out.

• Align your Template using a grid format, or by clicking the 
background of a Template editor, right-clicking, and 
selecting Layout. Note: You cannot customize a grid 
size.

• Snap your Template into place.

Navigate Allows you to navigate through all types of editors and resource types by going back, forward, next, or previous. 

Tools Allows you to access the following features:
• Links > Edit or Show
• Interface Types
• Login Profile > Delete > Save As
• Purge Sessions
• Archive Bin Rules > Run or Edit
• Discovery > Setup or Start or Stop
• Repositories

• Domains (displays the domain details configured with the 
system.

• Authentication Repositories (lists the LDAP or NIS 
repository associated with the system)

• Resource Pool Management
• Users and Groups 
• Maintenance Window
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Perspectives
Each Active System Manager application window contains one or more perspectives. A perspective defines 
the initial set and layout of views in the application window. Within the window, each perspective shares 
the same set of editors. Each perspective provides a set of functionality aimed at accomplishing a specific 
type of task or works with specific resource types. As you work in the application, you will likely often 
switch perspectives.

Perspectives control the layout of the user interface for the Active System Manager product; they define 
which views are displayed and their positions on screen. You can customize a perspective and use it at a 
future time; for more information, see the “Navigating Perspectives” section on page 1-8. To set 
preferences for your perspectives, see the “Modifying Perspective Preferences” section on page 1-7.

Note You can set your general preferences to open perspectives in the same window or in a new window.

Table 1-4 outlines the “out of the box” perspectives and the tasks that you can perform with each 
perspective.

Reports Allows you to perform all of the functions to create and print reports for your inventory (in alphabetical order, not functional 
order):

• Control Equipment Summary Report
• Custom Reports
• Detailed Session Report
• Group Management Report*
• Inventory Link Detail Report
• Managed Equipment Detail Report

• Managed Equipment Summary Report
• User Management Report*
• Service Profile Usage Report
• Session Audit Report

Window Allows you to perform the following functions:
• Navigate between the various Active System Manager views, editors, perspectives, and menus. 
• Customize and work with your perspectives
• Set preferences for elements used in your network.

Help Provides help and the search function for using the Active System Manager software.

Table 1-4 Tasks for Each Perspective 

Perspective Preferred Task Chapter Reference

Inventory Managing inventory. Chapter 6, “Using Inventory.”

Provisioning Managing the visibility of each repository 
content, particularly related with operating 
system (OS) images and configuration files.

Chapter 7, “Repository Management”

Template Managing templates and scheduling. Chapter 8, “Template Management”

Session (default) Managing sessions, interacting with equipment, 
and executing test cases.

Chapter 9, “Session Management”

Table 1-3 Active System Manager Menu Options (continued)

Menu Description
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The following topics describe the functions available for perspectives:

• Modifying Perspective Preferences

• Opening Perspectives

• Navigating Perspectives

• Customizing Perspectives

• Saving Your Perspective As

• Resetting Perspectives

• Closing One or All Perspectives

• Deleting Perspectives

Modifying Perspective Preferences
Perspective preferences are set by default; however, you can modify them at any time by performing the 
following steps:

1. On the Active System Manager menu bar, click Window > Preferences > General > Perspectives to 
display the Preferences—Perspectives dialog box.

2. Modify the preference settings, as appropriate; see Table 1-11 on page 1-36.

3. Click Apply > OK to accept the settings.

Opening Perspectives
To open a perspective, perform the following steps:

1. Open the Open Perspective dialog box by one of the following methods:

• On the Active System Manager toolbar, click the Open Perspective icon and select a visible 
perspective or click Other.

• On the Active System Manager toolbar, click the icon that represents the perspective you select to 
open.

• On the Active System Manager menu bar, click Window > Open Perspective and select a visible 
perspective or click Other.

2. Select the perspective to open and click OK to display the perspective within the application 
environment. 

Test Controls the layout of the user interface the 
Active System Manager software uses to display 
information for your test cases, including which 
views are displayed and their positions within the 
Active System Manager software. 

Chapter 11, “Working with Test and Script 
Execution”

Table 1-4 Tasks for Each Perspective (continued)

Perspective Preferred Task Chapter Reference
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Navigating Perspectives
You can use the standard procedure to open a perspective, but if you are in a working state and want to work 
with an existing perspective, you can navigate to a previous or next perspective. To do so, perform one of 
the following tasks:

• On the Active System Manager menu bar, click Window > Navigation > Next Perspective.

• On the Active System Manager menu bar, click Window > Navigation > Previous Perspective.

By default, the Session perspective displays on the perspective toolbar. To view additional default 
perspectives (Test, Template, Provisioning, and Inventory), with your mouse, grab the perspective toolbar 
tab and slide it to the left.

Customizing Perspectives 
You can customize perspectives based on your workflow. By default, when you launch the Active System 
Manager software, the last perspective you worked with opens.

To customize a perspective, perform the following steps:

1. Open or switch to the perspective you want to customize; see the “Opening Perspectives” section on 
page 1-7.

2. Optional. Lock the perspective toolbar by right-clicking the Active System Manager toolbar and 
selecting Lock the Toolbars. 

The Active System Manager software locks the toolbars until you unlock them by repeating this 
process.

3. Select a method to open the Customize Perspective dialog box:

• On the Active System Manager menu bar, click Window > Customize Perspective

• Right-click the Active System Manager toolbar and select Customize Perspective.

• On the Active System Manager toolbar, select a perspective, right-click and select Customize.

The Customize Perspective dialog box displays with the Shortcuts tab open by default. However, the 
Tool Bar Visibility, Menu Visibility, Command Groups Availability tabs are all functional in 
customizing a perspective. 

• The Tool Bar Visibility tab allows you to select (and organize) which toolbar menu options to 
display on the Active System Manager toolbar for the specified perspective. 

• The Menu Visibility tab allows you to select (and organize) which menu options to display for the 
specified perspective. 

• The Command Groups Availability tab allows you to select (and organize) the command groups 
to display with the specified perspective. When you select a command group, the menu bar toolbar 
details display, respective to the selected command group.

The Shortcuts options control the items that are available on the File > New > Window > Open 
Perspective and Window > Show View menus. 

4. Select the shortcuts to add as cascade items to the submenus displayed in the Customize Perspective 
dialog box.

Your selections only affect the current perspective.
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5. Click the Command Groups Availability tab and select the command groups that you want the Active 
System Manager software to add to the perspective. 

6. Click the Toolbar Visibility tab to organize how you want to view the Active System Manager toolbar 
options.

7. Click the Menu Visibility tab to control which menu options to display on the Active System Manager 
menu bar.

Note These tab options control the visibility of the menu items in the left panel. If you deselect these 
items, they become unavailable for use.

8. Click OK. 

Saving Your Perspective As
If you have modified a perspective by adding, deleting, or moving views, or if multiple users are using the 
same computer and have different preferences, you can save your changes for future. To do so, perform the 
following steps:

1. Select a method to open the Save Perspective As dialog box:

• On the Active System Manager menu bar, click Window > Save Perspective As.

• On the Active System Manager toolbar, select a perspective, right-click and select Save As.

2. Click the Name field and type a new name for the perspective, or click a perspective from the Existing 
Perspectives list to automatically display in the Name field. 

3. Click OK to add the name of the new perspective to the Window > Open Perspective > Other menu.

Resetting Perspectives
To reset your current perspective back to its default, associated views with the original count, and 
positioning and layout, perform the following steps:

1. Select a method to open the Reset Perspective dialog box, thus prompting you to accept the reset 
function:

• On the Active System Manager menu bar, click Window > Reset Perspective. 

• On the Active System Manager toolbar, select a perspective, right-click and select Reset. 

A prompt displays asking to reset the selected perspective to its default.

2. Click OK.

The reset takes effect the next time the perspective is opened.

Note You can also reset the perspective by modifying the perspective preferences: On the Active System 
Manager menu bar, click Window > Preferences > General > Perspectives to display the 
Preferences—Perspectives dialog box. Click Reset (see Table 1-11 on page 1-36 for details), and 
click Apply > OK to accept the settings.
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Closing One or All Perspectives
To close a perspective (or all perspectives), select one of the following methods:

• On the Active System Manager menu bar, click Window > Close Perspective or click Window > 
Close All Perspectives.

• On the Active System Manager toolbar, select a perspective, right-click and select Close.

Deleting Perspectives
To delete a perspective, perform the following steps:

1. On the Active System Manager menu bar, click Window > Preferences > General > Perspectives to 
display the Preferences—Perspectives dialog box; see Figure 2 on page 1-7.

2. In the Available perspectives section, select the perspective to delete and click Delete > Apply > OK.

The resetting of the available perspectives take effect the next time the perspective is opened.

Note You cannot delete the built-in perspectives (the Delete button is disabled), but you can delete any 
custom perspectives that you create.

Views
Views support editors and provide alternative presentations and methods to navigate the information in 
your application. Here are the key features of views:

• Views have their own menus and some views also have their own toolbars. The actions represented by 
buttons on view toolbars only affect the items within that view.

• A view can appear by itself, or stacked with other views in a tabbed notebook. 

• You can change the layout of a perspective by opening and closing views and by docking them in 
different positions in the application window.

Note You can refresh the data displayed within views and editors by one of the following methods:

• Right-click the view and select Refresh.

• Select the view and press F5.

• Click File > Refresh.

Table 1-5 lists the views available in the Active System Manager software, grouped by perspective. For 
more information about perspectives, see the “Preferences” section on page 1-27.
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Table 1-5 Views Associated with Perspectives

Perspectives

Inventory Provisioning Template Session Test

Default 
Views

• Resource Types
• Resource 

Instances
• Operation Center
• Outline
• Properties

• Resource Adapters
• File Server
• Source Control
• Software 

Repository

• Components
• Templates
• Resource Types
• Resource Instances
• Properties
• Outline

• Sessions
• Execution Queue
• Templates
• Properties
• Outline

• Sessions
• Execution Queue
• Test Cases
• Resource Scripts
• Properties

Other 
Views

• Templates
• Discovery Explorer
• Import Explorer
• Search
• Links
• Dependencies
• Resource 

Allocation
• Resource Port 

Allocation 
• Custom 

Operations
• Components

• Resource Adapters • Template Archive Bin
• Search
• Palette
• Sessions
• Components

• Search
• Active Terminals
• Terminal
• Console
• Palette
• Sessions
• Session Archive Bin

• Search
• Terminal
• Outline
• Execution Output

The following sections provide more detail about views:

• Using Navigator Views

• Opening Navigator Views

• Navigating Through the Views

• Creating Views

Using Navigator Views
The navigator views provide a hierarchical view of the resources in the Active System Manager 
application, which is where you can open files for editing or select resources for operations, such as 
exporting. Figure 1-1 displays an example of a generic navigator view.

Figure 1-1 Navigator View Example

For a graphical representation of the application icons that are available on a navigator view.
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To open a pop-up menu that allows you to perform operations (such as filtering, grouping, creating a new 
view, expanding or collapsing the view), right-click any resource in a navigator view and select the menu 
that best suits your needs. For more information about opening views, see the “Opening Navigator Views” 
section on page 1-16.

To see a description of each menu’s function, move the selection highlight to that menu item and press the 
context-sensitive help key (for example, press F1).

To display a system menu on a view that is currently open, click Window > Navigation > Show System 
Menu.

All navigator views support the Filters and Group By functions; that is, they have built-in system filters that 
you can customize. Depending on the view, you can filter and group by different properties. For more 
information about these functions, see the “Filtering” section (below) and the “Grouping” section on 
page 1-15.

Filtering 
You can use the filter to display a preferred subset of the entries in a list. Editors that allow filtering have 
the Filters icon available. You use the Filters feature to specify filters that forces the Active System 
Manager application to only display the resource type and resource instance information that you require 
within the associated views. 

Each view comes with a set of built-in filters. These filters screen resources based on their defined roles. 
The list of pre-defined filters cannot be removed and their status (disabled vs. enabled) can change based 
on the user or administrator profile role. For more information about these pre-defined filters, see 
Chapter 6, “Using Inventory.”

To access the filter options or change the way the resource type and resource instance information is 
displayed, perform one of the following methods:

• In the navigation view, click the Menu icon and select a filter type.

• In the navigation view, click the Filters icon and the Filters dialog box displays with a list of filter 
options in the left pane.

For more information, see the “Accessing Resources via the Filters Dialog Box” section on page 6-8.

As an added feature, user role-based users now have their default inventory views (types and instances) 
automatically set with the Filters > Managed Equipment filter enabled (checked).

The following topics describe filtering functions:

• Creating a Filter

• Adding Rules to a Filter

• Deleting Rules and Filters
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Creating a Filter
Creating a filter is a two-step process: creating a filter and then adding rules to the filter.

To create a filter, perform the following steps:

1. Click the Filters icon within the top-right toolbar area of the perspective or view. 

The Filters dialog box displays an example from the Session perspective—Template view; see 
Figure 1-2. Each perspective has their own unique display.

Figure 1-2 Filters Dialog Box 

2. In the All filters section, click Add. 

By default, this creates an empty filter called “Filter1”. 

3. Select the default name and enter a new filter name.

4. Define your filter by setting your rules using the Filter rules section (see right pane in Figure 1-2) using 
the Add or Delete button, as appropriate. 

For more information about adding and deleting rules for a filter, see the next sections, “Adding Rules 
to a Filter” and “Deleting Rules and Filters,” respectively.

Note Users cannot modify built-in filters. You can only enable or disable the default filters by clicking to 
select or deselect a specific filter.

5. Click to select (or deselect) the check box next to the filter name to turn it on and off.

Adding Rules to a Filter
To add rules to a filter, perform the following steps:

1. Click the Filters icon to open the Filters dialog box; see Figure 1-2.

2. In the Filters rule section, click Add. 

There are three fields to modify, to add a rule. 
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3. Select a property and an operator. 

The list of operators will change based on the property type. The parameters available in the Property 
field vary, depending on what dialog box you access. 

4. Set a value. 

The Value field contains any text string or numeric value that you want to filter. 

5. Press Ctrl+Spacebar to view the available data in the database.

6. Repeat step 1 to step 5, as needed.

Table 1-6 describes the values for each filter rule. These parameters represent fields in the database for 
each type of equipment. 

Table 1-6 Filter Rules

Property Type Operator Value

String contains The entry must contain the value string anywhere in the field.

does not contain The entry must not contain the string anywhere in the field.

is The value string must match the entry exactly.

is Not The value string must not match the entry.

starts with The entry must match value string from the first character.

ends with The entry must match value string to the final character.

Numeric or Date is equal to • For the numerical property type—The value is equal to the 
entry. 

• For the date property type—The date is equal to the date set.

less than • For the numerical property type—The value is less than equal 
to the entry.

• For the date property type—The date is earlier than the entry.

less than or equal to • For the numerical property type—The value is less than or 
equal to the entry.

• For the date property type—The date is earlier than or the 
same date as the entry.

greater than • For the numerical property type—The value is greater than the 
entry.

• For the date property type—The date is later than the entry.

greater than or equal to • For the numerical property type—The value is greater than or 
equal to the entry.

• For the date property type—The date is later than or the same 
as the entry.

The modifier options are defined as follows:

• Match All—Functions the same way as the AND logic feature. All of the rules must be met before the 
entry displays.

• Match Any—Functions the same way as the OR logic feature. If any of the rules are met, then the entry 
displays.
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Deleting Rules and Filters
To delete a filter or rule, select the associated rule or filter, and click Delete. 

Note You can only select more than one rule to delete; however, you can only select one filter at a time 
to delete.

Grouping 
The Group By function allows you to modify the way entries, such as resource types or resource instances, 
are presented in the navigator pane, or to group entries, based on various properties. Without any grouping 
options selected, the entries are group based on their basic elements. In the case of resource instances, they 
are listed by their name. 

The Active System Manager software screens the items you want to display by grouping and the order that 
they are presented by sorting alphabetically. Clicking the Group By icon reverses the current alphabetical 
sort order. 

To use the Group By function, perform the following steps:

1. Select one of the following methods to open the Group By dialog box (see Figure 1-3 for an example):

• Click the navigator view action bar and click the Group By icon. 

• Click the Menu icon and select Group By.

Figure 1-3 Group By Dialog Box

2. In the Available properties section, select the properties to associate with your working session.

3. In the Selected properties section, click Up and Down to modify the hierarchy of the entries. 

If you select more than one property, the navigation tree is resolved based on the hierarchy you select. 
For example, if you group first by Role and then by Model, the result is a list of roles with pertinent 
models in the subfolders. Alternatively, if you group first by Model and then by Role, the result is a list 
of each model type with the pertinent roles in the subfolders.

4. Click OK.
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Opening Navigator Views
To open a navigator view, on the Active System Manager menu bar, click Window > Show View and select 
one of the views. For a list of all available views by perspective, see Table 1-5 on page 1-11.

Navigating Through the Views
You can use the standard procedure of opening a view, but if you are in a working state and want to work 
with an existing view, you can navigate to a previous or next view:

• On the Active System Manager menu bar, click Window > Navigation > Next View.

• On the Active System Manager menu bar, click Window > Navigation > Previous View.

To minimize or maximize a view, perform one of the following options:

• In the active view, click the Maximize icon; or, on the Active System Manager menu bar, click Window 
> Navigation > Maximize Active View or Editor. To restore it back to its original view, click the 
Minimize icon.

• In the active view, click the Minimize icon; or, on the Active System Manager menu bar, click Window 
> Navigation > Minimize Active View or Editor. To restore it back to its original view, right-click the 
editor and select Minimize.

Creating Views
This section explains how to create the following views:

• Creating a New View

• Creating a Fast View

• Creating a Detached View

Creating a New View
To create a new view, perform the following steps:

1. On the Resource Types or Resource Instances view toolbar, click the down-arrow icon.

The toolbar menu displays the available commands; see Figure 1-4 for an example.
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Figure 1-4 Resource Instances View—New View Menu

Down-arrow icon

New View menu

2. Click New View to display the new view on the same view toolbar as the original. You can drag the new 
view to any part of the user interface.

3. Add any filtering, grouping, or sorting to the new view.

4. On the Active System Manager menu bar, click Window > Save Perspective As to save the 
perspective.

5. Click the Name field and type a new name for the perspective, or click a perspective from the Existing 
Perspectives list to automatically display in the Name field. 

6. Click OK to add the name of the new perspective to the Window > Open Perspective > Other menu.

Creating a Fast View
A fast view is hidden and can be quickly opened and closed. It works like other views, except that it does 
not take up space in your Active System Manager window. A fast view is represented by toolbar buttons 
on the fast view action bar, the horizontal toolbar, on the bottom left of the Active System Manager window. 
When you click the toolbar button for a fast view, that view opens temporarily in the current perspective. 
When you click outside that view, it is hidden again. 

To create a new fast view, click and drag any open view to the shortcut bar, or right-click the icon to the 
left end of the view’s title bar and select Fast View.

You can dock the fast view bar on the right and left side of the Active System Manager window by 
right-clicking the bottom, left corner and selecting the location.

Creating a Detached View
A detached view is a view that displays as a standalone, separate window. To create a detached view, 
right-click a view and select Detached; see Figure . To cancel or return to the previous program, right-click 
the detached view and select Detached. 
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Editors
Review the following tasks for using editors:

• Opening Files for Editing

• Activating Editors

• Modifying Editor Preferences

• Tiling Editors

• Changing the Tab Placement for Editors

• Maximizing, Minimizing, or Restoring the Editor Workspace

• Navigating Editors

• Using Multi-Editor Functions

• Context Menu Options Using Right-Mouse Click

An editor is a pane that modifies data or objects. The Active System Manager application contains all 
documents that are open for modification. Most perspectives are comprised of an editor area and one or 
more views.

Below are some basic guidelines to follow that can help you navigate more easily:

• You can associate different editors with different types of files. For example, when you open a file for 
editing by double-clicking it in one of the navigator views, the associated editor opens in the 
application. If there is no associated editor for a resource, the Active System Manager application 
attempts to launch an external editor outside the application. 

• By default, 10 editors can be open, but only one can be active at a time (see Window > Preferences > 
General > Editors) in the The main menu bar and toolbar for the Active System Manager window 
contains operations that are applicable to the active editor. You can change the number of editors that 
can be open under the editor preferences. 

• The workspace can contain more than one Template, but you cannot drag views into the editor 
workspace. The editor remains constant, regardless of how you rearrange your views. Click any element 
in the editor and the views update to represent that element.

• Tabs in the editor area indicate the names of resources that are currently open for editing. An asterisk 
(*) indicates that an editor has unsaved changes. Click File > Save to commit your changes to the server. 
The File > Save All command commits all changes in all open editors to the server. If you have made 
changes to a resource and want to undo those changes, click File > Revert. This returns the resource 
configuration to the values stored on the server. (It is the same process as closing an editor without 
saving your changes and then re-opening it.)

Note You can refresh the data displayed within views by pressing F5.

• Editors modify the values for resource types, resource instances, and links. To switch between editors, 
press Ctrl+F6.
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Opening Files for Editing
You can open an editor for a given file in one of two ways:

• Right-click the file in one of the navigator views and select Open.

• Double-click the file in one of the navigator views.

Either option opens the file in the default editor for that file type. To open a file in a different editor, select 
Open With from the file’s pop-up menu.

Activating Editors
You can activate an available editor; on the Active System Manager menu bar, click Window > 
Navigation > Activate Editor.

Modifying Editor Preferences
The Active System Manager software has preferences that control how editors open, close and display 
resources. 

To modify editor preferences, perform the following steps:

1. On the Active System Manager menu bar, click Window > Preferences > General > Editors; see 
Figure 1-5. 

Figure 1-5 Preferences—Editors

2. Optional. Modify your preferences, as appropriate. For information about the configurable parameters, 
see the parameter descriptions in Table 1-11 on page 1-36.

3. Click Apply > OK.
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Tiling Editors
By default, editors are stacked in the editor area, but you can choose to tile them to view source files 
simultaneously. The Active System Manager application allows you to have multiple files open in multiple 
editors. Unlike views, editors cannot be dragged outside the application to create new windows. However, 
you can tile editor sessions, to view source files side by side. To do so, perform the following steps:

1. With two or more files open in the editor area, select one of the editor tabs.

2. Holding down the left-mouse button, drag the editor over the left, right, top, or bottom border of the 
editor area. The mouse pointer changes to a drop cursor that indicates where the editor session will be 
moved when you release the mouse button.

3. Optional. Drag the borders of the editor area or each editor, to resize as needed.

Changing the Tab Placement for Editors
The tabs for stacked views or editors can appear at the top or bottom of the area that contains them. To 
change the placement of the tabs, perform the following steps:

1. On the Active System Manager menu bar, click Window > Preferences > General > Appearance to 
display the Preferences—Appearance dialog box; see Figure 1-6.

Figure 1-6 Preferences—Appearance

2. In the Editor tab and View tab positions options, select from the options displayed to arrange the tabs 
at the top or bottom.

3. Click Apply or OK to automatically move the tabs to their new locations.
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Maximizing, Minimizing, or Restoring the Editor Workspace
To maximize or minimize the editor workspace, perform one of the following options:

• In the editor workspace, click the Maximize icon; or, on the Active System Manager menu bar, click 
Window > Navigation > Maximize Active View or Editor. To restore it back to its original view, click 
the Minimize icon.

• In the editor workspace, click the Minimize icon; or, on the Active System Manager menu bar, click 
Window > Navigation > Minimize Active View or Editor. To restore it back to its original view, 
right-click the editor and select Minimize.

To restore the editor workspace back to its original state, double-click the editor tab twice.

Navigating Editors
The Active System Manager software allows you to navigate editors via the submenu options on the 
Window > Navigation menu.

The Navigation menu options for editors include:

• Maximize Active View or Editor—Allows you to maximize the active view or editor.

• Minimize Active View or Editor—Allows you to maximize the active view or editor.

• Activate Editors—Displays the active editor for your working Template or session.

• Next Editor—Displays the next editor within your working Template or session.

• Previous Editor—Displays the previous editor within your working Template or session.

• Quick Switch Editor—Allows you to switch from one editor to another.

Using Multi-Editor Functions
Multi-editors allow you to manage large amounts of editors in a spreadsheet-like manner; that is, you can 
manipulate rows and columns to perform bulk-like operations. 

The multi-editor is an advanced feature that lets you create multiple copies of resource types, or resource 
instances, simultaneously. The multi-editor modifies all of the core properties, except for Manufacturer, for 
multiple resource types; for resource instances, it modifies all of the core properties, except for 
Manufacturer, Model, Asset Tag, and Version. The Role property is modifiable for CRIs, but only if they 
are Version zero (v0). A CRI is v0 until it has an availability time assigned to it; then it becomes Version 1 
(v1).

To use the multi-editor, perform the following steps:

1. Right-click the content you want to view and select Open with Multi-Editor. 

You can select a single record, multiple records, a folder and all of its records, multiple folders, or 
multiple sub-folders within different branches. You may also open multiple instances of the 
multi-editor.

2. Make your changes to the fields. 

You can modify any field except for Manufacturer. Use the Fill feature (see the “Fill Feature” section 
on page 1-24) to create new content, or to create multiple field values.
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3. Delete content from the database, by highlighting records and selecting either Edit > Delete, using the 
Delete option on the right-click menu, or pressing the Delete or Backspace key.

Note You must resolve any existing dependencies before you delete the record.

4. Save your changes to the database, either by selecting File > Save, or right-clicking and then selecting 
Save.

5. Optional. Discard your changes by closing the multi-editor without saving your changes, or 
right-clicking and selecting Revert. 

The multi-editor manages the following functions:

• Column Header Functionality

• Icon Overlays

• Pasting Functions

• Drag-and-Drop

• Fill Feature

• Context Menu Options Using Right-Mouse Click

Column Header Functionality
When viewed in the multi-editor, the resource types and resource instances display in a tabular format, 
similar to a spreadsheet. The column headers support menu options for sorting and hiding the columns. The 
sort order for each column can be switched from ascending to descending with the right-click menu, or by 
left-clicking the column header. The Hide menu controls what columns are visible in the multi-editor. Use 
the Hide and Show options to control the column display. You can rearrange the columns by dragging the 
headers with your mouse pointer. 

In addition, you can create new columns for the configuration parameter and inventory parameter values, 
and then use the special Paste or Fill functions to populate the fields, which is effective at ensuring global 
consistency for these values. 

Icon Overlays
The icon overlays are unique to the multi-editor. The plus sign (+) signifies that the record is new and has 
not been saved to the database. The minus sign (-) signifies that the record has been marked for deletion 
from the database. The asterisk (*) signifies that the record exists in the database and has been modified in 
the multi-editor, but those changes have not yet been saved to the database. When you save your changes 
to the database, these options go into effect and the icon overlays disappear. For a listing of icon overlays, 
see Table 1-11 on page 1-36.
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Pasting Functions
The multi-editor supports the cut, copy, and paste functionality of a Windows clipboard, but there are 
several restrictions for the Paste function:

• The most common restriction is that if an entire record has been copied to the clipboard, the first column 
must be selected before the Paste option can function. 

• Alternatively, if only a single field resides in the clipboard, only a single field can be selected before the 
Paste option can function.

Note When pasting multiple rows or columns of values, the Active System Manager software clears the 
contents of the clipboard after each paste.

You can paste a column of data from another Windows program into a multi-editor column. For example, 
Figure 1-7 displays a spreadsheet used as a source and the resulting changes to the multi-editor column.

Figure 1-7 Pasting Columns Example

It is not necessary to select the entire target range in the multi-editor; you can select a single field as a target; 
however, the information is pasted from left to right and from top to bottom, so the field should be the 
top-left corner.

You can paste multiple columns of values into the multi-editor in a similar manner as pasting a single 
column (see Figure 1-8), but there are some restrictions. Some multi-editor columns (such as 
Manufacturer) are read-only; therefore, the source must be formatted correctly. For spreadsheets, you must 
leave a blank column within your selection for the read-only column. Any values that attempt to paste into 
a read-only multi-editor columns are automatically discarded. 

Figure 1-8 Pasting Multiple Columns Example
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Sometimes you need to enter dummy values for the read-only columns. When working with text programs, 
such as Notepad or Word, each value must be separated by tabs. Figure 1-9 display the “ReadOnly” string 
bracketed by tabs. When this text is pasted into the multi-editor, the “ReadOnly” values are discarded and 
the other values are pasted into the proper columns.

Figure 1-9 Text-Based Information Example

Drag-and-Drop
The multi-editor supports the drag-and-drop function from navigator views. You can select one or more 
items and drag them into an open multi-editor; however, you cannot drag-and-drop a group. 

Fill Feature
The multi-editor includes a Fill feature that is similar to the fill function available in some popular 
spreadsheets. Using the Fill feature, you can insert an entire series of values for any column that is not 
read-only. You can duplicate the entry for a single cell across the entire column, or generate a series of 
labels with incremental numbering. The Fill menu is accessible by right-clicking any field within the 
multi-editor. 

The Fill > Up option creates field values based on the field at the bottom of the selection; see Figure 1-10. 

Figure 1-10 Fill > Up Option Example

Before After

The Fill > Down option creates field values based on the field at the top of the selection; see Figure 1-11.
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Figure 1-11 Fill > Down Option Example

Before After

The Fill > Series option creates field values based on the difference between the numeric values in the first 
two fields. For example, if “Name00” is in the first record and “Name05” is in the second record, the 
subsequent records are called “Name10”, “Name15”, “Name20”, and so on; see Figure 1-12.

Figure 1-12 Fill > Series Option Example

Before After

A negative numerical difference generates numbers going down, and generates negative numbers, such as 
“Name05”, “Name00”, “Name-05” and so on. All discrete numeric values are generated. For instance, if 
the values “Test20Test” and “Test30Test” are used, the fields are populated; see Figure 1-13.

Figure 1-13 Fill > Series Option Example 2

Additionally, using more than one numeric value is legal. For example, if the values “10Test1000” and 
“20Test999” are used, the fields are populated; see Figure 1-14. The only limitation is that the numeric 
values must be separated by at least one alphanumeric character.
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Figure 1-14 Fill > Series Option Example 3

Note The Fill > Series option only works from the top of the selection to the bottom. To use this option 
going upwards: 1) switch the sort order to force the column to list in descending order, 2) create the 
values, and 3) then switch back to ascending order.

Context Menu Options Using Right-Mouse Click
Most of the functionality of the multi-editor is accessed through the right-click menu. Right-click any field 
within the multi-editor to access these options. Table 1-7 lists the context menu options using right-mouse 
click.
Note The multi-editor for resource types is similar to the multi-editor for resource instances, but they are 

not identical. The layout and settings are consistent from session to session. If you change the sort 
order, or hide any columns, those options remain in effect until you reverse them. However, the 
layout settings for the resource instances’ multi-editor are separate and persistent in their own right.

Table 1-7 Context Menu Options Using Right-Mouse Click 

Menu Description

Open Opens each selected row in a separate editor. You may open multiple editors simultaneously this way.

Cut Cuts the text of the selected field to the clipboard. If you select a row, the entire row content is cut to the clipboard and is 
available to paste over another row. You can cut, copy, or paste multiple rows simultaneously.

Copy Copies the text of the selected field to the clipboard. If you select a row, the entire row content is copied to the clipboard 
and is available to paste. You can cut, copy, or paste multiple rows simultaneously.

Paste Pastes the contents of the clipboard to the field or row. You can cut, copy, or paste multiple rows simultaneously.

Fill > Up If you highlight a number of fields in a single column and select Fill > Up, the contents of the field at the bottom of the 
selection is copied to all of the other records. 

Fill > Down If you highlight a number of fields in a single column and select Fill > Down, the contents of the field at the top of the 
selection is copied to all of the other records. For more information, see the “Fill Feature” section on page 1-24.

Fill > Series If you highlight multiple fields in a single column and select Fill > Series, the fields are populated based on the numerical 
difference between the first two fields. For more information, see the “Fill Feature” section on page 1-24.

Insert 
Before

Inserts a blank resource type above the currently selected row and copies the Manufacturer value. Unique Name and 
Model values are generated in the “name<##>” format, where <##> is the next highest numerical value available.

Insert After Inserts a blank row below the currently selected row and copies the Manufacturer value. Unique Name and Model values 
are generated in the “name<##>” format, where <##> is the next numerical value available.
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Preferences
In addition to configuring settings for your workspace environment and all the elements that comprise that 
environment, you can set user preferences by clicking Window > Preferences. The Preferences dialog box 
displays with a list of elements with which you can configure user preferences; see Figure 1-15.

Note The Active System Manager software automatically updates the UI display when you make changes 
via the Preferences dialog box; you do not have to restart the client.

Note All user preferences are saved on a local machine and the server, which allows users to keep their 
preferences on different computers or installations when using multiple clients. The only preference 
not stored on the server is the Account Name setting.

Insert 
Multiple

Works similarly to the Insert Before and Insert After options. It prompts you for the number of records you want to 
create, and then copies the Manufacturer value of the currently selected content.
Note: There is a Insert After check box. If this is enabled, the records are inserted below the current selection; if it is 
turned off, they are inserted above. The main difference for Insert Multiple is that the Name field and the Model field are 
automatically generated in the “name<##>” format, where <##> is the next numerical value available, in addition to 
copying the Manufacturer value. The number of records that can be generated is limited only by your computer's 
resources and your database configuration. 

Mark as 
Deleted

Marks the selected records for deletion. When changes are saved, the records are deleted from the database, assuming 
there are no dependencies. If the record has not been previously saved to the database, it is deleted without prompts.

Clear Clears the selected field or, if you have selected a row, it clears all of the fields except for Manufacturer, Model, and Role.

Drop Removes the selected row from the multi-editor without saving any changes.

Revert 
Selected 
Resources

Reverts the selected resources to their last saved configuration.

Save 
Selected 
Resources

Saves the changes for the selected resources to the database.

Revert Reverts all of the content in the multi-editor to their last saved configuration.

Save Saves all changes in the multi-editor to the database.

Table 1-7 Context Menu Options Using Right-Mouse Click (continued)

Menu Description
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Figure 1-15 Preferences Dialog Box (Default)

Table 1-8 describes the parameters you can configure for your user preferences, by preference type. The 
last column provides a figure reference, where you can view the dialog box and read how to configure the 
preference type setting.

Table 1-8 Preference Types—Configurable Parameters 

Preference Type Configurable Parameters and Description Reference

Archive Bin Filters & Filter Rules—Defines the filters and filter rules Active System Manager 
applies to templates and sessions to be moved into the Archive Bin. 

Figure 1-15 

Connectivity Driver Definitions—Allows you to add, edit, remove, or copy available driver 
definitions. 
Note: Used for BIRT reports only.
For more information about setting up connectivity, see Chapter 7, “Repository 
Management,” and Chapter 9, “Session Management.”

BIRT documentation

Resource 
Discovery

Allows you to select the domains to be used by the Discovery Engine. Chapter 5, “Inventory 
Management”

General • Always run in background—The Active System Manager software performs 
specific actions in the background without disturbing the user.

• Keep next/previous editor view and perspectives dialog open—Keeps the 
editor and view cycle dialog boxes open when their activation key is released. (In 
normal conditions, dialog boxes close as soon as the key combination is released.)

• Show Heap Status—Displays memory usage in the lower right corner of the 
interface.

• Double-click—Single clicking a resource selects it and double-clicking it opens it 
in an editor.

• Single click (select on hover)—Hovering the mouse cursor over the resource 
selects it and clicking it once opens it in an editor.
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General • Single click (open when using arrow keys)—Selecting a resource with the 
arrow keys opens it in an editor.

Note: Depending on which view has focus, selecting and opening a resource may 
have different behavior. This preference may not take affect on all views.

N/A

General > 
Appearance

• Lists the available, current presentation styles (look and feel):
• Classic Presentation
• Default
• UI Presentation (current)

• Override presentation settings—Overrides the presentation settings previously 
set by choosing a different presentation style.

• Editor tab positions—Specifies either top or bottom to indicate where you want 
tabs for stacked editors to appear.

• View tab positions—Specifies either top or bottom to indicate where you want 
tabs for stacked views to appear.

• Perspective switcher positions—Specifies the location of the perspective 
switcher bar.

• Current theme—Specifies the currently active theme (color and font set):
• Default (current)
• Reduced Palette
• Classic Theme

• Description—Allows you to provide a description for the settings you configure.
• Show traditional style tabs—Specifies whether traditional square tabs should be 

used in place of the curved tabs.
• Enable animations—Enables or disables the feature where views animate to their 

location when closed or opened.
• Use mixed fonts and colors for labels
• Show heap status

See the “Changing the 
Tab Placement for Editors” 
section on page 1-20 and 
Figure 1-6 on page 1-20

General > Display 
Options

Inventory
• Resource Types—Displays resource types by Name or Manufacturer & Model 

(default).
• Resource Instances—Displays resource instances by Name or Asset Tag 

(default).
• Resource Interfaces—Displays resource interface by Name or Location (default).
Session Calendar
• Display Session Label—Displays the session label by Session Name (default) or 

by Session Owner.
• Calendar Format—Displays a calendar format by Day (default), Week, Month, 

Quarter, or Year.
• Lock Horizontal Scrollbar—Allows you to lock the horizontal scrollbar.
Resource Allocation Calendar
Enables the Show Past Sessions feature to display past sessions. If you click this 
check box, you can also click to select the Show Archive Bin Sessions check box. 
Note: If you click these check boxes, it might impact application performance.
• Calendar Colors—The system administrator can disable this option by the system 

administrator by modifying the Active System Manager server configuration 
properties. If so, a message at the bottom of the screen will be available.

Note: For more information about setting colors in hexadecimal values (regarding 
the color configuration properties), refer to the following URLs:
• http://www.w3schools.com/Html/html_colors.asp
• http://www.w3schools.com/Html/html_colornames.asp

Chapter 6, “Using 
Inventory” and Chapter 9, 
“Session Management”

Table 1-8 Preference Types—Configurable Parameters (continued)

Preference Type Configurable Parameters and Description Reference
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General > Editors • Size of recently opened files list—For each file that is opened in an editor, it is 
stored in a list of recently used files. This option controls the number of files that 
display in this list at the bottom of the File menu. The default value is 4.

• Show multiple editor tabs—Allows more than one editor tab to display in your 
workspace. If active, you can specify the number of editors to open before they are 
recycled. 

• Restore editor state on startup—Restores the original settings for the editor.
• Prompt to save on close even if still open elsewhere—Save the editor when 

you close the application, even if an editor is open elsewhere.
• Close editors automatically—Specifies whether or not to recycle editors in the 

Active System Manager software. If active, you can specify the number of editors 
to open before they are recycled. The default value is 16. For example, if you have 
16 resources and you open a 17th resource, the first resource is closed. If it has 
unsaved changes, you are prompted to save your changes.

• Number of opened editors before closing—For each file that is opened in an 
editor, it is stored in a list of recently used files before closing the editor. The 
default value is 10.

• When all editors are dirty or pinned—You can also specify if a prompt dialog 
box should be opened or if a new editor should be opened when all the current 
editors are have unsaved information. Once it is turned on, the Pin Editor action is 
added to the toolbar and editor tab menu. Pinned editors are not recycled. To pin 
an editor so that it is not automatically closed, right-click the editor’s tab and select 
Pin Editor.

the “Activating Editors” 
section on page 1-19 
(Figure 1-6 on page 1-20)

General > Login 
Profile

Allows you to select a default login profile for subsequent logins. Click the Always 
log in using this profile check box to set your default login profile. By default, when 
you launch the Active System Manager software, a profile (Default) is assigned by 
the administrator; see Figure 3-5 on page 3-4. To modify the login profile settings, 
see the “Saving Your Environment as a Login Profile” section on page 4-13 and the 
“Deleting Login Profiles” section on page 4-14.

General > 
Perspectives

• Open a new perspective—Controls whether opening a new perspective in the 
Active System Manager software is handled by the current window or in a new 
window:
• In the same window—Opens a new perspective in the same window as your 

working application.
• In a new window—Opens a new perspective in a new window, separate from 

your working application.
• Open a new view—Turns the Fast View setting on and off for new views:

• Within the perspective—Opens a new view in the same window as your 
working perspective.

• As fast view—Opens a new view in a fast view; for more information about fast 
views, see the “Creating a Fast View” section on page 1-17.

Available Perspectives—Lists the available perspectives where you can set one as 
a default or restore the defaults:

• Set the default perspective; select a perspective and click Make Default.
• Reset the perspective to its original set of views and layout based on its 

definition by clicking Reset. (You can also perform the same task by following 
the procedure in the the “Resetting Perspectives” section on page 1-9.)

See the “Modifying 
Perspective Preferences” 
section on page 1-7.

General > Web 
Browser

Allows you to add, remove, or edit the currently installed web browsers. The selected 
web browser is used as the default when the web pages are open; however, some 
applications may always use the external browser. You can select the Use the 
internal Web browser or the Use external Web browser option (and click New to 
add the external web browser). The default web browser for your operating system is 
used for displaying the help contents.

Eclipse documentation

Table 1-8 Preference Types—Configurable Parameters (continued)

Preference Type Configurable Parameters and Description Reference
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Help Open Modes—Specifies how information is displayed:
• The Use External Browser check box allows you to select a web browser for this 

option. The default web browser for your operating system is used for displaying 
the help contents.

• Open help search—Allows you to select a separate window for this option (in a 
dynamic help view or in an infopop). A separate window becomes the default 
browser for displaying help contents

• Open help view documents—Allows you to select a dialog box (in a dialog tray or 
in an infopop) for this option. A dialog box becomes the default browser for 
displaying help contents.

• Open help content—Allows you to open your document in place or open in an 
editor area.

Context Help
• Open window context help—Allows you to select a separate window for this 

option (in a dynamic help view or in an infopop). A separate window becomes the 
default browser for displaying help contents

• Open dialog context help—Allows you to select a dialog box (in a dialog tray or 
in an infopop) for this option. A dialog box becomes the default browser for 
displaying help contents.

Note: Selections performed on this page can affect how the help view is presented. 
If the selected browser is not fully compatible with Internet Explorer or Mozilla, or has 
JavaScript disabled, the help view shown in the browser might be a simplified 
version.

N/A

Inventory When creating new inventory, you must set the default domain property by 
configuring the following preferences:
• Custom Icon Library Folder—Points the Active System Manager software to the 

folder where you store your custom icons for resource types.
• Resource Type Multi-Editor—Displays a warning for incompatible and hidden 

inventory/provisioning parameters upon opening an editor.
• Resource Instance Multi-Editor—Displays a warning for incompatible and 

hidden provisioning parameters upon opening an editor.
• Domain Information—Sets the default domain and is used as the default domain 

in resource instance Add and Import operations.
• Virtualization Settings—When enabled (checked), by default, enables resource 

virtualization for newly created inventory.

“Setting the Default 
Domain” section on 
page 6-15 

Inventory > 
Inventory Import

• Email notifications—Allows you to send notifications of a forced import to:
• Owner
• Participants
• None 

Note: Notifications are applicable in case of a forced import only.
• Specific Availability—Allows you to specify availability as follows:

• Always available
• Specify start (current or specific start) time or end (always or specific end) time

• Editor Options—Allows you to set the viewing and errors options as follows:
• View: Original or Hierarchical setting
• Errors: Multiple Syntax or Single Syntax Errors

Chapter 6, “Using 
Inventory” and Chapter 7, 
“Repository Management”

Table 1-8 Preference Types—Configurable Parameters (continued)

Preference Type Configurable Parameters and Description Reference
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Scheduler • Scheduler Wizard—Allows you to set the following wizard options:
• Show advanced scheduling options page during scheduling or rescheduling 

operations.
• Show provisioning sequencing options page during scheduling or 

rescheduling operations.
• Enable perspective switching on new session—Prompts you to switch to the 

application Session perspective at the end of scheduling or rescheduling 
operations.

• Scheduler Policy—During scheduling or rescheduling operations, if no solutions 
are found by the scheduler, based on your request, you can enable the following 
options and the scheduler will automatically try again:
• Identify blocking sessions
• Retry with ASAP scheduling

See the “Working with 
Running Sessions” 
section on page 9-3.

Scheduler > ASAP 
Rescheduling

Administrator task only. Enables the ASAP Engine (click the Enable automatic 
rescheduling for ASAP sessions check box) to specify the minimum duration for 
the engine to monitor sessions. You can specify the evaluation time in days, hours, 
and minutes.
Based on the specified duration, the ASAP Engine only considers session sessions 
to be updated if their start time is confirmed (future) from the specified duration time, 
and are then rescheduled at that time.

See the “Working with 
Running Sessions” 
section on page 9-3.

If other sessions cancel or finish early, there is an opportunity for a previously 
confirmed ASAP session to move up to an earlier time slot. ASAP does this 
automatically. The Active System Manager administrator can enable or disable this 
feature and the Active System Manager Welcome page displays its status. Typically, 
rescheduling occurs when a session is canceled or edited to terminate early. ASAP 
rescheduling uses the following rules:
• Other sessions that have not begun, and were originally scheduled in an ASAP 

manner, are reviewed by the scheduler to determine if they can be advanced to an 
earlier start time, thereby optimizing or “repacking” the schedule.

• The scheduler considers confirmed ASAP sessions, one at a time, to attempt to 
find each an earlier time. It begins with the next session, based on the time that the 
session is due to start its setup period, rather than on the session start time.

• There is a configurable value (set by the administrator) used to determine the 
minimum “opportunity” time difference required before a session is considered for 
rescheduling. For example, if a session is scheduled to start five minutes from 
now, there would be no sense in trying to find an earlier time for it.

• Once the first candidate session is evaluated and is either changed or not 
changed, the remaining candidate sessions on the list are evaluated, one at a 
time, and given rescheduling opportunities based upon whether or not the prior 
sessions in the list have been cancelled or rescheduled.

• Email notification of schedule changes is provided.
Note: E-mail notification is sent to the session owner, participants, and anyone 
included in the TO and CC lists defined in config.properties. Mail notification can be 
modified either in config.properties or by the Active System Manager administrator 
on the System Properties tab.
After considering an ASAP session for rescheduling, the result is that it obtains one 
of the following options:
• The same resources at the same time because no better options were available.
• Different but equivalent (typed) resources at the same time.
• A better time with either the same or equivalent resources.
Note: A session never loses a time slot, or gets a later time slot, due to ASAP 
rescheduling.

Table 1-8 Preference Types—Configurable Parameters (continued)

Preference Type Configurable Parameters and Description Reference
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Scheduler > 
Advanced 
Scheduling

General Tab 
Assigns default ownership. Administrator task only.
Allows you to set the following Quick Scheduling parameters:
• Behavior: As Soon As Possible (ASAP), ASAP within fixed time frame, Fixed start 

and end date, Recurring Session
• Duration: Days, Hours, Minutes
• Number of solutions requested <number> within <time> specified
• Optimization Method: Multiple Times or Multiple Resources
• Identify Blocking Sessions 
• Include Setup and Teardown time in overall scheduling time 
• Session Realization: Disables Runtime OS Image load operation during session 

setup
• Scheduling Priority: Allows the Scheduler to reschedule sessions based on their 

priority. When enabling the Allow session to be rescheduled check box, the 
Scheduler uses this priority to identify who has precedence in allocating resources 
among all users and groups. The values range from 1 to 5, where the highest 
priority is 1 and the lowest priority is 5 (the default is 3). Users with a lower priority 
may see their sessions rescheduled based on overall system allocations. 
Administrators can change the value; users can change the value equal or lower to 
the value assigned in their user profile. The Deadline is the maximum duration of 
time your session can be scheduled and pushed out.

Permission Tab
Assigns owners, default users, and groups to newly created and running sessions.

See the “Scheduling 
Templates” section on 
page 8-18.

Scheduler > 
Notifications and 
Reminders

Allows you to set email and calendar notification rules. See the “Rescheduling 
Sessions” section on 
page 9-21.

Search Allows you to set the search options and categories, as appropriate for your search.

Security Authentication Security Repositories—Administrator task only. Allows you to 
enable or disable the external security repositories associated with the system.

Chapter 4, “User Profile 
Management”

Template Allows you to set the following Template options:
• Enable resource interfaces on link creation—Allows you to create links without 

enabling resource interfaces. 
• Display labels by Template name—Displays resource and interface Template 

names in the Template editor, or resource and interface names or will use 
preference settings associated with general display options (General > Display 
Options).

See Chapter 8, “Template 
Management.”.

Template > 
Template Editor

Bulk Connectivity with VLAN—Allows you to create links in the Template editor 
using the Palette view. 
Refactoring—Warn user on automatic refactoring operations—The Active System 
Manager software displays a list of all changes related to previous preferences.
Resource Custom Operation—Allows you to display a resource custom operation 
status message on completion.
Annotations—Allows you to create the graphical functions to add to your existing or 
new templates. 

For bulk VLAN details, see 
the “Supporting Layer 2 
Switching” section on 
page 8-38.
For annotation details, see 
the “Using Annotations” 
section on page 8-41.

Table 1-8 Preference Types—Configurable Parameters (continued)
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Icons
The main Active System Manager toolbar provides shortcuts for commonly used menu commands, 
including:

• File > New

• File > Save 

• File > Print

• Navigate > Back

• Navigate > Forward

• Search

Figure 1-16 displays the Active System Manager toolbar and its icons; see Table 1-9 for icon descriptions.

Figure 1-16 Active System Manager Toolbar Icons

Table 1-9 Active System Manager Toolbar Icons

Icon Icon Name Description

New Defines the types of files available to choose from:
• Resource type
• Resource instance
• Other

Save (or 
Save All)

Saves the application work-in-progress.

Search Allows you to search for the information about resource types, resource instances, 
templates, links, and configurations. 

Import Allows you to import any Active System Manager source.

Export Allows you to export any Active System Manager source.
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Table 1-10 displays the Active System Manager application icons found in views and editors. This table 
organizes the icons by the default perspective they appear in and the window type where you can find the 
icon.

Table 1-10 Active System Manager Application Icons 

Icon Icon Name Default Perspective Window Type

Access Session/Console Views

Calendar Inventory/Session Views

Close Session/Console Views

Configuring Parameter Inventory Editors

Configurations Template Views

Connected Connection (not a perspective) Application

Connection Session/Console Views

Console Session/Console/Inventory Views

Disconnected Connection Application

Resource Instance Inventory Views

Resource Instance 
(Bulk)

Inventory Editors

Resource Instance 
(Component)

Inventory Views

Resource Type Inventory Views/Editors

Resource Type 
(Component)

Inventory Views

Resource Unknown Template Editors

Filesystem Inventory Views

Filters Inventory, Test, Session, Template Views

Filter Control Inventory Views

Filter Managed Inventory Views

Group N/A Views/Editors
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Table 1-11 lists the icon overlays available in the Active System Manager application.

Group By Inventory, Test, Session, Template Views

Interface Category Inventory Views/Editors

Interface Ghost Inventory Views

Interface Type Inventory Views/Editors

Inventory Parameters Inventory Editors

Links Inventory, Template Views/Editors

Power Supply Inventory Views

Relationship Inventory Views/Editors

Report Reporting Application

Session Scheduler Views

Simple Link Inventory, Template Views

Solution Scheduler (temporary)

Synchronize (Link to 
Resources)

Inventory Views

Template Template Views

User N/A Views

Table 1-11 Icon Overlays 

Icon Description Preferred Perspective Window Type

Add Inventory Editors

Managed Interface Inventory Editors

Orange Ball Inventory Editors

Table 1-10 Active System Manager Application Icons (continued)

Icon Icon Name Default Perspective Window Type
1-36 Active System Manager User Guide, Release 7.0



Active System Manager User Interface Elements
Deadlock Inventory Views

Delete/Remove Inventory Editors

Dirty Inventory Editors

Future State Inventory/Session Views

Past State Inventory/Session Views

Invalid Interface Inventory Editors/Views

Running State Session Views

Interface Inactive Inventory Editors

Invalid Resource Inventory Editors

Warning Inventory Views/Editors

Table 1-11 Icon Overlays (continued)

Icon Description Preferred Perspective Window Type
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Getting Started
C h a p t e r  2
Getting Started
This chapter provides the basic information you need to install, configure, launch, and uninstall the Dell™ 
Active System Manager client software. It also describes how to connect to the Active System Manager 
server and verify the connection status.

Active System Manager Client Application Requirements

The Active System Manager client application requires the following hardware components:

• 1 GHz 32-bit (x86) or 64-bit (x64) processor 

• 512 MB of system memory (1 GB recommended)

• Minimum hard drive free space prior to installation: 1 GB

For the latest client software requirements, see the Active System Manager Release Notes.

Installing the Active System Manager Client Software 

This section describes the procedures for installing the Active System Manager client software on a 
Windows or Linux workstation, and describes the Active System Manager software license error messages 
and associated remedies for each in the following subsections:

• Installing the Active System Manager Client Software on a Windows OS

• Installing the Active System Manager Client Software on a Mac OS

• Installing the Active System Manager Client Software on Linux

• Troubleshooting Active System Manager License Error Messages
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Installing the Active System Manager Client Software on a 
Windows OS

Note This procedure describes only how to install the Active System Manager software. To upgrade your 
Active System Manager client software, you must first uninstall the current version and then install 
the new version. For information about uninstalling your version of the Active System Manager 
software, see the “Uninstalling the Active System Manager Client Software” section on page 2-9.

To install the Active System Manager client software on a Microsoft Windows OS, perform the following 
steps:

1. Insert the Active System Manager Client Installation CD into your CD drive.

2. On your desktop, click Start > Run > Browse and navigate to the setup.exe file and click OK. Or, from 
your Windows Explorer window, navigate to the setup.exe file and double-click it.

A Security Warning window prompts you to run the file.

3. Click Run to enable the installation wizard to guide you through the installation process.
Note If an existing version of the Active System Manager client is on the client machine, invoking the 

installer will prompt you to select to uninstall the existing version already on the system. Once 
selected, the installer will uninstall the existing version and then exit. You must perform the 
originally intended install after uninstalling the previous version as a single step.

4. Click Finish to complete the installation process.

Now you are ready to launch the Active System Manager client software; see the “Launching the Active 
System Manager Client Software on Windows” section on page 2-4.

Installing the Active System Manager Client Software on a Mac OS
To install the Active System Manager client software on an Apple Mac OS, perform the following steps:

1. Download the Active System Manager -macosx.x86_64_7.0_xyzt.zip file, or copy the file from your 
CD using the Mac Finder. 

2. Unzip the file into a specific folder destination on your hard drive.

3. Create the Active System Manager folder and move the file contents to this location.

4. Execute the Active System Manager.app file.

Installing the Active System Manager Client Software on Linux
To install the Active System Manager client software on an Apple Mac OS, perform the following steps:

1. Download the Active System Manager -linux.gtk.x86_64_7.0_xyzt.zip file, or copy the file from 
your CD.

2. Unzip the file into a specific folder destination on your hard drive.

3. Create the Dell folder and move the file contents to this location.

4. In the console, execute the ./Active System Manager file.
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Troubleshooting Active System Manager License Error Messages
This section describes the following Active System Manager software license-related errors that you may 
encounter, along with suggested actions:

• License file doesn’t exist in the lux/etc folder

• Active System Manager license has expired

• Active System Manager application is deployed on un-licensed host machine

• Active System Manager application is deployed on un-licensed IP address

• Active System Manager license key is valid for previous installed Active System Manager version, but 
on upgrade license key is not being validated

• In case of corrupted license key string

• /etc/hosts file has incorrect format

Table 2-1 lists the Active System Manager license error messages, including their respective server 
message and suggested action.

Table 2-1 Active System Manager License Error Messages 

Error Message Server Message Suggested Action

License file doesn’t exist in 
lux/etc folder

Server.license.108 = License file 
does not exist. Please contact your 
Active System Manager administrator. 

Move license.lic file to the [installed 
directory]/etc file provided by the Dell 
Active System Manager support team.

Active System Manager 
license has expired

Server.license.101 = The Active 
System Manager license has expired. 
Please contact your Active System 
Manager administrator.

Contact the Active System Manager 
administrator, who should then request a new 
license from the Dell Active System Manager 
support team.

Active System Manager 
application is deployed on 
un-licensed host machine

Server.license.107 = Active System 
Manager hostname is not valid. 
Please contact your Active System 
Manager administrator. 

You should deploy the Active System Manager 
software on a licensed host or contact the Active 
System Manager administrator, who should then 
request a new license from the Dell Active 
System Manager support team for the targeted 
host machine.

Active System Manager 
application is deployed on 
un-licensed IP Address

server.license.103 = Active System 
Manager IP address is not valid. 
Please contact your Active System 
Manager administrator.

You need to deploy the Active System Manager 
software on a licensed IP Address, or contact to 
the Active System Manager administrator, who 
should request a new license from the Dell 
Active System Manager support team for the 
targeted IP Address.

Active System Manager 
license key is valid for 
previous installed Active 
System Manager version, 
but on upgrade license key 
is not being validated

server.license.102 = License version 
is not valid. Please contact your 
Active System Manager administrator. 

You need to contact the Active System Manager 
administrator, who should request a new license 
from the Dell Active System Manager support 
team for the newly-installed Active System 
Manager build (if the license build version has 
changed).

In case of corrupted license 
key string 

server.license.106 = Invalid license 
key. Please contact your Active 
System Manager administrator.

You should not alter the license key information 
present in the license.lic file; however, if the file 
has been altered/updated/corrupted, then you 
need to contact the Active System Manager 
administrator, who should request a new license 
from the Active System Manager support team.

/etc/hosts file has 
incorrect format 

License is not valid. Please contact 
your Active System Manager 
administrator.

In your /etc/hosts file add an alternative to 
“localhost” on the line with 127.0.0.1.
Getting Started 2-3



Launching the Active System Manager Client Software on Windows
Launching the Active System Manager Client Software on 
Windows

To launch the Active System Manager client software on Windows, perform the following steps: 

1. Select one of the following two options to launch the software:

• The first time you install the software (at the end of the installation process); after that, you launch 
the software from your desktop.

• On your desktop, click Start > All Programs > Dell > Active System Manager  7.0.

Either option produces the Dell Active System Manager splash screen (see Figure 2-1), followed by the 
Connect to Active System Manager Server dialog box; see Figure 2-4 on page 2-6.

Figure 2-1 Dell Active System Manager 7.0
2-4 Active System Manager User Guide, Release 7.0



Launching the Active System Manager Client Software on Windows
Figure 2-2 Connect to Active System Manager Server Dialog Box

2. Connect to the Active System Manager server; see the “Connecting to the Active System Manager 
Server” section on page 2-6.

If you are logged on as an administrator, the Select Login Profile User dialog box displays; see 
Figure 2-3.

Figure 2-3 Login Profile

3. Click OK to display the Active System Manager home page.
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Figure 2-4 Active System Manager Home Page

Connecting to the Active System Manager Server

To successfully establish a working environment session, you must connect to the Active System Manager 
server by one of two ways; you cannot work offline:

• Connecting to the Active System Manager Server for the First Time

• Connecting to the Active System Manager Server After Account Setup

• Verifying the Connection Status

Connecting to the Active System Manager Server for the First 
Time

To connect to the Active System Manager server for the first time, perform the following steps:

1. Launch the Active System Manager software; see the “Launching the Active System Manager Client 
Software on Windows” section on page 2-4.

2. Verify the connection status; see the “Verifying the Connection Status” section on page 2-8. 
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3. On the Connect to Active System Manager Server dialog box (see Figure 2-2 on page 2-5), create a new 
server account. 

4. Click OK to connect to the server.

If your server must load a very large inventory database, a dialog box may appear that displays the 
progress. You have the options of canceling the connection attempt, or running it in the background. 
Also, you can display the loading process details by clicking Details.

Note Client-server compatibility check. The Active System Manager client, Version 7.0 can only connect 
to an Active System Manager server, Version 7.0 and above. If your installed Active System 
Manager server is a prior version, you must either upgrade the Active System Manager server or 
downgrade your Active System Manager client.

Note The Active System Manager software auto-detects when a connection is lost and attempts to 
reconnect without user interaction. If you are in the middle of a work session, we recommend saving 
your work on a regular basis to ensure that any changes are not lost should a disconnection occur.

Connecting to the Active System Manager Server After Account 
Setup

To connect to the Active System Manager server after creating one or more server accounts, perform the 
following steps:

1. Launch the Active System Manager software; see the “Launching the Active System Manager Client 
Software on Windows” section on page 2-4. The Connect to Active System Manager Server dialog box 
displays; see Figure 2-2.

2. Click the Account field and select the account you want to use for your working session.

3. Click the Username and Password fields and type the associated username (up to 25 characters) and 
password with the selected account, and click OK.

4. Click OK to access the server.

Note You cannot disconnect from the server manually; you must exit the application. You can always 
reconnect to a secondary server by using the File > Connect to Server menu option at any time. Or, 
reconnect to the same server with different user account.

Note The Active System Manager software auto detects when a connection is lost and attempts to 
reconnect without user interaction. If you are in the middle of a work session, we recommend saving 
your work on a regular basis to ensure that any changes are not lost should a disconnection occur. 

Note If your server must load a very large inventory database, a dialog box may appear that displays the 
progress. You have the options of canceling the connection attempt, or running it in the background. 
Also, you can display the loading process details by clicking Details.
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Verifying the Connection Status
When you launch the Active System Manager software, it requires you to connect to the server, to 
successfully establish a working environment session. 

To verify the connection status, perform the following steps:

1. Launch the Active System Manager software; see the “Launching the Active System Manager Client 
Software on Windows” section on page 2-4.

The Welcome page displays the first time you log on. It is recommended to read the Welcome page at 
least once. It contains a brief product overview and information on finding help. When you are finished, 
you can close the page by clicking the X in the Welcome tab. To recall the Welcome page at a later time, 
on the Active System Manager menu bar, click Help > Welcome.

The bottom status bar on the Welcome Home page indicates whether or not you are successfully 
connected. A red light indicates that you are not connected; a green light (see Figure 2-5) indicates that 
you are connected. 

Figure 2-5 Active System Manager Welcome Page—Connected

2. Log on to the Active System Manager software to successfully connect to the server; see the 
“Connecting to the Active System Manager Server” section on page 2-6. 
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Uninstalling the Active System Manager Client Software

This section describes the uninstallation procedures for removing the Active System Manager client 
software from a Windows workstation.

To uninstall the Active System Manager client software on a Windows workstation, perform the following 
steps:

1. Click Start > All Programs > Dell > Active System Manager > Uninstall Active System Manager 
7.0.

The Dell Uninstall wizard displays and guides you through the uninstallation process.

2. Click Finish.

Note To perform an upgrade of the Active System Manager client software, you must first uninstall your 
current version and then install the new version. If you upgrade from one major release to another 
(e.g., from Release 3.x to Release 7.0), your settings and preferences will not automatically migrate.
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C h a p t e r  3
Account Management
This chapter defines how to set up one or more Active System Manager server accounts and to switch 
between a number of Active System Manager servers. 

Creating New Server Accounts

After launching the Active System Manager client software, you can create or add one or more server 
accounts, by performing the following steps:

1. Launch the Active System Manager client software; see the “Launching the Active System Manager 
Client Software on Windows” section on page 2-4. 

The Connect to Active System Manager server dialog box displays; see Figure 3-1.

Figure 3-1 Connect to Active System Manager Server Dialog Box
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2. Click Setup to display the Setting Up Accounts dialog box; see Figure 3-2.

Figure 3-2 Setting Up Accounts

3. Click Add to display the Add New Account dialog box; see Figure 3-3.

Figure 3-3 Add New Account

4. Enter the following values, as instructed by your Active System Manager administrator:

a. Click the Account field and type the name (up to 25 characters) to associate with the server 
properties. 

b. Click the Server field and type the name of the Active System Manager server to access; it is 
case-sensitive.

c. By default, the port number is already provided; however, you can override it as appropriate. 
Confirm with your administrator. 

d. Click the Transport field and select the Normal (over HTTP) or Secure (over HTTPS) option. 
The default is Normal (over HTTP). All data between the Active System Manager client and server 
is encrypted with the Secure (over HTTPS) option. 

Note If the Active System Manager application is running behind your company firewall, this should be 
a preferred option.
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5. Click OK to add the new account and to return to the Setting Up Accounts dialog box. 

The new account is listed in the List of Accounts section; for an example, see Figure 3-2 on page 3-2.

To create additional accounts, repeat step 3 and step 4, which connect you to different labs (each 
environment has its own Active System Manager server). 

6. Click Close when you have finished adding accounts.

The Connect to Active System Manager Server dialog box displays; see Figure 3-1 on page 3-1.

7. On the Connect to Server dialog box, perform the following steps:

a. Click the Username field and enter a username (up to 25 characters).

Note Your username establishes what access permissions you have. When the Active System Manager 
software starts, you have the option of connecting with an existing account or creating a new 
account.

b. Click the Password field and enter a password. 

8. Click OK to access the Active System Manager server. 

Note Some initialization windows may appear, depending on the network connectivity and your machine 
configuration.

The Welcome—Home page displays, confirming the connection; see Figure 3-4. For more information 
about verifying the connection status, see the “Verifying the Connection Status” section on page 2-8.

Figure 3-4 Active System Manager Welcome Page—Connected

9. Connect to the server using a designated account; see the “Connecting to the Active System Manager 
Server” section on page 2-6.
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Connecting to Server Accounts

Each Active System Manager server controls a environment, including equipment and scheduling. By 
entering more than one account, you can connect to servers on demand. This allows you to switch accounts 
to work with different labs. When you exit the Active System Manager client, it remembers the last account 
you used. Therefore, the next time you launch the Active System Manager software, it uses that account 
name.

To connect to a different server account, perform the following steps:

1. On the Active System Manager menu bar, click File > Connect to Server.

The Connect to Active System Manager Server dialog box displays; see Figure 3-1 on page 3-1.

2. Click the Account field and select the account to which you want to switch. 

3. Click the Username and Password fields and type the associated username (up to 25 characters) and 
password with the selected account, and click OK. 

If you have unsaved changes for your original server, the Active System Manager client prompts you 
to save them. When you connect to the new server, the Active System Manager client keeps its views 
and contexts open, provided they synchronize with the new, connected server. The status bar displays 
the server connection status. The Select Login Profile as User dialog box displays; see Figure 3-5.

Note Until you successfully connect to a new server, you remain connected to your original server.

Figure 3-5 Select Login Profile As User

4. Select your Login Profile.

Note If you have clicked the Always login using this profile check box in your profile preferences, this 
dialog box will be skipped and your selected profile will be used. 

5. Optional. Click the Reset check box to retrieve the latest customization from your latest login profile 
definition. However, if you select this option, you will lose all customizations previously created.

6. Click OK. 
3-4 Active System Manager User Guide, Release 7.0



Editing Server Accounts
Note You may be prompted to select between different login profiles published by your administrator. 

The Active System Manager product launches with the login profile you selected. To modify the login 
profile settings, see the “Saving Your Environment as a Login Profile” section on page 4-13 and the 
“Deleting Login Profiles” section on page 4-14.

Editing Server Accounts

You can modify the properties of any of the accounts that you create. If you modify the properties on the 
account to which you are currently connected, or if you change attributes, the Active System Manager 
client switches accounts to the changed version, if required. The Active System Manager client disconnects 
from the server and then reconnects to the server using the edited account properties. 

To edit a server account, perform the following steps:

1. On the Active System Manager menu bar, click File > Connect to Server to display the Connect to 
Active System Manager Server dialog box; see Figure 3-1 on page 3-1.

2. Click Setup to display the Setting Up Accounts dialog box; see Figure 3-2 on page 3-2.

3. Select the appropriate account and click Edit to display the Edit Account Information dialog box; see 
Figure 3-6.

Figure 3-6 Edit Account Information

4. Modify the Account, Server, Port, and Transport field values, as appropriate. For details about the 
field values, see the “Creating New Server Accounts” section on page 3-1.

Note You can only edit or delete the accounts you are not currently logged into.

5. Click OK when you have completed your modifications. 
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Deleting Server Accounts

To delete a server account, perform the following steps:

1. On the Active System Manager menu bar, click File > Connect to Server.

The Connect to Active System Manager Server dialog box appear; see Figure 3-1 on page 3-1.

2. On the Connect to Active System Manager Server dialog box, click Setup.

The Setting Up Accounts dialog box displays; see Figure 3-2 on page 3-2.

3. Select the account name and click Delete. 
Note You can only edit or delete the accounts you are not currently logged into.

4. Click OK > Close to confirm the deletion and return to the Connect to Active System Manager Server 
dialog box.
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C h a p t e r  4
User Profile Management
Note This chapter describes tasks and functions that are administrator-specific. A user can have 
administrator privileges based on its profile role. For a list of the built-in permissions based on 
administrator and user roles, see Table 4-1 on page 4-19.

The Active System Manager software allows you to set permissions for access to a number of privileges. 
Active System Manager users are defined by Active System Manager administrators; however, users have 
the ability to reset their password and edit their profile.

This chapter describes the following user profile management topics:

• Managing Security Functions

• Managing Groups

• Defining Permissions

• Modifying Permissions

• Managing Authentication Repositories

Managing Security Functions

This section describes the administrator’s role for managing security functions for the Active System 
Manager software.

Managing Users or Administrators
This section describes how you can use the Active System Manager software to manage users or 
administrators. The following topics are described here:

• Accessing a User List

• Adding New Users

• Adding an LDAP/AD Repository

• Adding NIS Users
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Accessing a User List
To access the available user list, on the Active System Manager menu bar, click Tools > Users and Groups.

The Security Management window displays with the Users tab open by default; see Figure 4-1.

Figure 4-1 Security Management Window—User and Groups—Users Tab

By default, the information provided on the Users tab is sorted by descending order based on the Username 
column; however, you can sort the information by clicking any of the table headers: Username, First Name, 
Last Name, Role, Authentication, Email, Status, and Time Zone.
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Adding New Users 
Based on external authentication methods and repositories, the Active System Manager software now 
supports internal, Lightweight Directory Active Protocol (LDAP)/Active Directory (AD) users, and 
Network Information System (NIS) users. 

You should create both a profile and a set of permissions for a new user (or group). For information about 
permissions, see the “Defining Permissions” section on page 4-19.

This section describes how to add a new user and create a profile for the new user. 

• Adding Internal Users

• Adding LDAP/AD Users

• Importing Users from a New LDAP Repository

• Importing Users from an Existing Repository

• Adding NIS Users

• Importing Users from a New NIS Repository

• Importing Users from an Existing Repository

Adding Internal Users
To add an internal user and create a profile for that user, perform the following steps:

1. Open the Security Management window; see the “Accessing a User List” section on page 4-2.

2. Click Add > Internal. The New User dialog box displays with the Profile tab open by default; see 
Figure 4-2.

Figure 4-2 New User—Profile Tab
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3. Configure the profile settings as appropriate:

a. Click the Username field and enter a username of at least three characters. 

b. Click the Password field and enter a password between 6 and 25 alphanumeric characters, including 
spaces.

c. Click the First Name field and enter a first name.

d. Click the Last Name field and enter a last name.

e. Click the Role field and select User or Administrator, as appropriate. An administrator role has 
full access to the inventory functionality.

f. Click the Email field and enter an e-mail address.

g. Optional. Click the Company and Department fields and enter that information, as appropriate.

h. Click the Time Zone field and select a time zone from the range of time zones provided. All Active 
System Manager application timestamp data will reflect this preferred time zone as defined in the 
user profile—not the time zone that is defined in the user’s desktop. 

Note When changing the time zone, you should reconnect to the server to enforce the new time zone in 
all displays (view, editors, and so on).

i. Scheduling Priority. The Scheduler uses this value to identify who has precedence in allocating 
resources among all users and groups. The values range from 1 to 5, where the highest priority is 1 
and the lowest priority is 5 (the default is 3). Users with a lower priority may see their sessions 
rescheduled based on overall system allocations. Only administrators can change this value.

j. Optional. Click the Specify maximum session duration constraint check box to set limits on the 
number of active sessions a user can run (in duration in day, hours, and minutes). 

Note The user time zone will be reflected in the application status bar. Once the time zone is updated, you 
must reconnect to the server for the time zone to take effect. You can also change your time zone 
via Tools > Users and Groups. Select the user and click Edit to change the time zone. You must 
restart the application for the new time zone to take effect.

4. Click the Membership tab and select the groups to include as members of your new group. You can 
click the check box next to each group to include individually, or to select all groups, click Select All; 
see Figure 4-3. Alternatively, to remove user membership in all groups, click Deselect All. To remove 
membership from a selected group, de-select the check box next to each selected group.
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Figure 4-3 New User—Membership Tab

5. Click the Permissions tab; see Figure 4-4.

Figure 4-4 New User—Permissions Tab

With this feature, you can:

• Sort the permissions by clicking the Name field. 

• Select more than one permission at a time by clicking the respective permission check boxes. 

• Select all permissions by clicking Select All.

• Remove all permissions from a group or user by clicking Deselect All.
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For more information about permissions, see the “Defining Permissions” section on page 4-19. 

6. Click OK.

The Security Management window adds the new user to the list of existing users.

7. Click Close to complete the procedure.

Adding LDAP/AD Users
Adding an LDAP/AD user remotely is performed using an import wizard. It consists of importing users 
from remote authentication repositories based on standards (LDAP/AD).

To add LDAP/AD users and create profiles for those users, perform the following procedures:

• Importing Users from a New LDAP Repository

• Importing Users from an Existing Repository

Importing Users from a New LDAP Repository
To import users from a new LDAP repository, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Users and Groups.

The Security Management window displays with the Users tab open by default; see Figure 4-1 on 
page 4-2.

2. Click Add > Remote. 

The Remote Repository dialog box displays with the Lightweight Directory Access Protocol (LDAP) 
repository (default) and Network Information Service (NIS) repository options.

3. Keep the Create a new LDAP repository option selected and click Next to open the LDAP Repository 
Definition dialog box > Next to open the LDAP User Filter dialog box.

4. Click Next to open the User Authentication Repository dialog box, which lists all users in a remote 
repository.

5. Select (at least) one user to import and for those to create Active System Manager profiles. An 
administrator can change the user’s role being imported either as a user (the default) or as an 
administrator. 

6. Click Finish to complete the import process.

Importing Users from an Existing Repository
To import users from an existing repository, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Users and Groups.

The Security Management window displays with the Users tab open by default; see Figure 4-1 on 
page 4-2.

2. Click Add > Remote. 

The Remote Repository dialog box displays with the Lightweight Directory Access Protocol (LDAP) 
repository (default) and Network Information Service (NIS) repository options.
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3. Click the Use existing repository option, click the drop-down list, and select a repository. 

The User Authentication Repository dialog box displays, which lists all users in a remote repository. 
You can use the Show new accounts only check box to remove users that are already in the Active 
System Manager system, to avoid duplication. If duplicates are found, you are prompted by the Active 
System Manager system, as a warning.

4. Select (at least) one user to import and for those to create Active System Manager profiles.

5. Click Finish to complete the import process.

Adding an LDAP/AD Repository

Note To perform this procedure, you must contact your system administrator to populate the following 
enterprise-specific fields.

Figure 4-5 represents a tree structure where each node represents an organizational unit within the LDAP 
repository. There is one root-level organizational unit called “system”, which has two nodes: “group1” and 
“group2”. Group1 has a subgroup named “Sub-group1” and Group2 has a subgroup named “Sub-group2”.

In the Active System Manager application, while defining an external authentication repository, there are 
two parameters, apart from others, which determine the behavior of the application; for example:

• Bind DN—Aids in establishing a context with the external security store, which is required to perform 
any operation on the security store. 

• Base DN—Used to search users at a particular, organizational unit level. 

Figure 4-5 External LDAP Repository

When a user adds or update a remote security store in the Active System Manager software, the value 
specified under “Bind DN” has two components; i.e., a user ID (UID) and organizational unit (OU). 

The UID used in the figure should be available at the same OU, which is specified with the “ou” attribute; 
otherwise, the Active System Manager repository is unable to establish a context with the external security 
store and hence no further operation (retrieving users, etc.) can be performed.

Secondly, the Base DN attribute (that is accepted by the Active System Manager software), describes the 
organizational unit level relative to the “ou” attribute specified under the Bind DN attribute, from where 
the users are to be picked up.
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For example, if the Bind DN attribute is specified as uid=admin,ou=system and the Base DN attribute 
is specified as ou=system, then all of the users belonging to the ‘system’ node will be picked up by the 
Active System Manager repository, and will be presented to the user to import into the Active System 
Manager repository.

If the Bind DN attribute is specified as uid=admin,ou=system and the Base DN attribute is specified 
as ou=group1,ou=system, then all of the users belonging to the ‘group1’ node will be picked up by the 
Active System Manager software and will be presented to the user to import into the Active System 
Manager software. In other words, the users belonging to the ‘system’ node will not be presented to the 
user. 

In second example above, the users are imported into the Active System Manager repository; however, 
using those user IDs, a user is unable to log into the Active System Manager application, because when a 
user tries to log in, the Active System Manager software creates a context with the external security 
provider by using the Bind DN attribute associated with that security store. In this case, the Bind DN 
attribute (uid=admin,ou=system) is used, but before that the UID is replaced by the user ID of the user 
who is trying to log in. For example, naresh attempts to log in, then the Bind DN attribute 
(uid=Naresh,ou=system) is used. This fails because the user naresh does not belong to ou=system. 

In conclusion, while configuring a security store in the Active System Manager repository, the OU 
specified with the Bind DN attribute should be of the lowest level in the hierarchy, if the users belonging 
to that level must be imported. Further, the Base DN attribute should have a hierarchical OU specification; 
i.e., starting from the lower level to highest level. In the second example above, for this to work properly, 
the Bind DN attribute should be specified as uid=admin,ou=group1,ou=system and the Base DN 
attribute should be ou=group1,ou=system.

Adding NIS Users
Adding NIS users remotely is performed using an import wizard. It consists of importing users from remote 
authentication repositories based on standards (NIS).

To add NIS users and create profiles for those users, perform the procedures in the following sub-sections:

• Importing Users from a New NIS Repository

• Importing Users from an Existing Repository

Importing Users from a New NIS Repository
To import users from a new NIS repository, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Users and Groups.

The Security Management window displays with the Users tab open by default; see Figure 4-1 on 
page 4-2.

2. Click Add > Remote. 

The Remote Repository dialog box displays with the Lightweight Directory Access Protocol (LDAP) 
repository (default) and Network Information Service (NIS) repository options.

3. Select the Network Information Service (NIS) option, select the Create a new NIS repository 
option, and click Next to open the NIS Repository Definition dialog box. 
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4. Configure the following connection settings:

a. Click the Name field and enter a name for the NIS repository. 

b. Click the Domain field and provide an NIS domain name.

c. Click the Host field and provide an NIS hostname or IP address.

5. Click Next to open the User Authentication Repository dialog box, which lists all users in a remote 
repository.

To avoid duplication, use the Show new accounts only check box to remove users that are already in 
the Active System Manager system. If duplicates are found, the Active System Manager system 
prompts as a warning.

6. Select (at least) one user to import and for those to create Active System Manager profiles.

7. Click Finish to complete the import process.

Importing Users from an Existing Repository
To import users from an existing repository, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Users and Groups.

The Security Management window displays with the Users tab open by default; see Figure 4-1 on 
page 4-2.

2. Click Add > Remote. 

The Remote Repository dialog box displays with the Lightweight Directory Access Protocol (LDAP) 
repository and Network Information Service (NIS) repository options.

3. Click the Use existing repository option, click the drop-down list, and select a repository. 

The User Authentication Repository dialog box displays, which lists all users in a remote repository.

You can use the Show new accounts only check box to remove users that are already in the Active 
System Manager system, to avoid duplication. If duplicates are found, you are prompted by the Active 
System Manager system, as a warning.

4. Select (at least) one user to import and for those to create Active System Manager profiles. An 
administrator can change the user’s role being imported either as a user (the default) or as an 
administrator.

5. Click Finish to complete the import process.

Editing User Profiles
To edit an existing user profile, perform the following steps:

1. Open the Security Management window; see the “Accessing a User List” section on page 4-2.

2. From the user list, select a user to edit and click Edit. (You can only select one user at a time to edit.)

The Edit User dialog box displays with all of the previously entered settings displayed in the Profile tab.

3. Click the Password field, enter the password, modify the other fields as appropriate, and click OK.

The Security Management—Users tab window displays the updated information. 
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Copying Users
Some administrators use a time-saving method for creating users by copying the users. Instead of manually 
configuring each new user’s permissions, the administrator can create a template user prior to the creation. 
This template user already has the basic groups and permissions that are common to all users. When a new 
user has is created, the administrator copies the template user and makes any individual modifications, as 
necessary.

To copy a user, perform the following steps:

1. Open the Security Management window; see the “Accessing a User List” section on page 4-2.

2. Select the entry for the user that you want to use as a starting point and click Copy. 

3. The New User—Add User dialog box displays, prompting you to enter a password for that user; see 
Figure 4-2 on page 4-3.

All of the fields, except for the Password field, are filled in, as for the original user. You can modify 
these fields as appropriate. 

4. Click OK when you have completed step 3.

The new user is created with the same permissions as the original user. You can modify the permissions, 
if necessary, as described in the the “Defining Permissions” section on page 4-19.

Deleting Users
To delete a user, perform the following steps:

1. Open the Security Management window; see “Accessing a User List” section on page 4-2.

2. From the user list, select one or more users to delete. (You can select more than one user at a time by 
holding down the Ctrl key and highlighting multiple users.)

The Confirm Delete dialog box displays, prompting you to confirm the deletion.

3. Click OK to delete the selected user (or users).

The Security Management—Users tab window displays the updated information with the user (or users) 
removed.

Note You cannot delete users that have active sessions and associated templates. Instead, you must 
re-associate the sessions to a different user.

Instead of deleting the user, update its profile by disabling the Allow Login permission. Upon 
saving the profile, the user will be unable to perform any Active System Manager tasks and log into 
the Active System Manager system.
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Switching User Repositories
To switch user repositories to migrate user authentication from the existing repository to a different one, 
perform the following steps:

1. Open the Security Management window; see the “Accessing a User List” section on page 4-2.

2. Click Switch To > repository name. 

Note The internal Active System Manager users can be migrated to external store types, and physically 
they are not moved to an external security store without re-creating them into the Active System 
Manager system, but they need to be created (or exist) in the external store being moved.

Resetting a User Password
To reset a user password, perform the following steps:

1. Open the Security Management window; see the “Accessing a User List” section on page 4-2.

2. Select one or more entries for those users (one at a time) requiring to reset their password, and click 
Reset Password. 

The Change Password dialog box displays, prompting you to enter a password for that user

3. Click the Password field and type in the new password.

4. Click the Retype field and re-enter the new password.

The Change Password dialog box changes to display the hidden changed password for the selected 
users.

5. Click OK.

6. On the Security Management window, click Close when you are finished with this user (or users).

Activating Users
To activate a user, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Users and Groups.

The Security Management window displays with the Users tab open by default; see Figure 4-1 on 
page 4-2.

2. Select one or more users in the table.

3. Click Activate > OK to confirm the activation operation.

Activated users will be allowed to log on, provided that the log on permission is set. 
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Deactivating Users
To deactivate a user, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Users and Groups.

The Security Management window displays with the Users tab open by default; see Figure 4-1 on 
page 4-2.

2. Select one or more users in the table.

3. Click Deactivate > OK to confirm the deactivation operation.

Deactivated users will not be allowed to log on, even if the permission to log on to their profile is set. 

Note When changing the time zone, you should reconnect to the server to enforce the new time zone in 
all displays (view, editors, and so on).

Publishing Login Profiles
The Active System Manager product allows you to create a login profile and assign them to users or groups. 
A login profile is a collection of perspectives that have been customized and published to users and groups. 

By default, there is a login profile already deployed with the Active System Manager product. The default 
user interface profile is composed of the following perspectives: Test, Session, Provisioning, Inventory, and 
Template. This login profile is known as “Default”.

To publish new login profiles, you must perform the following tasks:

• Customizing Targeted Environment

• Saving Your Environment as a Login Profile

• Associating Login Profiles with Users and Groups

• Deleting Login Profiles

Customizing Targeted Environment
To define a new login profile, you first must rearrange your environment by creating and customizing: 
perspectives, views displayed (and accessible on each perspective), menu bar items, shortcut views, and 
toolbar items. The way you set up your own environment (perspectives and views) is how you define your 
perspectives and views for your end users. There is no other tool within the application to define your 
environment. 

To learn how to customize a perspective, see the “Customizing Perspectives” section on page 1-8.
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Saving Your Environment as a Login Profile
To save your environment as a login profile, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Login Profile > Save As.

The Save As Login Profile dialog box displays.

Note All Login profiles will be displayed as defined by all administrators of the system, along with the 
Default Profile available with each Active System Manager deployment.

2. Click the Name field, type the profile name, and click OK. Or, in the Existing Profiles list, select one 
of the existing profiles to save, and click OK.

If you select one of the existing profiles to save for your profile, a prompt may display to overwrite the 
existing profile.

Note You are unable to add and remove perspectives and views to an administrator-defined login profile.

3. In the prompt dialog box, click Yes to overwrite or No to create a new profile name.

A prompt displays that the profile name is successfully added to the server and have been automatically 
published to end users.

Note You can also set a preferred default login profile using the Preferences dialog box. On the Active 
System Manager menu bar, click Window > Preferences > General > Login Profile, and click the 
Always log in using this profile check box.

Associating Login Profiles with Users and Groups

Note You are unable to add and remove perspectives and views to an administrator-defined login profile.

To associate login profiles with users and groups, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Users and Groups to display the Security 
Management—Users and Groups dialog box displays; see Figure 4-6.
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Figure 4-6 Security Management—Users and Groups

2. On the Users tab, select one or more (Ctrl+click) users to assign a login profile to your selection, and 
click Profiles. The Update Login Profiles dialog box displays.

3. Select at least one user profile and click OK.

4. On the Security Management—Users and Groups dialog box (see Figure 4-6), you can also select one 
individual user or group, click Edit, navigate to the Login Profiles tab to update or assign new login 
profiles, and click OK.

5. Select at least one user profile from the profile selection and click OK to display the Users and Groups 
dialog box displays; see Figure 4-6.

Deleting Login Profiles
To delete an existing login profile, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Login Profile > Delete.

The Delete Login Profiles dialog box displays

2. Select to click one or more login profiles to delete and click OK. 

A message displays prompting you to confirm the deletion.

3. Click OK to confirm the login profile deletion.
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Managing Groups

The following topics describe the procedures you follow to manage groups:

• Accessing a Group List

• Adding Groups

• Editing Groups

• Deleting Groups

Accessing a Group List
To access a group list, on the Active System Manager menu bar, perform the following steps:

1. Click Tools > Users and Groups.

The Security Management window displays with the Users tab open by default; see Figure 4-1 on 
page 4-2.

2. Click the Groups tab to display the Groups information; see Figure 4-7.

Figure 4-7 Security Management Window—Users and Groups—Groups Tab

By default, the information provided on the Groups tab is sorted by name and member affiliations.

3. Click Close. 
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Adding Groups
Groups are made up of users and groups. A group has its own set of permissions that are applied to its 
members.

To add (or create) a new group, you add the users and administrators to who they belong. You can also add 
other existing groups as members of your group, and then set the permissions for that group. Groups are 
managed similarly to users; for example: 

• A group list displays all existing groups.

• A group’s name, members, and permissions comprise its profile. 

• Permissions are created or modified by clicking Edit for a group, selecting the Permissions tab, and 
configuring the settings as appropriate.

To add a group, perform the following steps:

Note You can add a user or group to your group even if it is already a member of another group. Thus, a 
user can belong to a number of groups.

1. Open the Security Management window; see the “Accessing a Group List” section on page 4-15.

2. Click Add.

The New Group dialog box displays with the Group tab open by default; see Figure 4-8.

Figure 4-8 New Group—Group Tab

3. Click the Name field and enter a name for your group.

4. Scheduling Priority. The Scheduler uses this value to identify who has precedence in allocating 
resources among all users and groups. The values range from 1 to 5, where the highest priority is 1 and 
the lowest priority is 5 (the default is 3). Users with a lower priority may see their sessions rescheduled 
based on overall system allocations. Only administrators can change this value.
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5. Optional. Click the Specify maximum session duration constraint check box to set boundaries on the 
session duration. Specify the duration in day, hours, and minutes.

6. Click the Membership tab and select the users and groups to include as members of your new group. 
You can click to select the check box next to each user and group to include individually, or to select all 
users and groups, click Select All; see Figure . 

Alternatively, to remove users and groups as members of your group, click Deselect All.

Figure 4-9 New Group—Membership Tab

7. Click the Permissions tab to select and set permissions for your new group. 

With this feature, you can perform the following tasks to set the permissions:

• Sort the permissions by clicking the Name field. 

• Select more than one permission at a time by clicking the respective permission check boxes. 

• Select all permissions by clicking Select All.

• Remove all permissions from a group or user by clicking Deselect All.

For more information about permissions, see the “Defining Permissions” section on page 4-19. 

8. Click OK.
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Editing Groups
To edit a group, perform the following steps:

1. Open the Security Management window; see the “Accessing a Group List” section on page 4-15.

2. From the group list, select a group to edit, and click Edit. (You can only select one group at a time to 
edit.)

The Group [group name]—Edit Group dialog box displays with the previously entered name displayed; 
see Figure 4-10.

Figure 4-10 Group [group name]—Edit Group 

3. Optional. Click the Specify maximum session duration constraint check box to set boundaries on the 
session duration. Specify the duration in day, hours, and minutes.

4. Click the Membership tab and select the users and groups to include as members of your new group. 
You can click to select the check box next to each user and group to include individually, or to select all 
users and groups, click Select All; see Figure  on page 4-17. 

Alternatively, to remove users and groups as members of your group, click Deselect All.

5. Click the Permissions tab to select and edit permissions for your new group. 

With this feature, you can perform the following tasks to set the permissions:

• Sort the permissions by clicking the Name field. 

• Select more than one permission at a time by clicking the respective permission check boxes. 

• Select all permissions by clicking Select All.

• Remove all permissions from a group or user by clicking Deselect All.

For more information about permissions, see the “Defining Permissions” section on page 4-19. 

6. Click OK.
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Deleting Groups
To delete a group, perform the following steps:

1. Open the Security Management window; see the “Accessing a User List” section on page 4-2.

2. From the group list, select a group (or groups) to delete. (You can select more than one group at a time 
by holding down the Ctrl key and highlighting multiple groups.)

The Confirm Delete dialog box displays, prompting you to confirm the deletion.

3. Click OK to delete the selected group (or groups).

The Security Management—Groups tab window displays the updated information with the group (or 
groups) removed.

Defining Permissions

Table 4-1 defines the built-in permissions based on a user’s role.

Table 4-1 Built-In Permissions Based on Roles 

Functionality Administrator Role User Role

Inventory • Full access to inventory management 
(types, instances, connectivity/links)

• Manage dependencies
• Manage interface type and compatibility 

matrix

• Read-only view of the entire inventory
• R/O view of interface types

Discovery Access to Discovery functions None

Security • Manage all users, includes user profile, 
memberships, and permissions

• Manage all groups, includes group 
profile, memberships, and permissions

Update its user profile only

Authoring • Create, modify and share all templates
• Open and Save As All templates
• Delete all templates
• Import all templates
• Export all templates

• Create, modify, and share templates
• Update owned templates
• Open only private- and public-owned 

templates
• Delete owned templates
• Import/export templates

Scheduling/Sessions • Manage owned sessions
• Access to all sessions 
• Purge sessions

• Manage owned sessions
• Create, update, delete owned sessions

Session Notifications • Define system-wide notifications
• Define owned session notifications
• Define specific session notifications

• Delete user-defined notifications
• Define owned session notifications
• Define specific session notifications

Archiving • Define system-wide archiving rules
• Archive/restore owned templates and 

sessions
• Archive/restore any session

Archive/restore owned templates and 
sessions
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Table 4-2 describes the individual permissions of access that you can control.

Table 4-2 Permissions for Users or Groups 

Permissions Description

Allow Login Allows users to access the Active System Manager server.

Create Repository Element Allows the creation of repository elements. For details, see the “Creating 
a New Repository” section on page 7-6.

Create Session Sessions Allows the creation of sessions based on resource availability.

Delete Repository Element Deletes the repository elements. For details, see the “Deleting Repository 
Definitions” section on page 7-11.

Delete Resource Adapter Package Deletes Resource Adapters. For details, see the “Deleting Resource 
Adapters” section on page 7-26.

Export Template Exports templates. For details, see the “Exporting Templates” section on 
page 8-16.

Import Template Imports templates. For details, see the “Importing Templates” section on 
page 8-15.

Import Resource Adapter Package Imports RA packages. 

Modify Repository Element Updates the repository elements. For details, see the “Updating 
Repository Content” section on page 7-10.

You can assign permissions to a new user or group, and can modify those permissions at a later time. The 
following basic guidelines outline permission access:

• If you do not set any permissions for a user and you have assigned the user to a group, then that group’s 
permissions are inherited. 

• If a user that has no permissions assigned is not part of a group, then that user is denied any access. 

• If you set many of the permissions for a user, but leave some unspecified, the group’s settings are used 
for those permissions that were unspecified for the user. If those permissions are also unspecified for 
the group, or the user does not belong to a group, then those types of access are denied.

• If a user’s permission and their group’s permission disagree, then the user’s permission is accepted. 

Note If you have specified a permission for a user, then that overrides the group permission.

Reporting • Access to all reports
• Create and execute custom reports

• Access to user-based reports only
• Execute custom reports

Session • Access and to all sessions
• Manage console access

Access and manage only owned 
sessions, or one user is a participant

Testing List and execute associated test cases List and execute test cases within owned 
or participant sessions

Table 4-1 Built-In Permissions Based on Roles (continued)

Functionality Administrator Role User Role
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Modifying Permissions

The Active System Manager software allows you to set permissions for access to a number of privileges, 
such as making sessions, and importing and exporting files from the templates. There are three types of 
entities that have permissions assigned and that can be managed using the Users and Groups tabs:

• Users—Can perform core Active System Manager functions, such as making sessions and working 
with templates.

• Administrators—By default, administrators have all permissions that cannot be changed.

• Groups—Can be composed of administrators, users, and other groups. You can assign any number of 
users to a group, and then set the permissions for the group. All users have those permissions, without 
having to set them for each user individually.

Note Initially, the Active System Manager software is available with only one predefined administrator 
(username: “admin”) with no users. The administrator often has the responsibility of preempting 
sessions. To do this, you should log in as a user and create a separate user ID with user (not 
administrator) privileges. This user should have permission to create and modify sessions.

You can set permissions for a number of very specific types of access. For example, for the Active System 
Manager templates, you can determine whether users can create sessions or create functions with the Active 
System Manager product. The Permissions tab is available on the New User and New Group dialog boxes.

With users or groups, you can perform the following tasks:

• Sort the permissions by clicking the Name field. 

• Select more than one permission at a time by clicking the respective permission check boxes. 

• Select all permissions by clicking Select All.

• Remove all permissions from a group or user by clicking Deselect All.

• Complete the desired permissions tasks by clicking OK.

To modify permissions for a user, administrator, or group, perform the following steps:

1. Open the Security Management window and access a user, administrator, or group:

• To access a user, see the “Accessing a User List” section on page 4-2.

• To access a group, see the “Accessing a Group List” section on page 4-15.

2. Add a new user or group as described in the following sections:

• To add a user, see the “Adding New Users” section on page 4-3.

• To add a group, see the “Adding Groups” section on page 4-16.

3. From the user or group list, select a user, group (or groups) to modify the permissions, and click Edit. 
(You can only select one user or group at a time to edit.)

The User (username) or Group (group name) dialog box displays with the User or Group tab open by 
default (depending on which type you are modifying).
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4. Click the Permissions tab and modify the permissions settings as appropriate.

For more information about permissions and the allowable functions to set or modify permissions, see 
the “Defining Permissions” section on page 4-19.

5. Click OK to update the permissions for your user or group (or groups).

Managing Authentication Repositories

To retrieve a complete list of authentication repositories defined during the import of new users on remote 
servers (LDAP or NIS), on the Active System Manager menu bar, click Tools > Authentication 
Repositories. 
The Preferences—Security dialog box displays; see Figure 4-11.

Figure 4-11 Preferences—Security 

For more information about managing authentication repositories, see the following sub-sections:

• Activating Authentication Repositories

• Deactivating Authentication Repositories

Activating Authentication Repositories
The authentication repository must be activated for users to be authenticated. This setting will override the 
user-level activation status; see the “Activating Users” section on page 4-11.

To activate authentication repositories, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Authentication Repositories. 
The Preferences—Security dialog box displays; see Figure 4-11 on page 4-22.

2. Select the repositories to activate. 

3. Click Apply > OK.
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Deactivating Authentication Repositories
To deactivate authentication repositories, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Authentication Repositories. 
The Preferences—Security dialog box displays; see Figure 4-11 on page 4-22.

2. Select to deselect (disable) the repositories to deactivate. 

3. Click Apply > OK.
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Inventory Management
C h a p t e r  5
Inventory Management
Note This chapter describes tasks and functions that are administrator-specific. 

This chapter describes the Active System Manager Inventory perspective and associated tools that you use 
to catalog and define the equipment in your network environment. You use the Inventory perspective to 
manage resource types, resource instances, and connectivity to reflect the physical inventory of your 
environment.

Understanding Resource Modeling

To build your inventory, you should decide which modeling type to use. Table 5-1 lists and describes the 
characteristics for the basic modeling type. With basic inventory modeling, you essentially define resources 
with interfaces, sometimes referred to as “flat” or standard resources. 

Table 5-1 Basic Modeling Type Characteristics for Building Inventory

Operations Basic Modeling

Manual 1. Interface types
2. Resource type
3. Resource instance
4. Link

Automated via Tools and Processes 1. Discovery
2. CSV link import
3. CSV resource import

Note Each modeling type comes with its own set of tools to help build your inventory; however, you must 
stay within the context of the modeling characteristics. 

Table 5-2 outlines the topics (in this chapter) to use for building the inventory. Some topics are common 
between the two modeling types.
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Table 5-2 Reference Topics to Use for Building Inventory 

Basic Modeling Advanced Modeling

See the “Building a Standard Active System Manager 
Inventory” section on page 5-2.

See the “Using Resource Instances” section on 
page 5-19. 

See the “Using Resource Instances” section on 
page 5-19. 

See the “Using Resource Interface Types” section on 
page 5-30.

See the “Using Resource Interface Types” section on 
page 5-30.

See the “Linking Resources” section on page 5-34.

See the “Configuring Discovery Setup” section on 
page 5-3.

See the “Linking Resources” section on page 5-34. See the “Linking Resources” section on page 5-34.

Building a Standard Active System Manager Inventory 

The Inventory perspective provides a simple user interface for you to model and populate your inventory 
of equipment. You model your environment by creating and populating an inventory of all of the resources. 
This inventory includes the various general resource types within your environment—the resource 
types—as well as the specific resource instances that see a particular configuration for a particular piece of 
network equipment. The Active System Manager software uses resource types as templates for resource 
instances.

Table 5-3 outlines the typical workflow for building an inventory with the Inventory perspective.

Table 5-3 Building a Standard Active System Manager Inventory—Workflow Checklist 

Task 

1. Evaluate your set of managed (physical and virtual) and control equipment in your environment. You should 
consider all of your network servers, storage, and resource types (virtualized or not), the resource 
characteristics you want to expose, and the resource and interface metadata information.
To jump-start your inventory-building process, use the resource Discovery Explorer to gather information 
about your network equipment. For more information about the Discovery Explorer, see the “Configuring 
Discovery Setup” section on page 5-3.

2. Model the resource types for each type of hardware resource in your environment.
You open and modify resource types and resource instances in the Workspace area in an editor. For more 
information, see the “Using Resource Types” section on page 5-6.

3. Model resource instances for each piece of hardware in your environment. For more information, see the 
“Using Resource Instances” section on page 5-19. 

4. Model your network interface types. For more information, see the “Using Resource Interface Types” 
section on page 5-30.

5. Create links for the actual network resources in your environment.
Such links enable resource instances to communicate with each other to describe the actual physical 
resource connectivity in the environment. For more information, see the “Linking Resources” section on 
page 5-34.
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Configuring Discovery Setup

The Discovery Setup feature gathers the relevant information regarding your network equipment using 
domain-based information. To set up discovery domains and configure discovery parameters, perform the 
following steps:

1. On the Active System Manager menu bar, click Tools > Discovery > Setup.

The Discovery Configuration Setup editor displays. Figure 5-1 displays an example of a preexisting 
setup.

Figure 5-1 Discovery Configuration Setup

Note The Discovery Configuration Setup editor enables you to configure the discovery for the following 
Dell Active System Manager elements: servers, storage arrays, and switches (top of rack [TOR]). 

Before you proceed, it is recommended to:

• Gather IP addresses and access credentials associated with the chassis or blade infrastructure 
elements, storage arrays, and switches (TOR).

• Ensure that all elements have network connectivity, and that the associated element management 
interfaces are accessible from the Active System Manager server.

The system domain is preconfigured with the Active System Manager. Based on your deployment, your 
administrator may have configured multiple domains.
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2. Click Add System to select your Active System type and populate the information required for each 
element, such as username, password, IP addresses, and so on. (Required fields are marked in red with 
an asterisk.) For specific details that maps your environment, refer to the Active System Manager 
Solution Guide.

3. Click Add vCenter and populate the information required for each element, such as username, 
password, IP addresses, and so on. (Required fields are marked in red with an asterisk.) For specific 
details that maps your environment, refer to the Active System Manager Solution Guide.

Note VMware vCenter is currently supported for this release.

4. Optional. Click Add Element and populate the information required for each element, such as 
username, password, IP addresses, and so on. (Required fields are marked in red with an asterisk.) For 
specific details that maps your environment, refer to the Active System Manager Solution Guide.

Note Use this option if your environment deviates from the Active System’s reference architecture.

5. Save your configuration environment.

Running Discovery

After configuring discovery, to start resource discovery, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Discovery > Start. 

A prompt asks if you wish to start the discovery process. 

2. Click OK to start the discovery process.

The discovery process takes some time based on the amount of inventory to discover. At the bottom of 
the screen, the status displays that the discovery is in progress; see Figure 5-2.

Figure 5-2 Discovery Progress Status

While the discovery process is in progress, you can switch to the Inventory or Operation perspective to 
dynamically display the discovered elements; see Figure 5-3.
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Figure 5-3 Discovery Report

The report indicates failures (indicated in red) or success for each element. 
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Using Resource Types

The Active System Manager software uses resource types to model the various types of hardware resources 
in your environment. A resource type serves as a template for resource instances. A resource type does not 
see a particular piece of network hardware; it describes the basic structure of the basic model for that 
equipment. 

A single resource type can serve as the template for a variety of actual resource instances that exist in your 
environment. For example, assume your environment includes 50 servers. These servers have varying 
elements: different ports, different software versions. The purpose of a resource type is to serve as a 
baseline model that you can use to describe each individual resource’s unique characteristics. This baseline 
model describes that total number of interface ports that a server supports, the minimum time required to 
setup the software image, and so forth. Later, this resource type is accessed and modeled to fit one particular 
server as a resource instance. However, more than one resource type may be required if mutually exclusive 
options are available for the resource model. 

The following topics are described in this section:

• Building Resource Types

• Modifying Core Properties for Resource Types

• Adding Resource Interface Types

• Adding Provisioning Parameters

• Adding Inventory Parameters

• Creating Custom Icons for Resource Types

• Deleting Resource Types

Building Resource Types
You can build a resource type by copying an existing resource type, importing one, or creating a new one. 
This section describes some of the guidelines you should follow:

• Analyze—Identify what interfaces, other components, properties, and attributes does the resource 
have. Compile the information into a spreadsheet for reference.

• Copy and Modify—Find the most similar resource of that type that already resides in the Active 
System Manager inventory and use it as a starting point. Copy that resource and make the changes 
necessary to the properties and interfaces to match your target resource type. 

• Create a New Resource Type—If copying or importing an existing resource type is not practical, you 
can create a new resource type within the Active System Manager software.

This section describes how to build a resource type via the following methods:

• Creating a New Resource Type

• Importing a Resource Type

• Copying Existing Resource Types

• Updating Multiple Resource Types at Once
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Creating a New Resource Type
To create a new resource type, you may need a variety of different types of resource information, such as 
the resource data outlined in Table 5-4.

Table 5-4 Resource Type Resource Information 

Resource Description

Name Resource type name.

Manufacturer Resource type manufacturer name.

Model Resource type model name.

Role A list of roles available (by category listed below). Use the appropriate role value based on your 
resource type. For Layer 1 or Layer 2 switching infrastructure, select Matrix Switch as the role.

Advanced Modeling Physical Resources Virtual Resources
Controlled 
Equipment

Component Managed Equipment Virtual Hub
Matrix Switch
Patch Panel
Power Controller
Terminal Server
TFTP Server

Power supplies For example, 110 VAC, 220 VAC, or 48 VDC.

Console Used for managing the resource locally, often a Serial EIA-232 port.

Management ports One or more additional ports (Ethernet) that are able to manage the resource through a network.

Interfaces Many resources, especially network test resources, have a varying number of different kinds of 
interfaces on the same resource, such as DS-1 (T1), DS-3, and OC-3 ports. You may also need 
more details. 
For example, a DS-1 port can be used with standard Telco time division multiplexing or with 
Asynchronous Transfer Mode (ATM) signaling. In this case, you need to select the appropriate 
interface type in the Inventory perspective; either DS-1 or ATM DS-1. An OC-3 port might use 
standardized Synchronous Optical Network (SONET) OC-3 signaling or channelized signaling, in 
which case it carries the multiplexed signals of a number of lower speed lines. 
Depending on the resource type, you would select a SONET OC-3c port or a CHOC3 port. By 
qualifying the port in this manner, you make more information available to users of the resource 
type. More importantly, you prevent two incompatible OC-3 interfaces from being connected in a 
Template, heading off unneeded debugging efforts.

File System Used for managing the file system.

How many of each type of 
interface is present on the 
resource type

The Inventory perspective allows you to set a range; the minimum quantity of the type of interface 
allowed on the resource can be zero or higher. You also need to know the maximum number of 
interfaces allowable.

Interfaces, console ports, and 
power supplies

If you need an element of a type that is not currently available on the Active System Manager 
server, you can add a new element type. For more information, see the “Adding Interface Types” 
section on page 5-31.

Setup time and cleanup time Setup time is the time required to load software, boot and initially configure the resource before it is 
ready for use. 
Cleanup time allows for tasks related to restoring the state of the resource at the end of a session.

Runtime image name 
(provisioning parameters)

Allows a software image to be specified for a session.

Config file name (provisioning 
parameters)

Allows a configuration file to be specified for a session. This file is typically a script with 
command-line interface (CLI) commands to configure the resource at the beginning of a session, 
during the setup time.
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The core properties for a resource type contain fields for the Manufacturer, Model, and Families 
information. However, much of the information about a server can be included in the name itself. For 
example, you could use the manufacturer, model, and memory configuration as the resource type name, 
such as “Dell_PowerEdge1955_32gbRAM”.

To create a new resource type, perform the following steps:

1. On the Active System Manager menu bar, click File > New > Active System Manager > Resource 
Type > Next. Alternately, you can right-click anywhere in the Resource Type Navigation view and 
select New. 

The New Resource Type dialog box displays; see Figure 5-4.

Figure 5-4 New Resource Type

Properties for property-based 
scheduling

You can define new kinds of properties as inventory parameters with the “schedulable” flag set 
enabled. When creating a Template in the Template perspective, you can then specify values 
required for those properties. The Active System Manager scheduler checks that a resource meets 
those requirements before allocating it in a session. 
You can define new properties for a resource type at the resource level or at the interface level. For 
more information regarding property-based scheduling, see Chapter 5, “Inventory Management.”

Note For interfaces, console ports, and power supplies, if you need an element of a type that is not 
currently available on the Active System Manager server, you can add a new element type.

Table 5-4 Resource Type Resource Information (continued)

Resource Description
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Note The Active System Manager allows modeling of virtualized resourcing. Virtualized resources exist 
in inventory as a resource type, but virtual resource instances do not have associated resource 
instances in the inventory, which means that a virtual resource instance cannot be created using the 
traditional wizard. Instead, because the Active System Manager is responsible for the creation and 
destruction of those on-demand resources, the virtual resource instance is created at runtime. 
Examples of such virtual resources include Amazon AMI Instances, VMware virtual machines, and 
Citrix Xen virtual machines. When creating a virtual resource type, use the procedure for creating 
a resource type. 

2. For each new resource, enter a unique Name, Manufacturer, Model, select the Roles, and search (click 
Browse) for an Icon. 

Note You can create your own set of custom icons. For more information, see the “Creating Custom Icons 
for Resource Types” section on page 5-18.

3. Click Finish. 

4. Once you have created a new resource type, you can then add the following associated information:

• Core properties—see the “Modifying Core Properties for Resource Types” section on page 5-12.

• Interface types—see the “Adding Resource Interface Types” section on page 5-13.

• Provisioning parameters—see the “Adding Provisioning Parameters” section on page 5-14.

• Inventory parameters—see the “Adding Inventory Parameters” section on page 5-15.

Importing a Resource Type
To import a resource type, perform the following steps:

1. Select a method to open the Import dialog box; see Figure 5-5: 

• On the Active System Manager menu bar, click File > Import > Active System Manager > 
Resource Types > Next.

• In the Resource Types view, right-click and select Import > Resource Types > Next.

• On the Active System Manager toolbar, click Import > Active System Manager > Resource 
Types > Next.
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Figure 5-5 Import Resource Types

2. By default, the Select root directory option is enabled to allow you to manually type in the root 
directory location, or you can click Browse to navigate to the desired location.

3. Select the Select archive file option and type the archive file, or click Browse to navigate to the desired 
location.

4. In the Resource type specifications section, select a resource type, or click Select All to select all of the 
resource types available.

5. Click Finish.

Note Each imported resource type will open its own editor. You can modify this behavior by performing 
the following steps:

1. On the Active System Manager menu bar, click Window > Preferences > General > Editors.

2. Click the Close editors automatically check box.

3. Click the Number of opened editors before closing field and type a number of editors you want 
opened as the default number.

Copying Existing Resource Types
To make one or more copies of a resource quickly, you can use the Copy function. When you copy the 
currently selected resource, the copies are added to the Inventory perspective’s workspace. 

To copy an existing resource type, perform the following steps:

1. Select the resource to copy by highlighting it. 

2. Right-click the resource and select Save As. 

The Save As—Clone a Resource Type dialog box displays; see Figure 5-6.
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Figure 5-6 Save As—Clone a Resource Type

3. Once you have created a new resource type from the existing resource type, you can modify the 
following information:

• Core properties—see the “Modifying Core Properties for Resource Types” section on page 5-12.

• Interface types—see the “Adding Resource Interface Types” section on page 5-13.

• Provisioning parameters—see the “Adding Provisioning Parameters” section on page 5-14.

• Inventory parameters—see the “Adding Inventory Parameters” section on page 5-15.

Updating Multiple Resource Types at Once
To update multiple resource types at once, perform the following steps:

1. In the Resource Types view, select one or more resource types, right-click and select Open with 
Multi-Editor.

The selected resource types open in a spreadsheet editor. For more information about using 
multi-editors, see Chapter 1, “Active System Manager Overview.”

2. Update the resource types as appropriate.
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Modifying Core Properties for Resource Types
The core properties data is used throughout the Active System Manager software. Adding as much 
information about the core properties makes it easy to create test cases and templates.

To modify resource type core properties, perform the following steps:

1. In the Resource Types view, right-click a resource type and select Open to display the resource type 
core properties within the specified perspective. Table 5-5 displays the resource type core properties.

Table 5-5 Resource Type Core Properties 

Property Name Property Description

Manufacturer Resource manufacturer name.

Model Model number or name of the resource type.

Version Version number for the resource hardware.

Roles Resource role of a resource created from this model-managed Resource; or for an Active 
System Manager control resource, such as, a Component, Hub, Matrix Switch, Patch 
Panel, Power Controller, Terminal Server, or TFTP Server.

Name Name of the resource.

Description Text string describing this resource.

Families Family of resources to which this resource belongs. This represents another way of 
describing the resource. This property is optional.

Classification Descriptive field used to classify the resource. It is used mostly for component resource 
types.

Setup Time (Min) Amount of time required to setup the resource’s software.

Cleanup Time (Min) Amount of time required to remove the resource’s software.

Author Name The contact information for questions about this resource model.

Author E-Mail The author’s email address.

Author Company The author’s company name.

Icon Icon for this resource type.

2. Enter as much information about the core properties as possible. Fields that cannot be modified are 
displayed in gray (disabled).

3. On the Active System Manager menu bar, click File > Save to save your changes to the server.
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Adding Resource Interface Types
Once you create a resource type, you can define the associated interface types for that resource type. For 
more information regarding interface types, see the “Using Resource Interface Types” section on 
page 5-30.

To add resource interface types for your new resource type, perform the following steps:

1. In the Resource Types view, right-click a resource type and select Open.

The resource type core properties display within the specified perspective.

2. Scroll down to the Interface Types section; see Figure 5-7 for an example.

Figure 5-7 Resource Type—Interface Types Section

3. Click Add.

The Interface Type Selection dialog box displays; see Figure 5-8.
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Figure 5-8 Interface Type Selection

4. Select the desired interface type and click OK to update the resource type with the new interface type 
information.

5. Optional. If you add a new Console interface type, you can also update the Console parameters for the 
configuration and inventory as follows:

a. Navigate to the Console section, below the Interface section for the resource type; see Figure 5-7.

b. Click Add to add the desired provisioning parameters. You can specify the name, description, and 
default value for each.

c. Click the Inventory tab to add the necessary inventory parameters. You can specify the name, 
description, and encrypted parameters. If you click the Encrypted check box for inventory, the 
encryption works on the inventory parameter value, which is defined in the resource instance.

Adding Provisioning Parameters 
Provisioning parameters are used for resources that have Active System Manager resource integrations 
installed. Provisioning parameters can include operating software image files, and files with configuration 
commands for the resource. The attributes can be different, both in name and number, for different resource 
types. 

To add a provisioning parameter to the new resource type, perform the following steps:

1. In the Resource Types view, right-click a resource type and select Open.

The resource type core properties display within the specified perspective.

2. Scroll down to the Provisioning Parameters section (see Figure 5-9) and add a provisioning parameter 
as follows:

• Click Add to add a blank parameter to the section.

• Click Add Image to add a reference to an image file from one of your repositories; see Chapter 7, 
“Repository Management.”
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• Click Add Configuration to add a reference to a configuration file from one of your repositories; 
see Chapter 7, “Repository Management.”

Figure 5-9 Provisioning Parameters

3. Available on for the Add function: Modify the Name, Description, and Default Value fields as 
necessary. 

Note These parameters are case-sensitive and must be entered exactly as shown.

4. Click File > Save to save the changes to the server. 

You can also set resource type editor preferences to display warnings for incompatible provisioning 
parameters; on the Active System Manager menu bar, click Window > Preferences > Inventory, and then 
click the Resource Type Multi Editor check box; see Figure 5-11.

Note When using the Resource Types view, provisioning parameters are available for custom resource 
type filtering and grouping.

Adding Inventory Parameters
You can define many types of custom inventory parameters for resource types, and assign values for these 
parameters for each resource instance. Inventory parameters can include such things as environment, site, 
location, size, speed, acquisition date, vendor, style, color, etc. The following topics describe how to add 
inventory parameters:

• Adding Inventory Parameters for Resource-Based Scheduling

• Adding Inventory Parameters for Capacity-Based Scheduling

Note You can define new properties for a resource type at the resource level or at the interface level.
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Adding Inventory Parameters for Resource-Based Scheduling
Inventory parameters carry specific information about each resource type. It allows for a complex 
customization of the resource type. 

To add an inventory parameter for resource scheduling, perform the following steps:

1. In the Resource Types view, right-click a resource type and select Open.

The resource type core properties display within the specified perspective.

2. Scroll down to the Inventory Parameters section (see Figure 5-10) and click Add to add a blank 
parameter.

Figure 5-10 Resource Type—Inventory Parameters

3. Modify the inventory parameters as follows:

a. A default name is already provided. Click the Name and Description fields and modify, as 
appropriate. 

b. Click the Type field and select one of the following types:

• String—Text and numbers are allowed. There is no maximum number of characters to use.

• Password—Save the inventory parameter value in an encrypted format on the server. In addition, 
you can specify whether to encrypt the value for new or existing inventory parameters. All 
resource instances derived from this resource type will include the encrypted parameter. The 
encrypted flag can be used for password protection, sensitive access, and so on.

• Numeric—Only numerical data is allowed in the inventory parameter value.

• Date—User can select a date from the calendar, as appropriate.

c. Optional. Click the Unit field and type unit that best associates to the parameter name.

d. Click the Schedulable check box to use the resource type for property-based scheduling. 

Note Leave the settings for the Capacity check box and the Over Subscription field blank.

4. Click File > Save to save your changes to the server.

The Active System Manager application supports Template-level setup and teardown scripts as a standard 
feature. These scripts are run at the beginning and end of the session, respectively, when a Template is part 
of a live session. For resources that have Active System Manager resource integrations installed, the Active 
System Manager application also supports resource-level setup and teardown scripts, which can be 
specified and run in addition to Template-level scripts. 
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To define resource-level setup and teardown scripts, you must define the inventory parameters called 
resourceSetUpScript and resourceTearDownScript at the resource type level, and then associate a runable 
script with them in the resource instance. In each resource instance associated with the resource type, you 
can specify default values for these scripts.

Note Do not encrypt system-level inventory parameters, like resourceSetUp or resourceTearDown, that 
will be used by resource integrations.

Note Inventory parameters are automatically available for custom resource instance filtering and 
grouping when using the Resource Instances view.

Note These parameters are case-sensitive and must be entered exactly as shown.

Adding Inventory Parameters for Capacity-Based Scheduling
Capacity-based scheduling is used in the context of virtualized resources. The scheduler must identify the 
host resource that is responsible for creating and destroying the virtual resources based on its internal 
capacity. It can be CPU-bound, disk-bound, or memory-bound.

To add an inventory parameter for resource scheduling, perform the following steps:

1. In the Resource Types view, right-click a resource type and select Open.

The resource type core properties display within the specified perspective.

2. Scroll down to the Inventory Parameters section (see Figure 5-10 on page 5-16) and click Add to add 
a blank parameter.

3. Modify the inventory parameters as follows:

a. A default name is already provided. Click the Name and Description fields and modify, as 
appropriate. 

b. Click the Type field and select the Numeric type. 

Only numerical data is allowed in the inventory parameter value.

c. Optional. Click the Unit field and type a unit that best associates to the parameter name.

d. Click the Capacity check box to use the resource type for capacity-based scheduling. 

4. Click File > Save to save your changes to the server.
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Creating Custom Icons for Resource Types
The Inventory perspective contains a selection of custom icons for network resources. You can create 
custom icon images for your resource types. The image files must be of the .GIF file type. They should not 
be any larger than 80 pixels wide and 80 pixels high.

Each user can specify their own custom icon Library folder. However, it would be more efficient for all of 
the users to agree on a folder that resides on a server so that everyone has access to the same files. Or, each 
environment can have a unique icon library on a server. To build a library of custom icons and update the 
Active System Manager server properties, contact your administrator.

Note When a custom icon is used, it is copied to the database and attached to the entry. If you modify the 
original icon file, you must re-attach it to the resource type. 

To create a custom Library folder, perform the following steps:

1. Copy the icon GIF files to the target folder.

2. On the Active System Manager menu bar, click Window > Preferences > Inventory.

The Preferences—Inventory dialog box displays; see Figure 5-11.

Figure 5-11 Preferences—Inventory

3. In the Custom Icon Library Folder section, enter the folder path for the library folder, or click Browse 
and navigate to the path and click OK.

4. When the folder is selected, click OK. 

The custom icons are now available when creating or modifying a resource type. 
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Deleting Resource Types 
When you delete a resource type, the Active System Manager software removes it from your workspace, 
and permanently deletes it from the Active System Manager server. If the resource type has any 
dependencies, the Active System Manager server does not delete the resource type and will display 
associated dependencies.

To delete a resource type, perform the following steps:

1. In the Resource Types view, right-click a resource type and select Delete.

2. Click OK to confirm the deletion.

Using Resource Instances

A resource instance is an actual and specific piece of physical equipment, which conforms to the 
specifications of a resource type, and which can be uniquely identified by an asset tag. In the inventory 
model, in may also be considered as a a set of unique parameters that defines what interfaces are being used 
in the resource type for an actual piece of hardware in your environment. The resource instance also defines 
the format, tasks, availability, and the communication process used with the other resource instances in 
your environment. 

The following topics are described in this section:

• Building Resource Instances

• Modifying Core Properties for Resource Instances

• Modifying Resource Instance Resource Availability Dates

• Modifying Resource Instance Interfaces

• Displaying the Resource Availability Calendar View

• Deleting Resource Instances

• Setting Inventory Parameter Values
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Building Resource Instances
You can build a resource instance by copying an existing resource instance, importing one, or creating a 
new one. This section describes some of the guidelines you should follow:

• Analyze—Identify what interfaces, other components, properties, and attributes does the resource 
instance have. Compile the information into a spreadsheet for reference.

• Copy and Modify—Find the most similar resource instance of that type that already resides in the 
Active System Manager inventory and use it as a starting point. Copy that resource instance and make 
the changes necessary to the properties and interfaces to match your target resource type. 

• Create a New Resource Instance—If copying or importing an existing resource instance is not 
practical, you can create a new resource instance within the Active System Manager software.

This section describes how to build a resource instance via the following methods:

• Creating Resource Instances

• Importing Resource Instances

• Copying Resource Instances

• Updating Multiple Resource Instances at Once

Creating Resource Instances 
You can use the Inventory perspective to create a new resource instance. You add each of the needed 
element types (interfaces, power supplies, console, and so on) and each of the appropriate attributes to your 
new resource. 

To create a new resource instance, perform the following steps:

1. Select a method to open the New Resource Instance dialog box (see Figure 5-12):

• On the Active System Manager menu bar, click File > New > Resource Instance.

• In the Resource Instances view, right-click any resource type, and select New Resource Instance.

• On the Active System Manager toolbar, click New > Resource Instance.
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Figure 5-12 New Resource Instance 

2. Select an existing resource type. 

To search for particular existing resource type, use the filters, grouping and sorting tools to find the 
existing resource types that match your criteria. 

3. Click the Asset Tag, Name, and Role fields, and enter values for the selected resource. The Asset Tag 
value must remain unique across the entire inventory.

The Role field is automatically filled with the default values based on its type.

4. Click the Domain field and select an appropriate domain. 

By default, the default domain is selected.

5. Click Finish to display the new resource instance in the editor.

6. Update, add, or remove the availability using one of the following methods:

• Select the availability date and update manually.

• Select the availability date and click Add.

• Select the availability date and click Remove.
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7. Update, add, or remove interfaces and set properties using one of the following methods:

• Select one or more interfaces and update manually.

• Select one or more interfaces and click Add.

• Select one or more interfaces and click Remove.

When creating a new resource instance, the Active System Manager application will generate the 
minimum set of interface, as specified in the associated resource type. The minimum requirements must 
be available to save your resource instance.

8. On the Active System Manager menu bar, click File > Save to save your changes to the server.

Importing Resource Instances
To import a resource instance, perform the following steps:

1. Select a method to open the Import dialog box: 

• On the Active System Manager menu bar, click File > Import > Active System Manager > 
Resource Instances > Next.

• In the Resource Instances view, right-click and select Import > Resource Instances > Next.

2. By default, the Select root directory option is enabled to allow you to manually type in the root 
directory location, or you can click Browse to navigate to the desired location.

3. Select the Select archive file option and type the archive file, or click Browse to navigate to the desired 
location.

4. In the Resource instances specifications section, select a resource instance, or click Select All to select 
all of the resource instances available.

5. Click Finish.

Note Each imported resource instance will open its own editor. You can modify this behavior by 
performing the following steps:

1. On the Active System Manager menu bar, click Window > Preferences > General > Editors.

2. Click the Close editors automatically check box.

3. Click the Number of opened editors before closing field and type a number of editors you want 
opened as the default number.
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Copying Resource Instances
You can copy resource instances via the Inventory perspective’s Advanced Clone tool. Using the Advanced 
Clone tool to copy resource instances speeds the process for creating large numbers of resource instances. 
Based on an existing resource instance, the Inventory perspective copies the existing component and 
interface configuration, but does not copy any of the existing availability dates. The availability date is set 
to the default from the Preferences dialog box. The Keep availability check box option retains the 
availability of the source resource.

Key features of the Advanced Clone tool include: 

• Supports cutting and pasting

• In addition to the standard Ctrl key combinations, there are three dialog box buttons for cutting, 
copying, and pasting. 

• There are also buttons undo and redo through the lists of generated names. They function similarly to 
the Forward and Back buttons in your web browser.

Using the Pattern Generator Tool
The Active System Manager Pattern Generator tool can generate assets and resource names with unique 
identifiers. Using a special character string called a range you can create a long list of names and asset tags 
that have either letters or numbers appended to the string. 

The format for the range string is (1..9999), (A..Z), (a..z), (AA..ZZ), or (aa..zz). Because uppercase and 
lowercase letters are treated as different values, there is a range of 308,915,776 unique letter combinations. 
Special characters and punctuation are not supported. You can use any whole numbers in either ascending 
or descending order; you can use up to four range strings for an asset tag or name. Hence, if you used the 
pattern “Cisco(1..3)” for a resource name, the Inventory perspective generates three names (Cisco1, 
Cisco2, and Cisco3).

Note If your range string begins with a single digit (1 to 9), use a zero to force the generator to make the 
patterns identical; for instance, Cisco[01..25].

Using multiple range strings creates a geometric progression. A unique pattern is generated for every 
possible combination of the ranges. Therefore, if you used the Cisco(Z..X)_Port(01..03) pattern 
for an asset tag, the Inventory perspective generates nine asset tags:

• CiscoX_Port01, CiscoX_Port02, CiscoX_Port03

• CiscoY_Port01, CiscoY_Port02, CiscoY_Port03

• CiscoZ_Port01, CiscoZ_Port02, CiscoZ_Port03

There is also a supported modifier for the pattern generator. You can use the percent symbol (%) to limit 
the upper limit of a range. For example, the Cisco_(AA..ZZ%C) range only produces names from 
Cisco_AA to Cisco_ZC. This modifier works with numeric ranges, but it is only useful for alphabetical 
ranges.

Note There must be an equal number of unique asset tags and unique names. Duplicated resource names 
are not allowed. If you create duplicate names, an Add Resource Failed error message displays. 
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Copying Resource Instances Using the Advanced Clone Tool
To copy a resource instance via the Advanced Clone tool, perform the following steps:

1. Open the Inventory perspective; see the “Opening Perspectives” section on page 1-7.

2. In the Resource Instances view, right-click a resource instance and select Advanced Clone to display 
the Advanced Clone of Resource Instance dialog box.

Note To create a single copy, in the Resource Instance editor, right-click a resource instance and select 
Save As. Enter a unique name and click OK.

This dialog box accepts one or two column inputs from Excel. If you have a spreadsheet with two columns 
of unique names, you can paste them into the bulk save dialog box. If there are names already in the list, or 
if you are only pasting one column, the Inventory perspective prompts you to overwrite the existing names 
or append the new data, and confirms which column to paste the data. If there are two columns, it assumes 
the asset tags are in the left column.

3. Enter a unique Asset Tag Pattern and click the Generator icon. For example, AT (1..10) will generate 
AT1, AT2...AT10 distinct tags. 

4. Enter a unique Name Pattern and click the generator. 

5. Click the Open generated resource instances in workspace option to open in the workspace. 

Caution Risk of poor computer performance. Dell recommends that you not perform this if you create a 
large number of copies. It can affect your computer’s performance.

Note There is also a Keep availability flag to copy the availabilities of the copied resource instances. 

6. Click OK to automatically add the resource instance to the server and open it in the workspace. 

Note Dell recommends that you not create more resource instances than you have your preferences 
allocated for under the “Preferences” section. 

Updating Multiple Resource Instances at Once
To update multiple resource instances at once, perform the following steps:

1. In the Resource Instances view, select one or more resource instances, right-click and select Open with 
Multi-Editor.

The selected resource instances open in a spreadsheet editor. For more information about using 
multi-editors, see Chapter 1, “Active System Manager Overview.” 

2. Update the resource instances as appropriate; see the next section, “Modifying Core Properties for 
Resource Instances,” for updating the resource instance core properties.
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Modifying Core Properties for Resource Instances
The information in the core properties section provides a basic description of the resource instance. 
Table 5-6 lists the default resource instance core properties.

Table 5-6 Resource Instance Core Properties  

Property Name Property Description

Name Name of the resource.

Manufacturer (Read-only) Resource manufacturer name.

Model (Read-only) Model number or name of the resource type.

Asset tag Unique identifier for the resource model.

Version Version number for the resource hardware.

Role (Read-only) Role of a resource created from this model-managed resource; 
or for an Active System Manager control resource, such as a Virtual, 
Component, Hub, Managed Equipment, Matrix Switch, Patch Panel, Power 
Controller, Terminal Server, or TFTP Server.

Shared • If this property is selected, then the resource instance can be used in 
multiple sessions simultaneously, as long as it has interface ports available. 

• If this property is not selected, the resource instance can only belong to one 
session at a time.

Description Text string describing this resource.

Domain Domain name that manages that piece of equipment.

Note Virtual resources are usually hosted within other resources called Hypervisors, or hosts, or 
clouds—in a more abstract manner. Host resources can also be modeled and must be modeled to 
schedule and realize those virtual resources. Examples of possible host resources would be Vmware 
ESX/ESXi servers, CitrixXen Servers, Amazon Cloud, Rackspace Cloud. Those resources can be 
of managed or control roles, but the associated resource instance must have their virtualization flag 
set to true. This setting indicates to the scheduler that those resources are the ones responsible for 
creating and destroying virtual resources.

To modify resource instance core properties, perform the following steps:

1. Open the resource instance and select the Core Properties section. Enter as much information about 
the core properties as possible. Fields that cannot be modified (disabled) are displayed in gray. 

2. On the Active System Manager menu bar, click File > Save to save your changes.
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Modifying Resource Instance Resource Availability Dates
The resource instance requires, at least, one set of availability dates (i.e., a from and a to date). Availability 
dates are critical properties of the resource instance because the scheduler uses those dates to allocate the 
resource.

To modify the resource availability, perform the following steps:

1. In the Resource Instances view, right-click a resource and select Open. 

2. Scroll down to the Availability section.

3. Click Add and enter the availability dates (with an optional description) within the table.

You can edit any existing availability dates by selecting the date field and entering a new date.

Note The default availability time frame ranges from the current time and date to 12/31/2021 at 
11:59 p.m. To modify the dates, click the arrow and select the correct period using the pop-up 
calendar.

4. Optional. Delete an availability date by selecting it and clicking Remove.

5. On the Active System Manager menu bar, click File > Save to save the date updates.

Note Resource availabilities can be modified as long as the resource has not yet been scheduled. If you 
try to modify, then save the resource instance, session dependencies may display. Canceling those 
sessions is the only way to update the resource availability.

Modifying Resource Instance Interfaces
You can modify resource instance interface definitions (adding) or removing them as long as it still meets 
the minimum requirements from the associated resource type. Each interface includes properties that you 
can set. To save the changes, click File > Save.
Note Underlying physical connectivity information is displayed, if available.

Displaying the Resource Availability Calendar View
The Resource Availability calendar is a display option for the Resource Instances view that enables you to 
view availability and status of specific resources against a variable time frame. 

To display the Resource Availability calendar view, perform the following steps:

1. On the Active System Manager menu bar, click Window > Show View > Resource Instances.

The Resource Instances view displays.

2. Click the Show Calendar icon displayed in the top-right corner of the view.

The Resource Instances view displays with the Resource Availability calendar in the right side of the 
view; see Figure 5-13. 
5-26 Active System Manager User Guide, Release 7.0



Using Resource Instances
Figure 5-13 Resource Allocation Statistics

All of the associated sessions display for each resource instance that is part of the session within the 
Resource Availability calendar. The associated sessions for each resource instance appear as a colored 
rectangular bar. 

You may want to check status and availability for resources by using the Resource Availability calendar 
with the Session view and the Resource Instances view. Allocation statistics are displayed next to the 
resource name or asset tag. A resource is organized in one of three categories:

• Resource not allocated—Dubbed “available for use”; no statistics are displayed.

• Resource partially allocated—A resource that is currently allocated to, at least, one session, with a 
subset of its port. Statistics are displayed from 1 to 99%.

• Resource fully allocated—Either in one session if one resource is not shared, or many sessions if 
resource is shared. No percentage of statistics.

For all categories, the statistics reflect present time, when displayed. Statistics can change when a session 
goes into a setup or teardown state. Setup ports become busy; teardown ports become free.

Note If you expand a session (within a yellow-highlighted row), only the associated resources for that 
selected session are affected.

As a Active System Manager administrator, you can use the information in the calendar view to help users 
make changes and resolve conflicts. You can also use the Resource Availability calendar to perform the 
same functions as the users (check status and look for alternatives); however, the difference is that the 
administrator can go to the specific Session view to change the session. Changes made in the Session view 
calendar may not be reflected within the Active System Manager workbench until you refresh (press F5) 
your workspace.
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Deleting Resource Instances 
To delete a resource instance, perform the following steps:

1. In the Resource Instances view, right-click a resource instance and select Delete. 

You are prompted to verify the deletion, displaying only the asset tag. 

2. Click OK to confirm the deletion. 

If the resource is used in sessions, the update fails. You can resolve these errors by deleting the 
conflicting sessions. 

Setting Inventory Parameter Values 
Inventory parameter definitions are derived from the resource type and cannot be created in the resource 
instance; you can only set the define value in the resource editor. You can then use those values to identify 
search results and to perform property-based scheduling.

To set inventory parameter values to a resource instance, perform the following steps:

1. In the Resource Instances view, right-click a resource instance and select Open.

2. Open the Inventory Parameters section.

3. Select the parameter for which you want to enter (or change) and value.

4. Click the Value column for the parameter value you want to enter (click Ctrl+space). The data entry 
might be different based on the parameter type. For example, if the parameter is of the type “Date”, you 
will be prompted for a calendar. The other columns are for information only; they cannot be changed.

5. Click File > Save to save your changes to the server. 

Note If the resource instance is used in existing sessions, you must also resolve the dependencies; for 
more information, see the next section, “Resolving Resource Dependencies.”

Resolving Resource Dependencies
The Inventory perspective consists of the following conflicts (also called dependencies):

• It does not allow you to delete resource instances that are included in a session.

Note This is applicable to the active and future session only.

• It does not allow you to delete resource types that have resource instances that are included in a session. 

• It does not allow you to modify resource types in a way that might change resource instances or 
sessions. 

If a dependency is present when you delete an item, the Dependencies view displays at the bottom of the 
screen. 

To resolve resource dependencies by the Quick Fix option, perform one of the following operations:
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• Select one or more session dependencies, right-click and select Quick Fix > Cancel to cancel the 
session. Table 5-7 describes the results.

Note The Quick Fix option tries to automatically delete the conflicting issue. However, if 
those resources have dependencies of their own, you must resolve them first.

Note The Show Previous Dependencies icon (located in the top-right corner of the 
Dependencies view) allows you to select which level of dependencies to view. As you 
resolve each dependency, it is removed from the list. When all the dependencies are 
deleted, you can finish modifying or deleting the original resource.

• Select one entry, right-click and select Quick Fix > Update All to update all sessions (dependencies). 
Resources and resource interfaces will be removed from those sessions, but the sessions will continue 
in a Confirmed or Running state.

.

Table 5-7 Quick Fix Results 

Attempted Task Conflict Displayed Quick Fix Action

Deleting a resource 
type

Resource instances built on the resource 
type.

Delete the dependent resource instances. 

Modifying a resource 
type

Standard resource types. Delete the dependent resource instances. 

Deleting a resource 
instance

Conflicting Sessions. Cancel or update sessions by removing 
resources or resource interfaces.

Modifying a resource 
instance

Conflicting Resource Instances. Delete the conflicting resource instances.

Conflicting sessions. Delete the conflicting sessions.

Modifying a CRI Components do not have the requested 
time frame listed as part of their availability.

Update resource component availability.

Breaking a 
Compatibility Link

List of affected links. Delete the links.
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Using Resource Interface Types

This section lists all the resource interface types and selected interface type compatibility available in your 
environment. You can add or delete interface types, and associate certain interface types together. 

Table 5-8 displays the fields associated with resource interface types.

Table 5-8 Resource Interface Type Fields 

Field Name Description

Console Used for managing the resource locally, often a Serial EIA-232 port.

Interface Information that describes the interface. You can add this information when you add an interface 
type.
Note: For resource types only, this field is unavailable.

Power Supply For example, 110 VAC, 220 VAC, or 48 VDC.

File System Used for managing the file system.

The following topics are described in this section:

• Adding Interface Types

• Associating Interface Types

• Disassociating Interface Types

• Deleting Interface Types

• Modifying Resource Interface Type Location Information
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Adding Interface Types
To add an interface type, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Interface Types.

The Interface Type Definition and Compatibility dialog box displays; see Figure 5-14.

Figure 5-14 Interface Type Definition and Compatibility 

2. Click the desired Console, Interface, Power Supply, or File System, and then click Add. 

The Add Interface Type dialog box displays; Figure 5-15.

Figure 5-15 Add Interface Type 

3. Click the Description field and enter a descriptive name.

4. Click OK to save your changes.
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Associating Interface Types
To associate interface types, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Interface Types.

The Interface Type Definition and Compatibility dialog box displays; see Figure 5-14 on page 5-31.

2. Click the Show and manage interface types compatibility check box to display the Associate and 
Disassociate buttons.

3. Select the primary interface.

4. Hold down the Ctrl key and select the interface types to associate.

5. Click Associate. 

The interface types are listed under the primary type as secondary types and your changes are 
automatically saved.

Disassociating Interface Types
To disassociate interface types, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Interface Types.

The Interface Type Definition and Compatibility dialog box displays; see Figure 5-14 on page 5-31.

2. Click the Show and manage interface types compatibility check box to display the Associate and 
Disassociate buttons.

3. Hold down the Ctrl key and select the interface types to disassociate.

4. Select the secondary interface types and click Disassociate to automatically save your changes.

Deleting Interface Types
To delete an interface type, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Interface Types.

The Interface Type Definition and Compatibility dialog box displays; see Figure 5-14 on page 5-31.

2. Select the interface type and click Delete. 

Note You cannot delete interface types that are associated with other types, or that are being used by 
resource types, resource instances, links, and so on.

Modifying Resource Interface Type Location Information
This section (including the following topics) describes how you modify the interface type location 
information for your resource types: 

• Using Resource Interface Type Location Names

• Generating Unique Location Names
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Using Resource Interface Type Location Names
You can use the Inventory perspective to generate resource location names with unique identifiers. The 
Active System Manager Pattern Generator tool can generate assets and resource names with unique 
identifiers. Using a range, you can create a long list of names and asset tags that have either letters or 
numbers appended to the string. 

The format for the range string is (1..9999), (A..Z), (a..z), (AA..ZZ), or (aa..zz). Because uppercase and 
lowercase letters are treated as different values, there is a range of 308,915,776 unique letter combinations. 
Special characters and punctuation are not supported. You can use any whole numbers in either ascending 
or descending order; you can use up to four range strings for an asset tag or name. Hence, if you used the 
pattern “Cisco(1..3)” for a resource name, the Inventory perspective generates three names (Cisco1, 
Cisco2, and Cisco3).

Note If your range string begins with a single digit (1 to 9), use a zero to force the generator to make the 
patterns identical; for instance, Cisco[01..25].

For more information about the Pattern Generator, see the “Using the Pattern Generator Tool” section on 
page 5-23.

Note Dell recommends that you do not generate more than 100 patterns at once.

Generating Unique Location Names
To generate unique location names, perform the following steps:

1. In the Resource Types view, right-click a resource type and select Open to open the resource type in its 
own editor workspace.

2. Scroll down to the Interface Types > Locations column; see Figure 5-16.

Figure 5-16 Interface Types—Locations Column

3. Select the entry that needs locations and then click in the Locations area. 

The Edit Interface Type Locations dialog box displays; see Figure 5-17.
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Figure 5-17 Edit Interface Type Locations 

4. Enter the interface locations manually or use the Pattern Generator tool to generate a bulk set of 
locations in the table.

5. Modify any names by selecting them with your mouse.

6. Click OK to automatically add the locations to the resource type. 

Linking Resources

The Inventory perspective supports links between control equipment and managed equipment, or between 
two pieces of managed equipment. When you add managed equipment, you must plan the physical 
connections between the new equipment and the Active System Manager control equipment, and inform 
the Active System Manager software of these connections. 

Note The Resource Instance tree views can display either Managed or Controlled resources using the 
various filters.

This section describes the following topics:

• Using Resource Links

• Creating Links Between Resources
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Using Resource Links
You specify connections (links) between the following types of resources and resource components:

• Resource power supplies and power controllers

• Resource console ports and terminal servers

• Resource interface ports and matrix switches

• Resource interface ports and patch panels

• Resource interface ports and other managed resource interface ports

Creating Links Between Resources
When you create a link, the Inventory perspective compares the two associated ports against the following 
general conditions:

• Are both interface ports compatible?

• Are both interface ports available?

• Are both interface ports currently unassigned to a link?

• Are you trying to link an interface port to itself?

Note You must create and associate an interface type before you can create the associated link. For more 
information, see the “Using Resource Interface Types” section on page 5-30.

To create a virtual link to network environment resources, perform the following steps: 

1. On the Active System Manager menu bar, click Tools > Links > Edit.

The Links editor displays; see Figure 5-18. 

Figure 5-18 Links Editor
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2. Click New. 

Note It does not matter which New button you click; they all access the same dialog box.

The Inventory perspective displays the New Link dialog box; see Figure 5-19.

Figure 5-19 New Link—Link Management

3. Select interface locations for both resources, and then click Apply to create a new link or multiple links. 

4. Click Close.

If there is a problem with the link you have selected, a warning message displays at the top of the dialog 
box. Follow the instructions in the warning message to correct the problem.

5. When you have created all your links, on the Active System Manager menu bar, click File > Save to 
save your changes to the server. 

Note You can create a new link: in the Resource Instances view, right-click and select Link > Edit Links 
to modify or add new links; or click Link > View Links to view them in the Links view.

Once you have defined the physical link connections, you can create the links between your resource 
instances. For more information, see Chapter 8, “Template Management.” 
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Deleting Links
To delete links, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Links > Edit to display the Links editor with 
available links; see Figure 5-18 on page 5-35.

2. Select one or more links and click Delete.

3. Click File > Save to save this operation.

Note You can only delete physical links if they are not used by any Running sessions. If they are in use, 
the Dependencies view will display automatically and list one or more sessions. To remove the 
session links first, use the Quick Fix > Update All option, and then save the link editor one last 
time.

Importing Inventory

The Active System Manager Inventory Import tool enables the administrator to import an inventory of 
CRIs, or chassis-based resources (for example, cards and hierarchical resources) into your Active System 
Manager server, and then update their specific configuration (for example, module or port blade changes).

The Inventory Import tool accepts this resource inventory data in the form of input field definitions that are 
contained within a comma-separated value (CSV) file called the network inventory spreadsheet. The 
Active System Manager administrator inputs this inventory data according to the rules set according to the 
CSV field definitions into the Active System Manager software. 

Once this data is loaded into the Active System Manager client, the administrator uses the Input CSV editor 
to validate the input field definitions specified within the CSV file, provide status, error data, and report 
information on the associated inventory, and then upload the inventory data into the Active System 
Manager client.

This section describes how to import inventory, primarily by way of the following methods:

• Importing Standard Resource Instances

• Populating an SDI Inventory Spreadsheet

• Creating Location Generator Files

• Importing Plug-In Interface Files

• Validating CSV Resource Data

• Importing Validated Resource Data

Importing Standard Resource Instances
This section includes details for the overall process required to import your standard inventory, and some 
examples of the associated CSV files for different types of resources. 

Table 5-9 outlines the typical workflow checklist for importing standard resource instance (SDI)-based 
inventory with the Import tool.
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Table 5-9 Typical Workflow Checklist for Importing SDI-Based Inventory 

Task 

1. Perform a complete inventory of all standard network resources in your environment.

2. Use the inventory data from step 1 to populate a network inventory spreadsheet. For more information, see 
the “Populating an SDI Inventory Spreadsheet” section on page 5-38.

3. Migrate the data in the network inventory spreadsheet to a CSV file. Note: The CSV file also includes a set 
of additional input field definitions that are used by the Active System Manager software.

4. Import the CSV file into the Active System Manager client. For more information, see the “Importing 
Validated Resource Data” section on page 5-46.

5. Fix any returned CSV errors.

6. Re-import the validated CSV file into the Active System Manager client. For more information, see the 
“Importing Validated Resource Data” section on page 5-46. 
Note: If you use the CSV editor in the Active System Manager client, re-importing the CSV file is 
unnecessary.

7. Validate the imported CSV file; see the “Validating CSV Resource Data” section on page 5-45.

8. Fix any remaining errors and re-import the validated CSV file. For more information, see the “Importing 
Validated Resource Data” section on page 5-46.
Note: If you use the CSV editor in the Active System Manager client, re-importing the CSV file is 
unnecessary.

9. Create a resource interface location generator file for each resource. 

10. Perform a final validation check to ensure that your resource interfaces are correct.

11. Once resources have been saved, you can import links using the procedure described in the “Linking 
Resources” section on page 5-34. This is the same process with standard and composite resources.

Populating an SDI Inventory Spreadsheet

For additional information related to the CSV file, see Table 5-10, which lists and describes the illegal 
characters, value definitions, and field lengths that can be used when importing your composite 
resources.
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Table 5-10 CSV Input Field Definitions 

Field Name Field Length Illegal Characters Description

Resource 
Details

Resource 
Manufacturer

0 to 80 chars \ / : * ? \ " < >  | , ' & % 
" " (i.e. a space char)

Defines the Manufacturer of the resource. For the inventory 
spreadsheet, only list the Resource Manufacturer once per 
resource.

Resource Model 0 to 40 chars \ / : * ? \ " < >  | , ' & % 
" " (i.e. a space char)

Model of the resource. Be consistent when naming like models 
so that the Active System Manager software can appropriately 
select equipment for sessions. 

Resource Asset 
Tag

0 to 80 chars \ / : * ? \ " < >  | , ' & % 
" " (i.e. a space char)

Resource Asset Tag must be unique across your inventory. 
Defining a specific naming scheme is useful and recommended 
as Asset Tags are used across the entire application and reports.

Resource Display 
Name

0 to 80 chars \ / : * ? \ " < >  | , ' & % Displays the actual name that you would like to see the resource 
identified as within the Active System Manager software. Display 
Name does not have to be unique.

Resource 
Category

0 to 80 chars " \ ' < > & | Category of the resource. For example: managed resource, 
matrix switch, or hub.
You must identify a Resource Category for every component 
listed. There are several different options: hub, 
managedresource, matrixswitch, patchpanel, 
powercontroller, terminalserver, and tftpserver 
are the available options.
If it is a Cisco router or switch for instance, this would be listed as 
managedresource.
If it is a control resource, say an APCON, MRV, or layer one 
switch, it would be listed as a matrixswitch.
Resource category depends on the usage of the resource within 
the test Template. If the resource is to be used as a “resource 
under test” (RUT), the category needs to be 
“managedresource”. If the resource is not used as RUT, 
resource category need to be assigned based on the type of 
operation it performs. 

Resource 
Description

0 to 1024 chars " \ ' < > & | Description of the resource. This field is not a mandatory; 
however, you can use it to describe the chassis or resource.
For example: 6-slot catalyst switch, 24-port switch, or 4-slot 
modular router.

Interface

Resource 
Interface

0 to 80 chars " \ ' < > & | Use the Component Interface field to define the type and number 
of ports installed in a module. For example, if you have 48 Gigabit 
Ethernet ports, you can enter either “GigabitEthernet=48” 
or “10/100/1000=48”. Note that being consistent when 
naming ports can improve the software’s functionality.
Types of traffic interfaces belonging to the component, separated 
by a pre-defined separator (comma); for example:
• Ethernet10/100/1000=48
• Ethernet10/100=1
• Serial DS1=2

Management Interface
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Resource 
Management 
Interfaces

0 to 80 chars " \ ' < > & | Where you can enter the address assigned to the port on your 
chassis. This must be a port and not a VLAN. For example, if a 
management address is accessed through port 1 on your Gigabit 
Ethernet module, then enter “GigabitEthernet=1” as the 
value of this field; for example: 
• Ethernet10/100/1000=1
• Ethernet10/100=1

Resource 
Management 
Interface IP 
Address

0 to 80 chars " \ ' < > & | 
" " (i.e. a space char)

Identifies the IP address assigned to the resource

Resource 
Management 
Interface Subnet 
Mask

0 to 80 chars " \ ' < > & | 
" " (i.e. a space char)

Use this field to identify the Subnet Mask of the resource only if 
you entered a value in the Management Interface field. If you did 
not enter a value in Component Management Interface field, then 
leave this field blank; for example:
• 255.255.255.252
• 255.255.255.0
• 255.255.255.240

Resource 
Management 
Interface 
Gateway

0 to 80 chars " \ ' < > & | 
" " (i.e. a space char)

Use this field to identify the Gateway of the chassis only if you 
entered a value in Component Management Interface field. If you 
did not enter a value in Component Management Interface field, 
then leave this field blank; for example:
172.16.100.0,172.16.100.1

Power Supply

Resource Power 
Supply

0 to 80 chars " \ ' < > & | Used to provide power ports available on power controller.
Note: When you enter a description of the power controller, make 
sure you enter information related to the power wattage. If there 
are motile power port types available, provide the value as 
4000W=15000W=1.

Console

Resource 
Console

0 to 80 chars " \ ' < > & | Serial console port information. For Cisco controller cards having 
serial and auxiliary ports, the value can be provided in the 
following format: Serial Async RS 232=1,AUX=1.

Inventory Parameters

Resource 
Inventory 
Parameters

Field: 0 to 80 chars
Value: 0 to 50 chars

" \ ' < > & | Inventory parameters for the component, separated as a list with 
parameter name and value; for example: 
“color=blue,cost=10K”

Interface Parameters

Table 5-10 CSV Input Field Definitions (continued)

Field Name Field Length Illegal Characters Description
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Creating Location Generator Files
To create a location generator file, perform the following steps:

1. Create the following directory structure (within the lux/inventoryimport/plugindata 
directory) for the location generator files:

a. Create a subdirectory for each resource manufacturer.

b. Create a subdirectory within each resource manufacturer subdirectory for each model that is defined 
for each manufacturer.

c. Create a resource location generator file for each model. This file specifies how the resource 
interfaces are addressed. 

2. Copy each file to its associated subdirectory file location.

You use the location generator files to input information with the locations retrieved from Tool Command 
Language (Tcl) scripts. The following three Tcl scripts can be used to generate locations:

• Component location generator—The Tcl file for generating locations for a component. This can be 
changed as per component manufacturer/model information. Table 5-11 lists the component location 
generator file properties.

Resource 
Interface 
Parameters

Field: 0 to 80 chars
Value: 0 to 50 chars

" \ ' < > & | {inventory, invParamName, invParamVal, 
INTERFACE, TYPE, LOCATION}
• inventory—A keyword; always present.
• invParamName—Name of the inventory parameter.
• invParamVal—Value of the inventory parameter.
• INTERFACE—It will be always INTERFACE (no other type is 

supported in the CSV import).
• TYPE—Optional. Interface type. If TYPE is specified, then this 

inventory parameter will be applicable for that interface type 
and if not specified, then this parameter will be applied to all 
interface types. 

• LOCATION: Optional (Location): If not specified then it will be 
applicable for all the interface location of the TYPE interface. If 
specified, then it will be applicable to a particular location. 
There are two option available as of now: You can specify a 
sequence (1,2.. etc) or specific location:
• Sequence tells the sequence (on which this parameter will 

be applicable) generated by the location generator (for 
example, if 2 means that this parameter will be applicable on 
the 2nd location generated by the location generator).

• Specific Location means that the user must specify 
the exact interface location on which this parameter will be 
applicable.

For example:
• For a sequence type location:

{inventory,paramname,paramval,INTERFACE, 
Fibre Channel LW,2}

• For a specific location:
{inventory,paramname,paramval,INTERFACE, 
Fibre Channel LW,(Fibre_Channel_LW_00)}

Table 5-10 CSV Input Field Definitions (continued)

Field Name Field Length Illegal Characters Description
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Table 5-11 Component Location Generator Properties 

Property Name Property Description

Configuration File Property Name comp.location.gen.info.file

Default File Name complocgenerator.tcl

File format The default complocgenertator.tcl file is placed under 
<MYSERVER_PATH>/lux/inventoryimport/plugindata.

• Resource Location Generator—The Tcl file for generating locations for a resource. This can be changed 
as per component manufacturer or model information. Table 5-12 lists the resource location generator 
file properties.

Table 5-12 Resource Location Generator File Properties

Property Name Property Description

Configuration File Property Name dev.location.gen.info.file

Default File Name resourcelocgenerator.tcl 

File format The default resourcelocgenertator.tcl file is placed under 
<MYSERVER_PATH>/lux/inventoryimport/plugindata.

• Non-traffic interface location generator—This CSV file compiles the non-traffic interfaces (slot 
locations) for a particular manufacturer or model. Table 5-13 lists the non-traffic interface location 
generator file properties.

Table 5-13 Non-Traffic Interface Location Generator File Properties 

Property Name Property Description

Configuration File Property Name nontraffic.location.info.file

Default File Name nontrafficinterfacelocinfo.csv

File format CSV file contains multiple rows with three columns for manufacturer, model, 
and list of non-traffic interface locations.

The following location generator files are described:

• The icon location generator file retrieves the icon from a specified location for a particular manufacturer 
or model. Table 5-14 lists the icon location generator file properties.

Table 5-14 Icon Location Generator File Properties 

Property Name Property Description

Configuration File Property Name icon.information.file

Default File Name iconlocinfo.csv

File format CSV file contains only one row with two columns.
First column will specify the icon name.
Second column will specify the icon location (absolute path).
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• Configuration/inventory parameters generator file—You use the configuration/inventory parameters 
generator file to gather the configuration and inventory parameters for a specific manufacturer or 
model. Table 5-15 lists the configuration/inventory generator file properties. 

Table 5-15 Configuration/Inventory Parameters Generator File Properties

Property Name Property Description

Configuration File 
Property Name

parameters.information.file

Default File Name invconfigparams.csv

File format: 
CSV file contain 
two rows—one for 
provisioning 
parameters and 
other for inventory 
parameters

A row for provisioning parameters requires the following:
• “config” keyword in first column.
• In successive columns, it contains a key-value pair for each parameter; for example, 
config_param_name=config_param_value.

• The interface provisioning parameters can be provided as a sequence of attribute name, 
value, and category; for example, attributeName=attributeValue,CATEGORY.

• The category can be one of INTERFACE, POWERSUPPLY, CONSOLE, and FILESYSTEM.

This row for inventory parameters requires the following data:
• “inventory” keyword in first column.
• In successive columns, it contains key-value pair for each parameter; for example, 
inventory_param_name=inventory_param_value.

The interface inventory parameters can be provided as a sequence of attribute name, value, 
category, type, and location; for example, 
attributeName=attributeValue,CATEGORY,TYPE, LOCATION.

The category can be one of INTERFACE, POWERSUPPLY, CONSOLE, and FILESYSTEM. The 
type and location are the other applicability parameters, where location is numeric and 
specifies the ‘nth’ interface of the type and category, on which the attribute is applicable.
Inventory Management 5-43



Importing Inventory
Importing Plug-In Interface Files
You use the Import Explorer to manage plug-ins (to add, update, and delete).

To import your plug-in interface files, perform the following steps:

1. On the Active System Manager menu bar, click Window > Show View > Other > Import Explorer. 

The Active System Manager software displays the Import Explorer view; see Figure 5-20.

Figure 5-20 Import Explorer View

Table 5-16 lists the plug-ins (out of the box) are available.

Table 5-16 Import Explorer View Properties

Plug-In Purpose

Attributes Used for defining the configuration and inventory parameter that will be applied to the 
resources when a resource will be imported.

Component Location 
Generator

Used for the interface location generation for the component.

Hypervisor Used for marking the resource as virtual. The Hypervisor plug-in is used to apply the 
hypervisor property (enable virtualization) to a set of resources specifying the particular 
criteria. The plug-in file for the hypervisor plug-in is hypervisor.csv.

Icon Path Used to specify the icon that will be applied to the resource imported.

Resource Location 
Generator

Used for interface location generation for the composite resource instance.

Simple Resource 
Location Generator

Used for the interface location generation of the standard resource instance. The simple 
location generator plug-in and plug-in file for the simple location generator is 
simpleresourcelocgenerator.tcl. 

Slot Information Used to specify the extra non traffic interfaces to be added to the components (other than 
the generated by the location generator plug-in).

2. In the Import Explorer view, right-click and select New.

The New Inventory Import Plugin dialog box displays; see Figure 5-21.
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Figure 5-21 New Inventory Import Plug-in 

3. Click the Plug-in Type drop-down box and select a type.

4. Click the Manufacturer field and enter a name.

5. Click the Model name and enter a name.

6. Click Finish.

An empty Tcl file opens, enabling you to write the logic for the specific plug-in.

Validating CSV Resource Data 
To validate CSV resource data, right-click in the CSV editor, and select Validate.

Note The Validate menu is only enabled when there are no validation errors.

Figure 5-22 and Figure 5-23 (same image, but portioned in each figure to show its entirety) displays an 
example of an error on Validate invocation. 

Note the following characteristics:

• The Outline view with error (red)

• The red marker on the right (red square) 

• For each error, a simple marker on the right margin; when mousing over the red marker, see the error 
detail in a pop-up prompt.
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Figure 5-22 Error on Validate Invocation—Left Side

Figure 5-23 Error on Validate Invocation—Right Side

Importing Validated Resource Data
To import your resource data (as specified in the loader spreadsheet), right-click in the upper left corner of 
the file displayed in the Import editor, and select Import.

Note The Import menu option is enabled only when there are no validation errors.

The resource data and its component data are only updated when there are no validation error in the 
resource (CRI hierarchy or SDI).

The Import editor imports the resource data and performs the following tasks at the server:

• Creates and updates resource types (component or standard).

• Creates and updates resource instances (component or standard).

• Creates and updates the resource type for the component resource instance.

The import process provides with the status for each component in the Status column of the Import editor. 
The possible values of status at the import step includes the following:

• Validated—For a successfully validated chassis, card, or resource.

• Resource Server Validation Error—For resources that fail the validation at the server.

• Optional for CRI only: Component Server Validation Error—For components that fails the 
validation at the server.

• Resource Plugin Validation Error—For resources that include incorrect plug-in information.
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• Optional for CRI only: Component Plugin Validation Error—For components that include 
incorrect plug-in information.

• Resource Imported—For the successfully imported resources. This information is provided against 
the chassis of the resource.

• Optional for CRI only: Component Imported—For successfully imported components.

• Resource Import Error—For the resource that was successfully validated, but failed to import due to 
dependencies, such as the unavailable components.

• Optional for CRI only: Component Import Error—For the component that was successfully 
validated, but failed to import due to dependencies.

Using Forced Import for Resources with Session Conflicts
Importing a resource may have dependencies on the sessions running in the environment. To import the 
resource anyway, to reflect the changes, you must cancel the user sessions. Rather than manually canceling 
these sessions, you can use the Forced Import option, which automatically deactivates those resources in 
running sessions.

To force import for resources with session conflicts, in the Import editor, right-click the resource, and select 
Forced Import. 

The Import editor sends an email notification of cancelled sessions to the corresponding owners of the 
sessions. 

You can also extend the email notification to the participants of each session or you can also suppress it. 
You can set this preference before you perform a forced import. You can also specify the default availability 
dates in the Inventory Import preferences, where you can import the CRI with a specific time availability.

Importing Connectivity

The Inventory Links Import feature enables the administrator to import Resource Instance Specification 
(RIS) links into the Active System Manager server. This feature accepts this link data in the form of input 
field definitions that are contained within a comma-separated value (CSV) file called the link inventory 
spreadsheet. The Active System Manager administrator inputs this inventory links data according to the 
rules set according to the Link CSV field definitions in the Active System Manager software.

Once this data is loaded into the Active System Manager client, the administrator uses the Active System 
Manager Input CSV editor to validate the input field definitions specified within the CSV file, provide 
status, error data on the associated inventory, and then upload the inventory links data into the Active 
System Manager client. 

This section includes details for the overall process required to import your inventory links, and some 
examples of the associated CSV files. These details are described in the following topics:

• Populating the Link Inventory Spreadsheet

• Importing CSV Link Files

• Validating CSV Link Files
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Table 5-17 outlines the typical workflow checklist for importing links with the Import tool.

Table 5-17 Typical Workflow Checklist for Importing Links 

Task 

1. Perform a complete inventory of all links in your environment.

2. Optional. Manually validate the spreadsheet data.
This manual validation is required to identify and fix any illegal characters or field lengths within the input 
field definitions.

3. Migrate the data from step 1 to populate a link inventory spreadsheet. For more information, see the 
“Populating the Link Inventory Spreadsheet” section on page 5-48.

4. Migrate the data in the link inventory spreadsheet to a CSV file. Note: The CSV file also includes a set of 
additional input field definitions that are used by the Active System Manager software. These additional 
definitions include the following fields:
• Sequence
• Status
• Link Error

5. Validate the imported CSV file into the Active System Manager client. For more information, see the 
“Validating CSV Link Files” section on page 5-50.

6. Fix any returned CSV errors.

7. Re-import the validated CSV file into the Active System Manager client. 
Note: If you use the CSV editor in the Active System Manager client, re-importing the CSV file is 
unnecessary.

8. Fix any remaining errors and re-import the validated CSV file. 

9. Perform a final validation check to ensure that your links are correct.

Populating the Link Inventory Spreadsheet
To populate the link inventory spreadsheet, perform the following steps:

1. Perform a complete inventory links of all resources in your environment.

2. Enter the input field definitions for all links.

Table 5-18 defines the field properties. Use these definitions when you populate the link inventory 
spreadsheet.

Table 5-18 Field Properties of Link Inventory Spreadsheet 

Field Description

Link Name Optional. Represents the link name. If the link name is not provided, a link 
name is automatically generated.

Link Description Optional. Represents the link description.

From Asset Tag Represents the asset tag of the resource from which the link must be made.

From Dis Version Optional. Represents the resource version. If the version is not provided, a 
link is created on the active version of the resource; otherwise, an error 
displays.

From Location Represents the interface location of From Resource to be linked.

To Asset Tag Represents the asset tag of the resource to which the link must be made.
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Importing CSV Link Files 
To import CSV link files, perform the following steps:

1. Access your environment staging server.

2. On the Active System Manager menu bar, click File > Import.

The Import—Select dialog box displays.

3. Select the CSV Link Import icon and click Next to display the Import dialog box with status 
information about the CSV link file to import.

4. Click the Select input CSV file field and enter the CSV link file to import, or click Browse to search 
for the CSV link file and click Next.

Figure 5-24 displays a sample excerpt from the CSV Link editor.

Figure 5-24 CSV Link Editor

5. On the Import dialog box, click Finish. 

The Input CSV editor displays. The Import Explorer automatically identifies all invalid rows of the 
CSV file, with errors. You can view these errors in the following views:

• Import editor—First column in the import editor for the invalid row as an image marked with red.

• Import editor—The details of the error in the columns Link Error.

To Dis Version Optional. Represents the resource version. If this is not provided, a link is 
automatically created on the active version of the resource; otherwise, an 
error displays.

To Location Represents the interface location of To Resource to be linked.

Sequence, Status and 
Link Error

Output fields that are populated by the Active System Manager server when 
the user validates links, imports links, and imports valid links.

Table 5-18 Field Properties of Link Inventory Spreadsheet (continued)

Field Description
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• Outline view—Corresponding row information in the outline. You can also right-click the row in 
which the error is indicated and select Error Details.

• Error Indication Ruler—An error indication ruler attached on the right side of Import editor, which 
overviews the error status in an opened CSV file. This ruler displays the error in red color and shows 
error details in the tooltip when you hover your mouse. Clicking the error indicator selects and 
highlights the corresponding erroneous row in the Import editor.

You can also view the associated error details by right-clicking the erroneous row and clicking Details.

Validating CSV Link Files
To validate CSV link files, perform the following steps:

1. Right-click in the upper left corner of the file displayed in the Import editor, and select Validate.

Note The Validate menu is only enabled when there are no validation errors.

The validated CSV link files displays; see Figure 5-25.

Figure 5-25 Validated CSV Link Files

The Import Explorer validates the CSV link files according to the following rules:

• Basic validation

— Invalid characters

— Mandatory fields

— Length of each field supported by the Active System Manager software

— Duplicate link names within CSV
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— Duplicate links within CSV

— Same resource and location used in the CSV more than once

Note The Link Import editor performs all the basic validations.

• Link name already exists in the Active System Manager inventory.

• Existence of resources in the Active System Manager inventory.

• Existence of interface location in the resource.

Errors (if any) in the validation (at the server) are displayed as a server error in the error details, and in a 
light shade of red in the right margin of the editor. Validation also determines the status for each link.

Select links (and, if necessary, click the Show other related errors in CSV check box) to view the details 
and click OK.

Importing Validated Links
To import your validated links (as specified in the loader spreadsheet), right-click in the upper left corner 
of the file displayed in the Import editor, and select Import.

Note The Import menu option is enabled only when there are no validation errors.

The Active System Manager software only updates the link data when there is no validation error in the 
links. The Import editor imports the link data and performs the following tasks at the server:

• Creates links

• Creates interface compatibility

• Generates events for link creation and interface compatibility

This option imports links if there are no errors in the CSV file. The Active System Manager client returns 
all links if   a single error exists in the CSV file. If there are existing invalid links, you can use the Import 
Valid Links option to force the import of the valid links.

The Import Explorer validates the CSV link files according to the following protocols:

• Conflicts with the already existing inventory data on the server

• Accuracy of the applicable information provided in the plug-ins, including:

— Invalid characters

— Mandatory fields

— Length of each field supported by the Active System Manager software

• Validation also calculates the action for each component and the resource. The action is provided in the 
Import editor in the Status column, where the following values are possible:

— Link Imported—If the link is successfully imported.

— Link Data Validation Error—If basic validation fails.

— Link Server Validation Error—For server dependencies 
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Exporting Connectivity

The system allows you to export your physical connectivity in two file formats: XML and CSV. 

To perform a file export function, perform the following steps:

1. On the Active System Manager menu bar, click File > Export, and on the next wizard page, click 
Resource Links > Next to display the Export Resource Links dialog box.

2. Select one or more resources to export:

a. Click Browse and navigate to the directory where you want to export the resource links.

b. Select the file type: XML or CSV.

3. Click Finish.

Note You can also pre-select the resource list from the Resource Instances view and follow the steps. 
Resources will be pre-selected in the Export Resource Links wizard.

Managing Resource Pools

Resource pools allow you to allocate and assign a specific set of equipment to users and groups. By default, 
everyone can use all equipment based on their resource availability.

Note To be backward-compatible with previous software releases, any unassigned resource pool 
equipment is considered part of the free pool, and is visible and schedulable by all users.

Note To manage resource pools, you must be logged in as an administrator.

Adding Resource Pools
To add (create) resource pools and allocate resources, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Resource Pools Management.

The Manage Resource Pool dialog box displays; see Figure 5-26.

Figure 5-26 Managing Resource Pool
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2. Click Add to display the Add Resource Pool dialog box; see Figure 5-27.

Figure 5-27 Add Resource Pool

3. Configure the Resource Pool and Association Details as follows:

a. Click the Name field and enter a name for the new resource pool.

b. Optional. Click the Description field and enter a description for the new resource pool.

c. In the Resource Asset tab, select the resources (assets) to associate with this new resource pool.

d. Click the Users tab (see Figure 5-28) and select one or more users to add to this resource pool.
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Figure 5-28 Add Resource Pool—Users

e. Click the Resource Pools tab (see Figure 5-29) to bundle or create a hierarchy of the existing 
resource pools.

Figure 5-29 Modify Resource Pool—Resource Pools
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f. Click the Groups tab (see Figure 5-30) and add one or more groups to the new resource pool.

Figure 5-30 Add Resource Pool—Groups

4. Click OK.
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Modifying Resource Pools
To modify (edit) existing resource pools, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Resource Pools Management.

The Manage Resource Pool dialog box displays; see Figure  on page 5-52.

2. Select an existing resource pool and click Edit to display the Modify Resource Pool dialog box; see 
Figure 5-31.

Figure 5-31 Modify Resource Pool

3. Modify the Resource Pool and Association Details as follows:

a. Click the Name field and enter a new name for the resource pool.

b. Optional. Click the Description field and enter a new description for the resource pool.

c. In the Resource Asset tab, select the resources (assets) to associate with the resource pool.

d. Click the Resource Pools tab to modify the hierarchy of the existing resource pools.

e. Click the Users tab and modify the users associated to this resource pool.

f. Click the Groups tab and modify the groups associated to this resource pool.

4. Click OK.
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Deleting Resource Pools
To deleting existing resource pools, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Resource Pools Management.

The Manage Resource Pool dialog box displays; see Figure  on page 5-52.

2. Select an existing resource pool and click Delete. 

A message displays prompting you to confirm the deleting

3. Click OK to confirm the resource pool deletion.

Managing Maintenance Windows

An administrator uses a maintenance window to perform administrative tasks on the Active System 
Manager system without allowing users to log in during this time. This function can be ideal for critical 
inventory or connectivity changes. Another benefit is that user sessions (scheduled during this interval) are 
not impacted or terminated.

The goal of managing maintenance windows is to specify time where the Active System Manager system 
is down for maintenance. 

The following maintenance period rules apply:

• A normal user is unable to log in during the maintenance period.

• An administrator is allowed to perform all the activities in the Active System Manager during the 
maintenance period.

• An administrator can update or cancel the maintenance window in the confirmed and in progress state.

• At the start of maintenance period, a reminder is sent to the administrator.

• During the maintenance window, the Active System Manager RCP client displays an indication 
depicting that the system is under maintenance.

• Administrator’s sessions are ignored while finding the impacted sessions.

Accessing the Maintenance Window
To access the Maintenance window, on the Active System Manager menu bar, click Tools > Maintenance 
Window.

The Maintenance Window dialog box displays, listing all of the maintenance windows already defined.
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Adding a Maintenance Window
To add a maintenance window, perform the following steps:

1. Access the Maintenance Window dialog box.

2. Click Add to display and define the maintenance window;

During the selected maintenance hours, regular users will be unable to log in to the Active System 
Manager system; only administrators can log in.

3. Click the Name field and enter a name for the maintenance window.

4. Click the Reason field and enter a reason for maintenance.

An administrator can identify or specify a maintenance window with following two options:

• ASAP within fixed time frame—The administrator can specify two date and time options: 1) the 
date time range (start date time and end date time), and 2) the duration of the maintenance period. 
With these input request parameters, the system tries to search time period when there is no user 
session defined (except for the administrator-owned sessions). If there is any such time period 
available, then the same is returned, an error displays a message that the request cannot be accepted. 
The administrator can then select one of the time periods from the existing list and accept the same.

• Fixed start and end date: This option is applicable when the administrator already knows the time 
period for the maintenance period and wants to apply the same. In this option, the administrator 
provides the start date time and end date time as input for setting the maintenance period. The 
system will check if any session is scheduled for that time period and return those session as an 
impacted session.

If there is any impacted user session, the administrator can opt for a forced setting where all those 
sessions will be ignored during the confirmation process.

5. Click Next to determine possible time slots.

If sessions are expected to be active during this time frame, you will be presented with a list of sessions. 

a. Select the Acknowledge blocking sessions check box to proceed with the creation.

b. Select one entry from the proposed options.

c. Click Finish to create the maintenance window.

An email notification will be sent out to all when the maintenance window session gets confirmed and 
active (running).

Users who are trying to connect via the RCP or web portal are prompted with an information message.

6. Click OK.
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Modifying a Maintenance Window
An administrator can update or cancel the maintenance window in the Confirmed and In Progress states.

To edit a maintenance window, perform the following steps:

1. Access the Maintenance Window dialog box.

2. Click Edit to display the Update Maintenance Window and edit the existing settings

3. Modify the settings as follows:

a. Optional. Click the Name field and enter a new name.

b. Optional. Click the Reason field and enter a reason to update the maintenance window.

c. In the Time Options section, click the Start Date and End Date pull-down menus, respectively, to 
set a new start and end date for the maintenance time frame. If the maintenance window is already 
in progress, then only the end time can be changed.

Note You cannot modify the Start Date for an in-progress maintenance window.

4. Click Next to check for possible conflicts with ongoing sessions

5. In the Blocking Sessions section, all Running sessions display during the specified maintenance period. 

6. Select the Acknowledge blocking sessions check box to proceed with the creation and ignore those 
sessions.

7. Click Finish to complete the update.

8. Verify the new start and end date, and click OK to exit the dialog box.

An email notification will be sent out to all to indicate the time changes associated with the maintenance 
window. 

Canceling the Maintenance Window
To cancel the maintenance window, perform the following steps:

1. Access the Maintenance Window dialog box.

2. Select the maintenance window to cancel, and click Cancel to close the window.

Email notifications will be sent out and the entry is deleted.

3. Click OK exit the dialog box.

An email notification will be sent out to all administrators or the window cancellation.
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Managing Virtual Resources

This section introduces you to the Operation Center view and gives you an insight into dynamic hierarchy 
of resources displayed in the Operation Center view. This section also familiarizes you with the 
navigational aspects of Operation Center view, and the possible operations available per object type in the 
Operation Center view.

Note The Resource Managers are third-party vendors or equipment specific management agents, that are 
used to manage physical and /or virtual resources. The examples of Resource Manager include 
VMware vCenter and Cisco UCS Manager.

Note To perform Advanced Discovery and display the current hierarchy of resources in the Operation 
Center view, you are required to integrate the Active System Manager software with the Resource 
Manager. 

The following topics in this section describe Operation Center in detail:

• Understanding the Operation Center View

• Accessing the Operation Center View 

• Managing the Resource Manager Using the Operation Center View

• Editing Data Flow Values

Understanding the Operation Center View
The Operation Center view is a Active System Manager feature that displays the dynamic view of 
datacenter, consisting of virtualized and configurable resources. Using integrated Advanced Discovery 
mechanism, the Active System Manager software discovers and displays the current state of resources in 
the Operation Center view. The Active System Manager software retrieves information from 
vendor-specific Resource Managers and consolidates it, to display the visual representation of a consistent 
layout of resources in a hierarchial manner.

The Operation Center view facilitates maximum flexibility in tracking the consistent layout of a virtual 
infrastructure in the Resource Manager. To facilitate things further, the Operation Center view displays the 
current status of resources at regular intervals by scheduling the discovery operation. 

Note There may be a lag between the resource status in Resource Managers, and the hierarchy of 
resources reflected in the Operation Center view, in case of changed status of resources in the 
Resource Manager.

The Active System Manager software uses the power of Resource Adapters (RAs) to retrieve and display 
the hierarchical structure of resources on the Operation Center view. The RAs establish a connection with 
Resource Managers (for example: VMware vCenter, Cisco UCS Manager) using a set of open Application 
Programming Interfaces (APIs). These APIs communicate with Resource Managers to retrieve the nested 
relationships of resources, and reflect or replicate their corresponding consistent layout in the Operation 
Center view; for example: for the VMware vCenter, the Operation Center view comprises of objects 
discovered, such as Datacenter, Cluster, and ESX hosts in the cluster, along with the datastores and virtual 
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machine (VM) objects running in the clusters. The resources are displayed per data center, starting from 
the highest level of datacenter, down to the individual VM.This is presented in a hierarchical manner in the 
vCenter hierarchy, Operation Center view, see Figure 5-32.

Figure 5-32 vCenter Hierarchy in Operation Center View

Note Figure 5-32 displays the typical hierarchical scenario of Vomer's vCenter objects. However, there 
may exist scenarios where the root level of objects may vary depending upon the object type.

Accessing the Operation Center View
Note By default, the Operation Center view is a part of the Inventory perspective.

To access the Operation Center view, on the Active System Manager menu bar, click Window > Show 
View > Operation Center.
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Managing the Resource Manager Using the Operation Center View
The Operation Center view facilitates the following set of operations:

• Using Resource-Specific Operations

• Synchronizing Resources

• Viewing Resource Properties

• Dragging and Dropping Resources

Using Resource-Specific Operations
The Operation Center view allows you to perform operations on the visible resources in the hierarchy. The 
object specific right click operations vary based on the resource type and the resource level in the hierarchy. 
However, right click operations can also be customized for a specific resource. 

To perform object-specific operations, click a specific resource type and the supported operations display 
in the Resource Information editor; see Figure 5-33 for an example.

Figure 5-33 Object-Specific Operation (Example)

Synchronizing Resources
The Synchronize feature allows you to re-synchronize the retrieval of resources and display the current, 
logical layout of objects in the Operation Center view hierarchy. It updates the resource properties based 
on the latest status, as retrieved from the individual Resource Managers. 

Note The Synchronize operation can either be performed on all resources as viewed in the Operation 
Center view (by selecting the domain which is the highest hierarchy level in the Operation Center 
view), or on specific selected resource management agents such as vCenter (by selecting one or 
more resource management agents in the Operation Center view).

Viewing Resource Properties 
To view the properties of any specific resource, click the specific resource. The resource properties display 
in the Properties view. The Properties view contains information related to the current status of the resource 
that can be used by the administrator for planning immediate deployments; see Figure 5-34 for an example.
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Figure 5-34 Properties Panel

Dragging and Dropping Resources 
The drag and drop operation allows you to drag and drop blades from the Operation Center view to an 
active session or a template.

Note The drag and drop operation is available on blades in a subsequent manner.

Editing Data Flow Values
The Active System Manager software allows you to edit parameter values while executing a virtual 
operation from the Operation Center view.

To edit data flow values, perform the following steps:

1. Right-click any node or resource type in the Operation Center view. 

The list of virtual operations applicable on the selected resource type display.

Select the operation to perform from the list of menus; for example, select Create Mac Pool.

The Create Mac Pool dialog box contains the following two panes:

• Parameters Pane: Contains general execution details such as operation names and the Value field 
for entering values against input parameters. You can either enter these parameter values in the 
Value field manually or by selecting a value from the Possible Values pane. 

Note The star pre fixed in the icons (in the Name column - Parameters section), indicate mandatory 
values that you must enter.

• Possible Values Pane: Displays all elements contained in selected the Value Source. The 
information related to the Primary and Secondary Source is already embedded in a specific RA. If 
required, this panel allows you to select values from the Primary Source and Secondary Source 
drop-down list.

2. Select a parameter in the Parameters pane.

3. Click Primary Source In the Possible Values pane, and select the Value Source for the selected 
parameter; for example, select Software Repository.
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4. Click Secondary Source In the Possible Values pane, and select the Value Source Sub Type; for 
example, select a specific type of Software Repository.

Note For advanced users, step 4 on page 5-64 and step 5 on page 5-64, fulfill the requirements. By 
default, the Active System Manager RA pre populates the Primary Source and Secondary Source 
entries in most cases. However, step 4 on page 5-64and step 5 on page 5-64 allow you to select a 
value from the Primary Source and Secondary Source values.

5. Check the required parameter value to auto-populate the Value field. This value is referenced to 
determine the actual runtime parameter value at execution time.

6. Click OK to execute the custom operation.
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C h a p t e r  6
Using Inventory 
This chapter describes the Active System Manager Inventory perspective that catalogs and defines the 
inventory in your network environment. You can then use all of the Active System Manager perspectives 
to access your environment inventory. For a complete description of how the Active System Manager 
administrator builds the Active System Manager inventory, see Chapter 5, “Inventory Management.”

Introducing the Inventory Perspective

The Inventory perspective controls the layout of the user interface the Active System Manager software 
uses to display information for your inventory, including which views are displayed and their positions 
within the Active System Manager application. You can save the modifications you make to the Inventory 
perspective as you create them, making your own custom user interface.

Table 6-1 outlines the default views available when you open the Inventory perspective; see Figure 6-1 for 
a graphical representation of the views, which appear in tabular form.

Table 6-1 Inventory Perspective Elements 

View or 
Editor Name

View 
or 
Editor Description

Resource 
Types

View Displays all of the resource types that have been added to the inventory. This view can 
be filtered, grouped, and sorted to increase data accessibility. 

Resource 
Instances

View Displays all of the resource instances that have been added to the inventory. This view 
can be filtered, grouped, and sorted to increase data accessibility, and includes the 
resource availability calendar. 

Outline View Lists the selected inventory resources in an outline format. It represents a high-level 
summary of an open editor and allows you to navigate or find information. 

Workspace 
Area

Area where most of the data entry and modification takes place. It contains the data 
editors and most of the tools used in the Inventory perspective. Tabs in the Workspace 
indicate the resources that are currently open for editing. An asterisk (*) indicates that an 
editor has unsaved changes. 

Properties View Displays the properties for the selected session, Template, or configuration file. It is a set 
of property values that are reflected in what you see in the editors. 

Templates View Lists the available templates previously created. Supports built-in filters. From this view, 
you can customize filters or group the Template organization by tree. For more 
information, see Chapter 1, “Active System Manager Overview.”
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To open the Inventory perspective, perform one of the following options:

• On the Active System Manager navigation menu, click Inventory. 

• On the Active System Manager menu bar, click Window > Open Perspective > Inventory.

The Inventory perspective displays; see Figure 6-1.

Discovery 
Explorer

View Lists the resource data populated into your inventory when you run the Discovery 
Explorer.

Links View Lists the links between control equipment and managed equipment, or between two 
pieces of managed equipment.

Import 
Explorer

View Displays the plug-in data of used by IIT during the inventory import. The following 
resource data is displayed:
• Attributes
• Component Location Generator
• Resource Location Generator
• Icon Path
• Slot Information
• Hypervisor
• Simple Resource Location Generator

Import CSV 
Editor

Editor The Active System Manager administrator uses to validate the input field definitions 
specified within the CSV file, provide status, error data on the associated inventory, and 
then upload the inventory links data into the Active System Manager server.

Table 6-1 Inventory Perspective Elements (continued)

View or 
Editor Name

View 
or 
Editor Description
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Figure 6-1 Inventory Perspective

For information on how to customize the Inventory perspective preferences, see the “Customizing 
Perspectives” section on page 1-8.
Using Inventory 6-3



About Resource Types and Resource Instances
About Resource Types and Resource Instances

You use the Active System Manager Inventory perspective to access your managed environment 
equipment. Managed equipment refers to the resources or equipment under test (EUT). Resources are 
modeled by type, which are specifications by manufacturer and model that you can use as generic elements 
in templates you author, and by instance, which are specific resources with unique asset tags.

The generic hardware type is called a resource type. The Active System Manager software uses resource 
types as templates to model the various types of hardware resources in your environment. A resource type 
is the basic building block of the Inventory perspective. A resource type does not see a particular piece of 
network hardware; instead, it describes the structure of the base model for that equipment. 

A resource instance is a particular piece of network equipment residing somewhere in the environment that 
has an asset tag. A resource instance can also be considered as a set of provisioning parameters that defines 
the interfaces and properties that are being used in the resource type for an actual and specific piece of 
hardware. For example, if you want to work with a resource by just its type or model (rather than a specific 
piece of equipment), work with the specific resource type, and let the Active System Manager scheduler 
decide on the actual equipment for your Template. This method provides you with additional flexibility 
since you get more choices (any of environment’s equipment that matches the same resource type can be 
used) and a better overall use of your network environment. On the other hand, to use a specific piece of 
equipment, you would author the Template by the resource instance. 

Accessing Inventory

The Inventory perspective is one of the default perspectives and is used to view and manage your inventory. 
The two important navigator views for the Inventory perspective are the Resource Types view and the 
Resource Instances view. Figure 6-2 illustrates how your generic type of equipment (resource types) are 
displayed within the Resource Types view. For more information about other views associated with all the 
perspectives, see the “Views” section on page 1-10.

Figure 6-2 Resource Types View
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Note While the Inventory perspective is the first place to start working with inventory, you can also use 
other perspectives to accomplish the same tasks. Because you will typically use inventory when you 
are in the Template or Session perspective, you can open Resource Types and Resource Instances 
views from these perspectives, as well as from within the Inventory perspective.

Note The area in the Resource Instances view to the right of the actual instance data is the Resource 
Availability Calendar, which displays information regarding which resource instances are 
allocated for specific sessions. For more information on how to use the information displayed in this 
area of the view, see the “Using the Resource Allocation Calendar” section on page 6-11.

The Active System Manager application provides four methods for accessing your environment inventory:

• Group By feature—Allows you to group your resource type in a hierarchical fashion. You can change 
the way the Active System Manager software displays the resource type and resource instance 
information by clicking the Group By icon displayed in the top-right portion of the associated views. 
For more information, see the “Accessing Resources via the Group By Dialog Box” section on 
page 6-7, and the “Grouping” section on page 1-15.

• Filters feature—You use the Filters feature (Filter icon) to specify filters that forces the Active System 
Manager application to only display the resource type and resource instance information that you 
require within the associated views. Built-in filters are available and some are enabled by default.

Figure 6-3 Filters > Managed Equipment Filter Example

For more information about filtering, see the “Accessing Resources via the Filters Dialog Box” section 
on page 6-8, and the “Filtering” section on page 1-12.

• Search feature—The Active System Manager Search feature is simple toolbar option used to locate 
search categories, including resource types, resource instances, links, templates, configurations, and 
sessions that match a single character string. For more information, see the “Using the Search Function” 
section on page 6-11.
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This section describes the following topics:

• Using Resource Types

• Using Resource Instances

• Linking Views with Resource Instances

• Using the Search Function

Using Resource Types
You can explore the various resource types that Active System Manager displays in the Resource Types 
view, by performing any of the following operations:

• Navigate to the Resource Types view and open a resource type in the editor (double-click the resource 
type; for example, “Cisco 6509,” as displayed in Figure 6-2 on page 6-4).

• View the Resource Type properties in the editor by scrolling or by using the Outline view. (To open the 
Outline view, on the Active System Manager menu bar, click Window > Show View > Other > 
General > Outline.)

• In the Resource Types view, click the Filter icon and filter by “Control Equipment” only, then by 
“Managed Equipment” only. For more information about how to filter and display resources using this 
function, see the “Accessing Resources via the Filters Dialog Box” section on page 6-8.

• In the Resource Types view, click the Group By icon and group the resources by Role, then 
Manufacturer, then Model. For more information about how to group and display resources using this 
function, see the “Accessing Resources via the Group By Dialog Box” section on page 6-7.

• From the Resource Types view drop-down menu (see Figure 6-4), select Expand All.

Figure 6-4 Resource Types View—Expand All Menu

• In the Resource Types view, select resource types and observe that the instances displayed follow the 
types selected. 

• Close the Resource Types view and then re-open it (on the Active System Manager menu bar, click 
Window > Show View). Or click the Fast View icon (in the bottom left corner).

• Restore the Resource Types view to its former location by dragging the view. Or, reset the perspective 
by right-clicking the highlighted perspective name.
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This section describes the following topics:

• Accessing Resources via the Group By Dialog Box

• Accessing Resources via the Filters Dialog Box

Accessing Resources via the Group By Dialog Box
The Group By function (dialog box) includes the following features:

• Allows you to modify the way entries, such as resource types or resource instances, are presented in the 
navigator pane, or to group entries, based on various properties you can specify. Without any grouping 
options selected, the entries are group based on their basic elements. In the case of resource instances, 
they are listed by their name. You use the Group By feature to specify which properties display the 
resource type and resource instance information within the associated views.

• Determines the hierarchy of resources displayed in the associated folder according to the set of 
properties you select. The default Group By properties include a set of system properties; for example, 
but not limited to the following: Manufacturer, Model, Classification, Role, Domain (available only 
on the Resource Instances view), Asset Tag, Resource Pool, and Status (for the Resource Instances 
view, which indicates whether the resource is “active”, “future”, or “obsolete” based on the availability 
specified in resource).

• A list of Group By custom properties are also available when defined in the resource types.

• Displays the provisioning parameters properties in the Group By dialog box.

• For the Resource Instances view, displays inventory parameters for which you can apply group by 
functionality.

To access the Group By dialog box (see Figure 6-5 for an example), in the top-right of an associated 
navigator view, click the Group By icon. 

Figure 6-5 Group By Dialog Box

You can group by multiple folders and set the grouping order (for example, Role-Manufacturer-Model). 
You can also group by custom properties, if they have been created for the resource types in your system. 
For more information, see the “Grouping” section on page 1-15.
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Both the Resource Types and Resource Instances views allow grouping; the Group By icon is available at 
the top-right of the Resource Types and Resource Instances view menu bars. 

Note For many Active System Manager users, your site’s custom properties may be the most relevant 
properties for you to use while grouping and organizing your inventory.

Accessing Resources via the Filters Dialog Box
You can use a filter to modify the display of your inventory resources. Both the Resource Types and 
Resource Instances views allow filtering. You use the Filters feature to specify filters that force the Active 
System Manager application to only display the resource type and resource instance information that you 
require within the associated views. 

In general, you should set your resource types or resource instances filter to “Managed Equipment”, 
because for most practical applications, almost all of your inventory is defined as “managed”. 

To access the Filters dialog box, in the top-right part of an associated navigator view, click the Filters icon. 
Figure 6-6 displays an example of Filters dialog box.

Figure 6-6 Filters Dialog Box

The Filters dialog box includes the following built-in filters (for Resource Types and Resource Instances 
views only):

• Managed Equipment—The device under test (DUT) or equipment under test (EUT). Resources are 
modeled by type, which are specifications by manufacturer and model that can be authored as generic 
elements in templates, and by instance, which are specific resources with unique asset tags.

• Control Equipment—The infrastructure of the automated environment, including matrix switches 
(Layer 1 or 2; electrical, optical, or virtual), power controllers, and terminal servers.

• Virtual Equipment—Available only on the Resource Instances view.

• VLAN Equipment—Available only on the Resource Instances view.

• Schedulable Equipment—Available only on the Resource Instances view.

• Equipment in Maintenance—Available only on the Resource Instances view.
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You can create new filters and specify the associated rules for them. Once created, you can use the new 
filters for accessing your inventory. For more information, see the “Filtering” section on page 1-12.

Note You can also set the filter using the Show Active Equipment icon (only available on the Resource 
Instances view, not the Resource Types view), located on the navigation view action bar. If set, this 
filter displays only resources that have active versions; i.e., resources with availability dates 
intersecting with present time.

Using Resource Instances
The Active System Manager Resource Instances view is similar to the Resource Types view; both views 
follow the same format. You can explore the various resource instances that Active System Manager 
displays in the Resource Instances view, by performing any of the following operations:

• Navigate to the Resource Instances view and open a resource instance in the editor.

• In the Resource Instances view, click the Filter icon, filter by “Control Equipment”, and then by 
“Managed Equipment”.

• In the Resource Instances view, click the Group By icon and group the resources by Role, then 
Manufacturer, and then Model. 

• In the Resource Instances view, click the Show Active Equipment icon; however, as a user, it is already 
selected. If set, this filter displays only resources that have active versions; i.e., resources with 
availability dates intersecting with present time. 

• From the Resource Instances view drop-down menu (see Figure 6-7), select Expand All.

Figure 6-7 Resource Instances View—Expand All Menu

• In the Resource Instances view, select the Link with a resource type icon with a resource type to 
synchronize the instance displayed with any selected resource type.

• In the Resource Instances view, right-click multiple instances and select Open to display those 
instances in the multi-editor as a tabular list of resource instances.
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• Click Link with a resource type in the Resource Instances view to synchronize the instance shown with 
any selected resource type. Select resource types from the Resource Types view and observe that the 
instances displayed follow the types selected.

• Close the Resource Instances view and re-open it: on the Active System Manager menu bar, click 
Window > Show View menu. Or click the Fast View icon (in the bottom-left corner).

• Restore the Resource Instances view to its former location by dragging the view. Or, reset the 
perspective by right-clicking on the highlighted perspective name.

In the Resource Instances view, the Active System Manager software also provides a calendar function that 
you can toggle on/off to display resource allocation; for more information, see the “Using the Resource 
Allocation Calendar” section on page 6-11.

Linking Views with Resource Instances
To author templates that can be scheduled, check to what the resource is connected (that is, synchronized), 
and be aware of the actual resource connectivity—which resources are connected to matrix switches, or to 
other resources, and so on. 

To determine if two resources can be connected, you can use the Links view or the Resource Instances view 
to see if they are connected to each other. Alternatively, you can verify if the two resources are connected 
to the same matrix switch. If they are, you can author a Template that should be schedulable. 

Note The term “link” does not refer to a physical link between resources in this context; instead, this is 
actually a feature that synchronizes the link view to the resource selected in the Resource Instances 
view.

To link the Links and Resource Instances views, perform the following steps:

1. In the Resource Instances view, select a resource.

2. Open the Links view: on the Active System Manager menu bar, click Window > Show View > Links. 

3. On the Links toolbar, click the Link with a Resource Instance icon. 

The associated links for that resource display.

Note If you click the Link with a Resource Instance icon, the Links view works in 
conjunction with the selection in the Resource Instances view; that is, it only displays 
links associated with the selected resource instances in the Resource Instances view. 

As for any Active System Manager navigator view, you can also group and filter the information displayed 
within the view. This filter dialog is unique; for more information, see the next section, “Using Links View 
Filters.” 
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Using Links View Filters
The Active System Manager software includes four preset Links view filters:

• Managed to Managed (resource to resource links)—Displays the links created between two 
managed resources.

• Managed to Control—Displays the links between the interface of a managed resource to the interface 
of a control resource.

• Control to Managed—Displays the links between the interface of a control resource to the interface 
of a managed resource. 

• Control to Control—Displays the links created between two managed resources.

You can also create additional custom filters to determine if one resource is connected to another resource. 
For example, to view everything connected to a matrix switch, create a filter containing the name or model 
of the matrix switch.

When you apply a filter, synchronization automatically turns off, and vice versa.

Using the Search Function
You can also access your inventory via the built-in Active System Manager Search function. 

Using the Resource Allocation Calendar

The Resource Allocation Calendar is a display option for the Resource Instances view that enables you to 
view allocation of resources to sessions and their status. 

To display the Resource Allocation Calendar view, perform the following steps:

1. On the Active System Manager menu bar, click Window > Show View > Other > Active System 
Manager > Resource Instances.

2. In the top-right corner of the Resource Instances view, click the Show Calendar icon.

The Resource Allocation Calendar displays within the right-hand side of the view. All of the associated 
sessions for each resource instance that are part of the session within the Resource Availability Calendar 
display. The associated sessions for each resource instance appear as a colored rectangular bar. 

This section describes the following topics:

• Using the Resource Availability Calendar Options

• Analyzing Resource Instance Availability in Existing Sessions
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Using the Resource Availability Calendar Options
The Resource Availability Calendar includes a number of menu options and display characters that are 
designed to provide you with additional information. These elements of the calendar are described in the 
following topics:

• Accessing Calendar Menu Options for Resource Availability Calendar

• Displaying Aspects of the Resource Availability Calendar

Accessing Calendar Menu Options for Resource Availability Calendar
Right-click the Resource Availability Calendar date bar (the area at the top of the calendar that displays 
the sessions for resource instances within a time frame of a day, a week, or a month) to view the following 
calendar menu bar options:

• Day Calendar—Default; displays the calendar in one day segments.

• Week Calendar—Displays the calendar in one week segments.

• Month Calendar—Displays the calendar in one month segments.

• Quarter Calendar—Displays the calendar in quarterly segments.

• Year Calendar—Displays the calendar in yearly segments.

• Lock View—Locks the calendar so that the time frame remains within the display whenever the 
window is resized.

• Now—Displays the current date within the view. 

• Go to Date—Displays the Go To Date dialog box. Use this dialog box to set the date you want 
displayed, as well as the Day/Week/Month display. (The red line shifts to the new date.)

Displaying Aspects of the Resource Availability Calendar
The Active System Manager product provides additional information about the sessions displayed within 
the Resource Instance calendar via the shape and color of the session “bar” displayed for the associated time 
frame of that session.

These display aspects include the following:

• A normal color for a session “bar” is grey-blue.

• Color changes to a darker and bolder blue when the session intersects with the red indicator line. 

Note You can customize the colors and labels via the Preferences dialog box; on the Active System 
Manager menu bar, click Window > Preferences > General > Display Options.
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Analyzing Resource Instance Availability in Existing Sessions
The Resource Availability calendar enables you to quickly analyze how specific Resource Instances are 
allocated within past, present, and future sessions, as well as which resource instances are available for new 
sessions, including what percentage of each resource remains available.

You can use the Resource Availability calendar to access the following types of session information:

• Display (on a per-resource basis) the sessions for which the resource is allocated.

• View additional resource session information via a mouse-over action. 

To view this additional information, mouse over a colored bar within the Resource Availability 
calendar. The following session information displays for each resource instance: Start date and time, 
End date and time, Session Name, Type (within the Resource Availability calendar and the Session 
calendar, the session type is always “session”), Status (Active, Canceled, Completed, or Failed), 
Owner, and Participants.

• View all associated sessions for any specific resource instance. 

To view this additional information, double-click within the row for the specific resource instance (just 
before or just after the displayed session “bar”). If the resource is shared, the session presentation in the 
Resource Instance Calendar expands to show all sessions which include the resource.

• View the reserved allocation (a percentage) for all resources.

The Resource Instances view displays a percentage (at the end of the resource name) that indicates the 
current utilization level of the resource in a session basis—shared and on a port basis. For example, 22% 
means that 22% of its ports are taken at the present time, and no percentage displayed means that the 
resource is fully available (that is, it’s not part of any session).

You can use this feature to discover which resources are available, to check the availability of resources 
and schedule sessions accordingly, and to analyze why a session fails when scheduled by looking at the 
status of the associated resources.

If you try to schedule a Template and are unable to do so, you can analyze the information by performing 
the following steps:

1. Look up the specific resources in that Template and check the status of those resources within the 
Resource Availability Calendar for the time frame you are attempting to schedule the session. 

2. Using the information available within the calendar, determine when the resources are scheduled and 
who owns them. 

3. Contact the owner and the administrator to see if those sessions can be cancelled or changed.

4. View the availability of different resources and then author or schedule a different Template using 
resources that are available. 

5. Edit the associated Template to reflect the new resources, and then schedule the Template.
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Understanding Resource Allocation

The Active System Manager software provides two views that are introduced in the Inventory perspective: 
Resource Allocation view and Resource Port Allocation view.

The purpose of the Resource Allocation view is to understand the current resource allocation, at the 
resource and port level. This view displays all allocations associated to a particular resource. 

To access the Resource Allocation view, select one of the following methods:

• On the Active System Manager menu bar, click Window > Show View > Other > Active System 
Manager > Resource Allocation > OK. 

• In the Resource Instances view, right-click a resource instance and select Show Resource Allocation.

Features of the Resource Allocation view include:

• You can keep the content view synchronized with your resource selection in the Resource Instances 
view: click the Link with a Resource Instances view icon, navigate to the Resource Instances view, 
and select a resource. The resource allocation opens with the resource and all sessions where the 
resource is currently in use. 

• The standard calendar operations (switch, view, etc.) and sessions (extend, move, cancel) are allowed. 

• This view is refreshed automatically on session or allocation changes. 

The purpose of the Resource Port Allocation view is to display the selected resource with all ports, and for 
each port, in which session the ports are being used.

To access the Resource Port Allocation view, select one of the following methods:

• On the Active System Manager menu bar, click Window > Show View > Other > Active System 
Manager > Resource Port Allocation > OK. 

• In the Resource Instances view, right-click a resource instance and select Show Port Allocation. The 
resource allocation opens with the resource and all sessions where the resource is currently in use.

Features of the Resource Port Allocation view include:

• The standard calendar operations (switch, view, etc.) and sessions (extend, move, cancel) are allowed. 

• This view is refreshed automatically on session or allocation changes. 
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Viewing Provisioned Domains List
In a distributed multi-site environment, each site that has an Active System Manager server is referred to 
as a domain. Domains are provisioned by the Active System Manager administrator, but users of the system 
should be familiar with the different domains in their system, if applicable.

To view a list of provisioned domains on your network, on the Active System Manager menu bar, click 
Tools > Domains.

The Domain Definitions dialog box displays; see Figure 6-8.

Figure 6-8 Domain Definitions

Every piece of inventory must be associated with only one domain. For more information about managing 
domains, see the Active System Manager Server Installation Guide.

Setting the Default Domain
When creating new inventory, you must set the domain property. You can set the default domain by 
configuring your preferences. To do so, on the Active System Manager menu bar, click Window > 
Preferences > Inventory.

The default domain preferences display; see Figure 6-9.
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Figure 6-9 Preferences—Inventory—Domain Information

For information about configuring preferences, see the “Preferences” section on page 1-27.
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Repository Management
The Active System Manager software provides a set of provisioning capabilities, including major features 
to software, firmware, and configuration file management. Those features include the following:

• Support of virtually any software repository type, including file servers, change control systems, and 
Storage Area Network (SAN)- and Network Attached Storage (NAS)-based storage arrays.

• An enhanced user Setup perspective interface, which allows single or multiple software or firmware 
images or configuration files to be easily selected from associated repositories, and applied to resources 
in proper sequence and method.

Introducing the Setup Perspective

The Setup perspective controls the layout of the user interface the Active System Manager software uses 
to display information for your inventory, including which views are displayed and their positions within 
the Active System Manager application. You can save the modifications you make to the Setup perspective 
as you create them, making your own custom user interface.

Table 7-1 outlines the default views available when you open the Setup perspective; see Figure 7-1 for a 
graphical representation of the views, which appear in tabular form.

Table 7-1 Setup Perspective Elements 

View or 
Editor Name

View 
or 
Editor Description

Resource 
Types

View Displays all of the resource types that have been added to the inventory. This view can 
be filtered, grouped, and sorted to increase data accessibility. 

Resource 
Instances

View Displays all of the resource instances that have been added to the inventory. This view 
can be filtered, grouped, and sorted to increase data accessibility, and includes the 
resource availability calendar. 

Outline View Lists the selected inventory resources in an outline format. It represents a high-level 
summary of an open editor and allows you to navigate or find information. 

Workspace 
Area

Area where most of the data entry and modification takes place. It contains the data 
editors and most of the tools used in the Setup perspective. Tabs in the Workspace 
indicate the resources that are currently open for editing. An asterisk (*) indicates that an 
editor has unsaved changes. 
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To support this, the Dell software includes a specific perspective (Provisioning) and views to manage the 
content of the repositories. 

To open the Setup perspective, perform one of the following options:

• On the Active System Manager navigation menu, click Setup. 

• On the Active System Manager menu bar, click Window > Open Perspective > Setup.

Figure 7-1 displays an example of the Setup perspective.

Properties View Displays the properties for the selected session, Template, or configuration file. It is a set 
of property values that are reflected in what you see in the editors. 

Templates View Lists the available templates previously created. Supports built-in filters. From this view, 
you can customize filters or group the Template organization by tree. For more 
information, see Chapter 1, “Active System Manager Overview.”

Discovery 
Explorer

View Lists the resource data populated into your inventory when you run the Discovery 
Explorer.

Links View Lists the links between control equipment and managed equipment, or between two 
pieces of managed equipment.

Import 
Explorer

View Displays the plug-in data of used by IIT during the inventory import. The following 
resource data is displayed:
• Attributes
• Component Location Generator
• Resource Location Generator
• Icon Path
• Slot Information
• Hypervisor
• Simple Resource Location Generator

Import CSV 
Editor

Editor The Active System Manager administrator uses to validate the input field definitions 
specified within the CSV file, provide status, error data on the associated inventory, and 
then upload the inventory links data into the Active System Manager server.

Table 7-1 Setup Perspective Elements (continued)

View or 
Editor Name

View 
or 
Editor Description
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Figure 7-1 Setup Perspective

The Active System Manager software allows for management and visibility of each repository content, 
particularly related with operating system (OS) images and configuration files via the Setup perspective. A 
repository is a collection of organized files called elements to be used to provision a resource under test. 

The Active System Manager software supports three repository types that are used during the Active 
System Manager process at Template and session times: 

• File servers

• Storage arrays

Each type supports a wide range of standard protocols (File Transfer Protocol [FTP], Secure File Transfer 
Protocol [SFTP], Trivial FTP [TFTP], Hypertext Transfer Protocol [HTTP] and Secure HTTP [HTTPS]) 
to communicate with the repository from the Active System Manager application. Table 7-2 lists and 
describes repository support available.

Table 7-2 Repository Support 

Element Operations1

Type Protocol Discover Import Export Delete Validate getVersions 

File servers FTP Yes Yes Yes Yes Yes No

SFTP Yes Yes Yes Yes Yes No

TFTP No Yes Yes No Yes No
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Opening Views on the Setup Perspective
To open the navigating views available on the Setup perspective, on the Active System Manager menu bar, 
click Window > Show View. Four navigator views are available; three of which are associated with 
Repository management (see Table 7-3). All of the Setup perspective navigator views supports built-in and 
custom filtering and grouping functions. For more information, see the “Filtering” section on page 1-12 and 
the “Grouping” section on page 1-15.

Table 7-3 Setup Perspective Elements 

View Name
View or 
Editor Description

Resource 
Adapters

View Lists all Resource Adapters deployed in the Active System Manager environment. 
From this view, you can customize filters or group the Resource Adapter 
organization by tree. 

File Servers View Lists OS image files, configuration files, and other elements associated with each 
repository.

Software 
Repositories

View Lists OS image files, configuration files, and other elements associated with each 
repository of Storage Array type.

HTTP No No Yes No Yes No

HTTPS No No Yes No Yes No

Storage 
Arrays

Note: The Storage Arrays repository support can be performed through the Dell Professional 
Services Group.

1. The release notes will contain a set of platforms and services supporting those operations.

Table 7-2 Repository Support (continued)

Element Operations1

Type Protocol Discover Import Export Delete Validate getVersions 
7-4 Active System Manager User Guide, Release 7.0



Managing Repositories
Managing Repositories

Table 7-4 lists and defines the set of general properties for managing repositories. 

Table 7-4 General Properties for Managing Repositories  

Field Description

Name Name of the repository you assign. The name cannot be changed once it is created.

Description Description of the repository you create or update.

Location Pattern A simple way to force a structure on the repository. 
• File Format
• Folder Format
If files are organized per Manufacturer/Model, you can express it with the following 
{Manufacturer}{/}{Model}. 
Note: The value of the File Format and Folder Format is used by the saveas policy 
of the RA. It tells the saveas script where to save the image or configuration file in 
the repository. The file is created with the name according to the File Format and its 
path is determined according to the Folder Format. 

Repository Properties Each repository requires a specific set of property values to access the repository. 

Additional Properties Optional. The repository can carry a set of property values that can be retrieved by 
the Resource Adapters. This is extensible using the Active System Manager 
repository adapter framework.

Domain Association Association with one Active System Manager domain is optional. Select at least one 
domain to make the repository available for the resources. Each resource instance 
has one, unique domain it can be part of. A repository can span across multiple 
domains.

This section describes how to manage repositories using the following procedures:

• Creating a New Repository

• Adding Elements into a Repository

• Deleting Elements from the Repository

• Updating Repository Content

• Deleting Repository Definitions

• Associating Elements with Resource Types or Resource Instances
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Creating a New Repository
To create a new repository (or multiple file repositories), perform the following steps:

1. In the Setup perspective, perform one of the following options to display the New Repository dialog 
box:

• On the File Servers view, right-click an element and select Repositories. 

• On the Active System Manager menu bar, click File > New > Other > Active System Manager > 
Repositories.

• On the Active System Manager toolbar, click the New icon, select Other > Active System 
Manager > Repositories.

The wizard displays a New dialog box for you to create a new repository. 

2. Click Next to create a new repository.

3. Select the required repository type and protocol. 

4. Click Next to display and enter information about the new repository. 

5. Click Next to list and discover the files on the repository. 

6. Click Discover to start the browsing and discovery process and to view the associated file elements. 
This could take a few minutes.

7. Identify element levels to be marked as Base or Patch elements:

• To mark them as a base file, select one or more rows, right-click, and select Set As Base. 

• To not mark them as a patch file, in the Base column, click the check boxes to deselect your 
identified elements. 

Note Steps 7, 8, and 9 are required to complete to use the provisioning feature in the Active System 
Manager application.

8. Element types must be identified as an image file or an element or a configuration file. To do so, select 
one or more elements, right-click and select Set Type > Element | Image File | Configuration File.

9. Set the association: select a row and click Associate. To set the association to multiple images or 
configuration files, click Bulk Associate.

Note This operation is required to facilitate provisioning of resources under test for specific vendors.
 

10. Select all files to import into the repository view using the check boxes in the Name column. 

11. Click Finish. 
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Adding Elements into a Repository
To add elements in a repository, you must select files (also called elements) to add into the Active System 
Manager repository context view. 

Note This operation may not be supported for all repository types and protocols supported. Dell 
recommends reviewing the Repository Support table (Table 7-2 on page 7-3).

To do so, perform the following steps:

To add elements in to a repository, perform the following steps:

1. Open the Setup perspective; see the “Introducing the Setup Perspective” section on page 7-1.

2. Display the New Element dialog box using one of the following options:

• On the File Servers view, right-click and select New Element or Import. 

• On the Active System Manager menu bar, click File > New > Other > Active System Manager > 
Element.

• On the Active System Manager toolbar, click the New icon, select Other > Active System 
Manager > Element.

If you have the File Servers view open, then you can view your new files. The repository on the network 
can be very large; therefore, administrators can select a few and make them available to the rest of the 
users. A new blank dialog box displays for you to continue the process of adding a new element to a 
repository; see Figure 7-2.
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Figure 7-2 Adding a New Element to a Repository

Table 7-5 lists and describes the field properties in Figure 7-2.

Table 7-5 Properties for Repository Elements Discovery and Association 

Field Description

Repository Required. List of existing repositories. You must select one.

Name Required. Filename of repository; for example, pico-test.cfg. Select file from your 
desktop using the Browse button (currently only available on import).

Description Optional. Description associated with new elements.

File Type Required. You can set the file type. The options are:
• Element
• Image File
• Configuration File

Path Optional. Relative path to the file in the repository.

Level The options are:
• Base
• Patch (in case of an element or image file)
• Add on (in case of configuration file)
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3. Click Finish.

New elements should display in the associated repository navigator views.

Deleting Elements from the Repository
To delete elements from a repository, perform one the following options:

• In the Setup perspective, from any navigator view, select one or more elements, right-click, and select 
Delete. 

• In the Setup perspective, from any navigator view, select one or more elements, and on the Active 
System Manager menu bar, click Edit > Delete.

The Delete menu displays; see Figure 7-3. 

Figure 7-3 Deleting File Elements from the Repository

4.
Note If you click the Delete element from repository as well check box and click Yes, this 

action also deletes the file element from the repository.

When the Confirm Delete dialog box displays, click Yes. 

Size Required for repository type storage arrays.

Bundle Element definition is a bundle of elements (i.e., a container). You must move at least one 
element (see the Elements description) to the bundle.

Resource Association Sets the element association with resource types or resource instances. Use the Add or 
Remove buttons to customize your resource association. 

Elements Required when the Bundle check box is enabled. Displays the bundle content with a set 
of elements. Use the Add or Remove buttons to customize your bundled content. Use 
the Up and Down buttons to order the bundled content. Use the Versions button to 
select a specific version. 
Note: Enabled only for the Source Control-CVS repository.

Additional Properties Elements can carry customized property definitions; for example, name, value, 
mandatory. Use the Add or Remove buttons to customize your list.

Table 7-5 Properties for Repository Elements Discovery and Association (continued)

Field Description
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Removing Elements from a Bundle
To remove elements from a bundle, perform the following steps:

1. Open your repository navigator view.

2. Identify your bundle, select one or more elements within the bundle, right-click and perform one of the 
following options:

• Select Remove from group to remove it from the group, but not from the repository. 

• Select Delete to delete from the repository and from the bundle.

Updating Repository Content
To update the repository content by adding elements, perform the following steps:

1. In the Setup perspective, perform one of the following options to display the New dialog box:

• On the File Servers view, right-click an element and select Repositories. 

• On the Active System Manager menu bar, click File > New > Repositories.

• On the Active System Manager toolbar, click the New icon and select Repositories.

The Select Repository Type dialog box displays; see Figure 7-4.

Figure 7-4 Select Repository Type Dialog Box

2. Click Next.

3. Click the File Server > Existing options and select an existing repository from the pull-down selection.

Your existing repositories for each type should display in the list.

4. Click Next to display a dialog box that contains the information associated with your existing 
repository. 
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5. Click Next to perform a repository discovery and status update and to display an example of that result.

The files already exist in the repository, but have a new icon design. These filters allow you to filter out 
repository content. Table 7-6 lists and defines the icon filters.

Table 7-6 Filtering Icons

Icon Description

Displays only existing elements.  

Displays only newly discovered elements

Displays only conflicting elements 

Displays all elements 

6. Click Finish.

Deleting Repository Definitions
To delete repository definitions, perform the following steps:

1. Identify the existing repositories; on the Active System Manager menu bar, click Tools > Repositories.

The Repository-Asset Association dialog box displays; see Figure 7-5.

Figure 7-5 Repository-Asset Association
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2. Select one or more repositories and click Remove. 

You cannot delete repositories if the elements of the repository exist in the Active System Manager 
view; a dependency error displays (see Figure 7-6 as an example). 

Figure 7-6 Dependency Error

3. Click OK.

Associating Elements with Resource Types or Resource 
Instances

Repository elements (of any types) must be associated with resource types or resource instances. This 
association facilitates the workflow when you must select compatible configuration files or operating 
system (OS) image files with your resource under test. 

Association can be done under the following circumstances:

• Defining a new repository during discovery elements (wizard-based)

• Updating a repository during discovery and status updates (wizard-based)

• Navigating a repository element (view-based)

To associate elements, perform the following steps:

1. On the Discovery results dialog box, perform one of the following tasks:

• Select one or more file elements and click Associate to associate the selected file elements with the 
resource types.

• Select two or more elements and click Bulk Associate to associate the selected file elements with 
the resource types.

The Associate Inventory dialog box displays, where you can select resource types or resource assets to 
associate with the selected file elements.

A dialog box displays the complete list of resource types and resource instances supported (similar to 
the Resource Types or Resource Instances view) in the Active System Manager inventory. 

You can associate your elements with more than one resource type or resource instance, browse the tree 
and select. You have also filters and Select and Deselect options to select the elements

2. Click OK when you have completed your selections.

Once you click OK, the association displays in the Association column. In the Name column, verify the 
selected element. 

3. Click Finish.
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Editing Repository Elements
To edit repository elements, perform the following steps:

1. Open a repository navigator view; see Figure 7-7 for a repository element example.

Figure 7-7 Example of a Repository File Type

2. Select one element, right-click and select Edit to display the property dialog box associated with 
element.

Figure 7-8 displays an example of a property for a specified element.
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Figure 7-8 Element Properties for a Specified File

Table 7-7 lists and describes the field properties in Figure 7-8.

Table 7-7 Properties for Repository Elements Discovery and Association 

Field Description

Name Read only. Current element filename of repository.

Description Optional. Description associated with new elements.

Type Read only. Existing element file type:
• Element
• Image File
• Configuration File

Repository Read only. Existing repository name associated with the element.

Path Read only. Relative path to the file in the repository.

Level Optional. The options are:
• Base
• Patch

Size Read only. Required for repository type storage arrays.
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3. Click Add to define the association.

The Associate Inventory dialog box displays with the defined associations.

You can associate your elements with more than one resource type or resource instance, browse the tree 
and select. There are also filters and Select All and Deselect All options to select the elements.

4. Click OK when you have completed your selections.

Once you click OK, the association displays in the Association column.

Disassociating Elements
To disassociate elements, follow the procedure in the the “Associating Elements with Resource Types or 
Resource Instances” section on page 7-12; however, in this case, select multiple elements (click the check 
boxes) to disassociate and click Disassociate.

You can also remove the association from a selected element from the Repositories view > Edit dialog box.

Bundle Read only if enabled (checked). Only enabled if you are editing a bundle. Element 
definition is a bundle of elements (i.e., a container). You must move at least one element 
(see the Elements description) to the bundle.

Resource Association Sets the element association with resource types or resource instances. Use the Add or 
Remove buttons to customize your resource association. 

Bundle Elements Required when the Bundle check box is enabled. Displays the bundle content with a set 
of elements. Use the Add or Remove buttons to customize your bundled content. Use 
the Up and Down buttons to order the bundled content. Use the Versions button to 
select a specific version. 
Note: Enabled only for the Source Control-CVS repository.

Additional Properties Elements can carry customized property definitions; for example, name, value, 
mandatory. Use the Add or Remove buttons to customize your list.

Table 7-7 Properties for Repository Elements Discovery and Association (continued)

Field Description
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Working with Resource Adapters

In the Active System Manager system, resources—and therefore Resource Adapters (RAs)—are organized 
into a couple of categories:

• Managed Resources—Explicitly specified in Template designs, scheduled by the users and actually set 
up and configured in live or active sessions. Managed Resources may include switches, routers, servers 
and SAN equipment. Examples of the types of control methods used for managed resources may 
include operations such as Acquire Control, Discover Inventory, Send Command, Apply OS Image, 
Load Configuration, Save Configuration or Reboot. 

• Control Resources—Form what may be considered the control and connection plane of the 
environment. These resources help create or realize the Template designs that are authored by the users. 
Rather than being explicitly specified in Template designs these resources work implicitly “behind the 
scenes” to connect and configure the Managed Resources and to perform various control actions. 
Control Resources may include physical layer switches (electrical or optical,) Layer 2 switches, power 
controllers and terminal servers. Examples of the types of methods used for control resources may 
include operations such as Acquire Control, Make Link, Break Link, Configure VLAN, Power On or 
Power Off.

The Resource Adapter Framework (RAF) supports a wide range of protocols and methods including Telnet, 
SSH, SNMP, Sockets, TL1, XML, HTTPs, SOAP, WSDL, CORBA and various TMF standards. Once 
adapters are created using a Software Development Kit (SDK) they can simply be plugged-in to the Active 
System Manager system, without any changes to the operating software. 

The RAF is a fundamental element that provides flexibility and extensibility to the Active System Manager 
architecture, and which enables Active System Manager to be used across a wide range of technologies and 
applications. 

Resource adapters are built using the Dell software development kit and can be deployed using the Active 
System Manager application.

The following topics describe how to work with Resource Adapters:

• Opening the Resource Adapters View

• Opening the Resource Adapter Editor

• Deleting Resource Adapters

• Deleting Resource Adapters

• Editing Resource Adapters

• Exporting Resource Adapters

• Deleting Resource Adapters
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Opening the Resource Adapters View
In the Setup perspective, the Resource Adapters navigator view lists all Resource Adapters deployed in the 
Active System Manager application. 

To open the Resource Adapters view (see Figure 7-9), use one of the following methods:

1. Open the Setup perspective; see the “Introducing the Setup Perspective” section on page 7-1.

2. On the Active System Manager menu bar, click Window > Show View > Other > Active System 
Manager > Resource Adapters.

Figure 7-9 Resource Adapters Navigator View

Table 7-8 lists and describes the Resource Adapters property values.

Table 7-8 Resource Adapters Values

Property Description

Name Resource Adapter name.

Manufacturer Resource Adapter manufacturer name.

Model Resource Adapter model name.

Version-Release Number Resource Adapter version. Defined by the Resource Adapter integrator.
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Opening the Resource Adapter Editor
To open the Resource Adapter editor, in the Resource Adapters view, select a Resource Adapter, right-click 
and select Open.

The following tabs are available on the Resource Adapter editor:

• Overview—Defines all core properties of the Resource Adapter.

• Operations—Defines all custom and system operations for the Resource Adapter.

• Applications—Defines all applications that can be launched using the Resource Adapter.

• Files—Provides access and management to Resource Adapter property files.

• About—Provides free-form copyright and release information.

Overview
Table 7-9 lists and describes the Compatibility Matrix property values.

Table 7-9 Compatibility Matrix Property Values

Property Description

Manufacturer Compatibility Matrix manufacturer name.

Model Compatibility Matrix model name.

Description Description of the Compatibility Matrix.

Version Compatibility Matrix version. Defined by the Compatibility Matrix integrator.

Release Number Compatibility Matrix release number.

Release Date Compatibility Matrix release date.

To update the compatibility matrix, import a new CSV file as follows: 

1. In the Resource Adapters view, open the Resource Adapter editor, select a Resource Adapter, right-click 
and select Open.

2. In the Resource Adapter editor: 

a. Select the Overview tab.

b. Navigate to the Compatibility Matrix section.

c. Click the browse icon.

d. Import the CSV file. 
7-18 Active System Manager User Guide, Release 7.0



Working with Resource Adapters
Operations
Note All Resource Adapter editor changes (using the File > Save function) will take effect immediately 

in your environment. We recommend that you back up or export your Resource Adapters before 
making such changes.

To manage the system and custom methods defined in the Resource Adapter, perform the following steps:

1. In the Resource Adapters view, open the Resource Adapter editor, select a Resource Adapter, right-click 
and select Open.

2. In the Resource Adapter editor, select the Operations tab to list all system and custom methods defined 
in the Resource Adapter.

3. Perform the following tasks (followed by the File > Save function), as appropriate to your needs:

• To view or edit the methods, select one method to see associated detailed information and the associated 
custom attributes definitions. You can update the information at will. Click File > Save to save the new 
content of Resource Adapters.

• To remove a method, select one method and click Remove > File > Save to save the new content of 
Resource Adapters.

• To add a method to the Resource Adapter, click Add > a method type. Fill in the Operation Details and 
attributes for this exposed method. Reference to the Resource Adapter code (such as tcl files) must be 
present on the Active System Manager server to be executed properly.

Note Building Resource Adapters requires the Resource Adapter SDK module, along with the Active 
System Manager Resource Adapter Developer Guide. This guide highlights the Resource Adapter 
deployment structure and how to implement your RA interfaces.

Note Operation details, such as Available for End-Users can be enabled (checked) or disabled (not 
checked); if enabled, such operations are made available through the web application or in the 
application during the life of a session.

Applications
To manage the applications defined in the Resource Adapter, perform the following steps:

1. In the Resource Adapters view, open the Resource Adapter editor, select a Resource Adapter, right-click 
and select Open.

2. In the Resource Adapter editor, select the Applications tab to list all applications that can be launched 
from the application or web portal associated with the opened Resource Adapter. 

Two application types are supported: 

• Direct allows an administrator to link to a native application or specific URL that will be launched 
directly from the Active System Manager application or web portal.

• Resolve (Indirect) allows an administrator to invoke an appropriate RA method before launching 
the application or web portal. For more information about building such an application method, see 
the Active System Manager Resource Adapter Developer Guide. 
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3. Perform the following tasks (followed by the File > Save function), as appropriate to your needs:

• To view or edit the applications, select one application to see associated detailed information. You 
can update the information at will. Click File > Save to save the new content of Resource Adapters.

• To remove an application, select an application and click Remove. Click File > Save to save the 
new content of Resource Adapters.

• To add an application to the Resource Adapter, click Add > an application type. Fill in the Operation 
Details for this exposed method application. 

Files
You can add or edit property value content by double-clicking a file. File content is displayed in the editor 
and content is automatically syntax-colored-highlighted. Basic editing operations are allowed, such as 
Search, Cut, Copy/Paste. The administrator must save the file (File > Save) after changes are made.

To add a property file, click Add and select the associated level:

• Manufacturer—These files can be used across all Resource Adapters from the same manufacturer.

• Model—These files are unique to the selected Resource Adapter.

• Control Gear—These files are usually associated with Layer 1 switching Resource Adapters.

To delete a property file, select the file and click Remove. 

Note Removing files is not recommended as it may impact the Resource Adapter behavior.

About
To view the free-form copyright and release information details for the selected Resource Adapter, perform 
the following steps:

1. In the Resource Adapters view, open the Resource Adapter editor, select a Resource Adapter, right-click 
and select Open.

2. In the Resource Adapter editor, select the About tab to list all release information for the opened 
Resource Adapter. 

Editing Resource Adapters
The Active System Manager software allows you to edit the attribute values of parameters for custom and 
virtual operations as defined in RA editor. These parameter values are fetched by the executor while 
executing custom and virtual operations. However, while editing the parameter values for custom and 
virtual operations, the Active System Manager software provides you with an enhanced capability of 
selecting the parameter value from the ‘Value Source’ defined for custom and virtual operations, rather than 
entering parameter values manually.

Primary Source (Value Source) and its Secondary Source (SubType):

The Active System Manager software manages certain types of resources such as template, session, and 
repositories etc. The Value Source refers to such objects that have been recognized and categorized as 
‘Value Source’ in the Active System Manager software for convenience of use. 
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In Active System Manager software, a Value-Source is a context based list of values that dynamically 
displays values to choose from, based on operation properties. It is the categorization of system managed 
objects into possible list of broad categories, from where an operation can fetch parameter values. The Sub 
Type of Value Source further categorizes each categorized object in Value Source, to provide you with a 
double defined value-set; for example: consider Resource Properties to be a managed object, which serves 
as a Value Source for fetching parameter value for any operation while execution (if you define Resource 
Properties as a Value Source in operation definition). However, the Resource Properties can further be 
categorized into Provisioning properties, which serves as the Sub Type of Value Source and is supplied 
as a parameter value while execution (if you further select Provisioning parameter as Sub Type in 
operation definition).
Note In the Active System Manager software, the Value Source is referred to as the Primary Source and 

its Sub-Type is referred to as the Secondary Source.

Table 7-10 displays the possible Value Sources and its Sub-Types as defined in the Active System Manager.

Table 7-10 Value Source and its Sub-Types

Value Source Value Source Description Sub-Types Defined for Value Source

Custom 
Repositories

Manages Image files, Configuration files 
and Elements for particular type of 
Custom Repositories in the Active System 
Manager.

Lists all Custom Repositories existing in the 
Active System Manager and displays Image files, 
Configuration files, and Elements contained in 
the each repository.

File Servers Manages Image files, Configuration files 
and Elements for particular type of File 
Servers in the Active System Manager.

Lists all File Servers in the Active System 
Manager and displays Image files, Configuration 
files, and Elements contained in each File 
Server.

Operation Output Manages Output Parameters of existing 
custom operations that can be used as 
input parameters of some other custom 
operation. These Output parameters are 
defined for custom operations in 
Resource Adapters.

Lists all output parameters of custom operations 
that are defined in Resource Adapter of the 
selected resource.

Organization Manages all Organizations in the Active 
System Manager.

Sub Type not applicable.

Resource 
Properties

Manages inventory parameters, 
provisioning parameters and Interface 
elements of a specific resource on which 
the operations are executed.

Lists Resource Properties namely inventory 
parameters, provisioning parameters, and 
interface of a specific resource on which the 
operations are executed.

Session Objects Manages all resources and links of a 
Template with respect to the 
Orchestration being created or operation 
being executed.

Lists four types of session objects namely 
resources, links, resource properties, and link 
properties for Orchestration being created or 
operation being executed.

Session 
Properties

Manages all provisioning properties 
related to a Template.

Lists provisioning parameters related to a 
Template.

Software 
Configurations

Manages all software configurations. Lists all software configurations.

• Custom Operations—A set of RA operations that are associated with the resources in a template. 

• Virtual Operations—A set of RA operations that are associated with the resources in Operation Center 
view. 
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Table 7-11 displays the possible Value Sources applicable to custom and virtual operations.

Table 7-11 Applicable Value Sources for Custom and Virtual Operations

Custom 
Repositories

File 
Servers

Operation 
Output Organization

Resource 
Properties

Session 
Objects

Session 
Properties

Software 
Configuration
s

Virtual 
Operation

√ √ X √ X X X √ 

Custom 
Operation

√ √ √ √ √ √ √ √ 

Note While creating or editing RA operations in RA editor, the values in Primary Source drop-down 
display dynamically, and are populated with possible values retrieved from specific value source in 
corresponding operation definition in RA.

To edit RAs, perform the following steps:

1. Right-click a specific RA in the Resource Adapters view.

2. Click Open to open Resource Adapter editor; see Figure 7-10.

Figure 7-10 Resource Adapter Editor

3. Click the Operations tab. (To add or remove a specific operation, click Add).

4. Select a specific custom or virtual operation for editing attribute values; for example: select the 
rebootInstance operation to edit attribute values. On the right, in the Attributes panel, all attributes 
related to the rebootInstance display, see Figure 7-11.
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Figure 7-11 Operation Attributes

Table 7-12 lists and describes the operation attribute types as displayed in Figure 7-11.

Table 7-12 Operation Attribute Types 

Attributes Description

Name Lists all parameters related to selected operation.

Type Lists parameter type such as ‘String’ or ‘Number’.

Default Value Allows to enter default parameter value.

Possible Values Allows to select value from a list of pre-defined possible values.

Unit Allows to enter unit value.

Mandatory Allows to select parameter as ‘Mandatory’.

Editable Allows to select the parameter as ‘Editable’.

Common Allows to select parameter as ‘Common’.

Value Source Allows you to select value from a list of pre-defined context-sensitive values.

Sub Type Allows you to select value from a list of pre-defined values based on Value Sources.

5. Optional. View or edit the methods: select one method to see associated detailed information and the 
associated custom attributes definitions. You can update the information at will. Click File > Save to 
save the new content of RA.

6. Optional. Remove a method: select a method and click Remove > File > Save to save the new RA 
content.

7. Optional Add a method to the RA: click Add > a method type. Fill in the Operation Details and 
attributes for this exposed method. Reference to the RA code (such as tcl files) must be present on the 
Active System Manager server to be executed properly.
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Copying Resource Adapters
To copy a Provisioning Manager Resource Adapter directory structure under a different 
Manufacturer/Model, perform the following steps:

1. In the Resource Adapters view, select a Resource Adapter, right-click and select Copy Resource 
Adapters.

The Copy Resource Adapters dialog box displays; see Figure 7-12.

Figure 7-12 Copy Resource Adapters

2. Click the Destination Domain pull-down menu, select a domain, and click OK.

Importing Resource Adapters 
To import Resource Adapter Package (RAP) files (.rap files) from your file system, perform the following 
steps:

1. In the Resource Adapters view, select a Resource Adapter, right-click and select Import.

The core properties for that selection display by default; see Figure 7-13. By default, the Select root 
directory radio button is selected.

Figure 7-13 Resource Adapter Properties
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2. Click Browse to select a directory location to import one or more RAP files. 

3. Click the Select resource adapter package file option and click Browse to select a directory location 
for your imported RAP file.

4. Click the Domain pull-down menu and select the domain for this RAP file.

5. Review the Resource Adapter values (see Table 7-8 on page 7-17) and perform one of the following 
options:

• Click Select All to select all of the Resource Adapters to import.

• Click Deselect All to deselect the selected Resource Adapters.

• Click Refresh to reset the Resource Adapter list.

6. Click Finish to update the view.

Note The Resource Adapters will take effect immediately. New operations will be available to be 
executed in any running sessions.

Exporting Resource Adapters
To export Resource Adapter Package (RAP) files (.rap files) from your file system, perform the following 
steps:

1. In the Resource Adapters view, select a Resource Adapter, right-click and select Export.

The core properties for that selection display by default; see Figure 7-14.
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Figure 7-14 Resource Adapter Properties

2. Review the Resource Adapter values (see Table 7-8 on page 7-17) and either click Select All to select 
all of the Resource Adapters to export, or click Deselect All to deselect the selected Resource Adapters.

3. In the To directory field, type a directory path, or click Browse to select a directory location for your 
exported RAP files. 

4. Click Finish.

Deleting Resource Adapters
To delete Resource Adapters and the associated Resource Adapter directory structure on the Active System 
Manager server, perform the following steps:

1. In the Resource Adapters view, select one or more Resource Adapters, right-click and select Delete.

A confirmation prompt for the deletion displays.

2. Click OK.
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C h a p t e r  8  
Template Management
This chapter describes the Active System Manager Templates perspective and all of the functions available, 
including how to import and export Templates directly from the Active System Manager Template view 
into the Templates perspective. Lastly, it describes how to work with configuration files for equipment 
provisioning in a Template.

Before you can execute an environment session, you must define a requirement Template. The Active 
System Manager Templates perspective provides a graphical user interface (GUI) for creating author 
Templates. Once defined, the Template can be saved and re-used, or it can be modified to create variations. 

To open the Templates perspective, perform one of these tasks:

• On the Active System Manager toolbar, click the Open Perspective icon and select Templates. 

• On the Active System Manager toolbar, click the Templates perspective icon.

• On the Active System Manager menu bar, click Window > Open Perspective > Templates.
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Figure 8-1 Templates Perspective

Table 8-1 outlines the default views available when you open the Templates perspective.

Table 8-1 Template Perspective Elements 

View or Editor 
Name

View or 
Editor Description

Templates View Lists the available Templates previously created. Supports built-in filters 
(Public/Private) and group functions. For more information, see Chapter 1, “Active 
System Manager Overview.”

Template Editor Editor Defines the graphical area, where you can design your Template. The resource 
types and resource instances can be dragged and moved around in the Template 
editor. Links can be created between appropriate resources in the Template. 

Resource Types View Lists all available resource types. For more information about resource types, see 
Chapter 1, “Active System Manager Overview.”

Resource 
Instances

View Lists all available resource instances. For more information about resource types, 
see Chapter 1, “Active System Manager Overview.”

Outline View Lists the content of the open Template in an outline format. It represents a 
high-level summary of an open editor and allows you to navigate or find 
information quickly. When you select a node or link in this view, it also is selected in 
the Template editor, and the properties for the selected Template change, as 
appropriate, in the Properties view.
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The Active System Manager software supports the following three Template types; see Table 8-2.
Table 8-2 Template Types

Template Type Description

Normal Template The resources are selected from the free pool. By default, the Normal Template is selected.

Physical Template Provisions Hypervisors on raw blades. It is also used to provision the VLAN component with 
a range of VLAN IDs onto matrix switch. In case of Physical Template, the Resource 
Adapter internally makes clusters from Hypervisors.
Note The Physical and Logical Template types exist in the Active System Manager 

software to provision ESXI image on raw blades, and use such Hypervisors to 
provision VMs. This happens in the following two steps:

• Firstly, the Physical Template is created, and, during realization, the ESXI image is 
provisioned on raw blades. 

• Secondly, the Logical template is created to provision VMs on such Hypervisors, by 
realizing the template onto session created from the Physical Template.

Logical Template The Logical template is used to provision VMs on Hypervisor or cluster, from sessions, 
created from physical template. It is also used to provision the VLAN component from VLAN 
range given in the Physical template

Physical Template
The workflow of Physical Template consists of the following tasks:

• Linking Editor

• Creating a Physical Template

• Creating Orchestration for Provisioning

• Scheduling Template to Create a Session

• Provisioning

Properties View Associated with the selections in the Template editor, link editor, and the Outline 
view. The Properties view displays the properties of any of the selected objects in 
the associated views or editor. In case of multiple selections, the property of the 
object selected first will be displayed. 

Table 8-1 Template Perspective Elements (continued)

View or Editor 
Name

View or 
Editor Description
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Linking Editor
The first step in the workflow consists of connecting raw blades and L2 matrix switch in the linking editor. 

Creating a Physical Template
The next step consists of dragging and dropping the managed devices in the Template editor to provision 
Hypervisors. You are also required to drag some VLAN components in the Template editor, and, assign 
some VLAN ID range to it or auto schedule it. Then, connect managed devices to VLAN component.

Note The managed devices to be used in the Physical template should not be shared as the device, being 
provisioned with a Hypervisor in a session, should not be used in another session.

For more information, see the “Creating New Templates” section on page 8-6.

Creating Orchestration for Provisioning
In the next step, create a Setup type orchestration, to be mapped to the Physical template. The steps to create 
orchestration are as follows:

• Create clusters on the vCenter.

• Create a Hypervisor on the blades.

• Register Hypervisors with the vCenter.

• Add hosts to the cluster created.

• Run discovery to populate the Active System Manager inventory (vCenter discovery) with cluster 
entities.

Scheduling Template to Create a Session
The next step consists of scheduling Template to create a session. 

Note The session scheduled from the Physical template is of permanent type.

Note If the session scheduled from a Physical template is being used by the system to realize a Logical 
template (in present/future), and if the user cancels such physical session, then the system throws 
an error.

Provisioning
To provision Hypervisors and clusters, the Resource Adapters are required. To achieve this, a series of 
Setup orchestration steps are configured. In the session provisioning parameter, the RA adds cluster or 
independent Hypervisor’s assettag [cluster=cluster1,cluster2 hypervisor=hypervisor1,hypervisor2]. 

Logical Template
The Logical template is used to provision VMs on Hypervisor or cluster, from sessions, created from 
physical template. It is also used to provision the VLAN component from VLAN range given in the 
Physical template.

Note The difference between the Logical and Normal template is that, the Logical template is realized 
upon a Physical template based session.
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The workflow of Physical Template consists of the following steps:

• Creating a Logical Template

• Scheduling Template to Create a Session

• Provisioning

Note In the current implementation, there are separate inventory objects for raw blades and 
hypervisors/clusters provisioned, where they are brought into the Active System Manager’s 
inventory through discovery (these being logical entities have no link information).

Creating a Logical Template
The first step in the workflow consists of creating a Logical template by dragging VMs in the Template 
editor. You are also required to drag the VLAN components in the Template editor. Then, link VMs and 
managed devices with VLAN components. For more information, refer “Creating New Templates” section 
on page 8-6.

Scheduling Template to Create a Session
In the case of Logical template, while scheduling the session, the resources are selected from the associated 
Physical template. While scheduling a session, you can view the list of running sessions which are created 
from Physical type template where you are a participant. You can select the session, onto which, you want 
to realize the Logical template.

Note No session is selected by default. In such a case, the Active System Manager system considers the 
template as Normal, for scheduling resources on the template.

After selecting the session, the VMs are to be scheduled on the managed devices, as, clusters or independent 
Hypervisors in session (listed in the session parameters of the session, refer “Provisioning” section on 
page 8-4). If the selected physical session does not contain a valid device information in the session 
provisioning parameters; for example: if none of the devices are in the inventory, then the Logical template 
is not scheduled.

Note In case of Logical templates, the link realization is already done on the session 
associated with it. It is assumed that the links between VLAN component and VMs 
on logical template are Logical, and so, the link feasibility between these can be 
skipped while scheduling a session. For the same reason, during provisioning such 
links will be marked as realized without actually realizing them.

VLAN IDs for the VLAN component should be within the range provisioned in the session. Also, the 
VLAN component in the Logical template should be in AUTO mode. 

Note As per the Precondition, t he VLAN component on the chosen Physical session as well 
as the current Logical session should be shared. If either Physical session or the 
Logical session are exclusive, then the VLAN ids on physical session cannot be used. 
However, if the Physical based session is associated with a Logical template, and, 
PBS is also set on devices in Logical template, then the session bound mechanism 
overrides. In such as a case, the resources for realizing devices from Logical template 
are used from the associated session.
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Working with Templates

The Active System Manager software allows you to perform a variety of additional functions using the 
Templates perspective, including:

• Creating New Templates

• Saving Templates

• Changing Template Ownership and Permissions

• Opening Templates

• Closing Templates

• Deleting Templates

• Managing Template History Details

• Filtering Templates

• Validating Templates

• Importing Templates

• Exporting Templates

• Attaching a Template Image

• Scheduling Templates

• Archiving Templates Using the Templates View

• Restoring Archived Templates

• Updating Templates Using the Template Editor

• Updating Templates Using the Link Editor

• Associating an Orchestration Workflow with Templates

Creating New Templates
To create a new Template, perform the following steps:

1. Select a method to open the New Template dialog box:

• On the Active System Manager menu bar, click File > New > Template. 

• On the Active System Manager toolbar, click File > New > Other, expand the Active System 
Manager folder, and click the Template icon.

• On the Active System Manager toolbar, click the New icon and select Template.

• On the Active System Manager toolbar, click the New icon, select Other, expand the Active System 
Manager folder, click the Template icon, and click Next.

The New Template wizard displays; see Figure 8-2.
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Figure 8-2 New Template 

2. Click the Name field and enter a name for the new Template. 

Note The Template name can be up to 80 alphanumeric characters, including spaces. 

If you enter a name that has been previously used, a dialog box displays, prompting you to use another 
name; otherwise, skip to step 5. If you see this prompt, click OK to return to the New Template dialog 
box.

3. Select the Template Type as Normal, Physical, or Logical.
Note If you select the Logical template type, the option to choose the associated Physical 

template displays.

4. For each participant, select a Permissions option to assign: 

• The Delete permission allows the user to delete the Template. 

• The Update permission allows the user to edit and save the Template updates.

Note Only Template owners and administrators can change ownerships, participants, and 
permissions. 
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5. Click Finish to complete the new Template creation.

The new Template opens in the Template editor as a blank page.

You are now ready to add resource types and resource instances, set properties and define interface 
connectivity. For details, see the “Filtering Templates” section on page 8-13.

Saving Templates
You can modify and save any Template if you have permission (or if you are an administrator). 

To save a Template, with the working Template open, perform the following:

1. Select a method to open the Save As dialog box (see Figure 8-3):

• On the Active System Manager menu bar, click File > Save or click Save as. 

Note On the Active System Manager menu bar, you can click File > Save provided that there are no 
sessions against that Template; otherwise, the results include dependencies.

• On the Active System Manager toolbar, click the Save icon.

• In the Templates view, right-click a Template to save and select Save as. 

• In the Template editor, right-click a Template to save and select Save as.

Note Clicking Save As allows you to save the Template as a different name or change the permissions.
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Figure 8-3 Save As Dialog Box

2. Click the Name field and enter a new name for this Template.

3. Optional. Click the Description field and enter a description.

4. Optional. Click the Participants field and Add or Remove participants (sharing to a set of participants: 
users or groups), as necessary. 

5. Select a Permissions option; for each user, you can assign permissions, and by default, they can be read 
only:

• Delete is available for a specific user. 

• Update is available for a specific user.

6. Click the Keep existing history details check box to carry the existing notes to the new Template. 
Deselect the check box to clear all existing notes. The default is for the check box to be enabled.
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Changing Template Ownership and Permissions
Template owners can share Templates with other users and groups. To do so, perform the following steps:

1. On the Active System Manager menu bar, open the Templates view: click Window > Show View > 
Templates to open the Templates view.

2. In the Templates view, right-click a Template and select Edit.

The properties for that selected Template displays; see Figure 8-4 for an example. 

Figure 8-4 Properties for a Selected Template

3. Click the Owner field and select a new owner.

4. Click the Participants field and Add or Remove participants, as necessary.

Only non-administrator users are listed.

Note Active System Manager administrators have access to all Templates.

5. For each participant, select a Permissions option to assign (either Delete or Update). 

• The Delete permission allows the user to delete the Template. 

• The Update permission allows the user to edit and save the Template updates.

Note Only Template owners and administrators can change ownerships, participants, and permissions.

6. Click OK.

For more information about permissions, see the “Defining Permissions” section on page 4-19 and the 
“Modifying Permissions” section on page 4-21.
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Opening Templates
To open one or more Templates, see the following sub-sections:

• Opening a Single Template

• Opening Multiple Templates

Opening a Single Template
To open a single Template, perform one of the following options:

• In the Templates view, right-click the Template and select Open.

• In the Templates view, double-click the Template.

• In the Sessions view, right-click the Template and select Open.

Note Upon opening a Template, validation is invoked. For more information, see the “Validating 
Templates” section on page 8-13.

Opening Multiple Templates
To open one or more Templates from the Template view, you can open from the Templates perspective or 
the Sessions perspective (Sessions view), and perform the following steps:

1. Select the method to open the Template or Sessions perspective.

• On the Active System Manager toolbar, click the Template or Sessions perspective icon.

• On the Active System Manager menu bar, click Window > Open Perspective > Template, or click 
Window > Open Perspective > Session.

2. Select the method to display the Templates or Sessions view:

• On the Active System Manager menu bar, click Window > Show View > Templates, or click 
Window > Show View > Sessions. 

• On the Active System Manager toolbar, click the Template or Sessions perspective icon.

3. Select the method to open one or more Templates:

• In the Templates view, hold down the Ctrl key, right-click the desired Templates, and select Open.

• In the Sessions view, right-click and select Open Template.

The Templates view displays all of the available Templates. The owner of a public file is the user that 
authored the file (determined by the user account that created it). 

Note Upon opening a Template, validation is invoked. For more information, see the “Validating 
Templates” section on page 8-13.

Note As a non-administrator user, when you open a Template, unless it is one you created, you do not 
own the Template, and therefore you cannot modify or save it, but you can click Save As to save it 
as your own. A read-only watermark displays in the Template editor when you are not the owner of 
the Templates. For more information, see the “Saving Templates” section on page 8-8.

Note As an administrator user, you can edit the Templates owned by other users, even if you are not the 
Template owner. 
Template Management 8-11



Working with Templates
Closing Templates
There are two ways in which you can close your Template, but not leave your working session. To do so, 
perform the following steps:

1. Select a method to close one or more Templates:

• If you have more than one Template open in the Template editor, select which Template to close and 
click File > Close. Alternatively, to close all of the open Templates, click File > Close All.

• In your open Template editor, select which Template to close and click the Close icon in the 
top-right corner of the tab.

Using either option, the Save Resource dialog box displays, prompting you to save any changes.

2. Click Yes to save any changes, or click No to close the Template without saving changes.

Deleting Templates
To delete one or more Templates from the Templates view, perform the following steps:

1. On the Active System Manager menu bar, open the Templates view: click Window > Show View > 
Templates to open the Templates view. 

2. Select the method to delete one or more Templates:

• For a single Template—In the Templates view, right-click the Template, and select Delete. 

• For multiple Templates—In the Templates view, hold down the Ctrl key, select the desired 
Templates, right-click, and select Delete.

The Confirm Delete dialog box displays, prompting you to confirm the deletion.

3. Click OK to delete the selected Template (or Templates).

Managing Template History Details
Template history is an effective way to track the life cycle of your Templates and keep a set of comments 
and notes (i.e., history) of the current updates. Just as you can search and filter Template descriptions, you 
can search and filter history notes in the same manner. For more information about filtering, see the 
“Filtering” section on page 1-12. 

You can manage Template history details by using the following procedures:

• Adding History Note Details

• Displaying History Note Details

Adding History Note Details
To add history note details, perform the following steps:

1. On the Active System Manager toolbar, click Window > Show View > Templates.

2. In the Templates view, right-click the Template and select Open.
8-12 Active System Manager User Guide, Release 7.0



Working with Templates
3. In the Template editor, right-click and select Add History.

The History Note dialog box displays.

4. Type a description and click OK.

Note You can add and modify history notes; but, you cannot delete prior history notes.

Displaying History Note Details
To display history note details, perform the following steps:

1. On the Active System Manager toolbar, click Window > Show View > Templates.

2. In the Templates view, right-click the Template and select Open.

3. On the Active System Manager toolbar, click Window > Show View > Other > General > Properties 
> OK.

4. In the Properties view, click the History tab to display the following properties:

• Date—Displays the date when the note was created.

• Author—Can be the Template owner or any administrator.

• Notes—The Template history information you enter; see the “Adding History Note Details” section 
above for more information.

Note Template history details can be carried over from one Template to another when saving the 
Template (see the “Saving Templates” section on page 8-8) or saving a session.

Filtering Templates
You can use the Templates Filter dialog box to filter Templates and associated sessions by date range. This 
option is particularly useful if you want to filter out older sessions. The Templates Filter dialog box also 
includes “Template Imported Time” as part of the filter property list.

Validating Templates
Note For each Template, a validation is required. If a Template is not validated, it does not get scheduled 

and, therefore, does not get realized.

By default, the Template editor is valid or invalid. The term, valid, indicates that the Template is ready to 
be scheduled; invalid indicates that some of the Template objects are invalid. Invalid Templates are flagged 
with red labels and icons. For more information, switch to the link editor (the “Switching to the Link 
Editor” section on page 8-45) and move your cursor over the Template to read the explanations for why the 
Template is invalid. Figure 8-5 displays an example of an invalid Template because of missing interfaces 
and links.
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Figure 8-5 Invalid Template Example

The following list outlines the reasons why a Template is invalid:

• Missing resource types

• Missing resource instances

• Missing interfaces

• Links with incompatible interface types

• One or both of the link endpoints are missing

Note After performing the previously indicated Template checks, the Active System Manager application 
verifies that the Template is schedulable. If a Template is not schedulable, an error message 
displays.

You can validate Templates on demand and automatically, as described in the following subsections:

• Validating Templates Automatically

• Validating Templates On Demand

Note The Active System Manager server validates the Template content during Template save and import 
operations. 

Validating Templates Automatically
The Active System Manager client validates the Template when you open a Template and indicate the 
invalid resources with red icons. To automatically validate a Template, open the Template you want to 
validate. To validate more than one Template, right-click and select the Templates.
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Validating Templates On Demand

Note You can only perform this process on one Template editor at a time.

To validate a Template on demand, perform the following steps:

1. Open a Template; see the “Opening Templates” section on page 8-11.

2. In the Template editor, right-click and select Validate. 

Importing Templates
The import feature allows you to either import the Templates individually or to import Templates with 
Orchestrations. For more information on Orchestration, see Chapter 10, “Orchestration Management.”

To import a Template or Templates with Orchestrations, perform the following steps:

1. Select a method to open the Import Templates dialog box; see Figure 8-6.

• On the Active System Manager menu bar, click File > Import > Active System Manager > 
Templates > Next.

• In the Templates view, right-click and select Import.

Figure 8-6 Import Templates
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2. You can either Import Templates with Orchestrations or Import Templates only:

a. Import Templates with Orchestrations Section

• In the Select root directory, browse to perform a smart search that displays all Templates found 
in the default directory in Templates section. 

• In the Select Orchestration jar, select a Template with Orchestrations from your file system. 

• Select the Select root directory.

Note You can perform this step with a valid directory.

Note The Active System Manager software saves the last directory browsed.

b. Import Templates only

• In the Select root directory, browse to perform a smart search that displays all Templates found 
in the default directory, in Templates section.

• In the archive file, select a Template file from your file system.

3. Click Select All to select all the Templates that display or click Refresh to restart your selection 
process.

4. Click Finish to open the imported Templates into the Template editors (one per Template). 

Once imported, one editor per Template opens with the content of the Template displayed.

5. Click File > Save to save the Template, or update it first, then save. 

Exporting Templates
To export a Template, perform the following steps:

1. Select a method to open the Export Templates dialog box (see Figure 8-7):

• On the Active System Manager menu bar, click File > Export > expand the Active System 
Manager folder and click Templates > Next.

• In the Templates view, right-click and select Export.
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Figure 8-7 Export Templates

2. Select at least one Template to export or click Select All to select all of the Templates displayed. 

3. In the To directory field, type a location to export to, or click Browse to select a directory location for 
your exported Templates. If a directory is already noted, skip this step and go to step 5. 

Note The Active System Manager software remembers the last directory you visited.

Note You can only perform this step with a valid directory.

4. Check Export Orchestrations as well (if any) check box, if you want to export Orchestrations with 
the Template

5. Click Finish to generate, export, and save the selected Templates to your desktop. 

Attaching a Template Image
You can associate a picture rendering of your Template to make it visible in the Template report, or you can 
attach a custom rendering. The default rendering is an image of your Template in .jpeg format. 

For details, see the following sub-sections:

• Attaching a Template Image from a Screenshot

• Attaching a Custom Rendering (Template) from a File
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Attaching a Template Image from a Screenshot
To attach a Template image from a screenshot, perform the following steps:

1. Open a Template; see the “Opening Templates” section on page 8-11.

2. In the Template editor, click the background, right-click and select Attach Default Rendering > 
Screenshot (the default).

3. Click the Properties tab > Attachments to verify that the Template.jpeg attachment has been added.

The attachments are used for reporting purposes.

Attaching a Custom Rendering (Template) from a File
To attach a custom rendering, perform the following steps:

1. Open a Template; see the “Opening Templates” section on page 8-11.

2. In the Template editor, click the background, right-click and select Attach Default Rendering > File.

The Select image for Template rendering dialog box displays.

3. Navigate to the file location where your image resides and click Open.

Scheduling Templates
You can reserve equipment from a predefined Template and schedule it. Scheduling a Template allows you 
to invoke the session scheduler.

To schedule a Template, perform the following steps:

1. Select a method to schedule a Template:

• In the Templates view, right-click a Template and select Schedule.

• On the Active System Manager menu bar, click File > New > Session.

• On the Active System Manager menu bar, click File > New > Other > expand the Active System 
Manager folder and click Session.

• On the Active System Manager toolbar, click the New icon > click Other > expand the Active 
System Manager folder and click Session.

• From a Template editor, right-click the Template editor background and select Schedule.

The Scheduling Template dialog box displays as a tree view representation of the Templates, which 
allows for sorting, filtering, and facilitating Template searches; see Figure 8-8.
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Figure 8-8 Scheduling Session

2. In the Template Selection section, select a Template, if not done already.

3. Click the Behavior field and select a behavior; see Table 8-3 for the scheduling preferences.

Table 8-3 Behavior Scheduling Preferences

Behavior Definition

As Soon As Possible 
(ASAP)

Scheduler attempts to find the first available time slot where all resources are available for 
the proposed duration.

ASAP within fixed time 
frame

Scheduler attempts to find the first available time slot where all resources are available 
within the proposed start and end time and specified duration.

Fixed start and end 
date

Scheduler attempts to find available resources within those date constraints.

Group-based Scheduler books more than one session for the same start and end time. You can indicate 
number of sessions required.

Recurring Session Scheduler allocates resources for a weekly or daily recurring time frame. The black period 
can also be identified. (See note below.)

Permanent Scheduler attempts to infinitively find and allocate resources starting from a specified date.
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Based on the first four behaviors selected, the date and time options modify automatically.

If the Recurring Session behavior is selected, users can define scheduling recurrence properties in the 
next wizard page: 

• Recurrence Pattern (Daily, Weekly, Occurs after every <number of> Days)

• Time Options (Start <date> and Duration <hours>)

• Number of Occurrences (Start <date>, No End Date, End After <a number of> Occurrences, End 
by <date>)

• Blackout Dates (Start and End Dates)

Once the wizard is complete, the sessions are scheduled independently of each other with their own life 
cycle.

Note Group-based sessions are identified by a common group ID, and can be edited and 
cancelled either individually, or operations can be done at the session or group level.

4. Based on your preferences, you can adjust the Scheduler session and security properties. See the 
Preferences—Scheduler page for advanced scheduler options (click Window > Preferences > 
Scheduler > Advanced Scheduling).

The Advanced wizard page allows to change the following:

• Ownership

• Participants (users and groups)

• Scheduler options

• Priority scheduling

Most of these settings are inherited from the user preferences. 

Note Only the administrator and the existing owner can change the ownership; otherwise, 
this field is read-only.

5. Click Next to display all provisioning properties that are available (or editable) at all levels 
(provisioning properties for Template, resources, interfaces (ports), and links).

6. Click Next.
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Note You can adjust the scheduling behavior based on user preferences. See the Preferences—Scheduler 
page for scheduler options (click Window > Preferences > Scheduler). The Scheduler can 
automatically perform extra scheduling when no solutions are reported, including identify 
preemption or running ASAP Scheduling.

The scheduler has identified a set of solutions. 

If no solutions are reported, the wizard displays an error page with a high-level error message and a 
complete set of logs. Click Back to change your setting request.

Solutions should appear; however, if not, the Scheduler logs are displayed. The number of causes may 
result in the Active System Manager software being unable to find any suitable times to schedule your 
session. For example, the resources in your Template may not be available during the time window you 
requested, or the time window you entered may be too short for the time slot length that you requested. 

One of the following, possible responses are available at this time:

• If the request can be satisfied, you see a list of session time options.

• If a non-preemptive request cannot be satisfied, you will be prompted. 

If other sessions conflict with a preemptive request, a list of possible sessions display using resources 
already assigned to other sessions.
If no solutions are found, tentative time slots display and are marked with the Caution icon, instead of 
the Solution icon. 

7. Select a solution and then click Next to identify those blocking sessions. 

This wizard page displays resource allocation conflicts at both resource and interface level. You can 
remove conflicts to proceed with scheduling.

Caution   Removing conflicts will update your Template content, and will not affect your confirmed and 
running sessions by deactivating resources.

8. At scheduling time, you can add, remove, or edit session-based properties:

• To add session-based properties, click Add > Custom or Add > Provisioning.

• To edit session-based properties, click a Custom or Provisioning property and type (edit) the 
property name or value.

• To remove session-based properties, select a Custom or Provisioning property and click Remove.

9. On the Scheduling Sessions—Solutions dialog box, select a scheduling solution.

10. Optional. Click the Session Name and modify the given name.

11. Click Next to go to the allocated resource information, or click Finish to create the session. 

The top part displays the allocated resource instances selected by the Scheduler, including interfaces. If 
you click the Identify Preemption Opportunities check box, the bottom part can list sessions that 
should be canceled in order to schedule this session.

12. Click Next.

The next wizard page displays the option to associate remote scripts and test cases with the session. By 
default, the No Association option is selected. For more information about script association, see the 
“Managing Session Links” section on page 9-26.
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13. Click Finish to confirm your session. 

A prompt displays, confirming your scheduled session. The prompt asks if you would like to switch to 
the Sessions perspective to view your sessions. 

14. Click the Remember my decision check box to allow the software to always switch to the Session 
Perspective view after scheduling all future sessions.

Note This message displays if you are not in the Sessions perspective. If you have clicked 
the check box, the message does not appear on subsequent session scheduling.

15. Click Yes to automatically switch to the Sessions perspective, or click No to remain in your current 
perspective.

Your newly created session will display in the Sessions view. For more information about the Sessions 
view, see Chapter 9, “Session Management.”

Archiving Templates Using the Templates View
Typically you may want to archive older Templates, depending on the archive rules defined by your Active 
System Manager administrator. 

Note You retain the ability to search such Templates within the Archive Bin.

To archive Templates using the Templates view, perform the following steps:

1. Open the Templates view: on the Active System Manager menu bar, click Window > Show View > 
Templates > OK. 

2. In the Templates view, right-click a Template, and select Move to Archive Bin. 

When the Confirm Archiving Operation dialog box displays, click OK.

Restoring Archived Templates
You can restore Templates previously archived to the Template Archive Bin. To restore a Template to your 
Active System Manager workbench, perform the following steps:

1. Open the Template Archive Bin view: on the Active System Manager menu bar, click Window > Show 
View > Other > Active System Manager > Template Archive Bin > OK.

2. Select the associated Template and perform one of the following options:

• Drag it to the desired location in the Templates view.

• Right-click in the view and select Restore. When prompted to confirm the Restore operation, click 
OK.
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Updating Templates Using the Template Editor
Once you have created a blank Template, define the network configuration that you want to manage or test 
by adding elements, such as resource types, resource instances, interfaces, properties, and connectivity. For 
more details, see the following topics:

• Viewing and Modifying Template Properties

• Adding Resource Types

• Setting Resource Type Properties for Scheduling

• Deleting Resource Types

• Adding Resource Instances

• Deleting Resource Instances

• Modifying Resource Properties

• Defining Provisioning Policies

• Supporting Layer 2 Switching

• Using Annotations

Viewing and Modifying Template Properties
You can modify a variety of Template properties, including:

• Template-level properties for a specific Template

• Resource type-level and resource instance-level properties for the selected resource

• Interface-level properties for the selected interface

• Link properties for the selected link

To view the Template properties, select the Template in the editor background. Properties are typically 
displayed when you first add an element type. You can display properties and later modify them. 

Note If any properties are marked as Required by the administrator, the property value must be entered 
before saving and scheduling the Template.
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Figure 8-9 Template-Level Properties View

Table 8-4 lists and defines the Template-level properties.

Table 8-4 Template-Level Properties 

Tab Name Category Property Description Value

Template Custom Contains a set of custom and system Template-level 
property names and values. 
Note: A default set of properties may be available based on 
your Active System Manager deployment configuration.
You can add or remove the custom Template-level 
properties. The Open function is intended to use for opening 
URLs or links. It launches a new browser window.
To add a custom Template property (that must be 
overwritten) with a editable value, click Add.
To remove a custom Template property, select a row and 
click Remove.
Note: All of the Add and Remove functions must be saved 
to save those property changes (click File > Save).
Note: These custom properties can now be used in the 
Template view for grouping, filtering, and searching.

Template System Archive Mode that defines whether the archive is public or private. User-defined

Template System Created On Date created Template. User-defined

Template System Description Template description. User-defined

Template System Name Template name. User-defined

Template System Owner Template owner name. Login username

Template System Participants Template participants User-defined
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Provisioning Custom <custom names> Contains a set of custom and system Template-level 
property names and values. You can add or remove the 
custom Template-level properties. The Sequencing function 
allows you to move the properties in a specific order. 
To add a custom Template property (that must be 
overwritten) with a editable value, click Add. You can set 
scheduling permissions on each custom provisioning 
property. The permissions allows end users, at scheduling 
time, to display or edit those property values.
The permissions are:
• Allow to Edit—The property will be editable at scheduling 

time.
• Allow to Show—The property displays at scheduling time.
• Hide—The property is not displayed at scheduling time.

To remove a custom Template property, select a row and 
click Remove.
Note: All of the Add, Remove or Sequencing functions 
must be saved to save those property changes (click File > 
Save). For more information about sequencing functions, 
see the “Updating the Policy Sequencing” section on 
page 8-37.
Note: These custom properties can now be used in the 
Template view for grouping, filtering, and searching.

<custom values>

Provisioning Policy Setup Invoked during the session setup phase.

Provisioning Policy Snapshot Invoked during the session Save or Save as.

Provisioning Policy Teardown Invoked during the teardown setup phase.

Provisioning System Cleanup Time 
(Min.)

Time added at the end of the session. 
By default, the cleanup time for a Template is computed 
based on parameters specified in the resource type for each 
of the resources in the Template (i.e., the maximum time 
required for any resource in the Template).
The Cleanup Time property creates additional cleanup time 
for a Template. The number of minutes that you enter here is 
added to the normally computed setup or teardown time for 
the Template.

Specified in 
minutes. The 
default value is 0. 
The value must be 
in whole numbers.

Provisioning System Execute All Scripts Option to execute all scripts (when check box is selected). By default, all setup 
and teardown 
resource-level 
scripts do not 
execute.

Provisioning System Setup Script Script file to run before a session becomes active.
By default, no Template-level setup script is used; instead, 
the resource-level scripts are executed.
If the Template-level scripts are specified, the resource-level 
scripts are not executed. The Template-level scripts provide 
any needed functionality that would normally be handled by 
the resource-level scripts.

Located on the 
Active System 
Manager server.

Table 8-4 Template-Level Properties (continued)

Tab Name Category Property Description Value
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Adding Resource Types
To add a resource type to your Template, open the Resource Types view, select the resource type, and drag 
to drop it in your working Template.

Note If you add resource types to your Template by dragging and dropping them in the Template editor, 
you must drag and drop the resources individually, one at a time. 

On dragging and dropping the resource types in the working Template, the properties of that particular 
resource type appear in the Properties panel. You can update the values of property parameters in the 
Properties panel.

Note In case of Provisioning property, the Provisioning parameters are loaded in the panel from the CSV 
file, where these parameters are pre-defined in the form of input field definitions. For more 
information, refer the the “Adding Provisioning Parameters Using CSV” section on page 8-29.

The Outline and Properties views update to reflect what displays in your Template editor. When you click 
a resource type on the Template editor, a different set of properties values display in the Properties view (in 
table form) and the Outline view (in tabular form).

Provisioning System Setup Time (Min.) Time spent before a session becomes active.
By default, the setup time for a Template is computed based 
on parameters specified in the SDT for each of the 
resources in the Template (i.e., the maximum time required 
for any resource in the Template).
The SetUp Time property allows you to create additional 
setup time for a Template. The number of minutes you enter 
is added to the normally computed setup time for the 
Template.

Specified in 
minutes. The 
default value is 0. 
The value must be 
in whole numbers.

Provisioning System Teardown Script Script file to run at the end of a session.
By default, no Template-level setup script is used; instead, 
the resource-level scripts are executed.
If the Template-level scripts are specified, the resource-level 
scripts are not executed. The Template-level scripts provide 
any needed functionality that would normally be handled by 
the resource-level scripts.

Located on the 
Active System 
Manager server.

Attachments Name
Description

You can add or remove attachments. To add a file 
attachment, click Add, select a file from your file system, 
click Open, and the file attachment is added.
To open the file attachment, select one and click Open.
To remove a file attachment, select a file attachment and 
click Remove.

History Date
Author
Notes

Lists all history. For more information, see the “Managing 
Template History Details” section on page 8-12.

Note The Active System Manager server can be preconfigured with a default set of custom 
Template-level properties and default values for all sessions created in the system. For information 
on how to set your default template (support for unit, list of default values, IsEditable attribute 
definition).

Table 8-4 Template-Level Properties (continued)

Tab Name Category Property Description Value
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Note When dragging a virtual resource type (i.e., a resource type with the role set to virtual), you can 
request more than one resource for the same type by setting the Virtual Object Count resource type 
property (in the Properties view). 

The multiple resource types, as a single icon, are represented with two concentric circles.

Table 8-5 lists and defines the default properties for the resource types selected. 

Table 8-5 Default Properties for the Resource Types View 

Tab Name
Property 
Name Description

Resource List of all resource type information related to this Template. You can use this tab for a high-level 
view of information for the selected element.

Name • Template—Resource Template name of the Template resource. This name is automatically 
assigned by the Templates perspective.

• Inventory—Resource name, as specified in the inventory resource instance editor. 

Exclusive 
Resource

For the Managed Equipment role only. Option that determines whether the resource is exclusive or 
not. If a resource is sharable, some of its interfaces can be assigned to one session while others are 
used in other sessions. If your requirements include exclusive access to a resource, you can prevent 
it from being shared by turning on the “Exclusive” property in this Template. Any session based on 
the Template reserves the entire resource and prevent others from sharing it. This property forces 
the Active System Manager scheduler to find a resource that can be allocated in its entirety (i.e., all 
ports) during the life of your session. Thus, even if you request only a subset of the ports in the 
resource, the scheduler does not give any part of the resource a way to a new requirement for the 
same time period. The ports not being used during the requirement can still be used during the 
session realization because the resource is virtually owned by the session owner and participants.
Note: If you do not specify Exclusive for a sharable resource, then by default, others are allowed to 
use it concurrently.

Manufacturer Manufacturer name of the resource. Used for reference only; cannot be edited.

Model Model name of resource. Used for reference only; cannot be edited.

Description Description of the resource type.

Virtual Object 
Count

For the virtual resource types role only. Allows you to set the number of virtual resources to be 
created at realization time.

Provisioning Name
Value
Scheduling 
Permission

List of all provisioning parameters that can be overwritten from their default value.
The Type value is only string.
To add a custom Template property (that must be overwritten) with a editable value, click Add. You 
can set scheduling permissions on each custom provisioning property. The permissions allows end 
users, at scheduling time, to display or edit those property values.
The permissions are:
• Allow to Edit—The property will be editable at scheduling time.
• Allow to Show—The property displays at scheduling time.
• Hide—The property is not displayed at scheduling time.

Note: You must save the changes.

Inventory List of all scheduling properties that you can edit to request specific resource instances from the 
scheduler.
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• Custom
• System

• Custom properties—Inventory parameters that are defined in the Inventory perspective for a 
resource type. 

• System properties—Types of system properties, such as card type, that are pre-defined in the 
Active System Manager software. These properties are built in and are common to all resource 
types.

You can specify the property values for a resource, or for an interface. System properties at the 
resource level are:
• assettag
• domain
Specifying an resource’s asset tag by property value is a different than authoring a complete 
resource instance. In either case, you can access the resource with the named tag, but the 
assignment of ports is handled differently.
Properties are entered in the form of a conditional expression:
<Property name><Operator><Value>

where:
• Property name is the name of the property whose value is to be checked. This can be one of the 

system properties listed above, or a custom property defined in the resource type.
• Operator can be either the “IS” or “IS NOT” or “IN” or “NOT IN” mathematical symbols.
• Value is a string whose value is to be matched. The string is not case-sensitive. Both the property 

value and the string you enter is translated to lower-case before the comparison is performed.

More than one property can be specified for a resource or interface. The conditional expressions for 
the properties are logically AND-ed. That is, all specified properties must match the values that you 
entered for that resource or interface. 

This applies to all elements of a resource being considered by the scheduler. That is, all conditions 
specified for the resource must match, and all conditions specified for each interface required by the 
Template must match. Any property name can only be used once for a particular resource or 
interface. 
For example, you can not enter both “Author Name = John Doe” and “Author Name = John Smith” 
for a resource. This is the equivalent of a logical OR operation on the conditional expressions, and is 
not permitted.

Configuration 
Files
Image Files

Used if you want to provision the resource. Each tab allows you to select files from the newly created 
repositories; for more information about repositories, see Chapter 7, “Repository Management.”
The following menu options are available on each tab:
• Add—Before you type the filename, you can add an image file or configuration by clicking Add in 

the Properties view. A list of preassociated files are listed. You must then select from that list of 
files. If the list is empty, then file associations must be made in the repository definition. In all 
cases, the repository must be created and elements must be discovered, imported, and associated 
with a resource type.
Note: You can click the Show All Image Files check box while selecting an image file. This action 
displays all image files provisioned in the Active System Manager system (both associated and 
non-associated).

• Remove—Removes the file from the resource type for this Template.
• Open—Opens and modifies the configuration files while adding it into the Template.
• Up and Down—If you have, at least, two files, you can rearrange the order in which the files will be 

applied on the resource by the Active System Manager software.
For more information about repositories, see Chapter 7, “Repository Management.” 
For information about setting up provisioning parameters, see Chapter 6, “Using Inventory.”

Name Filename derived from the repository.

Path Path derived from the repository.

Repository Repository name assigned or selected.

Table 8-5 Default Properties for the Resource Types View (continued)

Tab Name
Property 
Name Description
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Adding Provisioning Parameters Using CSV
The Active System Manager software allows you to drag and drop resources in Template editor. Along with 
the resource types, the properties of each resource type are also loaded in the Properties panel of the 
Template editor; see Figure 8-10.

Figure 8-10 Properties Panel

In the Properties panel, the Provisioning parameters of dragged and dropped resources are loaded from the 
CSV file, called “provisioning_attributes.csv”, These parameters exist in the form of input field definitions 
in the CSV. The Active System Manager administrator inputs these provisioning parameters according to 
the rules set for the CSV field definitions into the Active System Manager software.

Note In case you open the existing template, the missing Provisioning parameters of resource types 
contained therein, are uploaded in the Properties panel from the CSV file.

The Provisioning parameters display in a tree structure in the Properties panel, as grouped in the CSV file; 
see 

Note The Provisioning parameters in the CSV file are grouped on the basis of the key parameter.

Figure 8-10.
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Table 8-6 describes the Provisioning parameters input fields defined in the CSV file.
Table 8-6 Provisioning Parameters in a CSV File

Provisioning 
Parameters Description

key Represents the name of the parent parameter for child parameters. Key is Null for root 
level parameters.

Name Represents attribute name.

datatype Represents attribute type: String (Default type), numeric, date, password.

ismandatory Represents if the attribute is mandatory or not. Possible values are Yes or No. Default 
value is No

valuelist Represents associated value list. The values is delimited by the vertical bar (|); for 
example, value1 | value2. 

iseditable Represents whether the value of the attribute can be changed or not in the user 
interface. Possible values are Yes or No (default value).

default value Represents the default value of the attribute. If attribute is marked as mandatory

scope Represents the scope of attribute association with the inventory elements. Possible 
value is manufacturer.

manufacturer Represents the name of the resource manufacturer to which the attribute is related. 

model Represents the name of the resource model to which the attribute is related.

The example CSV file below represents the Provisioning parameters as defined in the CSV file; see 
Figure 8-11.

Figure 8-11 CSV File Example - Provisioning Parameters
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Setting Resource Type Properties for Scheduling
Property-based scheduling is a standard capability of the Active System Manager scheduler. It applies only 
to the scheduler’s selection of resource types. If you author a resource instance, then there is no scheduler 
selection available. When you create a session, the Active System Manager scheduler checks the 
availability of resources required by the Template at the specified time and reserves them. If a resource 
instance is required, then only that particular resource is reserved for that element in the Template, and is 
used when realizing the Template. If a resource type is required, then the scheduler looks for any resource 
of that type having the minimum required interfaces available. In addition, the scheduler verifies that other 
properties match the values that you specified for the resource and its interface. This is called 
property-based scheduling. 

To set resource type properties for scheduling, perform the following steps:

1. In your Template, select a resource type and click the Inventory tab.

2. Set the preferred or required property check box status. 

A property for scheduling can be treated in two different ways:

• By default, properties are “Preferred”; that is resources or interfaces that match this property-value 
condition are the first choice. The Active System Manager scheduler attempts to find a solution that 
fulfills all of the requirements in the Template, including matches for the preferred properties. If the 
preferred properties are not found, the scheduler seeks solutions that are not restricted to the 
specified properties.

• Clicking the Required check box means that only resources or interfaces that match this 
property-value condition can be used. If an exact match cannot be found, any attempts to schedule 
a session based on this Template fails. In the property list, if a check box is selected next to a 
property, this indicates that the property is “Required”. 

3. Click the Operator column field and select an operator. The list of operators depends on the property 
type. 

4. Click the Value column field for the associated property and enter a value. When the light bulb displays, 
it means that control assistance is enabled. Press Ctrl+spacebar to search and display all possible 
values for that property; see Figure 8-12.
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Figure 8-12 Inventory Properties—Resource Level

5. Repeat step 1 to step 4 for each resource type.

Deleting Resource Types
In the Template editor, to remove the resource type from the Template (and not from the inventory), click 
the resource type, right-click, and select Delete.

Note If there is any connectivity in the Template with other resource types or resource instances, the links 
attached to the resource type (or resource instance) that you select will also be deleted. 

Adding Resource Types Based on Manufacturer Only
To add a resource type to your Template based on manufacturer only, perform the following steps:

1. Open or create a new Template.

2. Open the Components view and locate the Generic > Generic component.

3. Drag the Generic > Generic component to the Template editor to display the Select Manufacturer 
dialog box; see Figure 8-13.

Figure 8-13 Select Manufacturer
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4. Select a manufacturer from the existing list and click OK.

5. Right-click the component and select Add Interfaces to display the Add Interface dialog box; 
Figure 8-14.

Figure 8-14 Add Interface

6. Select the interface type and specify the count. To display all interface types, click the Show All 
Interface Types check box. 

7. Click OK.

Note To update the properties for the resource and its interfaces, see Figure 8-5 for definitions.

Adding Resource Instances
To add a resource instance to your Template, select a method to locate a resource instance to drop in your 
working Template:

• Click the Resource Instances view, on the Active System Manager toolbar, click the Search field, enter 
the resource’s name or asset tag, and click the Search icon.

• Click the Search icon to locate a resource instance.

Note If you add resource instances to your Template by dragging and dropping them on to the Template 
editor, you must drag and drop the resources individually, one at a time.

Note Only managed resource instances can be added in a Template. You can set your filter in the Resource 
Instances view accordingly. For filtering details, see the “Filtering” section on page 1-12.

The Resource Instances view displays all types of resource instances, but you are only allowed to author 
the managed resources. The Outline and Properties views update to reflect what displays in your 
Template editor. When you click a resource instance on the Template editor, a different set of properties 
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values display in the Properties view (displayed in table form). The Outline view (displayed in tabular 
form) does not update automatically with the specific resource selection; it only displays the selection 
corresponding to the resource in the Template editor.

Table 8-7 lists and defines the default properties when authoring resource instances. 

Table 8-7 Default Properties for the Resource Instances View 

Tab Name Property Name Description

Resource List of all resource instance information related to this Template. You can 
use this tab for a high-level view of information for the selected element.

Name in Template Name of the Template resource. This name is automatically assigned by 
the Templates perspective. You can change this name in the Properties 
view of the resource in the Template editor.

Name in Inventory Name of the resource in the inventory.

Exclusive Resource Option that determines whether the resource is exclusive or not. If a 
resource is sharable, some of its interfaces can be assigned to one session 
while others are used in other sessions. If your requirements include 
exclusive access to a resource, you can prevent it from being shared by 
turning on the “Exclusive” property in this Template. Any session based on 
the Template reserves the entire resource and prevent others from sharing 
it. This property forces the Active System Manager scheduler to find a 
resource that can be allocated in its entirety (i.e., all ports) during the life of 
your session. Thus, even if you request only a subset of the ports in the 
resource, the scheduler does not give any part of the resource a way to a 
new 

Exclusive Resource requirement for the same time period. The ports not being used during the 
requirement can still be used during the session realization because the 
resource is virtually owned by the session owner and participants.
Note: If you do not specify “Exclusive” for a sharable resource, then by 
default, others are allowed to use it concurrently.

Asset Tag Unique identifier assigned to each managed element of inventory.

Version Version associated with the current hardware configuration.

Manufacturer Manufacturer resource name. Used for reference only; cannot be edited.

Model Model resource name. Used for reference only; cannot be edited.

Description Description of the resource instance.

Domain Name of the domain.

Provisioning <custom or 
user-defined>

List of all provisioning parameters that can be overwritten from their default 
value.
The Type value is only string.
Use the Add or Remove buttons to manage your provisioning properties. 
To add a custom Template property (that must be overwritten) with a 
editable value, click Add. You can set scheduling permissions on each 
custom provisioning property. The permissions allows end users, at 
scheduling time, to display or edit those property values.
The permissions are:
• Allow to Edit—The property will be editable at scheduling time.
• Allow to Show—The property displays at scheduling time.
• Hide—The property is not displayed at scheduling time.

Note: You must save the changes.
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Modifying Resource Properties
Resource properties first appear when you add a resource (type or instance) to the Template by dragging it 
from the navigation tree. You can access the resource properties by clicking the resource. To modify 
resource properties, you must access and work within the resource Properties view. 

From this view, you can modify the editable properties listed on the Resource, Provisioning, Inventory, 
Configuration Files, and Image Files tabs. 

Deleting Resource Instances
To remove the resource instance from the Template (and not from the inventory), in the Template editor, 
right-click the resource instance and select Delete. 

Note If there is any connectivity in the Template with other resource types or resource instances, the links 
attached to the resource type (or resource instance) that you select will also be deleted. 

Configuration 
Files
Image Files

Used if you want to provision the resource. Each tab allows you to select 
files from the newly created repositories; for more information about 
repositories, see Chapter 7, “Repository Management.”
The following menu options are available on each tab:
• Add—Before you type the filename, you can add an image file or 

configuration by clicking Add in the Properties view. A list of 
preassociated files are listed. You must then select from that list of files. If 
the list is empty, then file associations must be made in the repository 
definition. In all cases, the repository must be created and elements must 
be discovered, imported, and associated with a resource instance.

• Remove—Removes the file from the resource type for this Template.

Configuration 
Files
Image Files

• Open—Opens and modifies the configuration files while adding it into the 
Template.

• Up and Down—If you have, at least, two files, you can rearrange the 
order in which the files will be applied on the resource by the Active 
System Manager software.

• Versions—Applies for source control repositories. Specific versions of 
files can be selected; otherwise, the latest files will be used.

For information about repositories, see Chapter 7, “Repository 
Management.” 
To set up provisioning parameters, see Chapter 6, “Using Inventory.”

Name Filename derived from the repository.

Path Path derived from the repository.

Repository Repository name assigned or selected.

Version Applies only for source control software-base repository.

Tag Applies only for source control software-base repository [CVS only].

Table 8-7 Default Properties for the Resource Instances View (continued)

Tab Name Property Name Description
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Defining Provisioning Policies
In order to have a fine-grained control over provisioning policies for all three main phases of the session 
life cycle (Setup, Teardown, and Snapshot operations), end users have the ability to define and change 
the sequencing of operations for each resource available in the Template. If provisioning policies are not 
overwritten, the Active System Manager system will execute its default policy. Policy changes are saved 
with the Template content.

Changing the Default Policy Associated with a Template
To change the default policy associated with your Template, open the Specify Provisioning Policies 
window by one of the following methods:

• In the Template editor, right-click and select Set Policies.

• From the Template property > Provisioning tab, click Sequencing.

The Provisioning Sequencing window displays and lists the default policies, along with all resources and 
resource types available in the Template. There is only one set of provisioning policies per Template that 
can be define.

Figure 8-15 Specify Provisioning Policies (1)

Policies that can be overwritten are: 

• Setup—Invoked during the session setup phase

• Snapshot—Invoked during the session Save or Save as

• Teardown—Invoked during the teardown setup phase

Template owners, users with update permissions on the Template and administrators, can define different 
sequences on each policy.
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Updating the Policy Sequencing
To update the policy sequencing, perform the following steps:

1. Select the policy impacted, and drag one or more resources or resource types in to the sequencing box.

A new sequence is automatically created (such as sequence1). You can add or remove resources or 
resource types at will by either dragging back resources, or inserting new sequencing directly in the 
sequencing box (right-click while operating elements).

2. Repeat step 1 for other policies (1 and 2).

Figure 8-16 Right-Click Menu Options

3. Click Reset to Default (see Figure 8-15) to re-apply the default policy (not the one saved).

4. Use the Filter text box to automatically filter out the resource or resource type list. 
This is helpful when you need to search for a specific resource in your sequencing.

Note The timer cannot be defined between each sequence. Sequencing simply allows the policy 
execution to happen in a sequential manner, as opposed to a parallel execution. Users do not have 
any control on the results of those operations—all are executed independently of the prior sequence. 
All operations are saved in the Session Audit report. 

5. Click OK to save the changes, and then click File > Save to save the Template definition.

Quick Policy Status Check
To verify the policy status, perform the following steps:

1. Open the Template—Properties view and navigate to the Provisioning tab.

The policy group displays for each policy if the policy is set to Default or Defined (Figure 8-17). 

2. Click Sequencing to update if necessary.
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Figure 8-17 Provisioning Policy Status

Supporting Layer 2 Switching 
Contrary to Layer 1 switch management where Layer 1 switches are entered in the inventory as 
control-based resources and underlying physical connectivity must also be pre-defined, Layer 2 switching 
requires inventory. At least one Layer 2 switch must be defined in your inventory with the Matrix Switch 
role that supports the VLAN option (enabled; see Figure 8-18) and optional VLAN IDs (in custom 
inventory properties).

Figure 8-18 Supports VLAN Option Check Box

For more information about supporting Layer 2 switching, see the following subsections:

• Setting Up Layer 2 Switching

• Defining Templates with VLAN

Setting Up Layer 2 Switching 
To set up your Layer 2 switching, perform the following steps:

1. Open your Resource Instances view, select a resource instance of role Matrix Switch. Use filters to 
search for such resource instances; for more information about filtering, see the “Filtering” section on 
page 1-12.

2. Ensure that you have a resource instance with the Supports L2 Switching check box enabled. 

The Supports VLAN check box is located in the resource instance editor. It is only available when the 
role is set to Matrix Switch. 

The values for the matrix switch can be defined in three different formats:

• Individual Value—For example: (10,11,12,15,17).

• Value Range—For example: (10..15), (25..34).

• Group Value Range—For example: {gp1}(10..20), {gp2}(21..30), {gp1}(31..40).
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3. In the resource instance editor, in the Inventory Parameters section, set the values for the supported 
VLAN ID.

Note The Supported VLAN ID property cannot be removed.

The following three options are available for the user to specify VLAN IDs:

• Auto—If the user does not provide any VLAN ID, then the scheduler automatically assigns a 
VLAN ID to the VLAN component. The value is assigned randomly from the value range defined 
for a specific matrix switch.

• Count—If the user provides a specific count; for example: 4, the scheduler assigns any 4 VLAN 
IDs to the VLAN component. These values are assigned randomly by the scheduler from the value 
range defined for a specific matrix switch; for example (3,2,1,7).

• Range—Apart from setting individual values, such as (15,16,17) for supported VLAN ID, the user 
can provide value range to VLAN IDs, such as (10..19), (20..28).

Note You can create groups for assigning value ranges and provide relevant names to 
groups to facilitate users in mapping their VLAN ID requirements by looking at the 
group names. This helps the users in selecting relevant VLAN IDs to serve their 
purpose rather than selecting random VLAN IDs. 

4. Double-click the Value field to display the Specify VLAN ID Range dialog box

5. Click Add to display the Add Pattern dialog box.

The pattern format is either a single value (n),or a value range (n..m), or a value range within a group 
{gp1}(n..m), where n and m are numerals and n is less than m.

6. Click OK to accept and generate all VLAN IDs associated with your pattern. 

Note Without one resource set, at least, in your inventory, the Template does not work, because the 
Scheduler expects this component in the Template.

Defining Templates with VLAN
To define Templates with VLAN, you must add a VLAN component into your Template. To do so, perform 
the following steps:

1. On the Active System Manager menu bar, click Window > Show View > Components to display the 
Components view.

2. In the Components view, select the VLAN component and drag it into the Template editor. By default, 
the Components view does not have an editor; you can only drag it into the Template editor.

3. Create a link for each resource that must be added into the VLAN from the resource to the VLAN 
component endpoint.
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Figure 8-19 Enabling VLAN in Template

4. Switch to the Link editor; see Figure 8-20.

Figure 8-20 Link Editor VLAN Display

5. Set the VLAN ID either implicitly (the default behavior) or explicitly (user-defined).

a. In the Template editor or link editor, select the VLAN component.

b. In the Properties view, perform the following actions:

• Provisioning—Click the Provisioning tab and set the values of the following Provisioning 
properties:
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VLANCount—VLANCount Provisioning property facilitates the user to fetch the user-defined 
range of VLAN IDs, from a group associated with VLAN component. If the VLANCount value 
is blank, the Active System Manager software selects a VLAN ID randomly from associated 
group and allocates it to the VLAN component. On the other hand, if count is specified and 
VLAN group name is not provided then Active System Manager will randomly pick the VLAN 
IDs and will associate with corresponding VLAN component

VLANId—Single or multiple VLAN IDs can be is associated with VLAN component in a 
template. However, in case of multiple VLAN IDs, either the value can be provided in the value 
range format (10..15). 

If the VLANId is blank, the VLAN ID is automatically by the Active System Manager software 
at the time of the realization; otherwise, the ID must be a valid number that you set in your 
inventory.

• Inventory—Click the Inventory tab and set the values of the following Inventory properties:

VLANGroup—Facilitates the user to provide VLAN IDs in a group. VLAN groups are created 
on a matrix switch where the user is required to create a VLAN group name that can have VLAN 
ID ranges along with individual VLAN IDs. 

The user can associate only one group at a time with VLAN component. If the user has specified 
the VLANCount, then the specified number of VLAN IDs will be associated with VLAN 
component. If the VLANCount is not specified, then a VLAN ID is selected randomly from the 
specified group and is associated to the VLAN component.

To create a VLAN ID group, the group name is to be defined in curly brackets and its 
corresponding VLAN IDs or Ranges must be in parenthesis. For example; {Group1}(1..10) 
where Group1 is the VLAN group name and 1..10 range are VLAN IDs added to Group1.

Assettag: The VLAN ID is associated with a matrix switch through an assettag. The value of 
assettag Inventory parameter can be any existing matrix switch.

For more information on setting VLAN ID values, see the “Setting Up Layer 2 Switching” 
section on page 8-38.

Using Annotations
The Annotations feature allows you to create the following graphical functions to add to your existing or 
new Templates:

• Note—Allows you to create a note and drag it to the Template within the Template editor. The 
properties for that note display in the Properties tab. The Note also has a Content tab that allows you 
to assign a name or content specific to the Note, assign the indentation (how far the text is from the 
border of the note), assign the font, and apply a URL to the note, where you can access the URL directly 
by pressing Ctrl+click the note. The Content tab is specific only to the Note annotation.

• Oval—Allows you to draw around a Template environment as a grouping or to highlight specific 
importance within a Template or Template editor. 

• Rectangle—Allows you to draw around a Template environment as a grouping or to highlight specific 
importance within a Template or Template editor.

• Annotations Connection—Allows you to link to the Template (or Templates) from one annotation to 
another, or from one annotation to a specific Template environment.
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For all annotation functions:

• The properties display in the Properties tab, where you can assign (or modify) the Border and Fill 
parameters, such as font style, font size, color, line style, line width, and opacity. 

• You can set the default preferences for those properties in the Preferences dialog box (click Window > 
Preferences > Template > Template Editor > Annotations).

Updating Templates Using the Link Editor
The link editor is an editing tool used to author resource or resource type interfaces and create connectivity 
between resource elements. Figure 8-21 displays an example of the link editor.

Figure 8-21 Link Editor Example

Common Features of the Link Editor
Below are some of the common features of the link editor:

• The link editor comprises three parts: a left pane with the selected element, the middle pane that displays 
any links, and the right pane that displays the other elements in a tree view.

• The top action bar (see Figure 8-22) that allows you to define link types, as well as building better 
connectivity.

Figure 8-22 Top Action Bar—Link Editor

• When you create a link in the link editor, the links also display in the Template editor. To avoid 
confusion, the link editor displays links from left to right. The right pane displays the connectivity from 
one resource to another, but the source is unknown. To find the source, in the right pane, select the 
resource, right-click and select Move to Left. The resource moves to the left pane. 

• You can share the resource; for example, you can request the scheduler to allow for a subset of the 
interfaces.

• While the link editor is the primary place to create links, you can also create links in the Palette view, 
which is only displayed in the Template editor.
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Quick Filtering
In the Filter text box (see Figure 8-22), enter a string to search and filter out elements on the right pane 
content. This is useful when working with a large set of resources and the focus is on specific end-devices 
and connectivity.

Link Type Selector
Creating links usually defines a link as “Simplex” (the default). On the action bar (see Figure 8-22), you 
can set other available options by selecting a link and applying a specific link type. The default is 
“Simplex”.

Table  lists and describes the filters available on the link editor You can identify the different types of links 
(through their link end point decorations); see each respective figure for each link type to view the end point 
decorators.
Link Editor Filter Options

Icon Description

Allows links to go in one direction; see Figure 8-23.

Allows links to go in both directions; see Figure 8-24.

Allows links to go to multiple receivers; see Figure 8-25.

Allows the source end of the connection into move to multiple directions; see 
Figure 8-26.

Figure 8-23 Simplex
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Figure 8-24 Duplex

Figure 8-25 Multicast

Figure 8-26 Tap
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Link Feasibility Toolbar
The link feasibility icons (mutually exclusive) allow you to build connectivity within your Template while 
being aware of your underlying physical connectivity and compatibility between interface types.

• Show Compatible Interfaces Only—To use this icon option, you must first select a resource type, 
resource instance, or an interface, and then click this icon. 

• Show Static or Switched Interfaces Only—To use this icon option, you must first select a resource 
type or resource instance. Effectively, this option removes interfaces that are not connected via the 
underlying infrastructure.

• Show Existing Physical Connectivity—Shows or hides all possible connectivity. Select one or more 
of the drawn links and right-click Create Link.

Note To display current, possible connectivity, perform the following steps:

1. Select a resource instance and interface end point.

2. Right-click (or press F2) to display the Quick Connectivity dialog box. 

3. Select an entry in the dialog box to author the resource and interface into the Template.

The following topics describe how to update Templates using the link editor:

• Switching to the Link Editor

• Authoring Interfaces

• Modifying Interface Properties

• Managing Template Links

Switching to the Link Editor
To switch to the link editor from the Template editor, perform one of the following methods:

• With the editor workspace open, click the Link editor tab.

• In the link editor, right-click the resource and select Switch to Link Editor (see Figure 8-21 on 
page 8-42).

• Double-click a resource or link.

Authoring Interfaces 
You can author interfaces only in the link editor; that is, make those interfaces enabled, and thereby, adding 
them in your configuration. By default and based on the Template preference, some interfaces might be 
enabled. To enable the interfaces essentially means to request the resource type or resource instance to 
schedule those interfaces to use in a session. For example, a Template is a request to the scheduler to book 
it. You disable or enable the interfaces on the left or right pane.

If the interfaces are already enabled, to disable interfaces, select one or more interfaces in the left pane, 
right-click, and select Enabled; see Figure 8-27. 
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Note The interfaces are disabled when the check mark next to the Enabled menu disappears.

Figure 8-27 Interface—Enabled

To enable all interfaces of a particular interface type (or on the resource), right-click the interface type, and 
select Enable All Interfaces. 

To disable all interfaces of a particular interface type (or on the resource), right-click the interface type, and 
select Disable All Interfaces. When you author by resource instances, all interfaces are enabled based on 
the resource instance’s shared property. If the property is set to “true”, then you can enable or disable it. If 
the shared property is set to “false”, then the resource cannot be shared, and therefore, all resources are 
enabled by default.

This section also describes the following methods for authoring interfaces:

• Authoring Interfaces by Resource Type

• Authoring Interfaces by Resource Instance

Authoring Interfaces by Resource Type

Note To control the capacity of ports to be shared across session, an administrator can provision a 
resource type with a new inventory parameter called the Capacity attribute at the interface level, 
which is used and enforced by the scheduler (not at an inventory level). (The Capacity attribute 
works for dynamic connectivity only.) 

Note Values should be defined for each resource instance; otherwise, the interface can be used in an 
unlimited session (the default value is infinite). 

Table 8-8 lists and defines the default properties, when selecting interfaces for a resource type. You can 
view the attributes of interfaces on the resource’s Properties view, and view and edit them on the interface’s 
Properties view.
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Table 8-8 Default Interface Properties for a Resource Type 

Tab Name
Property 
Name Description

Interface Name Name you assigned to this interface, or the default name assigned by the Templates perspective.

Description Text string that describes this interface. The string can be unlimited in length and composed of 
alphanumeric characters, including spaces and special characters, to uniquely describe this 
connection.

Type Interface type.

Exclusive Indicates that the interface can be shared across multiple sessions at the same time.

Inventory System Lists all inventory parameters to schedule in the associated types:
• cardlocation—Location on the card resource containing this interface.
• cardname—Name of the card containing this interface.
• cardtype—Type of the card containing this interface.
• location—Interface’s location on the resource. This is a selection from a drop-down list whose 

options are set by the resource type. Specifies a particular port, rather than just the type.

Properties are entered in the form of a conditional expression:
<Property name><Operator><Value>

where:
• Property name is the name of the property whose value is to be checked. This can be one of the 

system properties listed above, or a custom property defined in the resource type.
• Operator can be either the “IS” or “IS NOT” mathematical symbols.
• Value is a string whose value is to be matched. The string is not case-sensitive. Both the property 

value and the string you enter is translated to lower-case before the comparison is performed.
More than one property can be specified for a resource or interface. The conditional expressions for 
the properties are logically AND-ed. That is, all specified properties must match the values that you 
entered for that resource or interface. 

This applies to all elements of a resource being considered by the scheduler. That is, all conditions 
specified for the resource must match, and all conditions specified for each interface required by the 
Template must match. Any property name can only be used once for a particular resource or interface. 
For example, you can not enter both “Author Name = John Doe” and “Author Name = John Smith” for 
a resource. This is the equivalent of a logical OR operation on the conditional expressions, and is not 
permitted.

Provisioning List of all provisioning parameters that can be overwritten from their default value. For information 
about setting up provisioning parameters, see Chapter 6, “Using Inventory.”

Authoring Interfaces by Resource Instance
Table 8-9 lists and defines the default properties, when selecting interfaces for a resource instance. You can 
view the attributes of interfaces on the resource’s Properties view, and view and edit them on the interface’s 
Properties view.

Table 8-9 Default Interface Properties for a Resource Instance 

Tab Name
Property 
Name Description

Interface Name Name you assigned to this interface, or the default name assigned by the Templates perspective.

Description Text string that describes this interface. The string can be unlimited in length and composed of 
alphanumeric characters, including spaces and special characters, to uniquely describe this 
connection.

Type Interface type.

Location Interface physical location, usually referred to by the manufacturer.
Template Management 8-47



Working with Templates
Modifying Interface Properties 

Note Only the attributes with values are shown in the interface—Properties view; the others are omitted.

To modify interface properties, display the interface Properties view and perform the following steps:

1. Display the interface Properties view.

For Resource Type, you can modify the editable properties listed on the Interface, Inventory, and 
Provisioning tabs.

For Resource Instance, you can modify the editable properties listed on the Interface and 
Provisioning tabs.

2. On the Authoring tab, edit the Name field as appropriate.

3. On the Configuration tab, edit the property.

Managing Template Links
Authoring links essentially means to create connectivity (links) between or among the interfaces of the 
resources. The following topics describe how to author links:

• Creating Links

• Defining Custom Attributes for Links

• Disabling and Enabling Template Links

Creating Links
You can only create a link for interfaces based on user preferences. If the preferences (Enable resource 
interfaces on link creation check box is selected; see Figure 8-27 on page 8-46), you can link the 
interfaces, even if some of the interfaces are disabled. If it is not selected, you cannot create links using 
disabled interfaces. 

Links have properties. By default, they are automatically named (for example, Link_n). Link names must 
be unique. If you have 10 names, all links must have different names; if not, you cannot save the Template. 

To display link properties, perform one of the following methods:

• In the link editor, select a link.

• In the Outline view, select a link.

IP Address Interface management port. Only available when a management port is selected.

IP Subnet Interface subnet associated with IP address. Only available when a management port is selected.

Gateway Gateway IP address. Only available when a management port is selected.

Provisioning List of all provisioning parameters that can be overwritten from their default value. For information 
about setting up provisioning parameters, see Chapter 6, “Using Inventory.”

Table 8-9 Default Interface Properties for a Resource Instance (continued)

Tab Name
Property 
Name Description
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To create a simple link, select an interface in the left pane and drag it to the right pane, or from right to left. 

To modify the link properties, click a property field and enter an appropriate value. 

Figure 8-28 Link Properties Example

Table 8-10 lists and defines the default properties for the selected links. 

Table 8-10 Default Template Link Properties 

Property 
Name Description

Name Name you assigned to this link, or the default name assigned by the Templates perspective. Enter a 
link name of up to 80 alphanumeric characters, including spaces and special characters.

Description Text string that describes this link. 

Type Type of link: simple.

Priority You can assign a priority level to links in a Template by clicking the Priority-Value field and 
selecting a priority value. The lowest priority level, highest priority level, and default priority (the 
priority of any link that has not been set) are determined by a file on the Active System Manager 
server. If these values have not been modified in that file, they come with the default priority is 1 
(the priority of any link that the priority has not been set, including links in old Templates that 
predate the Active System Manager link priority feature). These values can be changed on the 
server in the config.properties file. 

Note You can also perform loopbacks; for example, a loop back to itself on two different ports. 
Loopbacks are only allowed in the left pane, not the right pane.
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Links can point to the same interfaces (see Figure 8-29); that is, interfaces can have multiple links 
associated in Templates and sessions. For example, when enabling a resource interface, a new 
interface-level property in the Template, “Exclusive”, is present, indicating that the interface cannot be 
shared across multiple sessions at the same time.

Figure 8-29 Shared Interfaces

Defining Custom Attributes for Links
You can define custom attributes for the links. To define a custom attribute, perform the following steps:

1. In the Template editor, select the link.

2. In the Properties view, select the Provisioning tab. 

3. Click Add to add the name and value of the custom attribute.

Disabling and Enabling Template Links
By default, Template links are enabled. While scheduling Templates, disabled links are not considered for 
link feasibility validation. Disabled links will not use any physical infrastructure. 

To disable and enable Template links, perform the following steps:

• To disable: with a Template open, click the Template editor, right-click one ore more Template links 
and select Disable; see Figure 8-30. 
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Figure 8-30 Disabling Template Links

• To enable a Template link that you disabled: With a Template open, click the Template editor, 
right-click one ore more Template links and select Enable. 

Note Disabled links do not have a direct impact on an underlying physical structure during the session 
Cleaning Up state.

Associating an Orchestration Workflow with Templates
An orchestration workflow is a set of operations that can be defined within a Template. The workflow is 
executed automatically by the Active System Manager software when a session comes into a Running state. 

These operations are inherited from each RA and each operation will contain a set of optional and required 
parameters that the user must set. Operations can be grouped by step (with no limitations) and an operation 
within a step is executed in parallel; otherwise, each step is sequentially executed.

Note Only one orchestration workflow can be associated per Template. To define a new workflow, you 
must save the Template first, under a different name.

Editing Orchestration Workflows
To edit an orchestration workflow, perform the following steps:

1. Open the Templates perspective, and in the editor, select a template with existing orchestration. 

The list of associated orchestrations will be automatically displayed in the Orchestration view. 

2. Select one orchestration from the Orchestration view by double-clicking (or right-click > Open).

The orchestration displays as an editor in the workspace; see Figure 8-31.
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Figure 8-31 Orchestration Editor

Two panes display: 

• Available Operations View—Contains all Resource Adapter custom operations associated with 
each resource in your Template.

• Orchestration View—Working pane where you build your workflow by drag-and-drop operations 
from the Available Operations View pane.

3. Add a step (or steps) by one of the following methods:

• Select operations from the Available Operations view pane and drag those to the Orchestration View 
pane. The Specify Input Values dialog box displays (Figure 8-32) where you must provided 
Resource Adapter values, where required, then click OK. To find out more information about the 
Resource Adapter capabilities, see the “Working with Resource Adapters” section on page 7-16.
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Figure 8-32 Specify Input Values for Selected Operation (Example)

• In the Orchestration view, right-click any Step n folder and select Add Step. The step is 
automatically added at the end of the step process.

• In the Orchestration view, right-click anywhere in the pane and select Add Step. The step is 
automatically added at the end of the step process.

4. In the Orchestration view, right-click the Step n folder to insert a step and select Insert Step. The step 
is automatically between where you clicked the Step n folder and the next step.

5. In the Orchestration view, right-click a specific step in the Orchestration view pane (or within the 
Orchestration view) and select Remove Step.

6. In the Orchestration view pane, right-click an operation within a step (or within the Orchestration View 
pane) and select Remove Operation.

Note You can change the order of the steps, at any time, by right-clicking in the Orchestration view pane, 
and dragging to the preferred sequence location.

You can also specify a name to the step ID. 

7. Click OK to save the workflow.

Deleting Orchestration Workflows
To delete a workflow, perform the following steps:

1. Open the Templates perspective, and in the editor, select a template with existing orchestration. 

The list of associated orchestrations will be automatically displayed in the Orchestration view. 

2. Select one orchestration from the Orchestration view by double-clicking (or right-click > Delete).

You can delete multiple groups or one, by selecting more entries. 

You will be prompted to confirm the deletion.
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C h a p t e r  9
Session Management
This chapter describes the Active System Manager Sessions perspective, including all of the functions 
available for you to view, modify, and save sessions, as well as interact with equipment in running sessions 
and remotely run test cases. The Sessions perspective controls the layout of the user interface the Active 
System Manager software uses to display information for your test cases, including which views are 
displayed and their positions within the Active System Manager software. 

Introducing the Sessions Perspective

The Sessions perspective (the default perspective) controls the layout of the user interface the Active 
System Manager software uses to display information for your sessions and test cases, including which 
views are displayed and their positions within the Active System Manager software. You can save the 
modifications you make to the Sessions perspective as you create them, making your own custom user 
interface for viewing and executing sessions and test cases.

You can view and execute sessions and test cases locally and remotely via the Sessions perspective. 

Note You can use various Active System Manager perspectives to perform many of the same tasks. For 
example, you can also use the Sessions perspective to view, monitor, observe output, and stop the 
sessions or test cases that are associated with your previously defined templates.

To open the Sessions perspective (see Figure 9-1), perform one of these tasks:

• On the Active System Manager toolbar, click the Open Perspective icon and select Sessions. 

• On the Active System Manager toolbar, click the Sessions perspective icon.

• On the Active System Manager menu bar, click Window > Open Perspective > Sessions.
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Figure 9-1 Sessions Perspective

Table 9-1 outlines the default and non-default views available when you open the Sessions perspective; see 
Figure  for a graphical representation of the views, which appear in tabular form, except for the Template 
editor.

Table 9-1 Session Perspective Elements 

View or Editor 
Name Default

Non- 
Default Description

Orchestration X Displays orchestration executions.

Execution ID X Displays the output from your test cases and scripts, and provides 
a series of toolbar options that enable you to control both the test 
cases and script execution. 

Execution Queue X Displays all the scripts and test executions.
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Working with Running Sessions

The Active System Manager software allows you to perform a variety of functions using the Sessions 
perspective:

• Scheduling a Session Using Templates

• Creating an Instant Session

• Opening Sessions

• Opening the Session Editor

• Using the Sessions Calendar

• Viewing Session Properties

• Editing Default Session Properties

• Assigning and Changing Session Ownership

• Canceling Sessions

Sessions X Displays all the sessions for all the templates in all states. 
Displays all sessions in the Active System Manager application, 
including sessions that you reserved, and those reserved by 
others who have granted you access to their sessions. Sessions 
in running states are called sessions, which are indicated with a 
green arrow icon; see Figure 9-3 for an example.
The Sessions view is a navigator view that supports built-in and 
custom filtering (Past, Present, Future, Last 24 Hours, Last 7 
Days, Last 30 Days, Last 60 Days, Last 90 Days) and grouping 
functions. For more information, see the “Filtering” section on 
page 1-12 and the the “Grouping” section on page 1-15.
Sessions follow a session life cycle and states change over time. 
For a graphical representation of the Session workflow, including 
the states; see Figure 9-4.

Session Archive 
Bin

X Displays the archived sessions.

Templates X Lists the available templates. 

Resource Scripts X Displays resource-level scripts and test case association.

Session Editor X Displays a graphical representation of the allocated network 
configuration.

Outline X Displays the content of the running sessions in an outline format. 
It represents a high-level summary of an open editor and allows 
you to navigate or find information quickly. When you select a 
node or link in this view, it also is selected in the session editor, 
and the properties for the selected session change, as 
appropriate, in the Properties view.

Properties X Tracks resource instance properties associated with sessions. It 
is a set of property values that are reflected in what you see in the 
session and link editors.

Table 9-1 Session Perspective Elements (continued)

View or Editor 
Name Default

Non- 
Default Description
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• Deleting Sessions

• Purging Sessions

• Rescheduling Sessions

• Managing Session Links

• Handling Link Preemption

• Managing Session Resources

• Associating Scripts to Sessions

• Archiving Sessions

Scheduling a Session Using Templates
To schedule a new session, perform the following steps:

1. Select a method to open the Scheduling Template dialog box (see Figure 9-2):

• On the Active System Manager menu bar, click File > New > Other > Active System Manager > 
Session. 

• On the Active System Manager menu bar, click File > New > Session.

• On the Active System Manager toolbar, click the New icon, select Other > Active System 
Manager > Session > Next.

• On the Active System Manager toolbar, click the New icon, select Session and click Next.

• In the Templates view, right-click a template and select Schedule.
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Figure 9-2 Scheduling Session

2. Define the session parameters, as necessary. For details, see the “Scheduling Templates” section on 
page 8-18. 

Note For information about templates, see Chapter 8, “Template Management.”

Creating an Instant Session
Instant scheduling allows users to start a session with dedicated resources or resource types without 
creating and managing templates.

To create an instant session, perform the following steps:

1. Open the Resource Instances view or Resource Types view; see the “Opening Navigator Views” section 
on page 1-16.

2. Right-click one or more resources (or resource types) and select New Session.

3. Click the Name field and enter a session name.

4. Optional. Click the Description field and enter a description for this session.

5. Click Finish to open the session editor.

A new editor comes up with your resources layout automatically in the editor.

6. Set the properties in the Properties view and enable interfaces based on your requirements.
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7. Click File > Save (or in the session editor, right-click and select Save) to invoke the scheduler and start 
the session. 

8. Complete the scheduling wizard. For more information, see the “Scheduling Templates” section on 
page 8-18.

The session is created in the Confirmed state, then goes into the Setting Up state if all resources are 
deemed allocated and ready to be provisioned. Once in a Running state, users can interact with the 
resources per normal operation.

Opening Sessions
Opening a session is similar to opening a Template, except that sessions are opened with real, allocated 
resources. You can open the session in any state, but only in running status is where you can actually 
interact with the equipment. The session editor tracks the session status and that status is reflected in the 
session and Template background.

To open one or more sessions, perform the following steps:

1. Select the method to open the Sessions view:

• On the Active System Manager menu bar, click Window > Show View > Other > Active System 
Manager > Sessions > OK. 

• On the Active System Manager toolbar, click the Sessions perspective icon.

2. Select the method to open a session for a session; see Figure 9-3:

• For a single session, in the session editor or Sessions view, double-click (or right-click) the session, 
and select Open. 

• For multiple sessions, in the session editor or Sessions view, hold down the Ctrl key and select the 
sessions. Right-click and select Open.

Figure 9-3 Sessions View

You can re-order the default columns by dragging a column header to a different location. Adjust the 
session content by using the grouping and filtering function (see the “Filtering” section on page 1-12 
and the “Grouping” section on page 1-15).

The Sessions view displays the Canceled, Completed, Failed, and Running (if any) status. Figure 9-4 
illustrates the session state workflow. The tree is refreshed dynamically; however, you can click View > 
Refresh Sessions to manually update the tree or press F5 if the focus is on the Sessions view. Table 9-2 
defines the various modes and states of the Sessions perspective while processing a session request.
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Figure 9-4 Session States Workflow

Table 9-2 Session Perspective States 

Session State Status Description

Pending Mode Confirmed A validated or scheduled session.

In Process Mode Running A session that has started.

Wait Setting Up A scheduled setup time has arrived, but some of the resources required 
by the session have not yet been released by earlier sessions.

Setting Up The process of scheduling resources and laying down the required 
configuration files for a session.

Cleaning Up The process of restoring the original settings for a session.

Snapshot Takes the snapshot the running session and saves the modified 
Template.

Active A session that has started.

Past Mode Completed A session that has completed the start to end time.

Failed A session that did not get realized or problems occurred during the 
cancel operation.

Canceled A session canceled by the user or system.

Deleted A session deleted by the user.
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Opening the Session Editor
A session editor allows you to view session-based resources. When opening the session editor, the overall 
rendering looks similar to the underlying Template, but resource type definitions are replaced by real 
inventory or virtual resources.

The session editor displays a Template for a running session, and for each session, you can perform the 
following operations:

• View its allocated resources, including all resources and links.

• Add or delete links.

• Add, delete, activate, and deactivate resource operations (dynamic session features).

• Save the current session configuration.

• Power on and off resources.

• Open resource terminals.

• List and execute test cases.

• Snapshot.

• Specify/edit Provisioning policies.

• Perform system/custom operations.

• Monitor/view Resource Adapter logs.

• Execute session scripts.

• Activate/inactivate resources.

• Retry setup.

You can also update the representation of the session rendering, by performing the following operations, 
similar to the environment during the Template creation and update processes. 

From a session editor, many other functions can be invoked, such as working with a resource console, 
adding or deleting links, and saving the Template. Each resource is shown with its name beneath its icon. 
If a resource is shown in red, it indicates that the resource could not be successfully set up for this session 
by the Active System Manager software. A line between resources can represent one or more actual links, 
and also indicates the current status of those links. For more information about these functions, see 
Chapter 7, “Repository Management.”

To open the session editor, perform the following steps:

1. Open the Sessions perspective; see the “Introducing the Sessions Perspective” section on page 9-1.

2. Select a method to open the session editor from the Sessions view:

• Double-click any session.

• Right-click any session and select Open; see Figure 9-5 for an example session editor displayed.

For further details about the session editor, see the next section, “Using the Session Outline View with the 
Session Editor.”
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Figure 9-5 Opening Session Example

Using the Session Outline View with the Session Editor
The Session Outline view content that lists the resources and links can be customized using the Show icons:

• Show Outline—The default outline view content. Lists all resources and links in the session editor. 
This session outline is bidirectional (selecting an element from that view automatically selects the 
element from the editor).

• Show Overview—Displays a graphical overview of the Template. Allows you to navigate large 
Template content in a graphical manner.

• Show Elements—Displays all resources with associated configuration and image files that were used 
at realization time. There are no links that can be found.

• Show Hosts—Displays relationships between virtual resources and their hosted environment. There are 
no physical resources, nor links that can be found.
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Viewing the Session Realization Information
When opening a session editor for a running session, you can view the session realization information. The 
realization phase is where the Active System Manager system builds, provisions, and interconnects the 
resources for the defined requirements. 

For example, the editor can indicate the following results on the Realization tab (for each resource and 
link):

• Power Off Resources are displayed as grayed-out; see Figure 9-6.

• Resource Instance Realization Error displays in red and are outlined; see Figure 9-7.

• Unrealized Links (simple) are marked in red and are outlined; see Figure 9-8. You can retry or discard 
a failed link. To display the properties of the link, select the desired link in the Template tree or select 
the line representing the link in the Template window. The properties are displayed in the Properties 
view.

Figure 9-6 Power Off Resources Displayed
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Figure 9-7 Resource Instance Realization Error

Figure 9-8 Resource Instance Realization Error

For reference, see “Running a Session Audit Report” section on page 12-4.

Retry Setup on Failed Resource Realization
When the resource setup Resource Adapter methods have failed during the realization phase, you can retry 
the realization process for the failed resource realization. To do so, select the failed resource, right-click and 
select Retry Setup. You can view the setup result in a dialog box, in the Session Audit Report, or in the 
Realization tab in the Properties view.

Note In case of realization errors, the resource icon is displayed in red.
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Using the Sessions Calendar
The Sessions view—calendar toolbar (see Figure 9-9) assists planners and managers with planning, 
scheduling, tracking, and allocating environment resources. The Sessions view—calendar toolbar enables 
you to view availability and session status of inventory or sessions—as well as resolve scheduling 
conflicts—against a variable time frame that displays schedule status and the availability of selected items.

Essentially, the Sessions view—calendar toolbar is a visual aid for your overall Active System Manager 
session status to help you schedule sessions, monitor activities, and perform future session planning. 

This section includes the following topics:

• Using Sessions View Features

• Opening the Session Calendar

Using Sessions View Features
Figure 9-3 on page 9-6 displays the Sessions view (including the tree and calendar components); Figure 9-9 
displays the Sessions view toolbar; and Table 9-3 lists and describes the icons, features, and menu options 
found in the Sessions view. You access each icon via the Sessions view toolbar. Figure 9-10 displays an 
example of “Show Mine Sessions” results using the calendar components; Figure 9-11 displays an example 
of “Show All Sessions” results using the calendar components.

Figure 9-9 Sessions View Toolbar

Table 9-3 Sessions View Features—Calendar Components 

Icon/Feature/Menu 
Option Description

Calendar menu options 
(feature)

The actual time frame resolution depends on whether you are viewing the Day, Week, 
Month, Quarter, Year time frame. From the calendar header, right-click and select from 
the following to switch the time resolution:
• Day Calendar
• Week Calendar
• Month Calendar
• Quarter Calendar
• Year Calendar

colored bars (feature) The Active System Manager software displays the following information for each 
session: 
• Start and end date and time
• Session Name
• Type (session)
• Status
• Owner
• Participants
To view this additional information, mouse over a colored bar within the Session 
calendar.

color schemes (feature) You can customize the Calendar color schemes for sessions that you currently own or 
are a participant of. Sessions that you do not own will always display with a white 
background with black border. Right-click in the calendar and select Preferences (or 
on the Active System Manager toolbar, click Window > Preferences > General > 
Display Options) to edit preferences to set the colors.
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Figure 9-10 Show Mine Sessions Example

Drag (feature) Edits existing sessions, or extends or reduces the time frame for selected sessions.

Filters and Group By 
(icons)

Displays specific sessions; for more information, see the “Filtering” section on 
page 1-12 and the “Grouping” section on page 1-15.

light-yellow horizontal 
line (feature)

Indicates the selected session in the tree view within the left side of the Sessions 
view.(This color highlights the selected row for that session).

red vertical marker 
(feature)

Indicates a date and time you select.

• goto (menu) When you select goto, the red bar displays the specific time frame indicated with the 
red vertical marker.

• Now (menu) When you select Now, the red vertical marker moves to the present time. 

• F9 (feature) Pressing F9, when the focus is on the calendar, is equivalent to selecting Now.

• New (menu) Creates new sessions.

session bar shape 
changes (feature)

Displays your sessions.

Show All Sessions (icon) Displays all sessions or only the ones you own and the ones of which you are a 
participant. The calendar display distinguishes between those sessions you own vs. 
the other sessions. For an example, see Figure 9-11.

Show Calendar (icon) Hides and shows the calendar component. When turned on, the time marker (that 
indicates the current time) is visible.

Show Mine (feature) Displays only the sessions you own and the ones of which you are a participant. The 
calendar display distinguishes between those sessions you own vs. the other 
sessions. For an example, see Figure 9-10. You access this feature by deselecting the 
Show All Sessions icon.

yellow bar (feature) If you are viewing a session, you can double-click within the associated yellow bar for 
that session, and the Active System Manager software opens and displays the 
sessions.

Show In Calendar Use the Show In Calendar menu option (right click the session and select Show In 
Calendar) to display the selected session directly in the center of the session 
calendar; a red vertical marker identifies the selected session.

Table 9-3 Sessions View Features—Calendar Components (continued)

Icon/Feature/Menu 
Option Description
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Figure 9-11 Show All Sessions Example

Opening the Session Calendar
To open the Session calendar, perform the following steps:

1. On the Active System Manager menu bar, click Window > Show View > Other > Active System 
Manager > Sessions > OK.

The Sessions tab displays with the Sessions view; see Figure 9-12.

Figure 9-12 Sessions View

2. Click the Show Calendar icon, if the calendar is not already displayed.

3. Open, at least, one folder to display the sessions; see Figure 9-13.

Figure 9-13 Session Calendar View

Note Move your cursor over the colored bar within the calendar view to view the session properties.
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Note Use the Show In Calendar menu option (right click the session and select Show In Calendar) to 
display the selected session directly in the center of the session calendar; a red vertical marker 
identifies the selected session.

Right-click the Sessions calendar date bar to view the following calendar options:

• Day Calendar—Default; displays the calendar in one day segments.

• Week Calendar—Displays the calendar in one week segments.

• Month Calendar—Displays the calendar in one month segments.

• Quarter Calendar—Displays the calendar in quarterly segments.

• Year Calendar—Displays the calendar in yearly segments.

• Lock View—Locks the calendar to keep the time frame within the display when the window is resized.

• Now—Displays the current date within the view.

• Go to Date—Displays the Go To Date dialog box. Use this dialog box to set the date you want 
displayed, as well as the Day/Week/Month display. (Red line shifts to the new date.)

Viewing Session Properties
To view the session properties, select the session in the session editor background. You can display 
properties and later modify those that allow for editing; see Table 9-5 on page 9-18. 

Most of these properties (displayed in the Properties view) for the selected session are in the session editor 
background; see Figure 9-14. For reference, see the “Running a Session Audit Report” section on 
page 12-4. 

Figure 9-14 Session Properties View
Session Management 9-15



Working with Running Sessions
Table 9-4 lists and defines the session-level properties.

Table 9-4 Session-Level Properties 

Tab Name Category Property Description Value

Session Custom Name Contains a set of custom and system 
session-level property names and values. 
Note: A default set of properties may be 
available based on your Active System 
Manager deployment configuration. 
You can add or remove the custom 
session-level properties. The Open 
function is intended to use for opening 
URLs or links. It launches a new browser 
window.
To add a custom session property (that 
must be overwritten) with a editable value, 
click Add.
To remove a custom session property, 
select a row and click Remove.
Notes: 
1. All of the Add and Remove functions 

must be saved to save those property 
changes (click File > Save).

2. These custom properties can now be 
used in the Sessions view for 
grouping, filtering, and searching.

Read-write.

Session Custom Name 3. If any properties are marked as 
Required by the administrator, the 
property value must be entered before 
saving the session.

Read-write.

Session System Actual End Date/Time End date and time of when the 
environment session ended, failed, 
cancelled, or completed. 

Read-only.

Actual Start Date/Time Start date and time of when the 
environment session started. 

Read-only.

Duration Duration of your session in day, hours, and 
minutes.

Read-only.

End Date/Time End date and time of when the 
environment session is scheduled. Can be 
updated based on resource availability; 
that is, not booked by someone else.

Read-only. Can be 
changed; see the “Editing 
Default Session 
Properties” section on 
page 9-17.

Session System ID Internal number assigned for the session. Read-only.

Session System Name Name assigned to the session. Read-only.

System Owner Name of individual who created the 
session.

Read-only.

System Participants List of session participants. Read-only. Can be 
changed; see the “Editing 
Default Session 
Properties” section on 
page 9-17.

System Start Date/Time Start date and time of when the 
environment session is scheduled. The 
start time cannot be edited if the session is 
already in progress.

Read-only. Can be 
changed; see the “Editing 
Default Session 
Properties” section on 
page 9-17.
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Editing Default Session Properties
To edit the default session properties, perform the following steps:

1. Select a session to modify by one of the following ways:

• In the Sessions view, right-click the session and select Edit.

• In the calendar view, right-click the session and select Edit.

The Session properties dialog box for the selected session displays; see Figure 9-15.

System Status Session status; see Table 9-2 on page 9-7.
Current status of your session for that 
Template. Pending sessions always 
display as “Confirmed”. The status for 
sessions currently running is “Active”.

Read-only.

System Time Left Computed time left in days, hours, 
minutes.

Read-only.

System Template Name of the underlying Template created. No

System Type Session type: session. No

Provisioning Custom <custom names> Contains a set of custom and system 
session-level property names and values. 
You can add or remove the custom 
session-level properties. The Open 
function is intended to use for opening 
URLs or links. It launches a new browser 
window.
To add a custom session property (that 
must be overwritten) with a editable value, 
click Add.
To remove a custom session property, 
select a row and click Remove.
Note: All of the Add and Remove 
functions must be saved to save those 
property changes (click File > Save).
Note: These custom properties can now 
be used in the Template view for grouping, 
filtering, and searching.

<custom values>

Attachments Name
Description

You can add or remove attachments. To 
add a file attachment, click Add, select a 
file from your file system, click Open, and 
the file attachment is added.
To open the file attachment, select one 
and click Open.
To remove a file attachment, select a file 
attachment and click Remove.

Table 9-4 Session-Level Properties (continued)

Tab Name Category Property Description Value
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Figure 9-15 Session Properties

Most of these properties are also displayed in the Properties view for the selected session in the session 
editor background; see Figure 9-14.

2. Modify the properties, as appropriate. Table 9-5 lists and defines the session’s default properties for the 
Session tab. The Editable column defines which properties you can modify.

Table 9-5 Default Session Properties 

Property Name Description Editable

General

ID Internal number assigned for session. No

Name Name assigned to the session. Yes

Template Name of the underlying Template created. No

Owner Name of individual who created the session. No

Type Session type: session. No

Status Session status; see Table 9-2 on page 9-7. No

Scheduled Start 
Date/Time

Start date and time of when the session is scheduled. The start time cannot be edited if the 
session is already in progress.

Yes/No; see 
description

Scheduled End Date/Time End date and time of when the session is scheduled. Can be updated based on resource 
availability; that is, not booked by someone else.

Yes/No; see 
description
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3. Click Apply or OK to accept the modifications. 

Assigning and Changing Session Ownership 
You can assign and change the session ownership by two methods:

• Using the Scheduling Wizard at Creation Time

• Using the Edit Session Properties

Using the Scheduling Wizard at Creation Time
Note The criteria described to configure scheduling a Template can also be configured in the Preferences 

dialog box. To do so, on the Active System Manager menu bar, click Window > Preferences > 
Scheduler.

To assign the session ownership by using the scheduler wizard, see the “Scheduling Templates” section on 
page 8-18. As an administrator, the scheduler wizard allows you to assign session ownership to a different 
user. 

Using the Edit Session Properties
To change the session ownership by using the edit session properties, see the “Viewing Session Properties” 
section on page 9-15 and the “Editing Default Session Properties” section on page 9-17. 

Actual Start Date/Time Start date and time of when the session is scheduled. The start time cannot be edited if the 
session is already in progress.

Yes/No; see 
description

Actual End Date/Time End date and time of when the session is scheduled. Can be updated based on resource 
availability; that is, not booked by someone else.

Yes/No; see 
description

Participants List of users that have access to the session. Owner is responsible for establishing the 
participants, which can be edited using the Edit Properties menu; see Figure 9-15 on 
page 9-18.

Yes

Notifications and 
Reminders

Session Notifications Email notification settings for defining who is notified for specific sessions (Admin: 
notifications can be applied to all sessions; User: notifications can be applied if user is the 
owner, or on a ‘per session’ basis.)

Yes

Script

Script and Test Case 
Association

Displays only information related to the script association with a session.
Displays the resource-level scripts and the associated test cases.
Note: In case of confirmed session, script, and test case association is editable.

Yes/No; see 
description

Table 9-5 Default Session Properties (continued)

Property Name Description Editable
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Canceling Sessions
Based on the current state of your session, the Cancel option is available. 

To cancel a session (or multiple sessions), perform the following steps:

1. In the Sessions view, select one or more sessions to cancel.

2. Right-click and select Cancel to display the Confirm Cancelation dialog box.

3. Click OK to confirm the cancellation.

Deleting Sessions
Based on the current state of your session, the Delete option is available. 

To delete a session (or multiple sessions), perform the following steps:

1. In the Sessions view or session editor, select one or more sessions to delete.

2. Right-click and select Delete to display the Confirm Delete dialog box.

3. Click OK to confirm the deletion.

Purging Sessions
Note procedure can only be performed by an administrator. If you (as a user) try to purge a session, the 

menu command is disabled.

To purge a session, perform the following steps:

1. Delete the session; for details about deleting sessions, see the “Deleting Sessions” section.
Note You can only purge a session after it has been deleted.

2. On the Active System Manager menu bar, click Tools > Purge Sessions.

The Purge Sessions dialog box displays; see Figure 9-16.
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Figure 9-16 Purge Sessions

Select, at least, one session to purge. To select all sessions, click Select All; to change your selected 
sessions, click Deselect All or click the session to deselect it.

Note The utilization statistics are also purged.

3. Click OK.

Rescheduling Sessions
You can reschedule an existing session by using the underlying Template or the original allocated 
resources.

To reschedule a session, perform the following steps:

1. In the Sessions view or session editor, right-click a session and select Reschedule. 

The Rescheduling Session dialog box displays; see Figure 9-17.

Figure 9-17 Rescheduling Session

2. Click the Resources field to select one of the session resources:

• Use authored resources (resource types and instances)—Uses the underlying Template associated 
with the session you want to reschedule.
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• Use same resource instances—Uses previously allocated resources with that session.

3. Click the Behavior field to reschedule the session (see Table 8-2 on page 8-3 for definitions):

• As Soon As Possible (ASAP)

• ASAP with fixed time frame

• Fixed start and end date

• Permanent Session

4. Specify the Date/Time Options in Days, Hours, and Minutes.

5. Click Next.

The next Scheduling Template dialog box displays, where you can now create sessions on behalf of 
other users.

Note Only the administrator and current owner can change the ownership. This field is 
read-only if you are not the administrator user. 

6. Click Next.

Note You can adjust the Scheduler session and security properties. See the Preferences—Scheduler page 
for advanced scheduler options (click Window > Preferences > Scheduler > Advanced 
Scheduling). 

Note You can adjust the scheduling behavior based on user preferences. See the Preferences—Scheduler 
page for scheduler options (click Window > Preferences > Scheduler). The Scheduler can 
automatically perform extra scheduling when no solutions are reported, including identify 
preemption or running ASAP Scheduling.

The scheduler has identified a set of solutions (see Figure 9-18). 

If no solutions are reported, the wizard displays an error page with a high-level error message and a 
complete set of logs. Click Back to change your setting request.

Solutions should appear; however, if not, the Scheduler logs are displayed. The number of causes may 
result in the Active System Manager software being unable to find any suitable times to schedule your 
session. For example, the resources in your Template may not be available during the time window you 
requested, or the time window you entered may be too short for the time slot length that you requested. 

One of the following, possible responses are available at this time:

• If the request can be satisfied, you see a list of session time options.

• If a non-preemptive request cannot be satisfied, you will be prompted.

If other sessions conflict with a preemptive request, a list of possible sessions display using resources 
already assigned to other sessions.
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Figure 9-18 Rescheduling Session—Solutions

7. Click Next to display the next wizard page. 

If no solutions are reported, the wizard will display an error page with a high-level error message and 
a complete set of logs. If this happens, click Back to change your setting request.

Solutions should appear; however, if not, the Scheduler logs are displayed. The number of causes may 
result in the Active System Manager software being unable to find any suitable times to schedule your 
session. For example, the resources in your Template may not be available during the time window you 
requested, or the time window you entered may be too short for the time slot length that you requested. 

You receive one of the following, possible responses at this time:

• If the request can be satisfied, you see a list of session time options.

If a non-preemptive request cannot be satisfied, you are prompted. 

• If other sessions conflict with a preemptive request, you see a list of possible sessions using 
resources already assigned to other sessions.

8. On the Scheduling Template—Solutions dialog box, select a scheduling solution.

9. Optional. Click the Session Name and enter a name.

10. Click Next to go to the allocated resource information (see Figure 9-19), or click Finish. 
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Figure 9-19 Allocated Resources

The top part displays the allocated resource instances selected by the Scheduler, including interfaces. If 
you click the Identify Preemption Opportunities check box, the bottom part can list sessions that 
should be canceled in order to schedule this session.

11. Click Next.

The next wizard page (see Figure 9-20) displays (if the option is set in the Window > Preferences > 
Scheduler > Wizard dialog box) only for a session; otherwise, skip to step 6. By default, the No 
Association option is selected. For more information about script association, see the “Managing 
Session Links” section on page 9-26.
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Figure 9-20 Scheduling Template Wizard

12. Click Finish to confirm your session. 

If the Perspective check box is enabled on the Window > Preferences > Scheduler dialog box, a 
prompt displays, confirming your scheduled session.

13. Click the Remember my decision check box to allow the software to remember the scheduled session 
and view the all of your sessions.

Note This message displays if you are not in the Sessions perspective. If you have enabled 
the check box, the message will not appear on subsequent session scheduling.

14. Click Yes to automatically switch to the Sessions perspective, or click No to remain in your current 
perspective.

Your newly created session will display in the Sessions view. 
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Managing Session Links
Authoring links essentially means to create connectivity (links) between or among the interfaces of the 
resources. The following topics describe how to author links:

• Adding Connectivity

• Common Features of the Session Link Editor

Adding Connectivity
When the Active System Manager software starts a session by attempting to realize the associated 
Template, one of its main tasks is to implement the Template’s links. You can assign a priority level to links 
in a Template by clicking the Priority-Value field and selecting a priority value. The lowest priority level, 
highest priority level, and default priority (the priority of any link that has not been set) are determined by 
a file on the Active System Manager server. If these values have not been modified, they are preset with 
the following values: highest priority is 5, lowest priority is 1, default priority is 1. You can change these 
values on the server in the config.properties file. 

Note From the Sessions perspective, you can specify the link priority only if the value of 
lmc.linkpriorityenabled is set to “true” in config.properties while deploying the 
Active System Manager application.

Common Features of the Session Link Editor
Below are some of the common features of the session link editor:

• The link editor comprises three parts: a left pane with the selected element, the middle pane that displays 
any links, and the right pane that displays the other elements in a tree view.

• The top action bar (see Figure 9-21) that allows you to define link types, as well as building better 
connectivity.

Figure 9-21 Top Action Bar—Link Editor

• When you create a link in the link editor, the links also display in the session editor. To avoid confusion, 
the link editor displays links from left to right. The right pane displays the connectivity from one 
resource to another, but the source is unknown. To find the source, in the right pane, select the resource, 
right-click and select Move to Left. The resource moves to the left pane. 

• You can share the resource; for example, you can request the scheduler to allow for a subset of the 
interfaces.

Quick Filtering
In the Filter text box (see Figure 9-21), enter a string to search and filter out elements on the right pane 
content. This is useful when working with a large set of resources and the focus is on specific end-devices 
and connectivity.
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Link Type Selector
Creating links usually defines a link as “Simplex” (the default). On the action bar (see Figure 9-21), you 
can set other available options by selecting a link and applying a specific link type. The default is 
“Simplex”.

Table 9-6 lists and describes the filters available on the link editor You can identify the different types of 
links (through their link end point decorations); see each respective figure for each link type to view the 
end point decorators.
Table 9-6 Link Editor Filter Options

Icon Description

Allows links to go in one direction; see Figure 9-22.

Allows links to go in both directions; see Figure 9-23.

Allows links to go to multiple receivers; see Figure 9-24.

Allows the source end of the connection into move to multiple directions; see Figure 9-25.

Figure 9-22 Simplex
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Figure 9-23 Duplex

Figure 9-24 Multicast
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Figure 9-25 Tap

Link Feasibility Toolbar
The link feasibility icons (mutually exclusive) allow you to build connectivity within your Template while 
being aware of your underlying physical connectivity and compatibility between interface types.

• Show Static or Switched Interfaces Only—To use this icon option, you must first select a resource 
type or resource instance. Effectively, this option removes interfaces that are not connected via the 
underlying infrastructure.

• Show Existing Physical Connectivity—Shows or hides all possible connectivity. Select one or more 
of the drawn links and right-click Create Link.

Note To display current, possible connectivity, perform the following steps:

1. Select a resource instance and interface end point.

2. Right-click (or press F2) to display the Quick Connectivity dialog box. 

3. Select an entry in the dialog box to author the resource and interface into the Template.
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Creating Session Links
To create a session link, perform the following steps:

1. Select an interface in the left pane and drag it to the right pane, or from right to left. 

The Create Link dialog box displays; see Figure 9-26.

Figure 9-26 Create Link

2. By default, a link (with assigned properties) is automatically named; for example, Link_n. Link names 
must be unique. To change the link name, click the Name field and enter a new link name.

3. Optional. Click the Description field and enter a description for this link.

4. Click OK.

To display link properties, perform one of the following methods:

• In the link editor, select a simple link.

• In the Outline view, select a simple link.

The Link properties display in the Link Properties view—Link tab; see Figure 9-27 for an example. 
Session link properties cannot be modified.

Figure 9-27 Link Properties Example
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Table 9-7 lists and defines the default properties for the selected links. 

Table 9-7 Default Session Link Properties 

Property 
Name Description

Name Name you assigned to this link, or the default name assigned by the Template perspective. Enter a 
link name of up to 80 alphanumeric characters, including spaces and special characters.

Description Text string that describes this link. 

Type Type of link: simple.

Note You can also perform loopbacks; for example, a loop back to itself on two different ports. 
Loopbacks are only allowed in the left pane, not the right pane. Adding VLAN switching is also 
available in the session if there are more than two VLANs authored.

Disabling and Enabling Session Links
By default, session links are enabled. To disable and enable session links, perform the following steps:

• To disable: With a session open, click the session editor, right-click one or more session links and 
select Disable; see Figure 9-28. 

Figure 9-28 Disabling Session Links

• To enable a session link that you disabled: With a session open, click the session editor, right-click 
one or more session links and select Enable. 

Note Disabled links do not have an impact on underlying physical structure during the Cleaning Up state.
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Handling Link Preemption
For information about creating new links and link priority, see Chapter 6, “Using Inventory.” 

If a path segment (part of one of your links) is preempted while the session is running, the preempted link 
displays in red. You can try reconnecting the link by right-clicking it and selecting Retry.

To delete the links, right-click the links to delete and select Break Link. 

You can add session links by switching to the link editor and dragging the link from one interface to a 
second one.

Managing Session Resources
You can add resources, make them inactive, and remove them from ongoing sessions to maximize resource 
allocation. The system scheduler is involved in committing any changes that affects resource allocation.

The following sub-sections describe how to manage session resources:

• Understanding Resource Representation

• Displaying Resource and Link Status

• Displaying Resource Instance Properties

• Adding Resource Instances

• Substitution Resource Instances

• Deactivating and Activating Resources

• Deleting Resources

Understanding Resource Representation
Managed Equipment are represented with a single icon. Virtual equipment can be represented as groups in 
a single icon to facilitate the management of a larger set of resources; see Figure 9-29.

Figure 9-29 Session Example with 1 Virtual Group of 5 Resources and 1 Managed Resource

To interact with a Managed Equipment resource, perform the following steps:

1. Open a session editor; see the “Opening the Session Editor” section on page 9-8.

2. In the session editor, select the resource.

3. Right-click and select one of the operations for this resource.
9-32 Active System Manager User Guide, Release 7.0



Working with Running Sessions
When interacting with a group of virtual resources, you must first identify the resource in the group to 
interact with as follows:

1. Open a session editor; see the “Opening the Session Editor” section on page 9-8.

2. In the session editor, select the group.

3. Right-click and select Switch To > resource ID > resource by name.

The selected resource name will be set in the session editor.

4. Right-click and select one of the operations for this resource.

Displaying Resource and Link Status
The Active System Manager software can monitor resources and connectivity by invoking specific 
Resource Adapter methods on end resources, end-resource interfaces, and underlying physical Layer 1 or 
Layer 2 switches responsible for establishing logical connectivity in the running sessions. The status for 
resource and connectivity translates into color in the session editor.

Note Session resources and links are assigned colors. Status colors can be customized per deployment 
and not per user profile. 

Note The following feature is only available if the underlying Resource Adapter supports such 
functionality. Please check your Resource Adapter README/About content to check for Status 
Monitoring support.

Figure 9-30 Session with Monitoring “on”
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Displaying Resource Status
To display a resource’s status, perform the following steps:

1. Open a session editor; see the “Opening the Session Editor” section on page 9-8.

2. In the session editor, select a resource and click the Link Editor tab.

The resource and interface status displays in the label; see Figure 9-31.

Figure 9-31 Resource Status

Figure 9-32 Interface Status
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Displaying Link Status
To display link status, perform the following steps:

1. Open a session (or link edit); see the “Opening the Session Editor” section on page 9-8.

2. In the session editor, select a resource and click the Link Editor tab.

3. Click the Properties tab (view) and select the link.

4. Click the Realization tab.

The Realization path properties identify both end points of the underlying connectivity; see Figure 9-33.

Figure 9-33 Realization Path Properties

You can also look at the underlying Layer 1 or Layer 2 port-level status by selecting a realization path in 
link realization tab and right-click Show Status Details. Or, you can bring up a port-level diagnostic tool. 
To do so, perform the following steps:

1. Open the Resource Instance view and navigate to the Layer 1 or Layer3 matrix switch type resource.

2. Select the resource, right-click Show Resource Status or press F2.

A list of all ports displays with the latest status, message, and timestamp. Figure 9-34 displays the 
resource status example using the right-click (Show Resource Status) option.

Figure 9-34 Resource Status Using the Right-Click (Show Resource Status) Option

Figure 9-35 displays the resource status example using the F2 key.
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Figure 9-35 Using the F2 Key

Displaying Resource Instance Properties
To display resource instance inventory properties, perform the following steps:

1. With a session open, click the session editor and select a resource instance. (The Properties view must 
also be open.) Selecting a resource instance in the session editor will automatically refresh the content 
of the Properties view.

Table 9-8 defines tab names, description, and user action of the Resource—Properties view.
Table 9-8 Resource Properties 

Tab Name Description User Action

Resource Displays resource-level information based on inventory. 
Note: If you have selected a virtual resource, note the 
Host * properties (Host Asset Tag, Host Version, Host 
Manufacturer, Host Model, Host Domain) have been 
added. This indicates where the virtual resource is being 
hosted.

Read-only.

Provisioning Properties have been added by the Resource Adapter 
Framework (RAF) during the setup process. Read-only 
properties cannot be updated, others can. Some 
properties are grayed out based on the read-only state.

Some property values can be 
overwritten. You can also Add, 
Remove, or edit provisioning 
properties.
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Displaying Link Session Properties
To display link session properties, with a session open, click the session editor and select a link or click the 
Link editor tab. If there are multiple links between two resources, the link in the Template window is shown 
with a thicker line.

Table 9-9 defines tab names, description, and user action of the Link Session—Properties view.
Table 9-9 Link Session Properties

Tab Name Description User Action

Link Displays link properties. Read-only.

Provisioning List of property name values associated with the link. Read-only.

Realization Displays Resource Adapter operations associated with the creation of the 
connectivity (Layer 1 or Layer 2). If Layer 1, routing information with proper 
endpoints will be identified. 

Read-only.

Adding Resources by Type
To add resources by type, perform the following steps:

1. Open a session editor > Resource Types view.

2. Drag a resource type node into the session. The outline indicates that the node has not yet been allocated 
to your session. 

3. Enable interfaces.

4. Set the properties as required:

• Use the Resource tab to set exclusivity.

• Use the Inventory tab to set characteristics of the desired resource.

• Use the Configuration Files and Image Files tabs if you need provisioning.

5. Save the session (File > Save or click Ctrl+S). 

The scheduler determines the best resource to be allocated and adds into the session. The resource 
operations, such as Resource Adapter setup methods, will be executed once the resource has been 
allocated.

Realization Displays Resource Adapter operations during setup and 
teardown operations by providing logs. Current status is 
also provided. Same information is also visible in the 
Audit Log (Report > Session Audit Report).

Read-only.

Configuration 
Files

Displays how the resource was configured by Resource 
Adapters based on the original Template requirement or 
last system operation.

To change configuration file settings, 
in the session editor, execute 
System Operations > Apply 
Configurations.

Image Files Displays how the resource was configured by Resource 
Adapters based on the original Template requirement or 
last system operation.

To change configuration file settings, 
in the session editor, execute 
System Operations > Apply Image 
Files.

Table 9-8 Resource Properties (continued)

Tab Name Description User Action
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Adding Resource Instances
To add resource instances, perform the following steps:

1. Open a session editor > Resource Instances view.

2. Drag a resource instance node into the session. 

The outline is yellow, which indicates that the node has not yet been allocated to your session. 

3. Enable interfaces.

4. Set the properties as required. Use the Configuration Files and Image Files tabs if you need 
provisioning.

5. Save the session (File > Save).

The scheduler determines the best resource to be allocated and adds into the session. The resource 
operations, such as Resource Adapter setup methods, will be executed once the resource has been 
allocated.

Note If the scheduler cannot allocate this resource for this session, the dependency manager will list all 
sessions.

Substitution Resource Instances
Resource instances can be swapped or substituted as soon as a session is in a Confirmed or Running state.

To substitute resource instances, perform the following steps:

1. Open a Running or Confirmed session.

2. In the Template editor, select a resource instance, right-click and select Substitute.

The Resource Substitution dialog box displays with the Automatic Substitution Option selected by 
default; see Figure 9-36. 

Figure 9-36 Resource Substitution 
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3. Select a substitute option:

• Automatic—Allows the Active System Manager software to determine (based on current 
allocation and availability) a new resource that satisfies the original requirement.

• Select resource from reserved pool (For Administrators Only)—For more information about 
resource pooling, see the “Managing Resource Pools” section on page 5-52.

• Manual—Allows you to select from the existing resources available in the inventory.

4. Click OK to replace the existing resource with the new resource.

If the session is in a Running state, the Resource Adapter methods are invoked as part of the default 
setup process. 

Deactivating and Activating Resources
Deactivating a resource during the session life cycle does put the resource back into the free pool of 
resources, but it is still displayed in the session as a convenience. 

To deactivate resources, perform the following steps:

1. Open a session editor.

2. Right-click a resource and select Status > Inactive.

The editor displays with the inactive resources; see Figure 9-37.

Figure 9-37 Deactivating a Resource (Example)

3. Save the Template for the changes to take effect.

Operations on the inactive resource are no longer available. To return the resource into Active State 
again (activating), in the editor, right-click your resource and select Status > Active.

4. Save the Template for the changes to take effect and to invoke the scheduler and Resource Adapters.
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Deleting Resources
Inactive resources can be deleted from the session editor. The only way to bring the resource instance back 
into the session editor is to drag it from the Resource Instances view or the Search results view; see the 
“Adding Resource Instances” section on page 9-38.

To delete resources, perform the following steps:

1. Open a session editor.

2. Select an inactive resource in the editor.

3. Right-click and select Delete.

4. Save the Template for the changes to take effect.

Using Annotations
For detailed information about using annotations, see the “Using Annotations” section on page 8-41.

Associating Scripts to Sessions
You can associate scripts (and test cases associated with the Template being scheduled) with sessions at the 
time of scheduling or post-scheduling. If there is an association, the script will be executed when the session 
enters a Running state, and the Active System Manager server can monitor and report the test case 
execution result.

Figure 9-4 on page 9-7 and Table 9-2 on page 9-7 define Active System Manager session states.

There are three types of scripts that you can execute:

• Shell scripts (CLI-based); remote hosts should be provisioned with remote shell access or SSH access.

• HTTP-based scripts; an administrator should provision, at least, one HTTP server using the Active 
System Manager web interface (Tools > Script Servers > New).

Note One or more scripts can be applied to a session. 

To associate a script to a session, perform the following steps:

1. Perform one of the following tasks to open the Script Association window/page:

• At the time of scheduling, using the scheduling wizard (see the “Scheduling Templates” section on 
page 8-18. At step 9 in that procedure, stop, and continue with this procedure).

• In the Session view, edit a session and select the script property and the Association tab.

The Rescheduling Session—Associate Scripts/Test Cases dialog box displays; see Figure 9-38.
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Figure 9-38 Associating a Script on a Confirmed Session

2. Select the Associate Script/Testcase option and add a script (see step 3).

Associate Script/Testcase—The hostname, username, password, script, and Is Secure and Timeout 
(Mins) value can be automatically generated from your preferences that you set up in Figure 9-38. You 
can modify all six values, if necessary. Selecting the Secure check box encrypts all communication 
between the Active System Manager application and the remote script execution. Script names with a 
full path should be provided; for example, /home/user/testing/validatenetwork.sh.

3. For the Associate Script/Testcase option only, you can add or remove script definitions using the Add 
or Remove buttons. You can add from three different repositories:

• Add Default Script

• Add from Repository (built-in)

• Add from HTTP Server

4. Optional. Click the Description field and enter a description for the association. 

5. Optional. Click the Execute Sequentially check box to force the executions in a sequential order.

6. Click Next (in the scheduling wizard) or otherwise, click OK.

On completion of the wizard, a new session is created:

• The Sessions view displays sessions associated with scripts. A new indicator displays for each new 
session.

• The Execution Queue view has an added script that reflects the script association properties associated 
with a session.
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To set or view script association preferences, see the following sub-sections:

• Setting Script Association Preferences

• Viewing Session Script Properties

Setting Script Association Preferences
To set script association preferences, perform the following steps:

1. On the Active System Manager menu bar, click Window > Preferences > Test and Script Execution.

2. Click the Script and Folder Location fields and set the default values, respectively. 

These field preferences point to your Active System Manager file system. 

The Secure check box represents secure communication from and to the execution host.

3. Click OK.

Viewing Session Script Properties
To view session script properties, perform the following steps:

1. In the Sessions view or session editor, right-click a session and select Edit > Script.

The script properties display; see Figure 9-38 on page 9-41 for an example.

The properties are read-only and display the properties defined at scheduling time. You can modify 
these properties only when the session is in a “Confirmed” state.

2. Click OK to save and exit.

Archiving Sessions
Typically you may want to archive older sessions, depending on the archive rules defined by your Active 
System Manager administrator. You retain the ability to search such sessions within the Archive Bin.

You can archive sessions using either of the following views:

• Archiving Sessions Using the Sessions View

• Archiving Sessions Using the Session Archive Bin View

• Restoring Archived Sessions

Archiving Sessions Using the Sessions View
To archive sessions using the Sessions view, perform the following steps:

1. On the Active System Manager menu bar, click Window > Show View > Sessions > OK. 

2. In the Sessions view, right-click a session, and select Move to Archive Bin. 

3. Click OK when the Confirm Archiving Operation dialog box displays.
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Archiving Sessions Using the Session Archive Bin View
To archive sessions using the Session Archive Bin view, perform the following steps:

1. On the Active System Manager menu bar, click Window > Show View > Other > Session Archive 
Bin > OK. 

The Session Archive Bin view displays; see Figure 9-39.

Figure 9-39 Session Archive Bin View

2. Select the session you want to archive within the Sessions view.

3. Drag the selected session from the Sessions view to the Session Archive Bin.

Note You can also specify an Archive Bin rule by one of these methods:

• On the Active System Manager menu bar, click Window > Preferences > Archive Bin.

• On the Active System Manager menu bar, click Tools > Archive Bin Rules > Edit.

You can create an Archive Bin rule for a session or Template, and then execute these rules; on the 
Active System Manager menu bar, click Tools > Archive Bin Rules > Run. This process runs all 
of the rules specified in the Archive Bin preferences.

Restoring Archived Sessions
To restore an archived session to your Active System Manager workbench, perform the following steps:

1. Open the Session Archive Bin view: on the Active System Manager menu bar, click Window > Show 
View > Other > Session Archive Bin > OK.

2. Select the associated session and perform one of the following options:

• Drag it to the desired location within the Session view.

• In the Session Archive view, right-click and select Restore. When prompted to confirm the Restore 
operation, click OK.
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Working with Archive Bin Rules

Note All users retain the ability to search such templates and sessions within the Active System Manager 
Archive Bin.

Note You may want to archive older templates and sessions, depending on the Archive Bin rules defined 
by the Active System Manager administrator.

The following sub-sections describe how to work with Archive Bin rules:

• Setting Archive Bin Rules

• Running Archive Bin Rules

• Editing Archive Bin Rules

• Deleting Archive Bin Rules

Setting Archive Bin Rules 
To set the Archive Bin rules for templates and sessions, perform the following steps:

1. Open the Preferences—Archive Bin dialog box (see Figure 9-40) by one of the following methods:

• On the Active System Manager menu bar, click Tools > Archive Bin Rules > Edit.

• On the Active System Manager menu bar, click Window > Preferences > Archive Bin.

Figure 9-40 Preferences—Archive Bin 
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2. In the All filters section, perform the following sub-steps:

a. Click Add.

b. Click the Name field and type a rule name that you want to keep for the rule you are defining.

c. Click the Type field and select archive or session type. If you select archive type, see the 
corresponding property types in the Templates column in Table 9-10; if you select the session type, 
see the corresponding property types in the Sessions column in Table 9-10. 

3. In the Filter rules section, perform the following sub-steps:

a. Click Add.

b. Click the Property field and set the session property type from the properties listed in Table 9-10.

Table 9-10 Corresponding Property Types 

Sessions Description Templates (archive) Description

Template Name Name of the underlying Template created. Owner Name of individual who created the 
Template.

Start Date/Time Start date and time of when the environment 
session is scheduled. The start time cannot be 
edited if the session is already in progress.

Created On Date when the Template was created.

End Date/Time End date and time of when the environment 
session is scheduled. Can be updated based 
on resource availability; that is, not booked by 
someone else.

Status Session status; see the “Viewing Session 
Properties” section on page 9-15.
The valid session status that can be specified 
is one of the following:
• Canceled
• Completed
• Failed

Owner Name of individual who created the session.

Note For the archive type, the Owner and Created On properties are available.

c. Click the Operator field and select one of the following values:

• Is—Available only with the Template Name, Status, Owner properties. The value string must 
match the entry exactly.

• Is After—Available only with the Start Date/Time and End Date/Time properties. 

• Is Before—Available only with the Start Date/Time and End Date/Time properties. 

4. Click the Value field and set a date in mm/dd/year format. To view a list of possible valid values, mouse 
over the light bulb icon or press Ctrl+Space to view the options.
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5. Click the Match [all] or [any] of the above rules field and select all or any.

• The all option functions the same way as the AND logic feature. All of the rules must be met before 
the entry displays. 

• The any option functions the same way as the OR logic feature. If any of the rules are met, then the 
entry displays.

Note You can define multiple rules; for example, one for templates, one for dates, and so on.

6. Click Apply > OK.

Running Archive Bin Rules
To run the Archive Bin rules, perform the following steps:

1. On the Active System Manager menu bar, click Tools > Archive Bin Rules > Run to display the 
Archiving dialog box.

Note The Session Archive Bin includes a calendar, and as such, this Archive Bin includes the same fields 
as the normal Sessions view.

2. Click OK to accept the process.

Based on the rules, when Archive Bin rules are run, the affected templates and sessions will be moved to 
the archive bin. Archived templates are available in the Template Archive Bin view and archived sessions 
are available in the Session Archive Bin.

Editing Archive Bin Rules
To edit Archive Bin rules, perform the following steps:

1. Open the Archive Bin dialog box (see Figure 9-40 on page 9-44) by one of the following methods:

• On the Active System Manager menu bar, click Tools > Archive Bin Rules > Edit.

• On the Active System Manager menu bar, click Window > Preferences > Archive Bin.

2. Modify the settings, as appropriate, and click Apply > OK.

Deleting Archive Bin Rules
To delete Archive Bin rules, perform the following steps:

1. Open the Archive Bin dialog box (see Figure 9-40 on page 9-44) by one of the following methods:

• On the Active System Manager menu bar, click Tools > Archive Bin Rules > Edit.

• On the Active System Manager menu bar, click Window > Preferences > Archive Bin.

2. In the All filters section, select and click the Archive Bin filters to delete.

3. In the Filter rules section, select and click the Archive Bin rules to delete.

4. Click Apply > OK.
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Supporting Layer 2 Switching
During the life of a running session, session owners can operate on a VLAN in similar ways as in Template 
authoring. The following operations are allowed in the session when it comes to VLAN management:

1. A new VLAN component can be introduced to indicate new VLAN connections between resources.

2. Adding resources into a VLAN by setting proper VLAN IDs or allowing the underlying switch select 
the VLAN ID while creating a link between the VLAN component and the resource.

3. Multiple VLAN IDs can be specified on the same VLAN component in the running session. The 
specified VLAN IDs can be in the form of range as well. 

4. VLAN groups can be accessed from any session

5. Removing resources from an existing VLAN by breaking the virtual link.

6. Remove a VLAN Layer 2 switching component from the session, which will automatically break the 
VLANs.

7. VLAN switching is also available when multiple VLAN IDs are available in the session. This allows 
an automatic re-allocation of connectivity from one VLAN component to the next without performing 
those actions manually.

Figure 9-41 Layer 2 Template
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Updating VLAN IDs in a Running Session
In a running session, you can add a new VLAN component and provide VLAN IDs by entering values in 
any of the following properties:

Note Updating values in a running session is irrelevant if a VLAN component is already scheduled.

• VLANCount Value

• VLANId

• VLANGroup

• Assettag

VLANCount Value
The VLANCount provisioning property facilitates you to fetch the user-defined range of VLAN IDs from a 
group associated with VLAN component. By entering a count value in the VLANCount, you can assign 
random values, as per the count, to the VLAN component. For example; if you specify a count of 4, the 
scheduler searches across the matrix switch to randomly assign any four VLAN IDs to the VLAN 
component. 

Note If the VLANCount value is blank, the Active System Manager scheduler selects a VLAN ID 
randomly from the associated group, and allocates it to the VLAN component. However, if 
VLANCount is specified and VLANGroup is not specified, then the Active System Manager 
scheduler randomly picks the VLAN IDs and associates it with corresponding VLAN component.

To provide count of VLAN IDs to be assigned to the VLAN component, enter the required count value in 
VLANCount; see Figure 9-42.
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Figure 9-42 Assigning VLAN Count to VLAN Component

Note The VLANCount or VLANId property can contain value at a single point of time.

VLANId
The VLANId provisioning property facilitates you to provide comma separated single or multiple VLAN 
IDs to the VLAN component. In case of multiple VLAN IDs the value can be provided in the value range 
format (10..15).

Note If the VLAN ID is blank, the VLANId value is automatically assigned by the Active System 
Manager software at the time of the realization; or else, the VLAN ID must be a valid number that 
you set in your inventory

To assign a VLAN ID to the VLAN component, enter the valid VLANId value; see Figure 9-43.
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Figure 9-43 Assigning VLAN ID to VLAN Component

VLANGroup
The VLANGroup inventory property facilities you to provide VLAN IDs in a group. Creating groups for 
VLAN IDs facilitates you to map your VLAN ID requirements with the existing group names, so as to 
choose from a set of VLAN IDs as per your requirements. 

The VLAN groups are created on a matrix switch. To create a VLAN ID group, you are required to define 
the group name in curly brackets, and its corresponding VLAN IDs or ranges must be in parenthesis; for 
example: {gp1}(20..25).

Note Groupname is associated with assettag and it is mandatory to select an asset tag before selecting a 
value for VLANGroup.

Note You can associate only one group at a time with the VLAN component. 

To assign a VLANGroup to the VLAN component, press Ctrl+spacebar and select the group name; see 
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Figure 9-44 Assigning VLANGroup to VLAN Component

On saving the value assigned to VLANGroup, the schedular randomly assigns value from the range for the 
selected group, and assigns the value to the VLAN component; see Figure 9-45.
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Figure 9-45 VLAN ID Assigned from Selected Group Range

Assettag
The Assettag associates a VLAN ID with a matrix switch. 

To assign value to the Assettag inventory property, press Ctrl+spacebar to select the matrix switch value; 
see Figure 9-46.
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Figure 9-46 Assigning Value to Assettag 

Note If you select a value for Assettag inventory property and VLANGroup value is blank, then the 
scheduler searches across selected matrix switch, and assigns a random VLAN ID to the VLAN 
component. However, if both the assettag and VLANGroup properties contain a value, then the 
scheduler assigns a VLAN ID to the VLAN component from the selected VLANGroup range.

On saving the value assigned to the Assettag property, the schedular assigns a VLAN ID to the VLAN 
component; see Figure 9-47.
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Figure 9-47 VLAN ID Assigned to VLAN Component

Deleting a VLAN Component from a Running Session
To delete a VLAN component from a running session, perform the following tasks:

1. Right-click a VLAN component, select Status and click Inactive; see Figure 9-48.

Figure 9-48 Inactivating VLAN Component
9-54 Active System Manager User Guide, Release 7.0



Working with Running Sessions
2. Click Save.

3. Right-click the VLAN component and click Delete; see Figure 9-49.

Figure 9-49 Deleting VLAN Component

4. Click Save to delete the VLAN component.

Saving Sessions
The session editor allows you to save the current configuration at any time and the Template is saved to the 
Active System Manager archive, so that the next time you use the equipment, you can continue from where 
you last worked on that session. 

To save the session as a Template, the following conditions must be met:

• The session must be in a running state.

• All resources must be powered on.

To save a session, with the working Template open, perform the following tasks:

1. Select a method to access the Save As dialog box (see Figure 9-50) and apply the save to the currently 
selected session:

• On the Active System Manager menu bar, click File > Save As. 

• In the Sessions view, right-click a running session and select Snapshot.
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Figure 9-50 Saving the Session as a New Template

Note You can modify certain parameters (see Table 9-5 on page 9-18) and save any session you create. 
The default name you use for the session in the Session properties dialog box (see Figure 9-15 on 
page 9-18), determines how the session is recognized in the Active System Manager archive.

2. Click the Name field and enter a name for the Template. 

Do not use the original name. Enter descriptive text in the Description field. The current state of your 
work is saved to a new file in the archive and the original Template is not modified.

3. Optional. Click the Description field and enter a description for this Template.

4. Click the Option field and select one of the following asset tag options:

• Save all resources as specific resource instances—Saves the current state of your network. All 
asset tags, that were assigned when the Template was realized, are saved in the Template. The next 
time the Template is realized, the exact same equipment is used. Resources that were authored “by 
resource type” in the Template are now “by asset tag”.

• Save all resources as generic resource types—Removes all asset tags from the Template, even 
from resources that were authored “by asset tag”.

• Save resources as originally authored—Keeps the “by asset tag” or “by resource type” setting of 
the resources as it was in the original Template.

5. Select an archive option:

• Select the Public button to make this Template available to all Active System Manager users. 

• Select Private if you do not want anyone else to access it. 

6. Click the Keep existing history details check box to carry the existing notes to the new Template. 
Deselect the check box to clear all existing notes. The default is for the check box to be enabled.

7. Click OK to save the session as a Template. 

The watermark in the session editor changes its states during the process of saving. 
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Note The Save feature only commits changes to templates in the Public or Private area within the 
system. Use a new Template name when using the Save As feature. If you save a Template, the 
Active System Manager software adds it to the Active System Manager archive. To view changes 
made to the saved Template, perform the following steps:

1. With a working session open, select the Templates view.

2. Select the Template to view and ensure that your Template is displayed with the Public or 
Private archive mode. You can check the archive mode in one of two ways:

•   Select the editor background and click the Properties view.

•   Check the filtering rules assigned; for more information, see the “Filtering” section on 
page 1-12. 

The new Template should be listed in the view and can now be viewed, deleted, exported, or 
reserved for a new environment session.

Note Only the Template is saved, with or without asset tags as you request. The configuration files in the 
Active System Manager archive are not changed.

Configuring Session Notifications and Reminders

The Active System Manager software includes a notification mode and a reminder mode that enables users 
and administrators to set flexible session notifications for all session state changes (such as Canceled, 
Completed, Confirmed, Failed, and Running) and reminders for starting and ending a session. For the 
session state workflow, see Figure 9-4 on page 9-7, and their description, see Table 9-2 on page 9-7.

Note Notifications and reminders are sent as email messages with a 1:1 relationship; that is, one email is 
sent for each notification and each reminder.

The Active System Manager administrator sets the system-wide preferences for the session notifications 
and you may receive notifications based on those system preferences. However, you can override them by 
setting your own preferences, and you can also set your own notifications on an individual per-session 
basis. You can set default notification preferences via the Preferences dialog box. For more information, 
see the “Preferences” section on page 1-27.

This section describes how you can use the Preferences—Session Notifications dialog box to set the various 
notification options for your own sessions, or on a per-session basis.

This section describes how to configure session notifications:

• Setting Session Notifications and Reminders

• Adding Session Notifications

• Editing Session Notifications

• Deleting Session Notifications

• Adding Session Reminders

• Editing Session Reminders

• Deleting Session Reminders
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Setting Session Notifications and Reminders
To set session notifications and reminders, perform the following steps:

1. On the Active System Manager menu bar, click Window > Preferences > Scheduler > Notifications 
and Reminders. 

The Preferences—Notifications Reminders dialog box displays; see Figure 9-51.

Figure 9-51 Preferences—Notifications Reminders (for Sessions) Dialog Box

2. In the Global Session Notifications section, click the Active check box for each notification and 
reminder rule to enable it so that the server will look it up.

3. Click Apply > OK to accept the updates.

Adding Session Notifications
To add session notifications, perform the following steps:

1. On the Active System Manager menu bar, click Window > Preferences > Scheduler > Notifications 
& Reminders.

The Preferences—Notifications Reminders dialog box displays; see Figure 9-51 on page 9-58.

2. Click Add > Notifications.

The Session Notification—Add Session Notification dialog box displays with the Events tab open; see 
Figure 9-52.
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Figure 9-52 Add Session Notification—Events Tab Dialog Box 

3. In the Rule section, perform the following sub-steps:

a. Click the Name field and type a name for the notification rule. 

Note A notification rule cannot be saved without a name.

b. Click the Description field and type a corresponding description for the notification rule.

c. Click the Scope field and select All Sessions (System Wide).

By default, the administrator can view and access two scope types:

• All Sessions (System Wide)

• My Sessions (Owned)

4. In the Session Notification Criteria section, select one or more session notification criteria:

• On date/time start/end changes

• On ASAP rescheduling

• On name change only

• On participants list change

• On ownership change
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• On session resource change 

• On status change

5. Optional. If you select the On status change check box in step 4, select the session status to change. If 
not, skip this step and go to step 6.

Status options include:

• Canceled

• Cleaning Up

• Completed

• Confirmed

• Deleted

• Failed

• Running

• Setting Up

• Snapshot 

Figure 9-4 on page 9-7 illustrates the session state workflow associated with these sessions and 
Table 9-2 on page 9-7 provides a description of those states, as well as defines the various modes and 
states of the Sessions perspective while processing a session request.

6. Click the Format tab. 

The Add Session Notification—Format Tab dialog box displays; see Figure 9-53.

Figure 9-53 Add Session Notification—Format Tab
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7. In the Email Recipients section, select one or more email recipients:

• Owner—Owner of the session notification.

• Participants—Participants of the session notification.

• Other—List of email addresses you enter, separated by a semicolon.

8. In the Email Format section, select the email format that the Active System Manager system sends out:

• Plain text—Email is provided in plain text format.

• iCalendar—Email is provided in a Microsoft Exchange- or Mozilla-compatible format. Select 
between Free or Busy, to display in your calendar.

9. Click OK > Apply > OK.

Editing Session Notifications
To edit session notifications, perform the following steps:

1. On the Active System Manager menu bar, click Window > Preferences > Scheduler > Notifications 
& Reminders.

The Preferences—Notifications Reminders dialog box displays; see Figure 9-51 on page 9-58.

2. Select one (and only one) session notification or reminder to edit and click Edit.

The Add Session Notification dialog box displays with the Events tab open; see Figure 9-52 on 
page 9-59.

3. Edit the session notification criteria, as necessary, and click OK.

Deleting Session Notifications
To delete session notifications, perform the following steps:

1. On the Active System Manager menu bar, click Window > Preferences > Scheduler > Notifications 
& Reminders.

The Preferences—Notifications Reminders dialog box displays; see Figure 9-51 on page 9-58.

2. Select one (or more, by pressing Ctrl+click) session notifications to delete and click Delete.

3. Click Apply > OK.

Adding Session Reminders
Session reminders are different from notifications in that reminders provide advance notice of session start 
and end times (not status changes and error conditions). 

To add session reminders, perform the following steps:

1. On the Active System Manager menu bar, click Window > Preferences > Scheduler > Notifications 
& Reminders.

The Preferences—Notifications Reminders dialog box displays; see Figure 9-51 on page 9-58.
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2. Click Add > Reminders.

The Add Session Reminder dialog box displays; Figure 9-54.

Figure 9-54 Add Session Reminder

3. In the Rule section, perform the following sub-steps:

a. Click the Name field and type a name for the reminder rule. 

Note A reminder rule cannot be saved without a name.

b. Click the Description field and type a corresponding description for the reminder rule.

c. Click the Scope field and select All Sessions (System Wide).

By default, the administrator can view and access two scope types: All Sessions (System Wide) or 
My Sessions (Owned).

4. In the Email Recipients section, select one or more email recipients:

• Owner—Owner of the session notification.

• Participants—Participants of the session notification.

• Other—List of email addresses you enter, separated by a semicolon.

5. In the Before Start Time (Minutes) section, select one (or more) of the following values in minutes: 
5, 15, 30, 45. Or, you can click the Custom check box and specify a value in hours or days.

6. In the Before End Time (Minutes) section, select one (or more) of the following values in minutes: 5, 
15, 30, 45. Or, you can click the Custom check box and specify a value in hours or days.

7. Click OK.
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Editing Session Reminders
To edit session reminders, perform the following steps:

1. Open the Preferences—Notifications Reminders dialog box by one of the following methods:

• In the Sessions view or session editor, select a session to set the reminder options, right-click and 
select Edit.

• On the Active System Manager menu bar, click Window > Preferences > Scheduler > 
Notifications & Reminders.

The Preferences—Notifications Reminders dialog box displays; see Figure 9-51 on page 9-58.

2. Select one (and only one) session reminder to edit and click Edit.

The Add Session Reminder dialog box displays; see Figure 9-54 on page 9-62.

3. Edit the session reminder criteria, as necessary, and click OK.

Deleting Session Reminders
To delete session reminders, perform the following steps:

1. On the Active System Manager menu bar, click Window > Preferences > Scheduler > Notifications 
& Reminders.

The Preferences—Notifications Reminders dialog box displays; see Figure 9-51 on page 9-58.

2. Select one (or more, by pressing Ctrl+click) session reminders to delete and click Delete.

3. Click Apply > OK.

Starting and Stopping ASAP Rescheduling

When you create a session, you can specify to start the session as soon as all the required resources become 
available. This is called an ASAP session. The Active System Manager software schedules the session at 
the earliest time it can find, and sets the entry’s state to Confirmed.

If other sessions cancel or finish early, there is an opportunity for a previously confirmed ASAP session to 
move up to an earlier time slot. ASAP does this automatically. The Active System Manager administrator 
can enable or disable this feature and the Active System Manager (web GUI) Welcome page displays its 
status. Typically, rescheduling occurs when a session is canceled or edited to terminate early.

Before canceling multiple sessions, it is sometimes useful to stop the ASAP Rescheduling engine. You can 
start and stop ASAP Rescheduling by one of the following methods:

• On the Active System Manager menu bar, click Window > Preferences > Scheduler > ASAP 
Rescheduling. Make necessary schedule updates and click OK.

• From the session/resource calender, right-click a session and select Start Automatic Rescheduling or 
the Stop Automatic Rescheduling menu; see Figure 9-55.
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Figure 9-55 Start and Stop Automatic Rescheduling Menu Options

Managing Virtual Resources

Note All operations associated with managing session resources applies to virtual resources only. For 
information about inventory management used to model virtual resource types and resources, see 
Chapter 5, “Inventory Management.”

If you are working with session elements modeled as virtual resources, there are few more operations 
available to you. Those operations reflect enhanced management capability around the use of virtual 
resources, those that reside and run on hypervisor class resources. To understand more about virtual 
modeling, see Chapter 5, “Inventory Management.” This section describes the following topics:

• Verifying Virtual Resource Data

• Duplicating Virtual Resources

• Relocating Virtual Resources

• Scaling Up Virtual Resources

Verifying Virtual Resource Data
To verify virtual resource data, perform the following steps:

1. Open a session editor; see the “Opening the Session Editor” section on page 9-8.

2. Select a virtual resource.

3. In the Properties view:

a. Click the Resource tab. 

b. Check the Hypervisor Host properties (Manufacturer, Model, and Asset Tag) to determine where 
this virtual resource is actually running.

4. In the Properties view, click the Elasticity tab to understand the capacity constraint associated with the 
virtual resource.
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Duplicating Virtual Resources
This procedure allows you to quickly clone a virtual resource in your environment by adding a new 
resource with same characteristics as the one selected. Set-up script will be also running during this 
operations.

To duplicate virtual resources, perform the following steps:

1. Open a session editor; see the “Opening the Session Editor” section on page 9-8.

2. Select a virtual resource, right-click and select Duplicate.

A new icon representing the new virtual resource will be inserted in the session editor.

3. Save the Session (File > Save) to bring the resource to life and execute its setup workflow operations.

Relocating Virtual Resources
This procedure allows you to move the selected virtual resource from one hypervisor to a secondary one. 
This procedure can use third-party software to perform such operations as the use of vSphere vMotion for 
vmWare hypervisor.

 To relocate virtual resources, perform the following steps:

1. Open a session editor; see the “Opening the Session Editor” section on page 9-8.

2. Select a virtual resource, right-click and select Relocate.

The following options are available:

• Automatic—Active System Manager determines a secondary hypervisor to move your current 
virtual machine to run on, and still validates the original capacity constraints.

• Manual—The session owner (or participants) can pick from a list of other hypervisors available in 
the Active System Manager inventory. 

Note The hypervisor list does not filter elements matching the capacity constraint of the selected virtual 
resource.

 

3. Click OK.

The original virtual resource becomes inactive, and a new virtual resource is now available on the 
session editor. To check the new hypervisor resource identification, select the new resource, click the 
Resource tab and search for the Host Asset Tag.

4. Optional. Select the inactive virtual resource, right-click and select Delete.

5. Click File > Save. 
Session Management 9-65



Managing Virtual Resources
Scaling Up Virtual Resources
Scaling up a virtual resource allows for administrators and session owners to request and immediately 
change the capacity-based properties of the virtual resources. This feature can also be used in the context 
of relocation if necessary. The current capacity property values can be found in the Elasticity tab.

To scale up virtual resources, perform the following steps:

1. Open a session editor; see the “Opening the Session Editor” section on page 9-8.

2. Select a virtual resource.

3. In the Properties view, click the Resource tab to view all capacity-based properties associated with the 
selected virtual resource.

To scale up virtual resources and (optionally) relocate them, perform the following steps:

1. Open a session editor; see the “Opening the Session Editor” section on page 9-8.

2. Select a virtual resource, right-click and select Scale Up.

3. Update one or more the capacity values.

4. Optional. Enable the Relocation option. This option is only available if new capacity values are not 
fulfilled by the current host. Relocation options include:

• Automatic—The Active System Manager determines a secondary hypervisor to move your current 
virtual machine to run on, and still validates the original capacity constraints.

• Manual—The session owner (or participants) can select from a list of other hypervisors available 
in the Active System Manager inventory.

5. Click OK to start the scaling operation.

The Session editor updates once the operation has completed.

6. Optional. Check the new capacity values of the virtual resource on the Elasticity tab (the Properties 
view) and check the targeted hypervisor from the Resource tab (Host Asset Tag, Host Domain 
property).

Invoking Resource Adapters
The following topics describe how to invoke built-in or custom Resource Adapter operations and 
applications on resources under test and underlying control resources in a running session:

• Executing System-Based Operations

• Executing Custom-Based Operations

• Executing Monitoring Operations
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Executing System-Based Operations
There are three sub-menus available (out of the box) to execute system-based operations; see Figure 9-56:

• Apply Configuration Files—Applies a new configuration to the resource using the associated 
configuration file.

• Apply Image Files—Applies a new set of OS images to the selected resources.

• Snapshot—Saves the current configuration and image file back into the repository.

Figure 9-56 System Operation Menu

To execute system-based operations, perform the following steps:

1. Open a session, right-click one or more resources, and select System Operation. 

2. Select Apply Configuration Files, Apply Image Files, or Snapshot, as appropriate for your execution.

3. Follow the procedures described in the following sections and click OK when you complete your task:

• Using the Apply Configuration Files Menu

• Using the Apply Image Files Menu

• Using the Snapshot Menu

Using the Apply Configuration Files Menu
The Apply Configuration Files menu applies a new configuration to the resource using the associated 
configuration file. 

A list of pre-associated files are available from which you can select. If the list is empty, then file 
associations must be made in the repository definition. In all cases, the repository must be created and 
elements must be discovered, imported, and associated with a resource type.
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You can apply the non-associated configuration file to the resource. To display all configuration files, click 
the Show All Configuration Files check box.

The Up and Down button is available f you have, at least, two files, you can rearrange the order in which 
the files will be applied on the resource by the Active System Manager software.

For information about setting up provisioning parameters; see Chapter 6, “Using Inventory.”

For more information about repositories; see Chapter 7, “Repository Management.” 

Using the Apply Image Files Menu
The Apply Image Files menu applies a new set of OS images to the selected resources. You can select the 
images, move them up or down, and click OK. When you click OK, the Active System Manager software 
updates the changes on the resources. A dialog box displays the results for each resource.

The Resource Operation Results display the Asset Tag, Result, Return Code, and Message. Click OK when 
finished reviewing the results.

Using the Snapshot Menu
The Snapshot menu saves the current configuration and image file back into the repository. The Resource 
Operation Results display the Asset Tag, Result, Return Code, and Message. Click OK when finished 
reviewing the results.

Executing Custom-Based Operations
Custom-based operations can be performed on managed and control resources. These operations are 
defined in the Resource Type Resource Adapter and marked available for end users. For more information, 
see the “Working with Resource Adapters” section on page 7-16.

Note Custom-based and monitoring operations are available if they are defined in the resource adapter. 
System operations are always available.

For details on executing custom-based operations, see the following sub-sections:

• Executing Custom-Based Operations on Managed Resources

• Executing Custom-Based Operations on Control Resources
9-68 Active System Manager User Guide, Release 7.0



Managing Virtual Resources
Executing Custom-Based Operations on Managed Resources
To execute custom-based operations on managed resources, perform the following steps:

1. Open a running session, right-click one or more resources, and select Custom Operation > <select an 
operation name>; see Figure 9-57.

Figure 9-57 Custom Operation Menu—Managed Resources

An example of a custom operation dialog box displays. The list of parameters and operations change, 
depending on the resource Resource Adapter. The Operation pull-down menu is pre-filled and a list of 
associated properties display.

2. Optional. Specify the following values for those properties:

• Name—By default is available by the Resource Adapter.

• Value—The default value (if available) displays.

• Mandatory—If true, then the value must be provided.

3. In the Execution Properties section, enter the number of times to run this operation. The default value 
is 1.

4. Click the Execute Sequentially check box to enable it. If it is disabled (not checked), all executions are 
performed in parallel.

5. Click OK.

6. Open the Custom Operations view (on the Active System Manager menu bar, click Window > Show 
View > Other > Active System Manager > Custom Operations > OK.) to display custom view 
operation results; see Figure 9-58 for an example. 

Note For this to function properly, you must have an open, running session.
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Figure 9-58 Example—Custom View Operation Results

The Custom Operations view is a ordinary navigation view that supports Filter and Group By functions 
(custom filtering and grouping). It allows you to re-execute and see the status and history of all those 
operations.

Executing Custom-Based Operations on Control Resources
To execute custom-based operations on control resources, perform the following steps:

1. Open a running session, right-click a link, and select Custom Operation > <select a control resource>; 
see Figure 9-59. 

Figure 9-59 Custom Operation Menu—Control Resources 
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2. In the Operation list that displays, select the resource to perform the operation.

One or more control resources display. 

The list of parameters and operations will change depending on the resource Resource Adapter.

The Operation pull-down menu is pre-filled and a list of associated properties display.

3. Optional. Specify the following values for those properties:

• Name—By default is available by the Resource Adapter.

• Value—The default value (if available) displays.

• Mandatory—If true, then the value must be provided.

4. In the Execution Properties section, enter the number of times to run this operation. The default value 
is 1.

5. Click the Execute Sequentially check box to enable it. If it is disabled (not checked), all executions are 
performed in parallel.

6. Click OK.

Executing Monitoring Operations
Each resource type Resource Adapter may contain one or more operation definitions. Those operations can 
be launched either from the Active System Manager system or from the Active System Manager portal. 

To execute monitoring operations from the Active System Manager system, perform the following steps:

1. In the session editor, open a running session.

2. Right-click a resource and select Monitoring Methods > select a monitoring operation> and enter 
optional parameters if required. 

Executing Applications
Each resource type Resource Adapter may contain one or more application definitions. Those applications 
can be launched either from the Active System Manager system or from the Active System Manager portal. 

To execute applications from the Active System Manager system, perform the following steps:

1. In the session editor, open a running session.

2. Right-click a resource and select Applications > select an appropriate application> and enter optional 
parameters if required.

Opening Resource Adapter Log
The Active System Manager application provides access to the Resource Adapter log on the Active System 
Manager server, for each resource in a running session (or session).

To open the Resource Adapter log, perform the following steps:

1. In the Sessions view, open a running session.

2. Right-click a resource and select Resource Adapter Log > View.

The log displays in a file editor on the workspace; see Figure 9-60.
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Figure 9-60 Resource Adapter Log Output Example

Monitoring Resource Adapter Execution
You can monitor Resource Adapter operation logs “live” while they are executing. To do so, perform the 
following steps:

1. Open a running session editor (session editor).

2. Right-click a resource and select Resource Adapter Log > Monitor.

A new view displays where the Resource Adapter execution output can be viewed while it is being 
executed; see Figure 9-61. View content can be frozen and also saved using the View action bar 
functions.

Figure 9-61 Resource Adapter Log Execution Output Example
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Working with Resource Terminals
The Sessions perspective allows you to work with the resource terminals of the resources in your Template. 
Multiple consoles can be open at the same time.

The following topics describe how to work with resource terminals:

• Opening a Resource Terminal

• Using the Active Terminals View

• Using Terminal Emulation Support

Opening a Resource Terminal
The Resource Terminal view displays console input and output to a resource. When the console window is 
closed, it loses the contents of your session. The Sessions perspective provides a logging function to allow 
you to save your session text.

To open a resource terminal, perform the following steps:

1. In the session editor, right-click a resource, and select Console. 

All management interfaces that were defined for the resource are listed.

2. Select the desired console mode (Dedicated, Shared, or Monitor) and connection type, and then click 
OK.

Table 9-11 describes the different session modes used with the MS to connect to environment resources.

Table 9-11 Session Modes 

Session Mode Description

Dedicated In this type of communication channel, user gets a dedicated communication channel. Each 
channel is an exclusive channel from a client to the resource. Commands are sent to the 
resource in parallel. 
In this mode, only the Telnet and SSH protocols are available.
This mode is also referred to as Session Exclusive Channel Mode.

Shared In shared mode, if there are no consoles opened on the resource port, and a console is 
requested by the user, the MS grants the channel to the first request. This user is able to 
execute the commands on the resource since they have the channel access.
Subsequent console requests to the same port in the multiplexed mode will be denied by the MS 
with an error message. Users can then again request access to acquire the channel.
In this mode, only the Telnet protocol is available.
This mode is also referred to as Session Shared Channel Mode.

Monitor To only monitor the selected port activity, open a console in monitor mode. In this mode, you are 
unable to execute commands on resources. For a particular port, open only a single monitor 
console. 
In this mode, only the Telnet and SSH protocols are available.
This mode is also referred to as Session Monitoring Mode.
Note: Monitoring is done for a resource port and not for a channel; therefore, all 
communications to the resource via the MS, on all exclusive and shared channels, is monitored 
and made available.

3. If the resource requires a login (SSH mode), supply a username and password for the resource as if you 
were using the resource console directly. After login, you can monitor the console output and, in 
Dedicated mode, execute commands on the resource.
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The Monitoring console mode is used to monitor already opened connections to the resource. It does 
not open any new connection with a resource; for example, if the protocol is set for Secure Shell (SSH), 
the user is not prompted for a username and password. The Show message on console display option 
displays the Mediation Server information messages. The Secure session check box option opens an 
SSL socket.

Note You can open multiple console windows from different Sessions perspective sessions.

Figure 9-62 Console Example

4. You can customize your console with the following options by clicking the console toolbar icons:

• New—Opens a new console with similar settings.

• Connect—Connects to the same resource with customized settings.

• View > Messages—Displays the message in the console as it runs.

• View > Status Bar—Displays the messages sent by the MS to the client.

• Display—Customizes the background color of your Terminal view and modifies the buffer size 
form.

• Options > Logging—Keeps a log of the session and displays a Save As dialog box, where you enter 
a name for the log file, browse to the appropriate location, and then click Save.

• Options > Local Echo—Displays the characters that you type.

5. Click OK in the upper-right corner to close it.

Note The back scroll buffer maximum for the Resource Terminal view is 1,000 lines.

Using the Active Terminals View
The Active Terminals view is a navigation view that is part of the Sessions perspective (for a running 
session); see Figure 9-63. This view displays all of the open terminals (mediation consoles) associated with 
that session, and it provides you with single-click access to all of your open consoles.

If you have many terminals open, to navigate to a specific terminal, you must located it manually. The 
Active Terminals view lists all the open terminals within a session and allows you to directly navigate to it 
by double-clicking (or using the Activate context menu) the desired terminal. 

This view also allows you to close selected consoles (a multi-select also provided), and it also provides the 
standard filtering and grouping capabilities. You can set up filters and the group by options via the Terminal 
properties. 
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Figure 9-63 Active Terminals View

Using Terminal Emulation Support
The Active System Manager Terminal Emulation is a visual software component that acts as the front end. 
It displays the data that is transmitted by the remote host and translates keystrokes to be sent to the remote 
host. The Active System Manager product supports: 

• An ANSI/vt100-compliant terminal, provided the resource to which you are communicating also 
supports the same.

• Basic terminal features like resizing of consoles, fonts, echo, text mode graphics such as used by Pine, 
VI, and so on.
Session Management 9-75



Managing Virtual Resources
9-76 Active System Manager User Guide, Release 7.0



Orchestration Management
C h a p t e r  1 0
Orchestration Management
This chapter describes the Active System Manager software’s Orchestration feature. The Orchestration 
feature helps you to create a template-like structure called Orchestration, for executing a sequence of 
operations in steps. 

In this chapter you learn how to create, update, and delete Orchestrations. The advanced features allow you 
to learn how to view the graphical representation of Orchestration while executing, troubleshooting errors 
in Orchestration, and linking Orchestrations with a selected template. 

Understanding Orchestration 

The Active System Manager software’s Orchestration feature is a logical grouping of administrative 
operations for management agents. It is a set of ordered or grouped Resource Adapter (RA) method calls 
against an authored resource. 

The Orchestration strings together a series of custom operations and scripts, which can be executed during 
the life cycle of the session, or by on-demand by session owner or participants:

• Custom operations. The custom operations are defined in RAs and can be associated with any step in 
Orchestration. A set of required or optional parameters are usually needed to invoke a RA operation. 

• Scripts are found in repositories defined in the Active System Manager. The scripts have access to all 
the session-level parameters that can be passed explicitly to the script call. For more information about 
repository management, see Chapter 7, “Repository Management.”

The Orchestrations are associated with templates. The custom operations from Resource Adapters are used 
in templates to build Orchestrations. These custom operations can be run independently or can be organized 
into steps to construct a step-wise group of operations termed as “Orchestrations”. Apart from custom 
operations, scripts can also be used to construct Orchestrations. For more information on adding scripts, 
see the “Creating Orchestrations” section on page 10-6.

In the Active System Manager software, all Orchestrations related to all existing templates are visible in 
the Orchestrations view. To view steps comprising of custom operations for the selected Orchestration, 
select and double-click an orchestration in the Orchestrations view. Orchestrations created for all existing 
templates are visible under Orchestrations.
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Figure 10-1 displays the organization of steps in Orchestration.

Figure 10-1 Organization of Steps in Orchestration 

In Figure 10-1, the Available Operations View pane displays the template resources, along with a list of 
custom operations related to each visible template resource. You can drag-and-drop these custom 
operations in Orchestration View pane to create ordered steps collectively (also called Orchestration).

There can be multiple number of steps in an Orchestration and each step can contain one or more 
operations.
Note If any step in an Orchestration contains more than one operation, then the operations are executed 

in parallel. However, if multiple steps exist in an Orchestration multiple steps exist, each step is 
executed in a sequential manner.

An Orchestration can either be created by an administrator or by the template owner. You can create three 
different types of Orchestrations; see the “Orchestration Types” section on page 10-3 for more information. 

The Orchestration feature facilitates ease of use and reduces operational complexity by automating the 
repeated operations that are performed in the environment. It is a powerful feature that is capable of creating 
some complex and highly interactive, automated step-based procedures. 
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Orchestration Types
The Active System Manager software facilitates you (template owner) with the ability to specify the 
Orchestration on the basis of three different reservation states, where Orchestrations can be executed. 
Table 10-1 lists and describes the various Orchestration types based on reservation states.

Table 10-1 Orchestration Types

Orchestration Type Description

Setup The Setup Orchestrations can be defined per template, and each template can 
contain a maximum of one Setup Orchestration. When a template with a Setup 
Orchestration is scheduled, and when the session attains a Setting Up 
reservation state, the Active System Manager software execution service 
implements the Setup Orchestration automatically. The custom operations 
defined in the Setup Orchestration steps run one after the other; thus, avoiding 
manual intervention. 
During a Setup Orchestration, the following steps effect in sequence: 
1. The devices are powered on.
2. The device connectivity is checked.
3. Resource-level scripts are executed.
4. Reservation scripts are executed.
5. The Setup Orchestration is executed.
Note: Setup Orchestrations are executed after the generation of reservation 
scripts.

On-demand The On-Demand Orchestration enables the ability to initiate an Orchestration 
execution in a running Active System Manager session, as needed. 
A single On-Demand Orchestration executes at a time in the running session. 
Before doing so, the Active System Manager software validates the Orchestration 
for any missing or removed device in the template. For more details, seethe 
“Executing Orchestration” section on page 10-15.

Teardown The Teardown Orchestration can be defined per template where each Template 
can contain a maximum of one Teardown Orchestration. When a template with a 
Teardown sequencing is scheduled and goes into a Clean Up state, the Active 
System Manager execution service implements the Teardown Orchestration as 
per the custom operations defined in the Orchestration steps. 
During a Teardown Orchestration, the following steps effect in sequence: 
1. Teardown Orchestration is executed.
2. Reservation Teardown scripts are executed (default or user-defined, as 

available).
3. Resource-level Teardown scripts are executed.
4. Connected devices are released.
5. On devices are powered off.
The template owner has the ability to specify Orchestration on the basis of 
reservation states for the custom Orchestration constructs, using a drag-and-drop 
method. 

Note On creation, all Orchestrations are of the On-Demand Orchestration type. However, you can easily 
change them into a Setup Orchestration or a Teardown Orchestration, and vice-versa, in the 
Orchestration view.
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Selecting Custom Operations
While building Orchestrations based on custom operations or prior to executing custom operations 
explicitly, you are required to provide certain parameter values for selected custom operations. Instead of 
manually entering these parameter values, you can choose to select pre-defined values from custom 
operations Value Source as defined in Resource Adapter definition.

In Orchestration, a Value Source refers to the Primary Source field. The Primary Source field displays 
context sensitive list of values dynamically in a drop-down list, which is populated with possible values 
retrieved from a specific value source in corresponding operation defined in the RA. The Sub Type is the 
Secondary Source field that further categorizes values based on the selected Primary Source. 

Selecting Context-Sensitive Values
To select context-sensitive values, perform the following steps:

1. While creating Orchestration or updating Orchestration while execution, drag an operation to include it 
into a step. 

The Specify Input Values dialog box displays, containing the following two panes:

• Parameters Pane—Contains general execution details such as operation names and Value field for 
entering values against input parameters. 

You can either enter these parameter values in Value manually or by selecting value from possible 
list of values in from Possible Values pane. 

Note The star pre fixed in the icons in Name column of Parameters section, indicates mandatory values 
field that you must enter.

• Possible Values Pane Displays all elements contained in selected Value Source. 

This panel allows you to choose values from Primary Source and Secondary Source drop-down 
list.

Note For information on Value Sources applicable on custom operations, see the “Deleting Resource 
Adapters” section on page 7-26.

2. Select a parameter in the Parameters pane.

3. Click the Primary Source in Possible Values pane and select the value source for the selected 
parameter; for example, select Software Repository. 

4. Click the Secondary Source in Possible Values pane and select the Sub Type of Value Source; for 
example, select a particular type of Software Repository. 

Note The step 3 on page 10-4 and the step 4 on page 10-4 is for advanced users or administrators. By 
default, the Active System Manager software’s RA pre populates the Primary Source and 
Secondary Source entries, in most cases. However, step 3 on page 10-4 and step 4 on page 10-4 
allow you to select value from Primary Source and Secondary Source from a list of context 
specific values.
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5. Check the required parameter value from the list of values displayed to auto-populate the Value field 
with selected value. 

This value is referred to determine the actual runtime value of the parameter at execution time.

6. Click OK to add custom operation in Orchestration.

Working with Orchestrations 

The direct access to Template and Orchestration view is available through the Perspective navigation bar, 
that appears on the extreme left of Active System Manager software. 

Accessing the Orchestrations View
To access Orchestrations view through Perspective navigation bar, perform the following steps:

1. On the Active System Manager navigation bar menu, click the Template perspective; see Figure 10-2.

Figure 10-2 Navigating Orchestration

The Orchestrations view displays, by default, with the Template view.
Note The alternate way to access the Orchestrations view is as follows:

1. On the Active System Manager menu bar, click Window > Show View >Other.

2. Click Active System Manager > Orchestrations.

3. Click OK to open the Orchestrations view.
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Creating Orchestrations
The On-Demand Orchestration can be set as Setup Orchestration or Teardown Orchestration. Any Template 
can contain a maximum of one designated Setup and Teardown Orchestration. The context-menu, to 
change Orchestration type, is based on applicability; for example, for an Orchestration which is of type 
Setup, the visible context-menu to change the Orchestration type contains On-Demand and Teardown 
Orchestration types.

To create a new Orchestration, perform the following steps:

1. Access the New Orchestration dialog box using one of the following methods:

• On the Active System Manager menu bar, click File > New > Other > Active System Manager > 
New Orchestration.

Note The Template perspective should be pre-selected to access New Orchestration dialog box via this 
method.

• From the Template view, select a Template, right-click, and select New Orchestration.

• On the Orchestrations view, right click and select New Orchestration. 

2. Select the Template for which the new Orchestration is to be created, and specify the name for the new 
orchestration sequence; see Figure 10-3. 

Figure 10-3 New Orchestration

3. Click Finish to open the Orchestration editor, from where you can add steps to the Orchestration; see 
Figure 10-4.
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Figure 10-4 Orchestration Editor 

The Orchestration Editor contains Available Operations View pane and Orchestration View pane:

• Available Operations view pane—Contains all RA custom operations associated with each resource in 
your Template.

• Orchestration view—Working pane where you build your workflow by any of the following two 
methods:

• Dragging and dropping custom operations from the Available Operations view pane.

• Adding scripts to steps by clicking Add Scripts.
Note Custom operations and scripts are associated with steps in the Orchestration View.

.

Adding Steps in the Orchestration View
To add steps in the Orchestration View pane using any of the methods as explained above, follow the steps 
below:

1. Click Add Step.

2. Drag-and-drop custom operations from the Available Operations View pane to the respective step 
(steps) in the Orchestration View pane (see step 3), or add a script by clicking Add Script (see step 4). 
The Specify Input Values dialog box that corresponds to a custom operation displays whenever any 
custom operation is dragged to the Orchestration view; see Figure 10-5.
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Figure 10-5 Specify Input Values

3. Enter RA input values in Parameters, wherever required.
Note For ease of use, Active System Manager facilitates context assistance for custom operations; see 

Possible Values in Figure 10-5.

4. In case of Add Script: 
Note The Active System Manager software has the ability to execute arbitrary scripts from the 

orchestration. You can associate script (scripts) with any step of orchestration. The scripts have 
access to all the session level parameters that can be passed explicitly to the script call. 

The execution of scripts in a running session is similar to the execution of custom operation. 

The Add Scripts dialog box displays; see Figure 10-6.

Figure 10-6 Add Scripts
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5. Click Add to add any of the following four script types:

• Add Default Script—Adds the default script.

• Add Script from Repository—Adds the script from the repository; see Figure 10-7.

Figure 10-7 Add Script from Repository

• Add from HTTP Server—Adds the HTTP scripts; see Figure 10-8.

Figure 10-8 Add from HTTP Server
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• Resource Level Script—Adds resource level scripts, see Figure 10-9.

Figure 10-9 Add Resource Level Script

6. Click OK to add the custom operation or script to the step in the Orchestration View pane. 
Note At each Orchestration step, you can choose to execute or skip executing any particular step in an 

orchestration. For more details, refer “Re-Executing Failed Steps” section on page 10-10

At each Orchestration step, you can choose to abort or skip, if any error occurs. For more details, 
see the “Error Handling/Abort on Error” section on page 10-11.

Re-Executing Failed Steps
The Execute feature provides a way to enable or disable execution of steps in Orchestration by checking 
or un-checking Execute check box, that appears next to each step in Orchestration. It provides you with the 
ability to re-execute any step or set of steps in Orchestration. 
Note By default, when a step is added, the Execute option is checked which means the step executes in 

the running session.

Using this feature you can skip the execution of certain steps of Orchestration in a running session. In such 
a case, the unchecked step appears with a ‘Skipped’ status in a running session. For more details, refer 
“Executing Orchestration” section on page 10-15.

To re-execute failed steps, click the Execute check box next to the required steps; see Figure 10-10.
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Figure 10-10 Re-Executing Failed Steps

The following right-click options are available to select steps for execution: 

• Rename—Allows you to rename the selected step by right clicking or double clicking on the step.

• Select Execute All—Allows you to select all steps for execution on a single click.

• Deselect Execute All—Allows you to deselect all selected steps on a single click.

• Execute From Here—Allows you to select all steps from a particular point in Orchestration. 

Error Handling/Abort on Error
The Abort on Error feature allows you to choose to abort execution of step (steps) in Orchestration. While 
execution, if the error occurs at a step where Abort on Error is checked, the steps thereafter do not execute 
and are aborted. 

You can choose to abort on error for each step while creating or updating an Orchestration. 

To specify Abort on error per Orchestration steps, perform the following steps:

1. Check Abort on Error on steps that you want to abort on error; see Figure 10-11.
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Figure 10-11 Abort on Error

2. Click Finish to save settings.
Note By default, the Abort on Error check box is deselected. 

Editing Orchestrations
Orchestrations can be edited from:

• Orchestrations View for Setup, On-Demand, and Teardown Type Orchestrations.

• Running Session Before Execution
Note When Orchestration is edited from Orchestrations view, the update is permanent, and is applicable 

to any Session that uses the edited Orchestration thereafter. However, in case of updating 
Orchestration in running session, the updates are associated with that particular On-Demand 
Orchestration, and the original Orchestration does not get updated. It is an on-the-spot update that 
can be done, as required, before executing a current On-Demand Orchestration. The updates in this 
case are not available for new On-Demand Orchestration. 

.
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To edit an existing Orchestration, perform the following steps:

1. Right-click (or double-click) an existing Orchestration and click Open; see Figure 10-12.

Figure 10-12 Context-Menu for Updating Orchestration

The Orchestration Editor displays; see Figure 10-13.

Figure 10-13 Orchestration Editor for Updating Orchestration

2. Edit the sequence as required.
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Deleting Orchestrations
To delete an Orchestration, perform the following steps:

1. Select the Orchestration to delete and right-click to select Delete, or press the Delete key.

2. When the Confirm Delete dialog box displays, click OK.

Linking Orchestrations with Template Selection
The Linking feature allows you to view all Orchestrations related to the selected Template. To view 
Orchestrations of a selected Template, select a Template and click the Linking icon ( ) in 
Orchestrations; for example, select the Amazon VPC template and click the Linking icon to see all 
related Orchestrations (see Figure 10-14).
Note By default, the Linking icon is enabled; by default, all related orchestrations display in the 

Orchestration panel. 

Figure 10-14 Linking Orchestration with Template

Save As
The Save As feature allows you to save the Orchestration with a different name. In this case the saved 
Orchestration, along with its associated Orchestration steps, are cloned. 

To clone Orchestration, perform the following steps:

1. Right-click an Orchestration in the Orchestrations view.

2. Click Save As to display the Clone Orchestration dialog box.

3. Click the Specify Orchestration Name field, enter a name, and click OK.

Note By default, the Orchestration name is pre-fixed by ‘copy of’ a selected Orchestration name.
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Executing Orchestration

Note On-Demand Orchestrations are executed in a running Session. You are required to schedule a 
Template before executing related Orchestrations in a running session. To do this, right-click a 
Template and click Schedule. Follow the scheduling process thereafter to reserve a Template for the 
session. 

To execute Orchestration, perform the following steps:

1. Right-click a running session and select the Orchestration to execute from Execute Orchestration.

Note Clicking Execute Orchestration displays all Setup, On-Demand, and Teardown Orchestrations 
defined for the selected Template. Setup and Teardown Orchestrations run automatically when the 
session goes into Setup or Cleanup reservation state respectively. However, you can choose to 
execute Setup and Cleanup orchestration anytime during the session. The list of Orchestrations 
appearing on clicking Execute Orchestration gives you an option to edit any Orchestration for that 
particular session before executing.

Note Right click menu is available both on the session graphical editor as well as on link editor.

2. Select the Orchestration to be executed. The Execute Orchestration dialog box displays; see 
Figure 10-15.

Figure 10-15 Execute Orchestration
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3. On selecting an Orchestration, the Execute Orchestration Update dialog box displays. Before executing, 
you can update the Orchestration. 

The selected Orchestration details display in Orchestration View pane prior to execution. If you 
change the Orchestration and then execute it, the original Orchestration associated with Template will 
remain unchanged. The change applies to that particular session where the Template is executed. 

4. Click OK.

Monitoring Orchestration Execution
The Orchestration execution monitoring refers to monitoring the real-time status of execution of steps in 
the Orchestration while the session is in a running state. It allows you to visually track the status of 
Orchestrations running in a Session. 

To monitor Orchestration execution, perform the following steps:

1. On the Active System Manager menu bar, click Window > Open Perspective > Session.
Note To access Session perspective directly, on the Perspective menu bar, click Session. 

You can monitor the Orchestration execution status in the following different views:

• Session Editor

• Orchestration Execution with default Operation Properties View 

• Orchestration Execution with Console View

Session Editor
The Session Editor view contains the watermark that indicates in the background, the Orchestration and 
the real-time step being executed; see Figure 10-16.

Figure 10-16 Session Editor
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Orchestration Execution with Default Operation Properties View
The Orchestration Execution view displays the Orchestration and its status (Completed, Aborted, 
In-Progress, Skipped (in case Execute is unchecked)) for the opened running session in a tree structure. It 
also facilitates viewing the hierarchial representation of real-time Orchestration step execution. In the 
selected session editor hierarchial view, each Step displays the Success or Failure of the step along with all 
operations by clicking on step. Each step is linked to complete Properties view of selected step. To view 
the status of operations in each step, expand each step by clicking . 

To view the hierarchial representation of Orchestration step execution, click the visible Orchestration in the 
Orchestration Executions view, click 5857 Orchestration in the Orchestration Executions view. The 
hierarchial representation of 5857 Orchestration displays. Click the step to view the related properties of 
operations in each step existing in 5857 Orchestration in the Properties view. Clicking on the step also 
displays the ‘Success’ or ‘Failure’ of the step. The steps unchecked in Execute check box while creating 
or updating Orchestration appear with ‘Skipped’ status in the hierarchial representation of Orchestration.

Note While creating or updating Orchestration, if the Execute check box is disabled, then the status of 
that step is displayed as ‘Skipped’ during Orchestration execution in a running session.

Note While creating or updating Orchestration, if you choose to Abort on Error on a particular step, then 
that particular step aborts if any error occurs while execution. The ‘Failure’ status is displayed in 
such a case on that particular step. All steps thereafter get aborted and do not execute.

Figure 10-17 Orchestration Execution with Default Operation Properties View
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Console View
The Console view displays the real-time status of each step in an executing Orchestration; see 
Figure 10-18.

Figure 10-18 Console View of Executing Orchestration
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Working with Test and Script Execution
This chapter describes the various methods of how to work with test and script execution using the Active 
System Manager software:

• Working with Test Cases

• Working with Resource Scripts

• Working with Session Scripts

• Customizing Script Execution

• Working with the Execution Queue View

Working with Test Cases

This section describes the following topics about working with test cases:

• Opening the Test Cases View

• Setting Preferences for Script Servers

• Starting a Test Case

• Viewing Test Case Properties

• Stopping a Test Case

Opening the Test Cases View
You can view test cases in the Test Cases view; to open the Test Cases view, see the “Opening the Test Cases 
View” section on page 11-1.
11-1



Working with Test Cases
Setting Preferences for Script Servers 
To set preferences and the default values for script servers, perform the following steps:

1. Select one of the following options to display the Preferences dialog box (Figure 11-1):

• On the Active System Manager menu toolbar, click Window > Preferences > Test and Script 
Execution > Script Server. 

• In the Test Cases view, select one or more test cases, right-click and select Preferences.

Figure 11-1 Setting Preferences for Test Cases

2. Click the Script and Folder location fields, respectively, and enter the respective information. This 
field defines the default project, workspace, or suite location where resource-level test cases are 
organized in a Manufacturer and Model. These test cases will be listed in the Scripts view upon opening 
a session editor.

3. Click the Secure check box to ensure that the communication from the Active System Manager server 
is secure via a Secure Shell (SSH) protocol. By default, this check box is enabled (secure). Non-secure 
communication uses a remote shell (RSH) protocol. to configure non-secure communication, click the 
check box to clear it.

4. Click Apply > OK.
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Starting a Test Case
You can use the Session perspective to view a list of all of the test cases that are associated with a reserved 
Template. You can then select one of those test cases to execute on the remote host. You can also execute 
multiple tests on the Template from the session editor. While other Session perspective sessions can connect 
to the same session, only the session that starts the test case can monitor it or execute commands on it.

To start a test case, perform the following steps:

1. Ensure that you are connected to the relevant session. 

The test case Console view is refreshed automatically when you open a session editor (in Running 
State). For information about session states, see Table 9-2 on page 9-7.

Use the expand buttons in the associated Test Cases view to display the project folder, work 
environment, and suite containing the desired test case.

2. Select and open a running session in your session editor.

3. Open the Test Cases view. The view content should be refreshed automatically based on the opened, 
running session.

Note To execute any test script, you must have a running session open.

4. Navigate the project hierarchy to select your test cases. 

5. In the associated Test Cases view, select one or more test cases to execute, right-click the desired test 
case, and select Start. 

A new execution entry will be listed in the Execution Queue view. 

Viewing Test Case Properties
To view test case properties, in the session editor or Test Cases view, select a test case and open the 
Properties view. 

Stopping a Test Case 
After test execution has begun, you can stop it at any time. This feature is designed for when you are 
executing many tests, or the execution time is lengthy, or when you want to change the settings and restart 
the test. 

Note It is impossible to resume execution of a stopped test case where it left off, but you can start it again 
from the beginning.

To stop a test case, perform one of the following options:

• On the Console view toolbar, click the Stop Test Case icon. This icon function ends the collection of 
data from a test, but it does not necessarily cause the test to abort (that is, to exit from the operating 
system). If you have a simple test that opens some temporary files, does processing, and then removes 
the temporary files, you might prefer that a “stopped” test still ran to completion—and deleted those 
files—rather than exiting abruptly. 

• On the Execution Queue view, right-click the test case and select Stop.
Working with Test and Script Execution 11-3



Working with Resource Scripts
Working with Resource Scripts

Resource scripts are executable files located in a script repository on a remote server. The repository must 
follow a strict directory structure to allow for resource-level scripts to be executed. The directory structure 
should follow the Manufacturer and Model name, as defined per each resource type. For example, if you 
have a Resource Adapter for a Cisco7206 resource type, your repository should be:

/

/<Manufacturer>

/<Manufacturer>/<Model>

This section describes the following topics:

• Opening the Resource Scripts View

• Setting Preferences for Resource Scripts

• Starting a Resource Script

• Viewing Resource Script Output

• Stopping a Resource Script

Opening the Resource Scripts View
You can view resource scripts in the Resource Scripts view; to open the Resource Scripts view.

Setting Preferences for Resource Scripts
The following sub-sections describe how to set preferences for resource scripts:

• Setting a Default Remote Script Execution Environment

• Setting Default Runtime Environment Variables

Setting a Default Remote Script Execution Environment
To set a default remote script execution environment, perform one of the following options:

• On the Active System Manager menu toolbar, click Window > Preferences > Test and Script 
Execution > Script Server. 

• In the Resource Scripts view, select one or more resource scripts, right-click and select Preferences.

All fields are required and must be completed to identify the scripts in the Resource Scripts view. The 
Secure check box indicates that the communication from the Active System Manager server to the remote 
script server is secure. Non-secure will use a Remote Shell Protocol (RSH). If you use Secure, it will be 
Secure Shell Protocol (SSH). 
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Setting Default Runtime Environment Variables
To set default runtime environment variables that will be passed to each resource script executions, perform 
one of the following options:

1. Open the Script Server preferences:

• On the Active System Manager menu toolbar, click Window > Preferences > Test and Script 
Execution > Script Server. 

• In the Resource Scripts view, select one or more resource scripts, right-click and select Preferences. 

2. In the Runtime Variable section, select Resource Level Script or Session Level Script.

Table 11-1 lists the default environment variables.

Table 11-1 Default Environment Variables 

Context Default Environment Variables

Resource Level Script Asset Tag
Version
Manufacturer
Model
Session ID
Session Name
Template Name
Owner

Session Level Script Session ID
Session Name
Template Name
Owner

3. Build the default environment variable list for each context clicking Variables to select from the default 
variables list, or enter manually your environment name. Each variable must be separated by a space.

4. Click Apply or OK to save your preferences. 

Starting a Resource Script
To start a resource script, perform the following steps:

1. Open the Resource Scripts view.

2. Open a running session open in your session editor (workspace) and select a resource in that session. 

3. In the Resource Scripts view, select one or more resource scripts, right-click, and select Start.

The Execute Scripts dialog box displays. Depending on how many scripts you select, that number of 
scripts will appear in the Execute Scripts dialog box.

Note To execute any test script, you must have a running session open.

4. Optional. Update individual script location or host information.
Working with Test and Script Execution 11-5



Working with Session Scripts
5. Optional. Select a script and click Environment to overwrite the default execution environment 
settings. For more information about the global settings, see the “Setting Preferences for Resource 
Scripts” section on page 11-4.

6. Click OK to start the resource scripts. For more information about script execution, see the 
“Customizing Script Execution” section on page 11-8.

Viewing Resource Script Output
The Active System Manager software opens a Console view when the resource script starts and displays 
the results in that view. You can view resource scripts (via the Session perspective) that are associated with 
a running session, by perform the following steps:

1. On the Active System Manager menu bar, click Window > Show View > Execution Queue to display 
the Execution Queue view.

2. Select your test case, right-click and select Monitor Execution Output.

A Console view with the test case ID displays the complete output in progress.

Stopping a Resource Script
After resource script execution has begun, you can stop it at any time. This feature is designed for when 
you are executing many resource scripts, or the execution time is lengthy, or when you want to change the 
settings and restart the resource script. 

To stop a resource script, perform one of the following options:

• On the Console view toolbar, click the Stop Execution icon. 

This icon function ends the collection of data from a resource script, but it does not necessarily cause 
the resource script to abort (that is, to exit from the operating system). If you have a simple resource 
script that opens some temporary files, does processing, and then removes the temporary files, you 
might prefer that a “stopped” test still ran to completion—and deleted those files—rather than exiting 
abruptly. 

• Open the Execution Queue view, navigate to your resource script. From here, you can either right-click 
the resource script and select Stop, or right-click the resource script and select Monitor Execution 
Output. For more information about the latter two functions, see the “Monitoring Execution Output” 
section on page 11-12 and “Reviewing Execution Output” section on page 11-12, respectively.

Working with Session Scripts

Session scripts are executable files located in a script repository on a remote server. Sessions scripts can 
only be invoked from a running session editor.

This section describes:

• Setting Preferences for Session Scripts

• Browsing and Executing Session Scripts
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Setting Preferences for Session Scripts
The following sub-sections describe how to set preferences for session scripts:

• Setting a Default Remote Script Execution Environment

• Setting Default Runtime Environment Variables

Setting a Default Remote Script Execution Environment
You can set runtime environment variables at the resource and session level. 

To set a default remote script execution environment, on the Active System Manager menu toolbar, click 
Window > Preferences > Test and Script Execution > Script Server. 

All fields are required and must be completed in order to identify the scripts in the Session Scripts view. 
The Secure check box indicates that the communication from the Active System Manager server to the 
remote script server is secure. Non-secure will use a Remote Shell Protocol (RSH). If you use Secure, it 
will be Secure Shell Protocol (SSH). 

Setting Default Runtime Environment Variables
To set default runtime environment variables that will be passed to each session script executions, perform 
one of the following options:

1. Open the Script Server preferences:

• On the Active System Manager menu toolbar, click Window > Preferences > Test and Script 
Execution > Script Server. 

• In the Resource Scripts view, select one or more resource scripts, right-click and select Preferences. 

2. In the Runtime Variable section, select Resource Level Script or Session Level Script.

Table 11-1 on page 11-5 lists the default environment variables.

3. Build the default environment variable list for each context by clicking Variables to select from the 
default variables list, or manually enter your environment name. Each variable must be separated by a 
space.

4. Click Apply or OK to save your preferences. 

Browsing and Executing Session Scripts
To browse and execute session scripts, perform the following steps:

1. Open the Sessions view; on the Active System Manager menu bar, click Window > Show View > 
Other > Active System Manager > Sessions > OK.

2. In the Sessions view, open a running session, right-click and select Execute Session Scripts.

The Execute Scripts dialog box displays.

3. Customize your script execution settings as needed; for more information, see the “Customizing Script 
Execution” section on page 11-8.
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Customizing Script Execution

To customize script execution, perform the following steps:

1. Open the Execute Scripts dialog box by one of the following methods:

• In the Sessions view, select a running session, right-click, and select Execute Session Scripts.

• In the Resource Scripts view, select one or more scripts, right-click, and select Start. Depending on 
how many scripts you select, that number of scripts will appear in the Execute Scripts dialog box.

• In the Resource Scripts view, double-click a script.

• In the session editor, right-click and select Execute Session Scripts.

Based on your selection, the script details may be pre-populated; however, when you use the session 
editor option of opening this dialog box, it will appear empty, because you must manually add the 
scripts (i.e., you must specify which ones to run). 

2. By default, you execute the scripts in parallel. However, to run in a specific order, click the Execute 
Sequentially check box to display the following options:

• Click Up or Down to manually change the sequence of scripts to execute. (Only available when you 
enable the Execute Sequentially check box.)

• Click Add to add a default script or click Add > Add Default Script or Add > Add Script from 
Repository to browse your script repository to add a script entry. Click OK after making your 
selection.

• Click Remove to remove or delete a selected script entry.

• Click each property field and modify the existing values; see Table 11-2. The default values are 
iterated from the preferences you configured in the Script Server (Window > Preferences > Test 
and Script Execution > Script Server).
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Figure 11-2 Script Server Properties

Table 11-2 Execute Scripts Property Fields 

Field Description

Hostname Script server hostname or IP address.

Username Remote Shell (RSH) or Secure Shell (SSH) username; a UNIX account.

Password Remote Shell (RSH) or Secure Shell (SSH) password; a UNIX account.

Script Default session script.

Folder Location Default location to store the scripts.

Secure (check 
box)

Indicates that the communication from the Active System Manager server to the remote script 
server is secure. Non-secure will use a Remote Shell Protocol (RSH). If you use Secure, it will be 
Secure Shell Protocol (SSH)

3. On the Execute Scripts/Test Cases dialog box, click OK.

4. Click OK to start the execution of selected scripts.

The executions are added to the Execution Queue; for more information, see the “Working with the 
Execution Queue View” section on page 11-10 to start, stop, delete, monitor, or review the scripts or 
test case executions.
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Working with the Execution Queue View

The Execution Queue view displays all test case and script (session startup, or session level, or resource 
level) executions. 

The Execution Queue view has a default set of filters: 

• Scripts 

• HTTP Scripts

• Test Cases 

Each execution is identified by a unique identifier (ID), which is recorded in the execution output and 
displayed in the Execution Queue view. Each execution ID equals one script. You can group execution IDs 
by using the Filtering > Group By option. Group By options to optimize view include: Type, Execution 
Level, Session ID, Status, Start By, Stop By, Group ID.

Table 11-3 lists and describes the execution states available for the Execution Queue view. It also list and 
describes the functions you can perform in each state when you right-click the execution ID related to the 
state.

Table 11-3 Execution States and Their Related Functions 

State Description Menu-Function-Description

Aborted The user aborted the execution. Includes a 
start and end date (created manually or 
automatically). When you stop a running 
session and when script execution fails 
(script non-available, status not available 
etc.), then the script goes into an Aborted 
state.

• Start—Starts a new execution.
• Delete—Deletes the execution.
• Review Execution Output—Allows you to review the complete 

execution output of script or test case in a file editor. You can bring up 
the full output of the execution. All past executions are saved on the 
server.

• Expand All—Opens all tree nodes.
• Collapse All—Collapses all tree nodes.
• Refresh—Refreshes the view to a current state.

Completed The execution was successful. Includes a 
start and end date (created manually or 
automatically).

• Start—Starts a new execution.
• Delete—Deletes the execution.
• Review Execution Output—Allows you to review the complete 

execution output of script in a file editor. You can bring up the full 
output of the execution. All past executions are saved on the server.

• Expand All—Opens all tree nodes.
• Collapse All—Collapses all tree nodes.
• Refresh—Refreshes the view to a current state.

Pending The execution will start soon (automatically). • Start—Starts a new execution.
• Delete—Deletes the execution.
• Expand All—Opens all tree nodes.
• Collapse All—Collapses all tree nodes.
• Refresh—Refreshes the view to a current state.
11-10 Active System Manager User Guide, Release 7.0



Working with the Execution Queue View
The following sections describe more about working with the Execution Queue view:

• Starting an Execution

• Stopping an Execution

• Deleting an Execution ID

• Monitoring Execution Output

• Reviewing Execution Output

Starting an Execution
To start an execution, perform one of the following options:

• In the Test Cases view, select one or more test cases, right-click and select Start. When the Execute 
Scripts/Test Cases dialog box displays, follow the procedure in the “Customizing Script Execution” 
section on page 11-8, starting with step 2 on page 11-8.

• In the Resource Scripts view, select one or more test cases or scripts, right-click and select Start. When 
the Execute Scripts dialog box displays, follow the procedure in the “Customizing Script Execution” 
section on page 11-8, starting with step 2 on page 11-8.

• In the Execution Queue view, right-click an execution ID (in any state; see Table 11-3) and select Start.

The new execution displays in the Execution Queue view.

Stopping an Execution
To stop an execution, in the Execution Queue view, right-click an execution ID (only in the Running state) 
and click Stop. 

Note You can only perform this function in the Running state. On session cleanup, the Active System 
Manager software will abort all running scripts.

Running The execution is in the process of running. 
You can view the start time.

• Start—Starts a new execution.
• Stop—Stops the execution.
• Delete—Deletes the execution.
• Monitor Execution Output—Displays a new view (Console) where 

you can monitor the output in an ongoing state. 
• Review Execution Output—Allows you to review the complete 

execution output of script in a file editor. You can bring up the full 
output of the execution. All past executions are saved on the server.

• Expand All—Opens all tree nodes.
• Collapse All—Collapses all tree nodes.
• Refresh—Refreshes the view to a current state.

Table 11-3 Execution States and Their Related Functions (continued)

State Description Menu-Function-Description
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Deleting an Execution ID
To delete an execution ID, in the Execution Queue view, right-click an execution ID (in any state; see 
Table 11-3) and select Delete.

Monitoring Execution Output
To monitor the execution output, in the Execution Queue view, right-click an execution ID (only in the 
Running state) and click Monitor Execution Output. 

The output displays in the Console view.

Note You can only perform this function in the Running state.

Reviewing Execution Output
To review the execution output in the editor, in the Execution Queue view, right-click an execution ID (only 
in the Aborted, Completed, or Running state), and select Review Execution Output. 

Note You can only perform this function in the Aborted, Completed, or Running state.
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Reports
The Active System Manager software has several built-in reports for tracking the usage of your 
environment’s inventory. They are usually displayed in your default web browser and can be printed or 
exported to PDF.

You can also use the Active System Manager software to create a wide array of custom reports. For 
additional information on creating custom reports, refer to the available BIRT documentation.

Note For all reports, you can print the output from your browser, or use the Export information in PDF 
format link to create a PDF file and display it in your browser, or to create a CSV file. The PDF file 
can be printed or saved from the browser.

To access the available built-in reports, on the Active System Manager menu bar, click Reports.

Using Standard User Report Types

The Active System Manager software includes a variety of standard report types for you to use, including: 

• Running a Control Equipment Summary Report

• Running an Inventory Link Detail Report

• Running a Managed Equipment Summary Report

• Running a Managed Equipment Detail Report

• Running a Session Report

• Running a Session Audit Report (available only with a Running session)

• Running Custom Reports
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Running a Control Equipment Summary Report
The Active System Manager software provides two types of inventory equipment summaries: one for 
managed equipment and one for control equipment. The Control Equipment Summary report displays 
summary information on the control equipment in inventory on the current server. This report lists each 
item of your control equipment, grouped by category (matrix switch, Trivial File Transfer Protocol [TFTP] 
server, and so on). Any category of equipment that has no resources in it is skipped. For information 
regarding the managed equipment report, see the “Running a Managed Equipment Summary Report” 
section on page 12-2 and the “Running a Managed Equipment Detail Report” section on page 12-3.

To run a Control Equipment Summary report, perform the following steps:

1. On the Active System Manager menu bar, click Reports > Control Equipment Summary Report.

The Control Equipment Summary Report for your environment displays in your web browser.

This report lists each item of your control equipment, grouped by category (matrix switch, TFTP server, 
and so on). Any category of equipment that has no resources in it is skipped.

Running an Inventory Link Detail Report
The Inventory Link Detail report lists each of the links to your equipment, by resource. You can filter the 
resources used for creating the report in the dialog box provided by your web browser.

To run an Inventory Link Detail report, perform the following steps:

1. On the Active System Manager menu bar, click Reports > Inventory Link Detail Report. 

The Inventory Link Detail report filter options dialog box displays in your default web browser.

2. Modify the report filter options, as appropriate, and click Create.

Running a Managed Equipment Summary Report
The Managed Equipment Summary report displays summary information for the managed equipment in 
inventory. For each item of your managed equipment, it displays its name, manufacturer, model, asset tag, 
version, and description. This report lists the number of entries and those entries are alphabetically sorted 
by Manufacturer and Model. 

To run a Managed Equipment Summary report, perform the following steps:

1. On the Active System Manager menu bar, click Reports > Managed Equipment Summary Report. 

The Managed Equipment Summary Report for your environment displays.

2. Modify the report filter options, as appropriate, and click Create.
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Running a Managed Equipment Detail Report
The Managed Equipment Detail report lists the ports on each resource, what card they are located on, and 
relationships that apply to them. Use this report to help you manage your environment physically and as a 
network. In particular, this report provides the following information:

• What cards are present on a resource?

• What is the location of each card?

• What ports are present?

• Which ports are on which cards?

• What is the total number of ports for each interface type and for each card type?

To run a Managed Equipment Detail report, perform the following steps:

1. On the Active System Manager menu bar, click Reports > Managed Equipment Detail Report.

The Managed Equipment Detail report—filter options display. 

2. Select one of the following Filter Options:

• All Resources—Displays information for all managed resources in your inventory. 

• Resource Types—Click this option and select one or more resource types. All resources of these 
types are displayed.

• Resource Instances—Click this option and select one or more resources to display.

• Port Types—Click this option and select one or more port types. All ports of these types are 
displayed, regardless of where the resources occur.

3. Optional. Enter a comment to appear at the beginning of your report. 

4. Click Create to proceed. 

The report can take a few minutes to generate.

If ports have a relationship, then the related ports are grouped in the same color rows. The groups are 
separated from each other by a white space. For each port, the port location is displayed, as well as the 
type of card that it is on and the location of the card.

There is also a summary report at the bottom that displays the total count of each interface type, and the 
total count of each card type for which a name has been entered.
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Running a Session Report
The Session report lists the sessions associated with the environment. To run a Session report, perform the 
following steps:

1. On the Active System Manager menu bar, click Reports > Session Report. 

The Sessions Filter Options display.

This filter works in the standard way for the Active System Manager software. 

2. If no criteria is entered, then all sessions are included in the report.

You can perform an advanced filter search based on the parameters:

• Owner

• Topology Name

• Session Name

• Status—Select one or more of the status values from the list (All, Active, Canceled). For example, 
you can choose to see only sessions whose status is Running or Setting Up. You can press 
Ctrl+click to select additional entries from the list. Press Shift+click to select a range of entries. If 
you leave this field blank, then the field is not used as a selection criterion (that is, any value is 
acceptable).

• Start Date—Select a start date by clicking on the calendar. Select “>” from the box at the beginning 
of the line to select sessions that started after the specified date and time, or “<” to select earlier 
dates.

• End Date—Select an end date by clicking on the calendar. Select “>” from the box at the beginning 
of the line to select sessions that ended after the specified date and time, or “<” for earlier dates.

• Click the Show only my sessions check box for those sessions to display.

3. Click Create to display the Administrator Session Report for your environment.

Session information is displayed for both session and allocation sessions. The current status of each 
session is included. Entries are sorted first by Owner alphabetically, then by Start Time, with the most 
recent listed first.

Running a Session Audit Report
The Session Audit report the contains core session properties, a complete inventory of resources and links 
used in this session, and a complete description of the session life cycle.

To run a Session Audit report, open a currently running session by performing one of the following options:

• On the Active System Manager menu bar, click Reports > Session Audit Report. 

• In the Sessions view, select a session, right-click and select Open Session Audit Report.

The report displays in your default web browser. Each of the Session Audit sections are linked at the top of 
this web page for you to easily access.
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Table 12-1 lists and describes the Session Audit report sections.

Table 12-1 Session Audit Report Sections 

Section Description

Overview List of core properties associated with the session.

Associated Rendering Screenshot of the session or custom rendering.

Template Scripts Status Success or failure messages associated with the execution of the Template-level 
scripts.

Session Properties Custom (user-defined) properties associated with the session.

Provisioning Properties Provisioning properties associated with the session.

Session Attachments Documents attached with the session.

Resources List of resources used in the session.

Links List of links used in the session.

Audit Trail List of all sessions operations with success or error messages up to the printout time.

Running Custom Reports
The Active System Manager server comes deployed with BIRT reporting services. For more information, 
see the BIRT documentation. Administrators have the ability to deploy BIRT reports and make them 
available to their end users. Those reports are accessible using the following procedure. 

To run a custom report, on the Active System Manager menu bar, click Reports > Custom Report. 

The web portal report displays with a list of deployed reports. 

Using Standard Administrator Report Types

This section describes the following types of administrator reports:

• Running a User Management Report

• Running a Template Utilization Report

Note In addition to the user, the Active System Manager administrator can also run all of the Active 
System Manager user reports. 
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Running a User Management Report
There are two types of security management reports available:

• The User report lists all of the administrators in the first section, and then all of the (non-administrator) 
users in the next section. Within each section, entries are listed alphabetically by last name, then first 
name.

• The Group Definition report lists all of the groups that have been defined in the Active System 
Manager software. For each group, every member is listed, as well as whether the member is an 
administrator or user.

To run a User Management report, on the Active System Manager menu bar, click Reports > User 
Management Report. 

The User Report for your environment resource displays.

Running a Template Utilization Report
The Template Utilization report displays details of top templates used by selected users.

To run a Template Utilization report, perform the following steps:

1. On the Active System Manager menu bar, click Reports > Template Utilization Report.

2. Complete the required fields:

• Specify Date Range—Allows you to select a period of time or specific start and end times.

• Period—Allows you to set the Utilization report on the prior week, or the last 30, 60, or 90 days.

• Specific Time—Allows you to specify a start and end time to define the time frame the report 
covers. 

• Filter Options—Allows you to select the resources the report is based upon:

• Security Store—An Active System Manager repository of secured store credentials (users and 
groups). The Active System Manager software supports a local and remote security store (via 
Active Directory or LDAP for example). 

• Groups—Lists all of the groups that have been defined in the Active System Manager software. 
For each group, every member is listed, as well as whether the member is an administrator or 
user.

• Users—Lists all of the administrators in the first section, and then all of the (non-administrator) 
users in the next section. Within each section, entries are listed alphabetically by last name, then 
first name. You can select a user and click Remove or Edit at any time to remove or edit the 
participants.

• Specify Top Template Count—Displays only the top 10 most-used templates in the report.

3. Click Run Report. 

The Template Utilization report displays in a new window, in your default web browser. This can take 
a few minutes. You can return to the Active System Manager software while the report is being 
generated.
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Printing Reports

The Active System Manager software reporting feature is designed to print out all information in a given 
category, not just the information you see displayed on the screen. For best results, use the Landscape 
mode in your browser’s print settings.

This section describes two ways to print reports:

• Printing Reports from an HTML Browser

• Printing Reports from a Web Browser

Printing Reports from an HTML Browser
To print a report from your HTML browser, click File > Print. This menu prints all information in a given 
category—not just the information displaying on the screen.

Printing Reports from a Web Browser
To print reports from your web browser, perform the following steps:

1. Click File > Page Setup.

2. Set the orientation to Landscape mode.

3. Verify that the Print background colors and images option is enabled.

4. Exit the Page Setup dialog box.

5. Click File > Print. Alternatively, you can use the link at the upper right of the report to export the report 
as a PDF.
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Settings
This chapter describes the Settings menu option; this option allows the administrator to set a variety of 
system settings.

To access the Settings page, on the Active System Manager menu bar, click Settings. 

The Settings page displays with the Settings sub-menu open, by default; see Figure 13-1. 

Note For the purpose of displaying a generic, full capture of the Settings page, the Settings page has been 
intentionally cropped. Figure 13-1 displays the Email Notification Settings and the Script Server 
Settings. Figure 13-2 displays the General Settings, Scheduler Options, and the Active System 
Manager Session Approval Settings.
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Figure 13-1 Settings Main Page (Email Notification, Script Server) 
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Figure 13-2 Settings Main Page (General, Scheduler Options, Session Approval Settings)
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Configuring Settings

The administrator can configure the following settings from the Settings sub-menu:

• Settings

• Database

• License

• Script Servers

• Properties

Settings
Note The Settings sub-menu page displays, by default, when you click the Settings sub-menu.

The Settings sub-menu allows the administrator to set E-mail notification settings, script server settings, 
general settings and auto-test deployment settings.

For system settings, perform the following steps:

1. Click Settings > Settings to display the Setting page; see Figure 13-1.

2. In Email Notification Settings section, specify your Email settings for outbound notifications.

Table 13-1 lists and defines the fields to be set for sending email notifications.

Table 13-1 E-mail Notification Settings Fields 

Fields Description

SMTP Server Host Enter SMTP server host

'From' Field Enter Active System Manager’s support email id; For Example: “Active System 
Manager.Support@galetechnologies.com”

'To' Field Enter recipients email id; For Example: “Active System 
Manager.Feedback@galetechnologies.com”

Email Subject Enter subject of the mail; For Example: “Active System Manager Feedback 
Notification”

 

3. In Script Sever Settings section, specify your script server settings that will be used by Active System 
Manager for remote scripts execution

Table 13-2 lists and defines the fields to be set for script server settings
 

Table 13-2 Script Server Settings Fields 

Fields Description

Host Enter script server host to be used by Active System Manager for remote scripts 
execution

Username Pre-populated filed. Enter script server username to edit username

Password Pre-populated field. Enter password to edit password
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4. In the General Settings section, configure the settings described in Table 13-3.

Table 13-3 General Settings Fields 

Fields Description

Enable preference based graphical editor 
support in the Active System Manager RCP 
client 

Check this option if the deployment involves huge templates. If 
this flag is true, RCP allows preference based graphical editor 
support in template and session.

Maximum resource count Set a maximum number of resources for which graphical editor 
can be opened. This is a performance setting for RCP client 

 

5. In the Schedular Options Settings section, specify the scheduler options for the fields described in 
Table 13-4.

Table 13-4 Scheduler Options Settings Fields 

Fields Description

Generate scheduler solution 
identification logs

Specify whether or not to generate logs in lux.log file identifying solutions for the 
given template request.

Use randomness while finding 
resource 

Specifies that while finding solution one can introduce the randomness within the 
identified candidates such that in overall Active System Manager system one set 
of resource is not consumed more than other. Here solution is no longer 
dependent on the sequence of resource in database. But this will have drastic 
impact on the Power management solution for VM resource.

Solution of differing resource Specify that while finding multiple solutions for a template whether scheduler 
should give solutions which are differing in interfaces or it should differ in 
allocated resource instances.

 

6. In the Active System Manager Session Approval Settings section, specify the AutoTest deployment 
options in Table 13-5.

Table 13-5 Active System Manager Session Approval Settings Fields 

Fields Description

Deploy Active System 
Manager Session Approval

Check to enable all deployment-related fields for entering information.

Session Approval Buffer Time The duration of time (in minutes) after which the session will expire automatically if 
no approval has been received. The default time is 30 minutes.

 

7. Click Save to save settings or click Cancel to cancel the settings operation.

Remote Script Location Enter servers’ remote script location 

Resource Script Location Enter servers’ resource script location

Reservation Script 
Parameters 

Enter scripts’ reservation script parameters

Device Script Parameters Enter scripts’ device script parameters

Secure Communication Check for establishing and ensuring securing communication

Table 13-2 Script Server Settings Fields (continued)

Fields Description
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Database
The Database sub-menu allows the administrator to backup the database and schedule backup operation 
for the database.

To back up and schedule database, perform the following steps:

1. On the Active System Manager menu bar, click Sessions > Database to display the existing database 
listing; see Figure 13-3.

Figure 13-3 Database

As shown in Figure 13-3, the following operations are available on the Database sub-menu:

• Database Backup

• Refreshing Database

• Database Scheduler

• Database-Related Operations

Database Backup
To back up the database, click Backup Now, see Figure 13-3.

Refreshing Database
To refresh database click Refresh, see Figure 13-3.

Database Scheduler
The Scheduler operation allows you to schedule the backup operation for database, as and when required. 

To schedule a database, click Schedule. The Schedule page displays; see Figure 13-4.
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Figure 13-4 Schedule Database

Table 13-6 lists and defines the fields to be set for scheduling database backup.

Table 13-6 Schedule Database Backup Fields 

Fields Description

Backup Location Enter backup location for database

Enable DB Backup 
schedule

Check to enable DB backup schedule

How Often Select from Daily/Weekly/Monthly scheduling options

What day Select a particular day of the months when backup scheduling begins

What time Select scheduling time

 

Click Save to save scheduling options.

Database-Related Operations
The available database-related operations include the following; see Figure 13-5.

Figure 13-5 Database-Related Operations

As seen in Figure 13-5, database-related actions available on each resultant record:

• Log File

• Delete

• Restore
Settings 13-7



Configuring Settings
Log File
The Log File operation allows you to create a log file of the selected database from the list for future 
reference. 

To create a log file of selected database entry, perform the following steps:

1. Click Log File in Action column. 

The Log File page displays; see Figure 13-6.

Figure 13-6 Log File Dialog Box

2. Open the file in XML editor or choose your own program to open the selected file.

3. Save the file in a designated location.

4. Click the Do this automatically for files like this from now on check box, if required.

5. Click OK to open or save the log file.

Delete
To delete an existing database record from the list, click Delete; see Figure 13-5.

Restore
A Restore message prompts you to restart your server to effect the change; click Restore. 

Note The Restore option is available only when the back-up operation is successfully completed. 
If the Restore operation is unsuccessful, the option does not appear in the drop-down box.
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License

The License sub-menu allows the administrator to view the licensing status.

To view licensing status, perform the following steps:

1. On the Active System Manager menu bar, click Settings > License to display the current licensing 
information and associated live (current) counters; see Figure 13-7.

Figure 13-7 Current Licensing Status

Note The User Sessions option is only displayed for superadmin users.Click User Sessions to 
display a list of all users accessed to the system. Only the superuser admin user has access 
to this operation, where you can force a log out of another user. The purpose is to reclaim 
client license counters

2. Optional. Click the (counters) icon in Figure 13-7, to refresh the resource count and display the 
currently allocated resources.

3. Optional. Click Get New License to deploy or install a new product license. 

4. When the next license screen displays (Figure 13-8), send an email (support@dell.com) to the Dell 
Support team to request a product license.
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Figure 13-8 Get New License

5. When the Dell Support team responds to your software license request, paste the license file provided 
and click Submit.
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Script Servers

The Script Servers sub-menu allows the administrator add and view the list of added script servers.

To view and add script servers, perform the following steps:

1. Click Settings > Script Servers to display the list of existing script servers; see Figure 13-9.

Figure 13-9 Script Servers

As seen in Figure 13-9, the following operations are available on Script Servers sub-menu:

• Defining New Script Server

• Deleting Server

Defining New Script Server
To create a new script server, click New; see Figure 13-9. The Add HTTP Script Server dialog box displays; 
see Figure 13-10.

Figure 13-10 Add HTTP Script Server
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Table 13-7 lists and defines the fields to be set for adding a new HTTP Script Server.

Table 13-7 Fields for Adding HTTP Script Server 

Fields Description

Server Name* Mandatory field. Enter HTTP script server name to be added

Server IP Address* Mandatory field. Enter HTTP script server IP address

Server Port* Pre-populated by default port number

 

2. Click Save to add new HTTP script server. 

Deleting Server
To delete an existing script server from the list, click Delete; see Figure 13-9.

Properties

The Properties sub-menu allows the administrator to update the properties of Inventory, Template, 
Session, Template Link and Preferences by importing the properties file in csv format.

To view components for updating properties, perform the following steps:

1. Click Settings > Properties to display the list of existing script servers; see Figure 13-11.

Figure 13-11 Properties
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Updating Properties
You can update the properties of the following Active System Manager components by exporting .csv file 
properties:

• Inventory

• Template

• Session

• Template Link

• Preferences
Note The Import (see the “Importing Properties” section on page 13-13) and Export (see the 

“Exporting Properties” section on page 13-14) operation works in a similar manner for all 
components.

Importing Properties
To import properties, perform the following steps:

1. On the Properties screen, click Import; see Figure 13-11. 

The Import page displays; see Figure 13-12.

Figure 13-12 Import Inventory Properties page

2. Click Browse to browse and select file (.csv file format only).

3. Click Import to import file.
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Exporting Properties
To export properties, perform the following steps:

1. On the Properties screen, click Export; see Figure 13-11.

Figure 13-13 Exporting Properties

2. Click Open or Save to a designated location.

3. Open the file from the designated location and update the properties in the .csv file.
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Dashboard
This chapter describes the Dashboard perspective and its features. The Dashboard perspective provides an 
“at-a-glance-birds-eye view” of your Active System Manager. To use this view, you can manage, add, or 
remove widgets to share with the administrator a solid understanding of your physical and virtualized 
infrastructure. Figure 14-1 displays an example of the Dashboard perspective, as a non-administrator user 
logged in.

Figure 14-1 Dashboard Perspective

To open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.
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Managing Widgets

The Dashboard perspective contains widgets that define your infrastructure in a specific layout. A widget 
is a stand-alone application that can be embedded into third party sites by any user on a page where they 
have rights of authorship (e.g. a web page, blog, or profile on a social media site). Widgets allow users to 
turn personal content into dynamic web apps that can be shared on websites where the code can be installed.

The Active System Manager comes with a default set of widgets (10) already defined:
Table 14-1 Default Set of Widgets 

Widget Description

Resource Allocation By 
Session

Provides resource allocation data for sessions in a Running state. This 
report displays CPU and memory allocations grouped by sessions.

Resource Allocation by 
Host

Provides resource allocation data for hosts on which some virtual 
machine instances are provisioned in the current running sessions. This 
report displays CPU and memory allocations grouped by hosts.

Resource Allocation By 
Group

Displays resource allocation data for virtual resources that are utilized 
in sessions owned by members of a group, grouped by an Active 
System Manager group name. This report also captures current group 
allocation, including CPU and memory allocation.
To configure: schedule a session with virtual machines (VMs) and the 
session owner should be part of one the groups. When the session is in 
a running state, the graph displays a grouped allocation of resources.

Top 10 Resource 
Allocation

Displays the top 10 users who currently consume a maximum of CPU 
and memory resources.

Top 10 Resource 
Utilization

Displays the top 10 hypervisor cluster resource utilization in the data 
center.

Virtual Machine (VM) 
Utilization per Session

Displays the most recent data (in percentage) for CPU and memory 
utilized on any VM, grouped by sessions. 
To configure: schedule a session with a VM and use the monitor 
operation to capture utilization data is present in RA. When the session 
is in a running state, it displays utilization in that specific session.

Host Utilization 
(Consolidated)

Displays information about how much capacity is utilized on a host by 
all running VMs with respect to the allocated capacity.

To configure: Open the Operations perspective, select a discovered 
host, and right-click to execute monitoring on that host.

Cluster Utilization 
(Consolidated)

Provides information about how much CPU and memory resources are 
utilized on a cluster by all running virtual machines, with respect to the 
allocated capacity.

Storage Utilization 
(Consolidated)

Provides storage utilization as a percentage of allocated storage for 
hypervisor clusters.

CPU/Memory Utilization 
Over Time Graph 

Displays CPU and memory utilization of hosts in percentage over a give 
period of time (eg. Weekly, 3Days,Daily, Hourly).

To configure: start monitoring on the host; utilization data will be pushed 
to the database, which will be retrieved, depending on time intervals.

Note More widgets will be added in future releases.
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The following topics describe how to use and manage the Dashboard content:

• Adding a Widget

• Editing a Widget

• Customizing a Widget

• Refreshing Widget Content

• Deleting a Widget

• Deleting a Widget

• Changing the Dashboard Layout

• Rearranging Dashboard Content

Adding a Widget
To add a widget, perform the following steps:

1. Open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Within the dashboard editor, on the top right, click the Add Widget link; see Figure 14-1.

The Widget Directory dialog box displays the widgets to select; see Figure 14-2.

Figure 14-2 Widget Directory

3. Select the widget to add and click Add it Now.

The view changes to refreshed display of the widgets, including the one you just added.
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Editing a Widget
To edit a widget, perform the following steps:

1. Open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Select a widget, on the title bar, click the down arrow icon, and select Edit; see Figure 14-3.

Figure 14-3 Editing, Minimizing, Refreshing, or Deleting a Widget

Customizing a Widget
Each widget can contain specific filters and options to select to customize their display. To customize a 
widget’s display, perform the following steps:

1. Open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Select a widget. If the widget is empty, on the title bar, click the down arrow icon, and select Edit; 
see Figure 14-3.

3. Select the required filter value and other options to customize the content.
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Refreshing Widget Content
For some widget, the associated data does not refresh automatically, so you may be looking at stale 
information. 

To get an up-to-date representation of the widget data, you will need to refresh its content; perform the 
following steps:

1. Open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Select a widget. If the widget is empty, on the title bar, click the down arrow icon, and select 
Refresh; see Figure 14-3 on page 14-4.

Deleting a Widget
The dashboard can contain many different types of widgets. If you need to delete a widget, perform the 
following steps:

1. Open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Select a widget, on the title bar, click the down arrow icon, and select Delete; see Figure 14-3 on 
page 14-4.

Maximizing or Minimizing a Widget
To maximize a widget, perform the following steps:

1. Open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Select a widget. If the widget is empty, click the Edit layout link; see Figure 14-4.

2) Select a widget, on the widget title bar, select the window icon to maximize (or minimize, depending 
on which state the widget is in), which extends (or minimizes) the width and height of the selected widget. 
Alternatively, to minimize the widget, you can also click the down arrow icon, and select Minimize.

3) To reset the widget position, on the widget title bar, re-select the window icon.
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Managing Widgets
Changing the Dashboard Layout
Depending on how you want to view the Dashboard content, you can manipulate the layout as follows:

1. Open the Dashboard perspective and view the widgets; use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Select a widget. If the widget is empty, click the Edit layout link; see Figure 14-4.

Figure 14-4 Edit Layout Link

3. Select from one of the five proposed layouts; see Figure 14-5.

Figure 14-5 Edit Layout Options

Rearranging Dashboard Content
To arrange your dashboard content, you can select and drag each widget to a new position. To do so, select 
the widget title bar and drag it to a new location on the dashboard.
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